Jump to content
Sign in to follow this  
scottymcloo

Worldpay support III

Recommended Posts

So thinking about it, some of you should check to make sure you don't have some sort of IP Address blocker built into your shop etc. If you have then worldpay callback cannot get back to your site.

Share this post


Link to post
Share on other sites

Thinking about using paypal module on my next oscommerce is it difficult to set up is Worldpay 4.0 - V1.0 the best bet. How do worldpay sort stuff out etc.

 

Any info would be much appriciated :)

Share this post


Link to post
Share on other sites

Hi Folks,

 

I've been trhough this thread and spent an hour in the forums but still haven't seen a definitive answer to the missing orders problem.

 

I lose about 1 in 6 orders using the Worldpay module and now I have just lost my first Paypal order, has anyone found a fix? There is nothing wrong with my order status table, the orders just don't get written into the database and the emails don't go out.

 

I've seen many people asking about this, did anyone find a fix.

 

Thanks in anticipation.

 

Andy.

Share this post


Link to post
Share on other sites

This is because the customer doesnt click back or continue or something or they close their browser in either worldpay or paypal. So they dont go to the checkout success page, which means osc doesnt log the order.

 

there is a contrib that recovers lost cart sales, or those abandoned (Which is technically what has happened, they have paid and then abandoned the process before it finished.) Install that and you should be able to recover the order, and put it through manually yourself then to keep your stock upto date.


Feel free to ask me for help

beep... beep....My Pager

Share this post


Link to post
Share on other sites

Hi all,

I have a callback problem to:

I use https://<wpdisplay item=MC_callback>

 

and get to https://secure.mysite.com/login.php?osCsid=blabla

I use STS and auto login (and several other contributions

 

Should I add below code at the end of the page?

 

Hi there

 

Got the Duplicate entry session problem solved by allowing all cookies from the clients site. Wonder if 'Force Cookie Use' in Sessions osC admin should be set 'true' I had it set at false!

 

Also noticed that my worldpay.php does not generate the

 

<input type="hidden" name="MC_oscsid">

 

from the  worldpay.php call

 

[/code]tep_draw_hidden_field('MC_oscsid', $oscSid);

 

but this doesn't seem to matter as the order still gets processed when working with STS in both normal and template displays enabled!

 

Still need to resolve the STS template display issue for the site to work well and look good. I've made to many changes to go back to the normal osC display. Would really appreciate some pointers on this one.

 

Cheers

Graham

[right][post=421056]<{POST_SNAPBACK}>[/post][/right]


Keesjan

Share this post


Link to post
Share on other sites
Hi, any one any ideas on the callback failure?

I have the same problem, if I put http://<wpdisplay item="MC_callback"> into the WP callback URL I get a failure. Replacing the callback URL with www.mysite.com results in a callback success and everything is fine.

Using osCommerce MS2 with Worldpay 4.0 v1.4

 

Robr

 

i think it should be

 

http://<wpdisplay item=MC_callback>

or for secure

https://<wpdisplay item=MC_callback>


Keesjan

Share this post


Link to post
Share on other sites

Ho post 207 was wrong:

it should be:

 

Hi all,

I have a callback problem to:

I use https://<wpdisplay item=MC_callback>

 

and get to https://secure.mysite.com/login.php?osCsid=blabla

I use STS and auto login (and several other contributions)

 

Should I add below code at the end of the page to avoid sts to wrapp the page? I tryed this but get no other solution, no status page nor is the product added to the databse as purchased.

 

Got the STS Templates Worldpay issue sorted by switching STS templates off when wpcallback.php is fed back - to do this I duplicated and edited an existing code in sts_display_output.php and added it back, so the added code reads

 

 

CODE 

if (strpos($scriptname, "wpcallback") !== false) {

$display_normal_output = 1;

$display_template_output = 0;

}


Keesjan

Share this post


Link to post
Share on other sites

or is call back not working in worldpay test account?

Another question?

 

I want to use recurring billing but cannot find a contribution for this.

I have also futurepay from worldpay. Is the worldpay contribution futurepay enabled?

Edited by helohelo

Keesjan

Share this post


Link to post
Share on other sites
or is call back not working in worldpay test account?

Another question?

 

I want to use recurring billing but cannot find a contribution for this.

I have also futurepay from worldpay. Is the worldpay contribution futurepay enabled?

 

Found out its not

I want to use it with Product Attributes:

 

under your Admin, Product Attributes add a Product Option called Billing Method, two Option Values one Yearly and one Monthly.

 

the paysystems contribution: http://www.oscommerce.com/community/contri...arch,paysystems

 

uses this.


Keesjan

Share this post


Link to post
Share on other sites
Found out its not

I want to use it with Product Attributes:

 

under your Admin, Product Attributes add a Product Option called Billing Method, two Option Values one Yearly and one Monthly.

 

the paysystems contribution: http://www.oscommerce.com/community/contri...arch,paysystems

 

uses this.

anyone? I dont get answers to my questions here so I dont think this contribution is supported?

Edited by helohelo

Keesjan

Share this post


Link to post
Share on other sites

I have recently installed worldpay v4.0-1.8 and i think it works but have no idea.

 

The worldpay module didnt appear in payment modules only under credit card is that normal?

 

So installed that and put it to test put my worldpay i.d etc then went and got something for a pound put a fake number in it said it was wrong so i assume it worked otherwise wouldnt have know that???

 

Then put my real one and and just went to success and logged as pending in the admin.

 

How do i know if worlpay got it etc.

 

Someone give me a quick guide please.

 

Any help would be appriciated:)

Share this post


Link to post
Share on other sites

Also when i installed and the files were in for example

 

worldpay\Worldpay\catalog\includes\modules\payment

 

I put that file in catalog\includes\modules\payment.

 

Is that right? Should there be an actual Worldpay install button like there is for paypal in the payment modules?

 

Soz couldnt edit the one above :(

Share this post


Link to post
Share on other sites
Also when i installed and the files were in for example

 

worldpay\Worldpay\catalog\includes\modules\payment

 

I put that file in catalog\includes\modules\payment.

 

Is that right? Should there be an actual Worldpay install button like there is for paypal in the payment modules?

 

Soz couldnt edit the one above :(

 

Hi, yes thats right, the install button is called 'Secure Credit Card Payment'


Keesjan

Share this post


Link to post
Share on other sites
I have recently installed worldpay v4.0-1.8 and i think it works but have no idea.

 

The worldpay module didnt appear in payment modules only under credit card is that normal?

 

So installed that and put it to test put my worldpay i.d etc then went and got something for a pound put a fake number in it said it was wrong so i assume it worked otherwise wouldnt have know that???

 

Then put my real one and and just went to success and logged as pending in the admin.

 

How do i know if worlpay got it etc.

 

Someone give me a quick guide please.

 

Any help would be appriciated:)

 

you get a testaccount for woldpay to test with setting in your admin for 'Secure Credit Card Payment'

Mode

100


Keesjan

Share this post


Link to post
Share on other sites

After all that installed using 'Secure Credit Card Payment' 100.

 

When i get to the cart i get an actual place to input my card details instead of going to the worlpay sever?

 

Also what is 'Use Pre-Authorisation' in admin does that have an effect?

 

Thanks for you help :)

Share this post


Link to post
Share on other sites

We have installed OsCommerce 2.2 MS 2 and WorldPay V4.0 - 1.8 today, and implement a client's WorldPay account. Everything works fine in 100 and 101 mode, even the Callback function. But when we turn to 0 mode, the Worldpay response:

 

Secure Payment Page 

Sorry, there was an error in processing this transaction:

The information sent from the merchant's site is invalid or incomplete. Please send the following information to the merchant:

The transaction cannot be processed due to one or more of the following:

 

the merchant account is suspended

the currency you selected is not supported

the authorisation mode is incorrect

test mode is unavailable

the installation is not live

 

We are pretty sure that the Worldpay account is already live, and all currency, authorisation mode are the same as the ones we used under 100 and 101. Is there any solution to this?

Share this post


Link to post
Share on other sites
We have installed OsCommerce 2.2 MS 2 and WorldPay V4.0 - 1.8 today, and implement a client's WorldPay account. Everything works fine in 100 and 101 mode, even the Callback function. But when we turn to 0 mode, the Worldpay response:

We are pretty sure that the Worldpay account is already live, and all currency, authorisation mode are the same as the ones we used under 100 and 101. Is there any solution to this?

 

mmm strange.

when testing with a zerro ($0,00) payement i also got thsi kind of message.


Keesjan

Share this post


Link to post
Share on other sites

Paysystems is not working anymore, they are out of business....

 

They even not notifide me about this. >_<

 

So I am setting up my Worldpay account now with futurepay (how expensive!!)

 

Graham mailed me his futurepay solution but that works different then this good paysystems recurring billing:

http://www.oscommerce.com/community/contri...earch,recurring

 

Grahams solution makes worldpay a futurepay solution, so when checking out you choose for the product a payemntmethode: future or normal cc. So its not possible to give discount for futurepay.

 

 

TheMadman made for mod Paysystems with setting in admin

 

> shop>catalog>/products attributes and a mod in

 

> includes/modules/Paysystems.php :

 

I like the worlspay module working the same as your Paysystems module, but Iam a php rooky. <_<

 

How it should work:

 

The client first choose product and as an atribute they select the ?1 time payment for 1 year? or ?recurring automatic billing?. The worldpay module will select its futurepay variant or its normal worldpay variant on this setting. This way I can give discount on recurring billing option.

 

So Invite anyone whith php skills (I am a php rooky) to mod the worldpay payment module http://www.oscommerce.com/community/contri...search,worldpay

Iam willing to pay for it, and then we can upload it as a contribution. (my way of saying tahnk you to this great community)

 

 

---------------------------------------------------------------------------------

 

 

 

I also have another problem with worldpay; callback is not working:

 

have a problem with worlspay callback problem to:

I use https://<wpdisplay item=MC_callback>

 

and get to https://secure.mysite.com/login.php?osCsid=blabla

I use STS and auto login (and several other contributions)

 

 

 

I tried to get STS of this callback page with the code

 

if (strpos($scriptname, "wpcallback") !== false) {

$display_normal_output = 1;

$display_template_output = 0;

}

 

 

 

on sts_display_output.php


Keesjan

Share this post


Link to post
Share on other sites

I've been using the Worldpay contribution for a few months now, and it all seems to be working as it should. I would like to a slight adjustment though, and can't find the issue mentioned on the forum.

 

My client has 3 accounts (6, including the associated test accounts) with worldpay, and I would like to get all osCommerce orders to consistently use the same account. When using static order pages (ie, not using osCommerce), this is done by adding the following to the WorldPay order form:

 

<input type="hidden" name="accId1" value="123456">

 

So, will adding the following to worldpay.php have the same effect?

 

tep_draw_hidden_field('accId1', 123456) .

 

Cheers.

Share this post


Link to post
Share on other sites

I have installed the worldpay module and installed it under the 'Secure Credit Card Payment' yet it doesnt appear when i get to the checkout area nothing appears to pay with.

 

HELP!

 

Why is this happening, does it go to worlpay after Delivery Information or after Payment Information?

 

please can anyone help :(

Share this post


Link to post
Share on other sites
I have installed the worldpay module and installed it under the 'Secure Credit Card Payment'

 

'Secure Credit Card Payment' ? That doesn't sound right. On mine it's under Admin -> Modules -> Payment -> Worldpay Secure Processing. But then I may have renamed it to be more specific. So first thing - do you have that in admin and is it definitely the Worldpay module that you've activated? You should have options e.g. 'Enable Worldpay module'..

 

yet it doesnt appear when i get to the checkout area nothing appears to pay with.

 

Have you set the sort order attribute of the module I mention above, in admin? I've got it set to 0. With no 'sort order' set, it won't appear.

 

Why is this happening, does it go to worlpay after Delivery Information or after Payment Information?

 

The process is:

 

Basket -> Delivery Information -> Payment Information -> Confirm all details -> WORLDPAY (x 2 screens) -> Back to store/thanks for your order.

 

 

please can anyone help :(

 

Hope this helps. Let me know how you get on! :)

 

Adam

Share this post


Link to post
Share on other sites

Thanks adam for your responce

 

'Secure Credit Card Payment' ? That doesn't sound right. On mine it's under Admin -> Modules -> Payment -> Worldpay Secure Processing.  But then I may have renamed it to be more specific. So first thing - do you have that in admin and is it definitely the Worldpay module that you've activated? You should have options e.g. 'Enable Worldpay module'..

Have you set the sort order attribute of the module I mention above, in admin? I've got it set to 0. With no 'sort order' set, it won't appear.

The process is:

 

Yes and it is set to 0

 

Basket -> Delivery Information -> Payment Information -> Confirm all details -> WORLDPAY (x 2 screens)

 

After delivery info it goes to payment info and says there is no payment information to select and def not a worldpay one.

 

:(

 

This is what it looks like in Payment Modules:

'Secure Credit Card Payment'

Secure Credit Card Payment

Enable WorldPay Module

Do you want to accept WorldPay payments?

 

True

False

 

Worldpay Installation ID

Your WorldPay Select Junior ID

 

 

Mode

The mode you are working in (100 = Test Mode Accept, 101 = Test Mode Decline, 0 = Live

 

 

Use Pre-Authorisation?

Do you want to pre-authorise payments? Default=False. You need to request this from WorldPay before using it.

 

True

False

 

Pre-Auth

The mode you are working in (A = Pay Now, E = Pre Auth). Ignored if Use PreAuth is False.

 

 

Payment Zone

If a zone is selected, only enable this payment method for that zone.

--none--UK

 

Sort order of display.

Sort order of display. Lowest is displayed first.

 

 

Set Order Status

Set the status of orders made with this payment module to this value

defaultDeliveredPendingProcessing

 

Thanks again :)

Share this post


Link to post
Share on other sites

Hi I have done succesfull payments and now get a payment order from Worldpay, but my osc geive me no email order. And in my asc admin this costumer seems to have not bought anything!

 

Strange? Somtehing to do wit hanging callback? The pament is made at worldpay but not transfered to my shop. # hours before it went ok with other purchase, very strange...

 

 

Any one?


Keesjan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×