Jump to content
Sign in to follow this  
scottymcloo

Worldpay support III

Recommended Posts

Hello,

 

I am receiving 3 or more requests to my private e-mail address every day for help on Worldpay - most of which is answered right here!!

 

I will not answer any more posts to my private e-mail address, so please dont ask for support there.

 

Thats what this forum is for. Also, I will only monitor this thread and give support from here, not other threads.

 

95% of all problems have been addressed in the three support threads I have created, so please read through them. I have a business to run and free support does not pay my mortgage.

 

Graeme

Share this post


Link to post
Share on other sites

Can I ask - how do you return the full order details (items, customer details etc) in the shop owner email that is received from Worldpay?

Alternatively am I missing something - should OSCommerce return its own shop owner email following an order because it doesn't with my installation.

 

Sincere thanks for your help

Share this post


Link to post
Share on other sites

I believe Worlpay accepts payment by Switch, however when someone goes to checkout and to the worldpay transaction page the only option available is mastercard, visa and visa delta.

 

Can someone expolain how to set worldpay up in order to accept switch.

 

Thanks

In Advance

Share this post


Link to post
Share on other sites

This is nothing to do with the module. Speak to Worldpay about it. It is part of their normal set-up (at least in GBP it is).

Share this post


Link to post
Share on other sites

Worldpay will only send an e-mail detailing to order totals, not the individual items.

 

Set up osCommerce to send you an e-mail of the order details, that way you can quickly cross match the order with the Worldpay recept and verify that it has been paid in full, without having to go into the Worldpay admin screen each time.

Share this post


Link to post
Share on other sites

@graeme:

 

> The Worldpay module is not compatible with the simple template system contribution, > so please do not install it.

 

:( :( :(

 

And I installed STS & Worldpay and am wondering since a week why

the whole thing does not work :-(..

 

But where is there the problem?

The "error" which I get is:

 

I dont get a callback from the Worldpay-server; i tried all 3 (worldpay-)contributions which i found in the contribution-section, but no one of them worked.

 

Contributions that i installed are: STS, Additional Images, Image_resize and Worldpay v4.0

 

 

Any ideas how can i fix it without to reinstall the whole shop?

To rollback the STS seems to be quite hard...

And i made tons of modifications in the php-files.... :(

 

Zucker

Edited by zucker

Share this post


Link to post
Share on other sites

Zucker

 

It took me around 3 hours to fix this problem for someone else - you need to remove all references to STS from wpcallback (and all its included modules, eg application_top, etc) - I did it "live" so didnt keep any files.

 

Basically, dont install STS - it is not compatible with Worldpay, or I suspect many other payment contributions (but I havent tested any others) - I know that doesnt help you.

 

The other contributions you loaded are fine.

 

Graeme

Share this post


Link to post
Share on other sites

@graeme:

 

ok, i'll try my best & report here how it was...

 

Hope, it will work.

 

Thx!

 

Zucker :)

Edited by zucker

Share this post


Link to post
Share on other sites

Hi again,,,

 

 

the success was 50/50.

 

The first problem - that i didnt got callbacks from Worldpay because of the STS - is solved. I getting now

proper "answers" from worldpay, and can see the confirmed orders in "Orders".

 

But the second problem isnt solved. The second "prob" is:

 

the transactions in the "100"(accept-Mode) and "101"(decline-mode) are working fine;

but if I switch to "live" my credit card is not accepted. Im getting the error W331.

Worldpay describes this error as follows:

 

-----------------------------------------------

What does W331 Declined mean?

This type of response corresponds to a decline from the processing bank. The authorisation process is carried out by the bank and WorldPay has no part in the subsequent decision. The decline message is sent to WorldPay by the bank with no explanation nor justification.

The reason for a decline is often to do with incorrect information entered, which does not relate to your card.

 

For example,

 

* Wrong issue number

* Wrong expiry date

* Wrong valid from date

* Wrong security code etc

 

If you still have problems we advise you to contact your card issuer to find out more information.

If you need to pay for the goods by alternative means then please contact the business which owns the site.

------------------------------------------------

 

My card is absolutely ok.

 

Is there maybe a kind of "minimum-payment-limit" at WorldPay or at my Bank? Cause i tried

to pay 2 Euro-cent's...

My bank assured me, that they doesnt have such "limit's"..

 

What Im doing wrong???... :~(

 

 

Zucker

Share this post


Link to post
Share on other sites

Yes that's right. I tried to pay one penny and my card was rejected by my site too!

Try with a normal amount. It should go through OK.

Share this post


Link to post
Share on other sites

@all:

 

YohuuUU!!!!!! :_) :-)) It worked! :-)) :-))

 

 

@radders:

 

It worked! :-)))

 

I payed 3,01 Euro and it worked! :-)))

 

But in that case - who have set up this limitation?

WorldPay? Or my Bank???

 

 

God,am I happy :-))

 

Zucker

Share this post


Link to post
Share on other sites

When I do a cash on delivery transaction, I get an order listed in the admin backend. But when I use the worldpay mod, the money is transferred, but the order isn't listed in admin.

 

I've followed the instructions that came with the mod, and I have checked for callback failures, but none are created.

 

Any Ideas? Thanks in advance,

 

Frank

Share this post


Link to post
Share on other sites

worldpay update worldpay update

worldpay upgrade worldpay upgrade

(see post above)

Edited by idarch

Share this post


Link to post
Share on other sites

Has anyone got a dime for the meter at worldpay .... all the lights have gone out !! Nothing zilch no support, no web site, no payment screens. Thats in the Uk anyway ?

 

Never thought I would see that !!!

Share this post


Link to post
Share on other sites

WORLDPAY SYSTEM STATUS

 

Some of you may find problems accessing the WorldPay payment and

administration systems at the moment.

 

We are aware of this problem and using all our resource

to identify its cause with the utmost urgency.

 

We will contact you again as soon as we know more - please bear with us.

Share this post


Link to post
Share on other sites
Thank you for your support and understanding whilst we undertook this work. This upgrade brings considerable benefits in terms of the performance and resilience of your WorldPay services.

 

Quote from WorldPay after upgrade

 

 

Hmmm .... these things happen, but brings to mind the old saying "If it aint broke - then do'nt fix it"

 

But I suppose you got to progress B)

Edited by pilot

Share this post


Link to post
Share on other sites

I suspect someone's trying to pick a hole in the new system... this is costing me a fortune... I never expected the system to be down all day.

Share this post


Link to post
Share on other sites

Just a suggestion..

 

Why don't you take the Worldpay module offline and put up the generic CC. Then you can take orders and process them later. That way you'll get the orders and you can get the cash later.

 

Its a 2 minute job


Citizen of US Minor Outlying Islands

Share this post


Link to post
Share on other sites

I don't do that because, since I use a payment portal such as Worldpay, I have no need for SSL on my site. Also, the generic CC module doesn't encrypt the card details; it splits the numbers between the database and the email it issues; since the POP3 email server and the database are on the same machine, this is no security at all.

 

I would never recommend anyone to take credit card details without SSL, or to use the CC module without GPG. I would rather lose business than take chances with my customers credit card details.

Share this post


Link to post
Share on other sites

Looks like it's back - all my Worldpay images have reappeared on my site.

 

I also could not do it manually, firstly because I don't have SSL either and secondly, I don't have the facilities to manually process credit cards.


Questions not being answered? mecry.gif

Try here first:

Search | Help documents

Share this post


Link to post
Share on other sites

I've just called Worldpay. They tell me they are experiencing a DOS attack from several sources around the world and have been trying to block these all day, but they keep popping up from different sources.

 

There is no estimated fix time, and their engineers are working through the night to block the relevant IP addresses causing the DOS.

 

He also said that 5% of transactions are getting through which explains why the Worldpay images have re-appeared.

 

I suspect a compensation of a big fat ZERO will be given to us all for lost business - I know from my logs I have lost a lot of business from users who have tried to check out but failed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×