Jump to content
Sign in to follow this  
Farrukh

[Contribution Update] All Prods v2.4

Recommended Posts

This is a great mod as I have said before, keep up the great work!

 

Maybe a few cheeky things:

 

possible options for images to be shown? Maybe collaberate with Small, Med, large images to have an allprod image which is really small?

 

Possible mini description with listings?

 

 

Obviously not requests or demands, but possible things for the future?

 

Peace -

pete

Share this post


Link to post
Share on other sites

Hi,

very nice contribution Thank you...

 

Is is possible that when one clicks on a second language, the product names are shown in that language?

 

They are shown always in one language..

 

Thanks

 

Salvo

Share this post


Link to post
Share on other sites

farruck could u tell me wich of the both contrib 2.4 and all in one 2.5 are also compatible with MS1 version ? by the way on my ian load 5 version it doesnt work at all ....


MS2

Share this post


Link to post
Share on other sites
farruck could u tell me wich of the both contrib 2.4 and all in one 2.5 are also compatible with MS1 version ? by the way on my ian load 5 version it doesnt work at all ....

 

Azer, i regret to tell you that I havent tested the All-Prods v 2.5 All in One on Loaded 5.

 

But what you can do is to install a previous version than 2.4.

 

Install v2.3 on Loaded 5 and it will work with it. I have done it before and it works fine. As far as MS1 is concerned , the update I have done for the compatibility for MS 2.2. only.

Share this post


Link to post
Share on other sites

I just finished installing All Products 2.4 and get the following errors at the top of catalog/allprods.php

 

Warning: main(includes/languages/english/FILENAME_ALLPRODS): failed to open stream: No such file or directory in /usr/local/etc/httpd/htdocs/catalog/allprods.php on line 15

 

Warning: main(): Failed opening 'includes/languages/english/FILENAME_ALLPRODS' for inclusion (include_path='') in /usr/local/etc/httpd/htdocs/catalog/allprods.php on line 15

 

 

Any suggestions??

 

Thanks,

 

Bob

Share this post


Link to post
Share on other sites

It looks like you need something like

define('FILENAME_ALLPRODS', 'allprods.php');

in includes/filenames.php (MS2) or includes/application_top.php (MS1 and earlier). Note: it might be named something other than allprods.php; make sure that you enter a file name that actually exists.

 

Hth,

Matt

Share this post


Link to post
Share on other sites

I added that line to filenames.php and now get the following errors (similar but a little different):

 

Warning: main(includes/languages/english/allprods.php): failed to open stream: No such file or directory in /usr/local/etc/httpd/htdocs/catalog/allprods.php on line 15

 

Warning: main(): Failed opening 'includes/languages/english/allprods.php' for inclusion (include_path='') in /usr/local/etc/httpd/htdocs/catalog/allprods.php on line 15

 

 

 

HELPPPPP!!!

 

bob

Share this post


Link to post
Share on other sites

DOH! :shock:

 

 

I'm a loser baby, so why don't you kill me....

 

 

I thought that I had, but if I did it disappeared. Yeah, that's it.... it disappeared. Anyway, thanks Mike. That did the trick.

 

Have a great holiday weekend. Thanks again!

 

Bob

Share this post


Link to post
Share on other sites

Is it a really tricky mod to change the All Products display page to list the Manufacturer instead of the Model number? The reason I ask is my store is a bookstore and we're using the manufacturer field for the author. I'd rather the search engines list the names of the books and the authors rather than the book names and ISBN's.

 

As always, any and all help is greatly appreciated.

 

Regards,

 

Bob

Share this post


Link to post
Share on other sites

Thanks for taking the time to modify the contribution for me. Seriously, I wasn't expecting such incredible service. The open source community continues to amaze me.

 

With that said, I'm getting the following error when I try and run the new version of allprods (the one with manufacturers but not model numbers):

 

1054 - Unknown column 'c.categories_status' in 'where clause'

 

select p.products_id, p.products_model ,pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from products p , categories c, products_to_categories p2c left join manufacturers m on p.manufacturers_id = m.manufacturers_id left join products_description pd on p.products_id = pd.products_id and pd.language_id = '1' left join specials s on p.products_id = s.products_id where c.categories_status=1 and p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and products_status = '1' order by p.products_date_added DESC, pd.products_name

 

[TEP STOP]

 

 

Any help is appreciated.

 

Thanks again,

 

Bob

Share this post


Link to post
Share on other sites
Thanks for taking the time to modify the contribution for me. Seriously, I wasn't expecting such incredible service. The open source community continues to amaze me.

 

With that said, I'm getting the following error when I try and run the new version of allprods (the one with manufacturers but not model numbers):

 

1054 - Unknown column 'c.categories_status' in 'where clause'

 

select p.products_id, p.products_model ,pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from products p , categories c, products_to_categories p2c left join manufacturers m on p.manufacturers_id = m.manufacturers_id left join products_description pd on p.products_id = pd.products_id and pd.language_id = '1' left join specials s on p.products_id = s.products_id where c.categories_status=1 and p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and products_status = '1' order by p.products_date_added DESC, pd.products_name

 

[TEP STOP]

 

 

Any help is appreciated.

 

Thanks again,

 

Bob

 

Bob

 

You can remove the c.categories_status=1.

I am using the Enable Disable Contribution and this is its part.

 

So now the code will become

 

select p.products_id, p.products_model ,pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from products p , categories c, products_to_categories p2c left join manufacturers m on p.manufacturers_id = m.manufacturers_id left join products_description pd on p.products_id = pd.products_id and pd.language_id = '1' left join specials s on p.products_id = s.products_id where p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and products_status = '1' order by pd.products_name

 

Ill update the contribution also

Share this post


Link to post
Share on other sites

Well Farrukh, all I can say is "Wow!" OK, that's not true, I can also say "Thanks!"

 

I do really appreciate your taking the effort to accomodate my trivial request. It was very kind of you.

 

Thanks again,

 

Bob

Share this post


Link to post
Share on other sites
Well Farrukh, all I can say is "Wow!" OK, that's not true, I can also say "Thanks!"

 

I do really appreciate your taking the effort to accomodate my trivial request. It was very kind of you.

 

Thanks again,

 

Bob

 

 

Not a problem and you are welcome

Share this post


Link to post
Share on other sites

Hi !

 

I did a minor change to have the titles of the Headings for the report language compliant (the text is still not compliant)

 

// In allprods for each language :

// Begin : Add by V. Duffaut

define('HEADING_TITLE_PRODUCT_NAME', 'Nom Du Produit');

define('HEADING_TITLE_MODEL', 'Mod?le');

define('HEADING_TITLE_MANUFACTURERS', 'Soci?t?');

define('HEADING_TITLE_PRICE', 'Prix');

// End : Add by V. Duffaut

 

in allprods generic

<td align="left" class="productListing-heading"><?php echo HEADING_TITLE_PRODUCT_NAME; ?></td>

<td align="left" class="productListing-heading"><?php echo HEADING_TITLE_MODEL; ?></td>

<td align="center" class="productListing-heading"><?php echo HEADING_TITLE_MANUFACTURERS; ?></td>

<td align="right" class="productListing-heading"><?php echo HEADING_TITLE_PRICE; ?>  </td>

<?php

// This is kept to show what to replace

// <td align="left" class="productListing-heading">Product Name</td>

// <td align="left" class="productListing-heading">Model</td>

// <td align="center" class="productListing-heading">Manufacturer</td>

// <td align="right" class="productListing-heading">Price  </td>

?>

 

 

Have fun !

 

Vincent :oops:

Share this post


Link to post
Share on other sites

Hi again !

 

I don't know if someone told but you wont see all product if one exist without a category describing it

 

Take care :(

Share this post


Link to post
Share on other sites

I have each of my products defined in 2 different categories. I end up seeing 2 of each of my products. I will look at the SQL query and hopefully find an easy fix. My guess is just finding the unique instance of each products in the categories.

Share this post


Link to post
Share on other sites

Hello,

 

I installed All Products. Clicked on "View All Products" and it worked. Only problem is it won't work again. It just tries to load the page but nothing happens. Weird.

 

Any ideas of what may be wrong?

 

TIA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×