Jump to content
Sign in to follow this  
Farrukh

[Contribution Update] All Prods v2.4

Recommended Posts

I've installed the 2.71 version. Everything seems to be ok but I do have one problem. I have some of my products in more than one category. So when I use this feature, the product is listed several times e.g. if one product appears in two different categories, the list shows 2 separate products (when in actual fact, it is the same product).

Is there a way to stop it from listing the same product more than once?

Share this post


Link to post
Share on other sites
Hi again !

I don't know if someone told but you wont see all product if one exist without a category describing it

Take care :(

 

How do I do that ? How do I have a category describing it and where ? My page http://www.carromex.com.au/applications/os...b32ca2c9294de72 is coming up, but only a to z and full are coming up, with nothing inside them.


Nina

Share this post


Link to post
Share on other sites
Ok, here's the fix... The bold lines are the ones I added...

 

$duplicates = array();

 

$languages_query = tep_db_query("select languages_id, name, code, image, directory from " . TABLE_LANGUAGES . " order by sort_order");

while ($languages = tep_db_fetch_array($languages_query)) {

$languages_array[] = array('id' => $languages['languages_id'],

'name' => $languages['name'],

'code' => $languages['code'],

'image' => $languages['image'],

'directory' => $languages['directory']);

}

for ($i=0; $i<sizeof($languages_array); $i++) {

$this_language_id = $languages_array[$i]['id'];

$this_language_name = $languages_array[$i]['name'];

$this_language_code = $languages_array[$i]['code'];

$this_language_image = $languages_array[$i]['image'];

$this_language_directory = $languages_array[$i]['directory'];

echo " <tr>\n";

 

 

 

$products_query = tep_db_query("select p.products_id, p.products_model ,pd.products_name, p.products_thumbnail, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p , " . TABLE_CATEGORIES . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and products_status = '1' order by pd.products_name");

 

 

$products_array = array();

while($products = tep_db_fetch_array($products_query))

{

$id = $products['products_id'];

if( !isset( $duplicates[ $id ] ) ) {

$duplicates[ $id ] = true;

$products_array[] = array('id'=> $products['products_id'],

'name' => $products['products_name'],

'image' => $products['products_thumbnail'],

'manufacturer' => $products['manufacturers_name'],

'price' => $products['products_price'],

'tax' => $products['products_tax_class_id'],

'special' => $products['specials_new_products_price']);

}

}

 

Hope this helps. BTW, the duplicates add relevance to your page & site. I just got spidered by Google & I got ranked as #1 for the products that I had duplicated on my allprods page. e.g.,

 

http://www.google.com/search?hl=en&lr=...G=Google+Search

 

But, I still put in the duplicates fix. I'd rather have a professional looking site.

 

 

This looks like exactly what I need but cant figure out which page I edit this on... I've been searching this thread for several hours. Can youtell me what page this is supposed to go on?

Share this post


Link to post
Share on other sites

Hello everyone! I can't seem to figure this out. I am using Download_Controllerv5.3b_MS2.2_2 and osCommerce_PayPal_IPN_v2.3.3 and my problem is that when I order two digital products from my store, and am returned back to my website for product download, only one link is downloadable but both products show up as files to download. I will always have one product with the download button and the remaining product with no button and no link for it. I am going crazy trying to figure this out. Any help would be gladly appreciated. :'(

Share this post


Link to post
Share on other sites

Nevermind! My human error as I originally thought...just couldn't find it. My own Error: the product that did not have the link for download after purchase made had the file extension missing, as in ("filename") when it should have been (filename.zip) So if you experience anything similar, don't forget to check the filename of your product. Anyways, thanks if anyone looked for me. finished my site so check it out whenever you can youbestproduct link in signature. Thanks osCommerce for a great product and AlexStudio for the super download shop contribution!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×