Jump to content
Sign in to follow this  
Farrukh

[Contribution Update] All Prods v2.4

Recommended Posts

pixxie, thank you VERY much. The kindness and willingness to help on this forum is OUTSTANDING and never ceases to impress me.

 

Thanks

Tammy

Share this post


Link to post
Share on other sites

You're welcome. It's the simple things that sometimes confuse us the most ...

 

:blink:

Share this post


Link to post
Share on other sites
is there a way to make it so that the pictures of the items are also shown in the allprods.php page

 

i am working on the site for an artist..... so the pics are necessary.....

 

take a look at

 

http://www.kenemmertdesigns.com/catalog/allprods.php

The link you give already shows photos on the allprods page - have you got it sorted now?

 

:rolleyes:

Share this post


Link to post
Share on other sites

i downloaded and installed a different contribution... and it has the pics....

 

what i am trying to figure out though, is how to make it sort by something other than price....

 

any suggestions?

Share this post


Link to post
Share on other sites

Hi, Carpenoctem

 

I use a contribution called Product_Sort_1.3 it works really well you set the order you want in admin.

 

There is also a contribution called ALLPRODS v3.1 which allows images to be displayed.

 

 

James

Share this post


Link to post
Share on other sites

Hi,

 

I haven't got any of the links to the "All Products" contribution as yet, as I wanted to test it before going any further.

 

Please check it out at:

 

http://christianaudioandvideo.com.au/all_products.php

 

No offense, but it doesn't look too 'nice', a space after the product category would make it look better, when the category name is rather long. Also, some posts in this thread talked about prices showing, but I don't see any ??

 

Is there something I'm missing ? The only parts of the install I didn't do are adding the links.

 

Thanks,

 

Peter

Share this post


Link to post
Share on other sites

When I click on the Add To Cart button, it takes me to product_info.php instead of to shopping_cart.php. Does anyone know how to change this to work correctly?

 

Jack

Share this post


Link to post
Share on other sites

Hi,

 

Do lines 91 to 99 of /all_products.php

 

while($products = tep_db_fetch_array($products_query)) {
 echo
"          <tr>\n" .
'           <td width="33%" class="pageheading"><h1>' . (($memory == $products['categories_id'])? '': $cat_info[$products['categories_id']]['link']) . "</h1></td>\n" .
'           <td class="pageheading"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products['products_id'] . (($language_code == DEFAULT_LANGUAGE) ? '' : ('&language=' . $language_code))) . '"><h1>' . $products['products_name'] . "</h1></a></td>\n" .
"          </tr>\n";
 $memory = $products['categories_id'];
 }
?>

 

need to be modified to just place a 'break' at the right point/s ?

 

Maybe .....................

 

while($products = tep_db_fetch_array($products_query)) {
 echo
"          <tr>\n" .
'           <td width="33%" class="pageheading"><h1>' . (($memory == $products['categories_id'])? '': $cat_info[$products['categories_id']]['link']) . "</h1></td><br>\n" .
'           <td class="pageheading"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products['products_id'] . (($language_code == DEFAULT_LANGUAGE) ? '' : ('&language=' . $language_code))) . '"><h1>' . $products['products_name'] . "</h1></a></td>\n" .
"          </tr>\n";
 $memory = $products['categories_id'];
 }
?>

 

or remove the .........

 

<nobr>"Category description"</nobr>

 

Peter

Share this post


Link to post
Share on other sites

Somebody help me please!!!

 

I installed the All-Prods-v3.01 and when I click on the "View All Products" link in the Categories box, it just goes back to the index page. I went back and reinstalled it, following the instructions in the ReadMe file, but the same thing happens, it still goes to the index page. Somebody please help me, I don't know what I'm doing wrong.

 

I have osCommerce 2.2-MS2 installed.

 

Please, please, please, please help a frazzled newbie. :(

 

Joan

Share this post


Link to post
Share on other sites
Somebody help me please!!!

 

I installed the All-Prods-v3.01 and when I click on the "View All Products" link in the Categories box, it just goes back to the index page.  I went back and reinstalled it, following the instructions in the ReadMe file, but the same thing happens, it still goes to the index page.  Somebody please help me, I don't know what I'm doing wrong.

Take a look in admin under categories->All Products. Make sure the All Products option set to On.

 

Jack

Share this post


Link to post
Share on other sites

Hi, Jack,

 

First of all, thanks for responding. Do you mean under Configuration? Because when I look under Categories, there isn't any "All Products" in there, but when I click on Configuration, I can see "All Products" listed as the last item in the left column.

 

However, when I click on the All Products link, it shows me three separate listings each (all on a separate line) of All Products: ON/OFF and All Products: filename.

 

Of All Products: ON/OFF, only the first one works, and if I try to turn on the other two, All Products shows up in my Category box, but the link returns me to the index page. I don't know if I should leave it alone, or if the duplicate and triplicate entries will mess up my catalog eventually.

 

I would be grateful for any advice.

 

Thanks,

Joan

Share this post


Link to post
Share on other sites
Hi, Jack,

 

First of all, thanks for responding.  Do you mean under Configuration?  Because when I look under Categories, there isn't any "All Products" in there, but when I click on Configuration, I can see "All Products" listed as the last item in the left column. 

 

However, when I click on the All Products link, it shows me three separate listings each (all on a separate line) of All Products: ON/OFF and All Products: filename. 

 

Joan

I apologize for the confusion. Yes, I meant to say Configuration, not categories. But when you click on the All Products link on the left, you should only have two entries showing. If you have more than that then you have probably made a mistake on the installation. Sounds like the .sql files were not added correctly. If you made a backup of your database before you started (you should always do this), then restore it and reinstall the .sql files. Be sure to install them in the order mentioned in the instruction.

 

Jack

Share this post


Link to post
Share on other sites

Hi,

 

I'm using version 3.0.a of this contribution, and only just realised (after checking out some site examples from earlier posts), that there are two different formats. I'm using the (new) simplr format, sorted by product name within category name with the file as all_products.php

 

The previous releases were called allprods.php (... doh), as an example

here shows.

 

I guess no-one has a solution to the problem with the new release, when the category name is rather long, it overlays the product description in Mozilla/Netscape, and in IE, it doesn't look too good either.

 

I've tried addding breaks (<br>) and also 'blank' rows to force it to space, but can't fix it. Any suggestions would be appreciated. I may try the other version also.

 

Peter

Share this post


Link to post
Share on other sites
I'm using version 3.0.a of this contribution, and only just realised (after checking out some site examples from earlier posts), that there are two different formats. I'm using the (new) simplr format, sorted by product name within category name with the file as all_products.php

 

I did the same thing. I uninstalled the 3.0 and installed the allprods v 2.61 from http://www.oscommerce.com/community/contributions,1562

 

I like the look better and it shows photos if you want them. I have a new problem though. It changed my font on my headernavigation . I find that very strange. Could someone help me change it back? Has anyone else had this problem?

 

I tried to fix it in the catalog/stylesheet to no avail.


Laser labels, barcode labels, custom labels

Share this post


Link to post
Share on other sites
It changed my font on my headernavigation

 

Never Mind. I actually did something really dumb.... It is all fixed. I just installed the upgraded version 2.71 and it looks great. I tried 3.1 then 2.61 now 2.71 and I like 2.71 the best. The contribution format should be sorted better. There are a lot of options with this.


Laser labels, barcode labels, custom labels

Share this post


Link to post
Share on other sites

Hi John,

 

Thanks for clarifying this for me, I had no idea there was a seperate contribution.

 

I did the same thing. I uninstalled the 3.0 and installed the allprods v 2.61 from http://www.oscommerce.com/community/contributions,1562

 

So, the contribution you mentioned above is v 2.61 "with images" (no model showing).

 

The

All Prods contribution has 2 different formats:

 

1. New format - v 3.0 and v 3.0.a

 

* Sorted by product name within category name, only displays product name.

 

2. Previous format - latest version is 2.71

 

* Sorted by product name, displays product name (..doh), price, make,model.

 

I think I get it now. :D

 

Peter

Share this post


Link to post
Share on other sites

For those of you using the earlier version: Does the Add to Cart button work correctly or does it also take you to the product page as in V 3?

 

Jack

Share this post


Link to post
Share on other sites

Hi,

I downloaded this but it seems there's no file to add the sql.

I can't seem to make the link work.

 

Thanks

Donna

Share this post


Link to post
Share on other sites

Great cotribution I have made some modifications here and there but it is "good stuff"

What i would like to do is show the products in rows of 3-vs. the 1 product per row.

I read somewhere along the way in this thread that you could change the colums by changing:

// Set number of columns in listing

                              define ('NR_COLUMNS', 1);

                              //

I really dont see any change and I dont think this is what I am after. Any suggestions?

Sorry if this has been answered. Couldnt find an answer.


Thanks in advance for your help!

Stephen

Share this post


Link to post
Share on other sites

Still looking for a way to make the products show up in colums of three across the page. With 1px wide colored spacers between each product. Any Ideas please. Site must go live this week.

Help and Thanks


Thanks in advance for your help!

Stephen

Share this post


Link to post
Share on other sites

Hi,

 

Maybe someone can help me. I just installed this contribution and it is taking forever to load. I am on a dialup connection, so I know it will take a while, but another site that has the same amount of products takes a lot less time. See what I mean:

 

My Site Let it load all the way (If you have time)

 

Other Site This one loads faster.

 

We both have 2772 products, and we both are using All-prods-v2.61. The only difference is I am using the STS_Template Contribution. I don't really think this could be affecting it that much though. I really don't know what to do or what to think. I really like this contribution and hope I can use it.

 

By the way, the only things I want to list in the allprods page is name and price, so maybe that would make the page load faster if it only was looking for those things. I really don't want to change it though, because I already screwed up the page once. And one more thing. I previsously had all-prods v3.01 installed, so the sql files I loaded to my database were from there. That's all thanks

Share this post


Link to post
Share on other sites

Hello

 

I have installed V.2.71 of All Products Page

but is possible show in the URLs the name of product like V.2.6 All in One?

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×