Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

well i have strange problem ..

 

Order Totals column is duplicating with every entry there, and numbers are not added below. No matter what i enter shipping costs and tax are not added to product price :(

 

<a href="http://www.vstopnice.com/vstopnice2.png">screenshot</a>

 

You have multiple entries in your database that is causing this. I would browse about your database for the errors. Just an idea.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
I have that working well but do not have a payment process implemented as of yet

 

 

You have manual order making working with 5.0?


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
You have manual order making working with 5.0?

Yes, so do I. No real problem. Just install Manual Order Maker 1.3 as well as Order Editor v5.

 

Nigel

Share this post


Link to post
Share on other sites
well i have strange problem ..

 

Order Totals column is duplicating with every entry there, and numbers are not added below. No matter what i enter shipping costs and tax are not added to product price :(

 

<a href="http://www.vstopnice.com/vstopnice2.png">screenshot</a>

 

The only time I ever saw this was when I was developing 5.0 and working out the kinks. As of right now I can't re-create this. As Silverado05 mentioned, you should go into your database and manually delete all the excess entries. Go to the orders_total table, sort by order_id, then find all the entries for this order. It looks like there will be a lot- delete all the extras (ie there should only be one subtotal, one shipping entry, maybe only one tax entry depending on the circumstances, and one total).

 

What are all those components that are showing up so many times? Shipping?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

those are shipping costs and tax pulled out of shipping, cause it has to be displayed separately ..

 

i'll take a look into database .. but i think this will not be a solution, since it duplicates this in every order if i try to edit costs ..

Share this post


Link to post
Share on other sites
those are shipping costs and tax pulled out of shipping, cause it has to be displayed separately ..

 

i'll take a look into database .. but i think this will not be a solution, since it duplicates this in every order if i try to edit costs ..

 

You have to delete them manually, obviously at this point Order Editor is not going to do it.

 

What is the class value of your shipping and tax components as stored in the orders_total table? Are they ot_shipping and ot_tax, or are you using custom components?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hi,

 

I would like to install "Order Editor 5.0 "Ultra Violet"". I would like to know if there are still afew bugs (and so need to wait a little bit) or if I can install it without major problem.

 

Thanks

 

Jean-Michel

Share this post


Link to post
Share on other sites

regarding Order Editor 5.0 "Ultra Violet"

 

the new feature: Advanced Add a Product function allows for searching by categories, subcategories, name, or model.

 

 

is it possible to just install this portion? i didn't locate the script in the zip, just install instructions... so whereabouts could i locate the codes?

Share this post


Link to post
Share on other sites
Hi,

 

I would like to install "Order Editor 5.0 "Ultra Violet"". I would like to know if there are still afew bugs (and so need to wait a little bit) or if I can install it without major problem.

 

Thanks

 

Jean-Michel

 

There are no bugs that I know of.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
regarding Order Editor 5.0 "Ultra Violet"

 

the new feature: Advanced Add a Product function allows for searching by categories, subcategories, name, or model.

 

is it possible to just install this portion? i didn't locate the script in the zip, just install instructions... so whereabouts could i locate the codes?

 

The file admin/edit_orders_add_product.php contains the Add a Product code. The zip file includes all files necessary for complete installation.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
those are shipping costs and tax pulled out of shipping, cause it has to be displayed separately ..

 

i'll take a look into database .. but i think this will not be a solution, since it duplicates this in every order if i try to edit costs ..

 

If that is the case you might want to also look in your configuration table as well because their might be multiple entries for that shipping module in there that is outputting this.


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
Yes, so do I. No real problem. Just install Manual Order Maker 1.3 as well as Order Editor v5.

 

Nigel

 

Ok thanks I will work on this tonight. When you say no real problem what does that mean...LoL


Search the forum and contributions before posting. If that doesn't work, keep looking, then post. The forum is for seeking help and advice NOT for someone to do your work for you. Try to do something on your on, if you are going to run a shop then learn how it works.

Share this post


Link to post
Share on other sites
There are no bugs that I know of.

 

Well, maybe one...

 

In admin/edit_orders.php find at about line 1557

		if (ORDER_EDITOR_USE_AJAX == 'true') { 
	 tep_draw_textarea_field("update_comments[" . $orders_history['orders_status_history_id'] . "][comments]", "soft", "40", "5", 
  "" .	tep_db_output($orders_history['comments']) . "", "onChange=\"updateCommentsField('update', '" . $orders_history['orders_status_history_id'] . "', 'false', encodeURIComponent(this.value))\"") . '' . "\n" .
	  '	</td>' . "\n";
	  } else {
	  tep_draw_textarea_field("update_comments[" . $orders_history['orders_status_history_id'] . "][comments]", "soft", "40", "5", 
  "" .	tep_db_output($orders_history['comments']) . "") . '' . "\n" .
	  '	</td>' . "\n";
	  }

 

and change it to

		if (ORDER_EDITOR_USE_AJAX == 'true') { 
	 echo tep_draw_textarea_field("update_comments[" . $orders_history['orders_status_history_id'] . "][comments]", "soft", "40", "5", 
  "" .	tep_db_output($orders_history['comments']) . "", "onChange=\"updateCommentsField('update', '" . $orders_history['orders_status_history_id'] . "', 'false', encodeURIComponent(this.value))\"") . '' . "\n" .
	  '	</td>' . "\n";
	  } else {
	  echo tep_draw_textarea_field("update_comments[" . $orders_history['orders_status_history_id'] . "][comments]", "soft", "40", "5", 
  "" .	tep_db_output($orders_history['comments']) . "") . '' . "\n" .
	  '	</td>' . "\n";
	  }

 

This way comments will actually show up on the page... :)


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Well, maybe one...

 

Hey djmonkey, thanks for updating the 5.0 to a stable code straight from the contrib. Install went fine and even caused me to find an error in my configuration file that I was unaware of. However I have an issue. One of my shipping modules is not getting some information from the order this is the following code.

 

      $restaurantname = $order->customer['firstname'];
     $restaurantname2 = $order->customer['lastname'];

 

This is inside the regions shipping module which actually is three seperate shipping types. I have it setup for Pickup, Delivery and Full service. Each has its own shipping module file. My pickup one should say the customers name while the other two pull in the address. I have tested the code from the other two in the first one and the following code works, its just not the customers name

 

      $testname = $order->delivery['state'];

 

So I know where to make the changes, I just don't know why its not pulling in the customer data during the order editing section. It works fine in a normal ordering situation.

 

Thank you thank you thank you once again because everything else works great.

 

edit: guess I should note that in the first box that code makes it return nothing for those two variables, just blank.

Edited by Niagol

Share this post


Link to post
Share on other sites
Hey djmonkey, thanks for updating the 5.0 to a stable code straight from the contrib. Install went fine and even caused me to find an error in my configuration file that I was unaware of. However I have an issue. One of my shipping modules is not getting some information from the order this is the following code.

 

	  $restaurantname = $order->customer['firstname'];
  $restaurantname2 = $order->customer['lastname'];

 

This is inside the regions shipping module which actually is three seperate shipping types. I have it setup for Pickup, Delivery and Full service. Each has its own shipping module file. My pickup one should say the customers name while the other two pull in the address. I have tested the code from the other two in the first one and the following code works, its just not the customers name

 

	  $testname = $order->delivery['state'];

 

So I know where to make the changes, I just don't know why its not pulling in the customer data during the order editing section. It works fine in a normal ordering situation.

 

Thank you thank you thank you once again because everything else works great.

 

edit: guess I should note that in the first box that code makes it return nothing for those two variables, just blank.

You're welcome for the contribution.

 

As for your problem, there is no such thing as $order->customer['firstname'] and $order->customer['lastname'] on the admin side, only $order->customer['name']. During the checkout process the first and last names are concatenated and stored in the database as one entry.

 

You could write special code that extracts the firstname and lastname from the name entry in order to re-create those variables.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Hey djmonkey, thanks for updating the 5.0 to a stable code straight from the contrib. Install went fine and even caused me to find an error in my configuration file that I was unaware of. However I have an issue. One of my shipping modules is not getting some information from the order this is the following code.

 

	  $restaurantname = $order->customer['firstname'];
					 $restaurantname2 = $order->customer['lastname'];

 

edit: guess I should note that in the first box that code makes it return nothing for those two variables, just blank.

Here is a possible solution: in admin/order_editor/order.php find

	 $this->customer = array('name' => $order['customers_name'],

and immediately below it add

						'firstname' => substr($order['customers_name'], 0, strpos($order['customers_name'], ' ')),
								 'lastname' => strstr($order['customers_name'], ' '),

This code takes everything before the first space in the name and makes it the firstname, then everything after the first space becomes the lastname. So, if a customer had a name like Ann Marie Van Massenhoven, it would return "Ann" as the first name and "Marie Van Massenhoven" as the last name. Not perfect but it does re-create those variables.

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Hey djmonkey.

 

I have update you 5.0.1, but only so the Danish are on it, and nothing else.

 

That's great! Thank you for all your help Michael!


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

No problem, i have it on my site, so i update it with the same i try it.

It a nice work you have make.

 

That's great! Thank you for all your help Michael!

Share this post


Link to post
Share on other sites

@djmonkey

That makes sense, guess I should have looked in the database. I don't actually need it seperated I just didn't want it to get truncated off the discription. Thanks again.

 

Also going to have to edit the code so that it can tell when to pull the two variables for the order being placed and when to pull the one variable when its being edited.

Edited by Niagol

Share this post


Link to post
Share on other sites
The file admin/edit_orders_add_product.php contains the Add a Product code. The zip file includes all files necessary for complete installation.

 

found it

was able to pull the add product codes and customize it to my site. i've been waiting for a code like this for ages, thanks for making it! :thumbsup:

Share this post


Link to post
Share on other sites
found it

was able to pull the add product codes and customize it to my site. i've been waiting for a code like this for ages, thanks for making it! :thumbsup:

 

I can't take credit for that one- it's been available as part of the MOECTOE Suite for over 3 years....


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hello djmonkey1,

 

I have a couple issues with order editor after updating to v5.00.

1. When I select products to delete, it does ask me if I want to delete the products, I hit yes but no products are being deleted. And there is an Error on page, Line: 210, Char: 3, Error: Unknown runtime error.

 

2. The real time shipping calculations do not take Fedex module into account, no fedex quotes are displayed. Is it suppose to list all the installed shipping methods?

 

3. I have also "Package tracking" module installed. Along with comments I can insert FedEx, UPS, USPS tracking numbers into pre-defined fields and send them to customers with order status change. It all worked fine with previous version of order editor, but now as all functions were spread out into different files, I can't get it to work. It seems that no tracking numbers are saved to the database neither they've been sent in emails. May be there is some trick with "Submit new comments" button that it takes only what was inserted into comments box and ignores the tracking numbers fields? djmonkey1, I'd appreciate if you could help me to shade a light on this.

 

4. And just a general question, why there is a code for sending emails included in edit_orders.php and edit_orders_ajax.php. If I understand it correct, when emails are sent the only code used is from edit_orders_ajax.php, so why it's also in edit_orders.php if not in use. Am I right or wrong?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Hello djmonkey1,

 

I have a couple issues with order editor after updating to v5.00.

1. When I select products to delete, it does ask me if I want to delete the products, I hit yes but no products are being deleted. And there is an Error on page, Line: 210, Char: 3, Error: Unknown runtime error.

 

2. The real time shipping calculations do not take Fedex module into account, no fedex quotes are displayed. Is it suppose to list all the installed shipping methods?

 

3. I have also "Package tracking" module installed. Along with comments I can insert FedEx, UPS, USPS tracking numbers into pre-defined fields and send them to customers with order status change. It all worked fine with previous version of order editor, but now as all functions were spread out into different files, I can't get it to work. It seems that no tracking numbers are saved to the database neither they've been sent in emails. May be there is some trick with "Submit new comments" button that it takes only what was inserted into comments box and ignores the tracking numbers fields? djmonkey1, I'd appreciate if you could help me to shade a light on this.

 

4. And just a general question, why there is a code for sending emails included in edit_orders.php and edit_orders_ajax.php. If I understand it correct, when emails are sent the only code used is from edit_orders_ajax.php, so why it's also in edit_orders.php if not in use. Am I right or wrong?

 

Thanks in advance.

 

1- Ahh, the unknown runtime error. My favorite. I'll need more information- I think you're using Internet Explorer, v6? Please let me know.

 

2- It should list all installed shipping modules.

 

3- Clicking on the "Submit new comments" button fires the JavaScript function getNewComment(), stored in admin/order_editor/javascript.php:

   function getNewComment() { //this is used for inserting new commments

	createRequest();
	var status = document.getElementById("status").value;
	var notify = document.getElementById("notify").checked;
	var notifyComments = document.getElementById("notify_comments").checked;
	var comments = encodeURIComponent(document.getElementById("comments").value);
	var url = "<?php echo FILENAME_ORDERS_EDIT_AJAX; ?>?action=insert_new_comment&oID=<?php echo $_GET['oID']; ?>&status=" + status +"&notify=" + notify + "&notify_comments=" + notifyComments + "&comments=" + comments;

	 xmlHttp.open("GET", url, true);

	 xmlHttp.onreadystatechange=
			 function(){if(xmlHttp.readyState!=4)return;if(xmlHttp.status==200){reloadDiv('commentsBlock', xmlHttp.responseText);clearComments();}};

	 xmlHttp.send(null);

}//end function getNewComment()

 

Just to make it that far, you would have to make sure that the tracking number field has a unique id (ie id="tracking_number") assigned to it within the base HTML code. Then you would have to add it as a variable in the JavaScript (var tracking = document.getElementById("tracking_number").value;). Next you have to change the url variable within the same JavaScript function to include the tracking variable info. After that you would head over to admin/edit_orders_ajax.php and modify the code found after

	//11. insert new comments
  if ($action == 'insert_new_comment') {

in order to write the tracking number to the database, send it out in the email, etc.

 

4- Yes and no. The package was designed to be fully functional with or without JavaScript, and the user can turn off the AJAX functions via the admin panel, so having the code in both files is required to cover all the bases.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×