Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

But I didn't understand the payment thing, I have several different to choose from, but it still sends the information, exept for the text in banktransfer, but thats not important.

 

I'm sorry, but I don't really understand your problem. Which information is sent? Do you mean the payment info text at the bottom of the email?

Share this post


Link to post
Share on other sites

Hi

Sorry for explaining myself poorly, as you probably understand english is not my first language.

 

I have both banktransfer and cod installed.

With cod I only write use the title text, so all info I need is printed, but with

banktransfer I have some text that is defined in admin(what bank, account number, etc) that is not displayed, only the title is displayed, but as I said before, it's not a problem.

Share this post


Link to post
Share on other sites
I'm having a very strange problem with Order Editor. I have two computers, laptop and my desktop computer, both are running WinXP and IE7. When I call edit_orders.php from my laptop, everything works perfectly but if I'm working on my desktop computer I'm getting a blank edit_orders.php page with no errors. I have no idea why is this happening on my desktop computer. What might the problem? Any help would be highly appreciated.

 

Thanks.

 

Which version of Order Editor? Using the same order number (order ID) or different order numbers?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

can i get this verified.. if i make any changes.. and i check the new lovely "new order confirmation" and then hit.. UPDATE..

 

is it sending the NEW changes i made or the old one..

 

why i ask well its sending the old info and not the newly changes i have made (which it did update succesfully so that's no problem).

 

if its not suppose to send the NEWLY made changes then i dont understand the difference/purpose this new update of order confirmation.

 

YES i can make the changes.. and it updates and then i can click on new order confirmation and click on update and it sends the new updated order.. but i think that is just doubling up on the new update.

 

please explain the purpose of it.

 

otherwise.. i love it.. cant live with this lvoely contrib.

Share this post


Link to post
Share on other sites
can i get this verified.. if i make any changes.. and i check the new lovely "new order confirmation" and then hit.. UPDATE..

 

is it sending the NEW changes i made or the old one..

 

why i ask well its sending the old info and not the newly changes i have made (which it did update succesfully so that's no problem).

 

if its not suppose to send the NEWLY made changes then i dont understand the difference/purpose this new update of order confirmation.

 

YES i can make the changes.. and it updates and then i can click on new order confirmation and click on update and it sends the new updated order.. but i think that is just doubling up on the new update.

 

please explain the purpose of it.

 

otherwise.. i love it.. cant live with this lvoely contrib.

 

I haven't used the new version yet, but in my experience, with the exception of the 'Add a Product' function, if you don't hit "update" then the changes you've made aren't saved to the database. So, in most cases, you would have to press "update" before sending the new order email. Hitting "update" again after sending the email should not be necessary.

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Which version of Order Editor? Using the same order number (order ID) or different order numbers?

I'm using the latest version of Order Editor, v2.9. Although, I tried to upload original edit_orders.php files from previous versions and starting from v2.7 and up I'm always getting a blank screen and from v2.6.5a and below I'm just getting the upper portion of the page up to '1. Customer and Payment Data' with no details. There is definitely something wrong but I have no idea what it might be. I'm using order editor to edit existing orders, same order numbers. Any help will be appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites
I'm using the latest version of Order Editor, v2.9. Although, I tried to upload original edit_orders.php files from previous versions and starting from v2.7 and up I'm always getting a blank screen and from v2.6.5a and below I'm just getting the upper portion of the page up to '1. Customer and Payment Data' with no details. There is definitely something wrong but I have no idea what it might be. I'm using order editor to edit existing orders, same order numbers. Any help will be appreciated.

 

Thanks.

 

I've been racking my brain on this one, trying to replicate the problem somehow but I'm not having any luck. The only idea that I've come up with is that the browser software on your desktop has a setting and/or an add-on that makes it different somehow then the one on your laptop, and there's also an error or errors in the HTML for Order Editor that results in it not displaying properly (ie normally the browser would ignore mistakes in the code but your desktop is set up to not correct mistakes, for script debugging or something like that).


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
I've been racking my brain on this one, trying to replicate the problem somehow but I'm not having any luck. The only idea that I've come up with is that the browser software on your desktop has a setting and/or an add-on that makes it different somehow then the one on your laptop, and there's also an error or errors in the HTML for Order Editor that results in it not displaying properly (ie normally the browser would ignore mistakes in the code but your desktop is set up to not correct mistakes, for script debugging or something like that).

So, is there anything I can do about that? Is there any other way to detect script errors so I can see what the problem is? What add-on or settings can cause the problem?

 

Thanks.

Share this post


Link to post
Share on other sites
is it sending the NEW changes i made or the old one..

 

Like djmonkey1 said; you've to hit the update button first to save the changes to the DB and then hit the update button again with the "New order confirmation" box selected. That way it should email a new confirmation mail to the customer (and a copy of it to the shop owner if the shop owner has configured osC to send copies of confirmations to an email address of the shop owner) containing the updated info.

 

I'll upload a new version which will inform users about this through a (!)image next to the "New order confirmation" box.

Edited by Ralph2

Share this post


Link to post
Share on other sites
Hi

Sorry for explaining myself poorly, as you probably understand english is not my first language.

 

I have both banktransfer and cod installed.

With cod I only write use the title text, so all info I need is printed, but with

banktransfer I have some text that is defined in admin(what bank, account number, etc) that is not displayed, only the title is displayed, but as I said before, it's not a problem.

 

I'm a bit late, but better late than never :) Thanks for the better explanation.

 

Anyway, despite the fact that you say it's not a problem, I'll explain to you how to get the (pretty important) banktransfer info in the email.

 

It's actually really simple: just open the language file (admin/includes/languages/yourlanguage/edit_orders.php) of the order editor and find:

 

define('EMAIL_TEXT_PAYMENT_INFO', '');

 

Just type or copy your banktransfer info between the ''. So, it should look something like this:

 

define('EMAIL_TEXT_PAYMENT_INFO', 'My bank, account number etc');

 

Then you'll have to verify the name which Order Editor is using for the banktransfer method. If I'm correct, this is a translated name if you're not using English language files with osC. I'm using Dutch language files for example, which means banktransfer is called "Overschrijving" within my shop.

 

How to verify the correct name of the banktransfer method:

 

1- Go the your shop's admin section and open Order Editor.

 

2 - Look for the billing address information box and, more specifically, for the pull down menus at the bottom of this box.

 

3 - The left pull down menu should be filled with all of the payment methods your shop is using. So, within this box you'll have to look for the name of the payment method which stands for the banktransfer method. Maybe it's called "Banktransfer", but it probably isn't.

 

4 - Open edit_orders_email.php (admin/edit_orders_email.php) and find:

 

if ($order->info['payment_method'] == 'NAMEOFPAYMENTMETHOD') {

 

5 - Replace 'NAMEOFPAYMENTMETHOD' with the exact name of the banktransfer method as verified at step 3. As mentioned before, within my shop banktransfer is called "Overschrijving", so in my case the line looks like:

 

if ($order->info['payment_method'] == 'Overschrijving') {

 

And that's it! Let me know if you're still having trouble with this.

Share this post


Link to post
Share on other sites

Note: If you change an order's payment method to banktransfer using Order Editor, hit the update button first in order to store the new payment method to your database and then hit it a second time with the "Send new confirmation" box selected in order to email the updated confirmation.

Edited by Ralph2

Share this post


Link to post
Share on other sites

I just installed this contribution following all of the instructions in the install document but when I click on the Edit button for the order I am getting the following error message:

 

Access Denied

 

No Right Permission Access

Please contact your Web Administrator to request

more access or if you found any problem.

 

Does anybody know what can be causing this?

 

Melissa

Share this post


Link to post
Share on other sites
I just installed this contribution following all of the instructions in the install document but when I click on the Edit button for the order I am getting the following error message:

 

Access Denied

 

No Right Permission Access

Please contact your Web Administrator to request

more access or if you found any problem.

 

Does anybody know what can be causing this?

 

Melissa

 

Nevermind! I figured it out. I had to do something in my admin login settings. Love this order contribution!

 

Melissa

Share this post


Link to post
Share on other sites
I've been racking my brain on this one, trying to replicate the problem somehow but I'm not having any luck. The only idea that I've come up with is that the browser software on your desktop has a setting and/or an add-on that makes it different somehow then the one on your laptop, and there's also an error or errors in the HTML for Order Editor that results in it not displaying properly (ie normally the browser would ignore mistakes in the code but your desktop is set up to not correct mistakes, for script debugging or something like that).

If I view a page source from my browser, I can see that the page stops loading on <script language="javascript" type="text/javascript" src="includes/general.js"></script>. Once I comment out that script, the page is loaded but partially. Only upper portion of the page is loaded including Customer Address and Shipping Address and then page just abruptly ends. And also, some strange numbers appear on the page: 279a to the right of state drop-down, 1011 to the right of Country drop-down, 27af to the right of the Shipping Address State drop-down, and 3ad1 to the left of the Shipping Address State drop-down. I have no idea what's happening. Here is my admin/includes/general.js:

function SetFocus() {

if (document.forms.length > 0) {

var field = document.forms[0];

for (i=0; i<field.length; i++) {

if ( (field.elements.type != "image") &&

(field.elements.type != "hidden") &&

(field.elements.type != "reset") &&

(field.elements.type != "submit") ) {

 

document.forms[0].elements.focus();

 

if ( (field.elements.type == "text") ||

(field.elements.type == "password") )

document.forms[0].elements.select();

 

break;

}

}

}

}

 

function rowOverEffect(object) {

if (object.className == 'dataTableRow') object.className = 'dataTableRowOver';

}

 

function rowOutEffect(object) {

if (object.className == 'dataTableRowOver') object.className = 'dataTableRow';

}

May be you can pick up something wrong with the code. I'll appreciate your help.

Share this post


Link to post
Share on other sites
If I view a page source from my browser, I can see that the page stops loading on <script language="javascript" type="text/javascript" src="includes/general.js"></script>. Once I comment out that script, the page is loaded but partially. Only upper portion of the page is loaded including Customer Address and Shipping Address and then page just abruptly ends. And also, some strange numbers appear on the page: 279a to the right of state drop-down, 1011 to the right of Country drop-down, 27af to the right of the Shipping Address State drop-down, and 3ad1 to the left of the Shipping Address State drop-down. I have no idea what's happening. Here is my admin/includes/general.js:

 

May be you can pick up something wrong with the code. I'll appreciate your help.

 

Something with the javascript causing problems with Internet Explorer? Ha! Impossible!

 

In seriousness, try disabling javascript to see if that has an affect. To disable javascript in IE7 click on Tools->Internet Options->Security->Internet Zone->Custom Level->Scroll down to the bottom of the menu and check "Disable" next to "Scripting of Java applets" and "Active scripting"->Hit OK->Hit OK->Restart IE

 

If it is the javascript then disabling it may allow IE to ignore whatever problems are coming up.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

can someone possibly help??

 

i would like a "field" added to the editor so i can edit the order. i would like to add and be able to edit this field.

 

i have a unique invoice number which relates to the orders of the customer... i would like to be able to enter this to each order i process.. which like i say is a reference number.

 

is it hard to add in.. can someone help me how i would be able to add this field so i can edit it for each order?

 

thanks for your time guys..

Share this post


Link to post
Share on other sites
Something with the javascript causing problems with Internet Explorer? Ha! Impossible!

 

In seriousness, try disabling javascript to see if that has an affect. To disable javascript in IE7 click on Tools->Internet Options->Security->Internet Zone->Custom Level->Scroll down to the bottom of the menu and check "Disable" next to "Scripting of Java applets" and "Active scripting"->Hit OK->Hit OK->Restart IE

 

If it is the javascript then disabling it may allow IE to ignore whatever problems are coming up.

As you said "Impossible", it is indeed. Disabling javascript doesn't change anything at all, still the same problems. If it's not js what else can it be? I also tried installing Firefox to see if it's problem with my IE7, but even with the Firefox it's the same problems.

 

Thanks for your help.

Share this post


Link to post
Share on other sites
As you said "Impossible", it is indeed. Disabling javascript doesn't change anything at all, still the same problems. If it's not js what else can it be? I also tried installing Firefox to see if it's problem with my IE7, but even with the Firefox it's the same problems.

 

Thanks for your help.

 

That makes it sound to me like a problem with your computer, not the browsers, but I can't think of what it could be.

 

Try deleting

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

from admin/edit_orders.php and see if that does anything.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
can someone possibly help??

 

i would like a "field" added to the editor so i can edit the order. i would like to add and be able to edit this field.

 

i have a unique invoice number which relates to the orders of the customer... i would like to be able to enter this to each order i process.. which like i say is a reference number.

 

is it hard to add in.. can someone help me how i would be able to add this field so i can edit it for each order?

 

thanks for your time guys..

 

It is not hard to add additional fields to edit. Is this reference number stored in the database, and if so where?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
That makes it sound to me like a problem with your computer, not the browsers, but I can't think of what it could be.

 

Try deleting

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

from admin/edit_orders.php and see if that does anything.

No, it didn't help either. Everything worked fine on this computer untill I formatted the drive and reinstalled WinXP and now I'm having problems with order editor. But except for this everything seems to be working just fine. So, I'm kind of frustrating. Is there anything that I may be missing on a brand new computer that is suppose to support the order editor, any special considerations to make this module to work?

 

Thanks.

Share this post


Link to post
Share on other sites
No, it didn't help either. Everything worked fine on this computer untill I formatted the drive and reinstalled WinXP and now I'm having problems with order editor. But except for this everything seems to be working just fine. So, I'm kind of frustrating. Is there anything that I may be missing on a brand new computer that is suppose to support the order editor, any special considerations to make this module to work?

 

Thanks.

I searched the web for any solutions to the problem I'm having and I found this problem is being addressed by Microsoft here. They say that a blank web page in IE7 may be caused by usage of <script> tags. It seems to be a pretty fresh problem with IE7, the article is written on February 20, 2007. Unfortunately, there is no fix yet; simply a note that they're aware of the cause and working on it. I wonder why is it just me having a problem and nobody else. Am I the "luckiest" one? :'(

Share this post


Link to post
Share on other sites

I searched the web for any solutions to the problem I'm having and I found this problem is being addressed by Microsoft here. They say that a blank web page in IE7 may be caused by usage of <script> tags. It seems to be a pretty fresh problem with IE7, the article is written on February 20, 2007. Unfortunately, there is no fix yet; simply a note that they're aware of the cause and working on it. I wonder why is it just me having a problem and nobody else. Am I the "luckiest" one? :'(

But you said you installed Firefox and got the same results. Both browsers having the exact same bizarro bug at the exact same time would be a rare situation to say the least. As long as you are the only one reporting this problem I have to lean towards it being a problem with your computer. There is nothing special that should have to be done to use Order Editor; it is, in the basic sense, just like any other page in osCommerce, and as far as the JavaScript is concerned it was designed to work on a wide array of browsers and operating systems.

Try downloading and installing Opera to see if you have the same problem. Also make sure you have all the latest software updates for your desktop.

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Note: If you change an order's payment method to banktransfer using Order Editor, hit the update button first in order to store the new payment method to your database and then hit it a second time with the "Send new confirmation" box selected in order to email the updated confirmation.

 

Ralph- I still haven't gotten around to using the new version, but reading the posts about it has me thinking. Isn't it possible to post the request to send the new order email back to the form such that the new order email will be sent as part of loading the page after the update has been completed? For example, checking the box sets a variable as true, all the updated information is sent to the database, then upon reloading the page with the updated order information, since the variable is true it fires off the email, resets the variable to false, then Order Editor continues on as normal.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
It is not hard to add additional fields to edit. Is this reference number stored in the database, and if so where?

 

hi djmonkey!!

 

thanks for the response.. what field i would like to edit is not yet in the d/b i would like an alt invoice number.. and you already have a "placeholder" for it.. where the title "invoice" or "packing slip".

 

This number i would like to edit bc it ref my own ordering from a warehouse.. and i would like it to associate with customer invoice number..

 

can you advise how to go ahead with it..

 

cheers!

Share this post


Link to post
Share on other sites
hi djmonkey!!

 

thanks for the response.. what field i would like to edit is not yet in the d/b i would like an alt invoice number.. and you already have a "placeholder" for it.. where the title "invoice" or "packing slip".

 

This number i would like to edit bc it ref my own ordering from a warehouse.. and i would like it to associate with customer invoice number..

 

can you advise how to go ahead with it..

 

cheers!

 

First off there needs to be a field in the database where this number can be stored. If there can only ever be one of these numbers per order I would recommend it be added to the orders table.

 

Isn't it possible to just put the reference number in the comments?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×