Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

Hi Stew et al.

 

Nice work on this contrib and nice support too!

 

I've checked through the last few pages of the thread but I didn't see anything about it.

 

I've installed 2.6.4 and its running fine (PS I think the javascript file is missing from the file, I used the old one from 2.6.3 instead). I have OSC2.2, MVS using PayPal IPN and various other smaller non related contribs. The way my site works is the customer makes an order, PayPal IPN writes an order to the system, the customer gets shipped off to the PayPal website and hopefully they pay :)

 

Now I made a small test order with a test customer.

 

I then go and change their shipping because for example some of the items can be combined and we were able to ship for cheaper than the shipping estimator calculated.

 

So later on the customer logs back in, and they go to their account page. (/account.php). They can see their existing order which has been changed, and they can see that the status of their order is set to Preparing (what we use when the customer has't paid but written an order to the system).

 

The customer can then click View and check out their order (/account_history_info.php?order_id=#####). However from here, there appears to be no way for the customer to be able to complete their order without making a new one, which obviously nulifies the changes to shipping that have been made previously.

 

To me it would be really awesome if this information (with the adjusted totals) could be sent of to PayPal with the customer, so that they could complete a payment for that order. That way, their order could be tracked permanetly in their history, plus they won't end up getting multiple orders over and over in their history (for some reason the customers tend to freak out a little and think they've been charged multiple times when they haven't been charged at all if their orders are still set to Pending.

 

Has anyone added a 'Proceed to Payment' or similar button that would allow this information to be sent straight to PayPal with the customer?

 

Thanks in advance,

 

Mark

Share this post


Link to post
Share on other sites
Hi Stew et al.

 

Nice work on this contrib and nice support too!

 

I've checked through the last few pages of the thread but I didn't see anything about it.

 

I've installed 2.6.4 and its running fine (PS I think the javascript file is missing from the file, I used the old one from 2.6.3 instead).

As of v2.6.4 Order Editor doesn't have an external javascript file; all the necessary javascript should be included in the file admin/edit_orders.php. If you could be more specific about this that would be very helpful.

 

I have OSC2.2, MVS using PayPal IPN and various other smaller non related contribs. The way my site works is the customer makes an order, PayPal IPN writes an order to the system, the customer gets shipped off to the PayPal website and hopefully they pay :)
Which version of MVS are you running (there are several), and are you using Order Editor for MVS?

 

Now I made a small test order with a test customer.

 

I then go and change their shipping because for example some of the items can be combined and we were able to ship for cheaper than the shipping estimator calculated.

 

So later on the customer logs back in, and they go to their account page. (/account.php). They can see their existing order which has been changed, and they can see that the status of their order is set to Preparing (what we use when the customer has't paid but written an order to the system).

 

The customer can then click View and check out their order (/account_history_info.php?order_id=#####). However from here, there appears to be no way for the customer to be able to complete their order without making a new one, which obviously nulifies the changes to shipping that have been made previously.

 

To me it would be really awesome if this information (with the adjusted totals) could be sent of to PayPal with the customer, so that they could complete a payment for that order. That way, their order could be tracked permanetly in their history, plus they won't end up getting multiple orders over and over in their history (for some reason the customers tend to freak out a little and think they've been charged multiple times when they haven't been charged at all if their orders are still set to Pending.

 

Has anyone added a 'Proceed to Payment' or similar button that would allow this information to be sent straight to PayPal with the customer?

 

Thanks in advance,

 

Mark

That would be a modification of the checkout process on the catalog side of osC and so is outside the scope of Order Editor.

 

For customers who have already processed their order through osC but not yet paid through PayPal, that can be as simple as them logging in to PayPal and sending you a payment. You can send them an email or an invoice requesting payment to remind them. Really, it's a bug in the PayPal IPN contribution that you're using; it shouldn't be possible for a user to create an order in osC but not finalize the payment. I know many people have complained about this problem with PayPal IPN. I've also heard that there are two versions of PayPal IPN and that the one supported by the osC development team doesn't have this problem but I may be mistaken about that. I use PayPal Website Payments Pro and as far as I know the scenario you've described isn't possible when using that contribution.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
As of v2.6.4 Order Editor doesn't have an external javascript file; all the necessary javascript should be included in the file admin/edit_orders.php. If you could be more specific about this that would be very helpful.

Oh no problem :) I had previously installed 2.6.3 but I backed out of it and a couple of days ago wanted to tryit again further so I went for 2.6.4 but I noticed that there was no longer a javascript file in the download. Nevermind :)

 

Which version of MVS are you running (there are several), and are you using Order Editor for MVS?

MVS 1.1; nope I didn't know it even existed. I have now found it in the contribs so I'll check it out :)

 

That would be a modification of the checkout process on the catalog side of osC and so is outside the scope of Order Editor.

 

For customers who have already processed their order through osC but not yet paid through PayPal, that can be as simple as them logging in to PayPal and sending you a payment. You can send them an email or an invoice requesting payment to remind them. Really, it's a bug in the PayPal IPN contribution that you're using; it shouldn't be possible for a user to create an order in osC but not finalize the payment. I know many people have complained about this problem with PayPal IPN. I've also heard that there are two versions of PayPal IPN and that the one supported by the osC development team doesn't have this problem but I may be mistaken about that. I use PayPal Website Payments Pro and as far as I know the scenario you've described isn't possible when using that contribution.

Ok no probs... basically I thought this was the case but I needed to make sure I wasn't missing something simple. At the mo we are sending Invoices through PayPal directly to the customer which works ok, but that would be a better solution. It tends to scare off some customers unfortunately so that's why I've been looking into alternative ways to go about it.

 

Thanks for your time, I appreciate it :)

Share this post


Link to post
Share on other sites

So I installed this contrib a couple months back and as I recall everything worked just fine. I finally had to use it to delete something from an order, i got to click update and *BAM* this sql error appeared. Anyone have any idea what this is and how I can fix it?

 

1054 - Unknown column 'shipping_tax' in 'field list'

UPDATE orders SET customers_name = 'BLANKED FOR SAFETY', customers_company = '', customers_street_address = 'BLANKED FOR SAFETY', customers_suburb = '', customers_city = 'BLANKED FOR SAFETY', customers_state = 'New Jersey', customers_postcode = 'BLANKED FOR SAFETY', customers_country = 'United States', customers_telephone = '845-978-6821', customers_email_address = 'BLANKED FOR SAFETY', billing_name = 'ilona lowy', billing_company = '', billing_street_address = 'BLANKED FOR SAFETY', billing_suburb = '', billing_city = 'BLANKED FOR SAFETY', billing_state = 'New Jersey', billing_postcode = 'BLANKED FOR SAFETY'', billing_country = 'United States', delivery_name = 'BLANKED FOR SAFETY'', delivery_company = '', delivery_street_address = 'BLANKED FOR SAFETY'', delivery_suburb = '', delivery_city = 'BLANKED FOR SAFETY'', delivery_state = 'New Jersey', delivery_postcode = 'BLANKED FOR SAFETY'', delivery_country = 'United States', payment_method = 'PayPal', cc_type = '', cc_owner = '', cc_number = '', cc_expires = '', shipping_tax = '' where orders_id = '11';

[TEP STOP]

thanks in advance., I don't recall this error ever showing up. Seems to me I may have added a column called shipping tax(possibly for another mod, i can't recall). How can I adjust this contrib tow ork with that new aforementioned column? I obviously wrote in "BLANKED FOR SAFETY'" for the privacy of my customer, this should not affect the anser to my question.

Edited by jacenstuff

We must be the change we wish to see in the world.

------------------------------------------------------------

p.s. BACKUP!

Share this post


Link to post
Share on other sites
So I installed this contrib a couple months back and as I recall everything worked just fine. I finally had to use it to delete something from an order, i got to click update and *BAM* this sql error appeared. Anyone have any idea what this is and how I can fix it?

 

thanks in advance., I don't recall this error ever showing up. Seems to me I may have added a column called shipping tax(possibly for another mod, i can't recall). How can I adjust this contrib tow ork with that new aforementioned column? I obviously wrote in "BLANKED FOR SAFETY'" for the privacy of my customer, this should not affect the anser to my question.

You missed this step:

 

-------------
STEP0
-------------

Run the following command on your MySQL database

###If you always or almost always charge tax on shipping, 
###you may want to enter a different default value for shipping_tax,
###ie 16.0000 instead of 0.0000):


ALTER TABLE orders ADD shipping_tax DECIMAL( 7, 4 ) DEFAULT '0.000' NOT NULL;
INSERT into configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) values ('', 'Order Editor- Display Payment Method dropdown?', 'DISPLAY_PAYMENT_METHOD_DROPDOWN', 'true', 'Display Payment Method in Order Editor as dropdown menu (true) or as input field (false)', '1', '21', NULL, '2006-04-02 11:51:01', NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),');


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

I could've sworn I ran this sql command before. I remember telling myself, "this has nothing to do with me, but for safe caution run this command as part of the install" and apparently I did NOT do it, because you jsut helped me fix my problem. Thanks so much man, I really appreciate that.


We must be the change we wish to see in the world.

------------------------------------------------------------

p.s. BACKUP!

Share this post


Link to post
Share on other sites
You missed this step:

 

-------------
STEP0
-------------

Run the following command on your MySQL database

###If you always or almost always charge tax on shipping, 
###you may want to enter a different default value for shipping_tax,
###ie 16.0000 instead of 0.0000):
ALTER TABLE orders ADD shipping_tax DECIMAL( 7, 4 ) DEFAULT '0.000' NOT NULL;
INSERT into configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) values ('', 'Order Editor- Display Payment Method dropdown?', 'DISPLAY_PAYMENT_METHOD_DROPDOWN', 'true', 'Display Payment Method in Order Editor as dropdown menu (true) or as input field (false)', '1', '21', NULL, '2006-04-02 11:51:01', NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),');

 

 

This is exactly the problem that I have been stuck on.

 

I have desperately needed this order editor contrib for my customer's web site, but I do not understand how to do Step 0 above. I have never messed with MySQL, so most of that step is Greek (or Geek) to me.

 

Is there any way to break it down into a bit more common English non-geek steps, or is there anyone who would be willing to help me 1-on-1 to get this fixed?

 

I also desperately need help with setting up the shipping options. I have studied 4 books on osCommerce, and I'm still stuck - I could really use a bit of mentoring / consulting now.

 

I have multiple installations I am stuck at the same steps on, so I do have a non-public site that I can try it on before messing with my live store.

 

Any help much appreciated!

Share this post


Link to post
Share on other sites

virtualend: Luckily, running this MySQL command is actually quite simple also for us non-tech-experts. There are softwares that help in managing the MySQL databases. Do you have phpMyAdmin installed? If you do, start up phpMyAdmin and choose the oscommerce database in the drop-down menu.Click the "SQL"-window in the menu and paste the SQL command text into the pop-up-window. Click "run" and that's it!

Share this post


Link to post
Share on other sites

Does this work with the PayPal_Shopping_Cart_IPN

 

Ie this one http://www.oscommerce.com/community/contributions,1753

 

Im on step 3 and it asking me to replace the paypal code..

 

//begin PayPal_Shopping_Cart_IPN

$order_query = tep_db_query("select customers_name, customers_company, customers_street_address, customers_suburb, customers_city, customers_postcode, customers_state, customers_country, blh, bla, blah

nat_id, payment_method, cc_type, cc_owner, cc_number, cc_expires, currency, currency_value, date_purchased, orders_status, last_modified, customers_id, payment_id from " . TABLE_ORDERS . " where orders_id = '" . (int)$order_id . "'");

//end PayPal_Shopping_Cart_IPN

Share this post


Link to post
Share on other sites

I'm using authorize.net for cc payments... and when i want to edit an order, i want it to update authorize.net's charges.

 

Is there any way to do this/what do you recommend?

 

Thanks!

Share this post


Link to post
Share on other sites
Does this work with the PayPal_Shopping_Cart_IPN

 

Ie this one http://www.oscommerce.com/community/contributions,1753

 

Im on step 3 and it asking me to replace the paypal code..

 

Use

$order_query = tep_db_query("select * from " . TABLE_ORDERS . " where orders_id = '" . (int)$order_id . "'");

and it will work fine.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
That's pretty weird, but it's most likely a problem with admin/includes/classes/order.php. Try uploading your backup copy or the copy of it that came with either of the contributions to see if you get different results. If you had even one error that would be something, but a blank page isn't much to go on.

 

hi,

 

I have followed what you suggested and put back the original file for admin/includes/classes/order.php

 

and this time, it works almost perfect except for some minor error.

 

so i make the changes according to the installation note one by one and upload the file after every change to see if there is any problem. My problem finally arrives after i made this change:

 

###Find this starting at line 80:
$index = 0;
  $orders_products_query = tep_db_query("select orders_products_id, products_name, products_model, products_price, products_tax, products_quantity, final_price from " . TABLE_ORDERS_PRODUCTS . " where orders_id = '" . (int)$order_id . "'");
  while ($orders_products = tep_db_fetch_array($orders_products_query)) {
	$this->products[$index] = array('qty' => $orders_products['products_quantity'],
									'name' => $orders_products['products_name'],
									'model' => $orders_products['products_model'],
									'tax' => $orders_products['products_tax'],
									'price' => $orders_products['products_price'],
									'final_price' => $orders_products['final_price']);

	$subindex = 0;
	$attributes_query = tep_db_query("select products_options, products_options_values, options_values_price, price_prefix from " . TABLE_ORDERS_PRODUCTS_ATTRIBUTES . " where orders_id = '" . (int)$order_id . "' and orders_products_id = '" . (int)$orders_products['orders_products_id'] . "'");
	if (tep_db_num_rows($attributes_query)) {
	  while ($attributes = tep_db_fetch_array($attributes_query)) {
		$this->products[$index]['attributes'][$subindex] = array('option' => $attributes['products_options'],
																 'value' => $attributes['products_options_values'],
																 'prefix' => $attributes['price_prefix'],
																 'price' => $attributes['options_values_price']);



****Replace it with this:

 $countryid = tep_get_country_id($this->delivery["country"]);
 $zoneid = tep_get_zone_id($countryid, $this->delivery["state"]);

$index = 0;
 $orders_products_query = tep_db_query("
  SELECT 
 op.orders_products_id, 
 op.products_name, 
 op.products_model, 
 op.products_price,
 op.products_tax, 
 op.products_quantity, 
 op.final_price, 
 p.products_tax_class_id,
 p.products_weight
 FROM " . TABLE_ORDERS_PRODUCTS . " op
 LEFT JOIN " . TABLE_PRODUCTS . " p
 ON op.products_id = p.products_id
 WHERE orders_id = '" . (int)$order_id . "'");

   while ($orders_products = tep_db_fetch_array($orders_products_query)) {
	 $this->products[$index] = array('qty' => $orders_products['products_quantity'],
									 'name' => $orders_products['products_name'],
									 'model' => $orders_products['products_model'],
									 'tax' => $orders_products['products_tax'],
	'tax_description' => tep_get_tax_description($orders_products['products_tax_class_id'], $countryid, $zoneid),
									 'price' => $orders_products['products_price'],
									 'final_price' => $orders_products['final_price'],
									 'weight' => $orders_products['products_weight'],
							   'orders_products_id' => $orders_products['orders_products_id']);

	$subindex = 0;
	$attributes_query = tep_db_query("select * from " . TABLE_ORDERS_PRODUCTS_ATTRIBUTES . " where orders_id = '" . (int)$order_id . "' and orders_products_id = '" . (int)$orders_products['orders_products_id'] . "'");
	if (tep_db_num_rows($attributes_query)) {
	  while ($attributes = tep_db_fetch_array($attributes_query)) {
		$this->products[$index]['attributes'][$subindex] = 
		array('option' => $attributes['products_options'],
			  'value' => $attributes['products_options_values'],
			  'prefix' => $attributes['price_prefix'],
			 'price' => $attributes['options_values_price'],
	  'orders_products_attributes_id' => $attributes['orders_products_attributes_id']);

 

i think the problem arises from here:

 

	$orders_products_query = tep_db_query("
  SELECT 
 op.orders_products_id, 
 op.products_name, 
 op.products_model, 
 op.products_price,
 op.products_tax, 
 op.products_quantity, 
 op.final_price, 
 p.products_tax_class_id,
 p.products_weight

 

what are these objects referring to i.e op and p? is there any other way i can overcome this? my code currently seems to work perfectly without this modification but i m sure i have missed out something if I don't modify these code.

 

pls advise

 

:D

Share this post


Link to post
Share on other sites
hi,

 

I have followed what you suggested and put back the original file for admin/includes/classes/order.php

 

and this time, it works almost perfect except for some minor error.

 

so i make the changes according to the installation note one by one and upload the file after every change to see if there is any problem. My problem finally arrives after i made this change:

 

Firstly, if you are receiving a specific error message please post it here.

 

Secondly, what version of MySQL are you running?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
I'm using authorize.net for cc payments... and when i want to edit an order, i want it to update authorize.net's charges.

 

Is there any way to do this/what do you recommend?

 

Thanks!

 

Order Editor isn't a payment module; collecting payment is something you need to work out with your customer(s).


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Firstly, if you are receiving a specific error message please post it here.

 

Secondly, what version of MySQL are you running?

 

 

if i made the last modification as mentioned, i can see this page without a problem:

http://www.xxx.com/admin/orders.php

 

this page basically shows a summary of all orders that i have. from here, when i try to click on "details", invoices", "packing slip" and "edit", i can only see a blank page except for the side bar and the header. one thing, the "delete" button on the same page works without a problem though

 

if i don't make the last modification, everything seems to be running fine and there is no blank page. seems like i can edit and update orders correctly but i suspect that certain fields will not be updated

 

by the way, i m running mysql 4.1.10-standard

 

thank you

Share this post


Link to post
Share on other sites
Order Editor isn't a payment module; collecting payment is something you need to work out with your customer(s).

 

I never said it was... but so there's no way I can edit the order and have it update w/ the CC processor? what does everyone else do?

Share this post


Link to post
Share on other sites
i think the problem arises from here:

 

	$orders_products_query = tep_db_query("
  SELECT 
 op.orders_products_id, 
 op.products_name, 
 op.products_model, 
 op.products_price,
 op.products_tax, 
 op.products_quantity, 
 op.final_price, 
 p.products_tax_class_id,
 p.products_weight

 

what are these objects referring to i.e op and p? is there any other way i can overcome this? my code currently seems to work perfectly without this modification but i m sure i have missed out something if I don't modify these code.

 

pls advise

 

:D

 

The "p" and the "op" are defined at the bottom of the query:

$orders_products_query = tep_db_query("
 SELECT 
 op.orders_products_id, 
 op.products_name, 
 op.products_model, 
 op.products_price,
 op.products_tax, 
 op.products_quantity, 
 op.final_price, 
 p.products_tax_class_id,
 p.products_weight
 FROM " . TABLE_ORDERS_PRODUCTS . " op
 LEFT JOIN " . TABLE_PRODUCTS . " p
ON op.products_id = p.products_id
WHERE orders_id = '" . (int)$order_id . "'");

where "p" corresponds to TABLE_PRODUCTS and "op" corresponds to TABLE_ORDERS_PRODUCTS. The reason for this is the joining of two tables.

 

This query has caused problems in the past with different versions of MySQL, but I wouldn't expect a problem from v4.1.

 

Try this query in this format and see if you have different results:

$orders_products_query = tep_db_query("
 SELECT 
 op.orders_products_id, 
 op.products_name, 
 op.products_model, 
 op.products_price,
 op.products_tax, 
 op.products_quantity, 
 op.final_price, 
 p.products_tax_class_id,
 p.products_weight
 FROM " . TABLE_ORDERS_PRODUCTS . " op
 LEFT JOIN " . TABLE_PRODUCTS . " p
ON (op.products_id = p.products_id)
WHERE (orders_id = '" . (int)$order_id . "')");


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
I never said it was... but so there's no way I can edit the order and have it update w/ the CC processor? what does everyone else do?
I use PayPal Website Payments Pro and whenever I need to charge a customer an additional amount, I have to call them, get their credit card information from them (our site doesn't store all the cc info), and run the additional charge as a new transaction. If it's a refund then I have to log in to PayPal and run the refund manually.

 

Perhaps Authorize.net has a different interface, but I can't imagine it's very different if you're running real-time cc processing.

 

What is it that you have in mind for this?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Hi again DJ.

I want to post here a little modification to show the model number of every product, when you put a new product in a new order.

 

In catalog\admin\edit_orders.php, about line 1863:

 

WAS

		SELECT products_name, p.products_id, categories_name, ptc.categories_id

 

NOW

		SELECT products_model, products_name, p.products_id, categories_name, ptc.categories_id

 

 

about line 1876:

 

WAS:

			$ProductList[$db_categories_id][$db_products_id] = $db_products_name;

NOW:

			$ProductList[$db_categories_id][$db_products_id] = $db_products_model . ' ' . $db_products_name;

 

Now, I can't mod your code for insert a field in which simply digit the model number for adding a new product, without setting the category or scroll a pulldown menu.

 

Do you think is difficult to implement?

Share this post


Link to post
Share on other sites

Whooops! I did it again :D

Another little big trouble, look at this:

 

vat.gif

 

I'll explain to you: IVA is the Italian "tax" (it's at 20%), sconto is a discount, spese di spedizione is the shipping fee...

Now, Iva at 20.00 is ok. The sub-total is calculated through the form, so is right.

But when I add a discount (with minus value), the total value is erroneus, just because it does:

 

[(subtotal + shipping fee) + iva] - discount = erroneus total

 

while it should be

 

[(subtotal - discount + shipping fee) + iva] = right total

 

Any solution?

Thanks, you're precious.

Share this post


Link to post
Share on other sites
Hi again DJ.

I want to post here a little modification to show the model number of every product, when you put a new product in a new order.

 

In catalog\admin\edit_orders.php, about line 1863:

 

Now, I can't mod your code for insert a field in which simply digit the model number for adding a new product, without setting the category or scroll a pulldown menu.

 

Do you think is difficult to implement?

 

You want to just type the model number into a box, enter the quantity, hit submit and you're done?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Whooops! I did it again :D

Another little big trouble, look at this:

 

I'll explain to you: IVA is the Italian "tax" (it's at 20%), sconto is a discount, spese di spedizione is the shipping fee...

Now, Iva at 20.00 is ok. The sub-total is calculated through the form, so is right.

But when I add a discount (with minus value), the total value is erroneus, just because it does:

 

[(subtotal + shipping fee) + iva] - discount = erroneus total

 

while it should be

 

[(subtotal - discount + shipping fee) + iva] = right total

 

Any solution?

Thanks, you're precious.

 

You have to modify the code in Order Editor to take the discount into account when calculating tax. To do this we have to know the ot_class value of the discount component. You can find this in the the 'orders_total' table in the database. For example, subtotal is ot_subtotal, total is ot_total, tax is ot_tax, etc.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
This is exactly the problem that I have been stuck on.

 

I have desperately needed this order editor contrib for my customer's web site, but I do not understand how to do Step 0 above. I have never messed with MySQL, so most of that step is Greek (or Geek) to me.

 

Is there any way to break it down into a bit more common English non-geek steps, or is there anyone who would be willing to help me 1-on-1 to get this fixed?

 

I also desperately need help with setting up the shipping options. I have studied 4 books on osCommerce, and I'm still stuck - I could really use a bit of mentoring / consulting now.

 

I have multiple installations I am stuck at the same steps on, so I do have a non-public site that I can try it on before messing with my live store.

 

Any help much appreciated!

 

I found the MyphpAdmin on my Plesk Control Panel on my server (it was labelled DB Admin), and I figured out how to enter the code for step 0 to modify the data base. I first tested it on a non-live osCommerce installation on another domain, and it worked fine, so I did the same on the live working store.

 

The order editor worked fine now - except - now we recieved an email from a customer who could not checkout. On the first step of checkout it reloads the same page, and does not continue to the payment page. I did a test order, & this works fine on the non-live domain - but not on the live working store now.

 

No error message - just an endless loop on the first step of checkout. :(

 

I do not know if I did something wrong to the data base (I did the exact same thing on both), or if I may have done something else wrong, or what could be wrong - but now the site can not process orders...

 

HELP!!!! :'(

 

Has anyone else had this problem on checkout? Do I need to re-upload anything? It is a live store with lots of customer history, so I don't want to lose my inventory or history.

 

DJ - let me know if you think you might know what the problem could be - or if you would be willing to test & fix, and I can PM you the URL info.

Share this post


Link to post
Share on other sites
You want to just type the model number into a box, enter the quantity, hit submit and you're done?

Yes yes yes! :D

Maybe it'd be better if there were both ways... don't you think?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×