Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

Did you ever get an answer to this? I am having the same issue. It goes to the login page everytime i add a product. Very annoying!

 

Thanks, Amy

 

I just recently installed the Order editor 5.0.9c package.

When I edit order, able to delete the orders.

When I click to add new products, new pop up comes and I am able to select the product and add to order.

Then the main order edit page refreshes but goes to login page. After that new items I am adding doesnt add to the order.

So ineffect only one line item I am able to add every time.

 

Is there a way to correct. I am getting incorrect order total as after the firat item added thro order editor, additional items are not counted by the sub total but shows in the order.

 

Thanks

Share this post


Link to post
Share on other sites

I'm having an issue where when I click edit orders in admin I receive this error:

 

1054 - Unknown column 'products_ship_sep' in 'where clause'

 

select products_id, products_price, products_tax_class_id, products_weight from products where products_id = '1' and products_ship_sep = '0'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

I'm having an issue where when I click edit orders in admin I receive this error:

If your version is higher than 5.0.7, see instructions for plugins integrated into OE 5.0.8 and higher. You should or revert back to 5.0.7 or install all of the plugins.

Share this post


Link to post
Share on other sites

The error is:

Warning: number_format() expects parameter 1 to be double, string given in admin/edit_orders.php on line 1740

 

I guess the problem is because I have AJAX-AttributeManager-V2.8.9 installed. They have been conflicting with each other cause same ID. Maybe someone have got a sollution? Thanx

Share this post


Link to post
Share on other sites

The error is:

Warning: number_format() expects parameter 1 to be double, string given in admin/edit_orders.php on line 1740

 

I guess the problem is because I have AJAX-AttributeManager-V2.8.9 installed. They have been conflicting with each other cause same ID. Maybe someone have got a sollution? Thanx

OE an AJAX AM can't conflict. $order->totals[$i]['value'] has its value as database field. Possible your database fieldis not integer nor float. Try to typecast $order->totals[$i]['value'] to double.

Share this post


Link to post
Share on other sites

Great contribution, I have just installed the latest one. The order editor menu item does appear in admin but when I click on orders, I get a blank page.

 

What could be the problem?

 

Regards

 

Felix

Share this post


Link to post
Share on other sites

Hi there,

 

I'm unable to add another line in the order total. I'm trying to add a line to add a discount to an order and I hit the green plus button, add some words in the next line and when it updates it disappears and goes back to how it was.

 

Any ideas what I've done wrong? I'm sure this used to work a few years ago?!?

 

Cheers

 

Dave

Share this post


Link to post
Share on other sites

Setup: Order_editor latest with manual order contribution that only works when order_editor is installed.

 

Going fine scenario's:

--> frontend order --> details + edit: sort order of total is as we have it in modules --> order totals: module sort orders

1: subtotal

2: loworderfee

3: total

4: tax

*tax=4 last which is OK / the way we want it really.

 

I can add products after which the order editor updates fine.

 

But now:

--> use the manual order mod --> select a client --> continue --> Order totals all show 0,00 and in the right sort order.

--> then I add a product --> order_editor updates BUT now changes the sort order somehow ( checked also in dbase and indeed, sort order values are changed in orders_total

NOW TAX is first instead of last....

after all are ok.

 

Don't think it is the manual order mod but something in the order_editor when order totals are 0 ?

 

Thanks!

 

Kookie

 

 

I have this same problem. I have checked my install, and even compared my edited files to the original oscommerce files, and the contrib files when provided. I cannot find a discrepancy which would cause this to happen. Additional information: It only happens when an order is created in admin. Customer side and order editor are both working the way they should. When creating a new order using manual order maker, the order totals box starts out looking like it should:

 

Subtotal

OT_Discount

Shipping

Tax

 

But then after I add a product, the tax suddenly jumps to below the subtotal, and calculates without the discount or shipping figured in. Of course I want to charge tax after the discount, and by state law I have to charge tax on shipping, so I desperately need this fixed!

 

Has anyone found a solution? Or can anyone provide any insight as to why this is happening?

Share this post


Link to post
Share on other sites

Since OE 5.0.7 too many unusable contribs are integrated into OE. Some of them are poorly integrated, but... explain a bit more, what happens after you click Delete checkbox?

Share this post


Link to post
Share on other sites

Hi guys,

 

I apologize in advance if this question has been already answered.

I have been through the thread and I have found many other person with similar problem, but I could not find a proper solution.

 

I have CCGV add-on deployed on my website (ot_coupon, ot_gv) unfortunately when I add a new product using order editor and then update, my discount is not applied at all(it is not sum up either though).

 

i.e.

 

Subtotal 36.50

Discount 3.28

Shipping 5.10

Total 41.60

 

Are those kind of coupon supposed to work out of the box?

In the description of this add on seems so:

 

"

PLUS! The ability to add products to an existing order, reliably update order totals, insert coupons & discounts & extra fees, update tax on individual products, edit product information on individual orders, update product quantities, product prices, and more!"

 

Is there anything that need to be change other than what is described on the instructions?

 

Can anyone point out where should I look to fix this issue?

Thanks in advance for your help.

 

Kind Regards

 

JK

Share this post


Link to post
Share on other sites

Here and here you found a solution for only SOME ordre totals modules to work with OE.

 

On one page of the topic I descripbed my point about CCGV issue. There is NO solution to OE + CCGV. And this solution is very-very hard to implement, because too many possible situations may happen if you edit order with Coupon.

Share this post


Link to post
Share on other sites

Hi RusNN,

 

Thanks for your feedback. It is really appreciated.

I saw those two threads already but were not really applicable in my case.

 

I agree with you that CCGV does so many checks that implements the same functionality in the back-end will be too complicated.

In the other hand I do not think a shop administrator would really need the same type of functionality.

It would be enough for me for example, to find a way to subtract from the subtotal: in that way you could easily simulate a gift, a discount coupon or a free shipping coupon.

 

Maybe set a variable to 0 and when calculate the order total always substract that variable.

If a discount is not applied then the total would remain the same (-0) if some discount is applied the the variable will be substract to the subtotal simulating the discount.

 

I supposed it could be simply done with:

 

if (var is set) then var=value

else var=0;

 

ordert_total=subtotal-var

 

Does it make any sense?

 

Do you know which part of the code I should change to get that type of functionality?

Do you know any other possible workaround?

 

Thanks in advance for your feedback.

Cheers

JK

 

 

Here and here you found a solution for only SOME ordre totals modules to work with OE.

 

On one page of the topic I descripbed my point about CCGV issue. There is NO solution to OE + CCGV. And this solution is very-very hard to implement, because too many possible situations may happen if you edit order with Coupon.

Share this post


Link to post
Share on other sites

I supposed it could be simply done with:

 

if (var is set) then var=value

else var=0;

 

ordert_total=subtotal-var

 

Does it make any sense?

 

Hi, farbor!

 

Unfortunatelly it is not so easy as it may apper on first look. Each total is calculated automatically by supplied module. We can't simple override that logic or we must make too many mocks in each order_total module. Your way is tempting, but I'm afraid it is not real in way OE works.

 

To implement your way we should realise new field for a variable which will be control CCGV the way you described. After that we should somehow realise logic above... I can't found a solution to it yet. When I realise 2 that posts for other ot modules it took many time to understand how get this modules work automatically correctly.

 

May be I'd like the other way. I just think about and I have no time to think carefully. We may change CCGC order total modules so, it will "see" admin or client side it working. On client side it works as usual, but on admin side we slightly change logic. We will use the varable you spoke and work according to this variable.

 

But this way is only for orders created manually on admin. And we still need a feature that will automatically calculate totals for order which clients makes themselves. This is the real headache. But I think it is possible to implement. Hard, but real.

 

Good idea with a variable!

Edited by RusNN

Share this post


Link to post
Share on other sites

Hi, farbor!

 

Unfortunatelly it is not so easy as it may apper on first look. Each total is calculated automatically by supplied module. We can't simple override that logic or we must make too many mocks in each order_total module. Your way is tempting, but I'm afraid it is not real in way OE works.

 

To implement your way we should realise new field for a variable which will be control CCGV the way you described. After that we should somehow realise logic above... I can't found a solution to it yet. When I realise 2 that posts for other ot modules it took many time to understand how get this modules work automatically correctly.

 

May be I'd like the other way. I just think about and I have no time to think carefully. We may change CCGC order total modules so, it will "see" admin or client side it working. On client side it works as usual, but on admin side we slightly change logic. We will use the varable you spoke and work according to this variable.

 

But this way is only for orders created manually on admin. And we still need a feature that will automatically calculate totals for order which clients makes themselves. This is the real headache. But I think it is possible to implement. Hard, but real.

 

Good idea with a variable!

Edited by ogwinilo

Share this post


Link to post
Share on other sites

I have re-installed the latest OE, I do get the OE interface in admin with the various options there. But I still get a blank page on clicking of 'orders' under customers in admin.

 

Am I looking at the wrong place? Where could there be a mistake?

 

Thanks in advance

 

Felix

Share this post


Link to post
Share on other sites

Happy New Year to all :)

 

I have tried to find the answer to why when i click "new order email" button it only send an empty email to customer?

The customer recive an blank email with only: Your order has been updated.

 

Doesnt it has have to inklude all of the order information such as totals an so on in it?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I installed the order_editor_5_0_9 and does not work ?????

 

basic software: 2.2rc2a

Other add-ons ajax work perfectly.

 

if true use of AJAX is not doing anything

 

if false use of AJAX adds product, it recalculates, but the javascript / plus.gif buttons do not work

I use the shipping / table and I do not recalculate

ot_surcharge is installed and it does not count

 

What do you think went wrong?

 

Oe_autoinstaller installed it and it did not work.

 

Please help me !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites

not sure if I am posting this in the correct thread.

 

I have order editor 1.5.8a installed along with manual order maker.

 

When I create a new order from an existing customer, the fields are populated in the new order ok but when I click save and I am taken to the edit_order screen all the fields are blank.

 

I know the order is there as it shows up in my customers order history but again with all the fields blank.

 

Is this a fault if the order editor or manual order maker?

 

 

Any help would be appreciated

 

Andy

Share this post


Link to post
Share on other sites

When I click "add a Product" an emty popup apears with a browser server error. The file edit_orders_add_product.php is uploaded on the server and is editable in dreamweaver(I havn't edited it). I tried looking through the thread with no results, anyone with an idea to what could be wrong?

 

Filenames are edited and everything is probably done according to the instructions. Ajax and SPPC are activated.

Share this post


Link to post
Share on other sites

Oe_autoinstaller installed it and it did not work.

 

Please help me !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

What's this? Restore from backup and install OE manually. The autoinstaller for OE is for too old version.

Share this post


Link to post
Share on other sites

not sure if I am posting this in the correct thread.

 

I have order editor 1.5.8a installed along with manual order maker.

 

When I create a new order from an existing customer, the fields are populated in the new order ok but when I click save and I am taken to the edit_order screen all the fields are blank.

 

I know the order is there as it shows up in my customers order history but again with all the fields blank.

 

Is this a fault if the order editor or manual order maker?

Hi Andy

 

Manual Order Maker create an empty records in database for new order. You may see newly created order in your order list. The Order Editor only takes information provided by the Manual Order Maker. If OE works fine with other orders, so MOM fail to fill proper info in your database. Check installation of MOM, check your database fields. Check information in table ORDERS after you create new order through MOM. The line with orders_id=<NUMBER OF YOUR NEWLY CREATED ORDER> should contain information about your customer. If not, check installation of MOM or ask in proper thread.

Share this post


Link to post
Share on other sites

When I click "add a Product" an emty popup apears with a browser server error. The file edit_orders_add_product.php is uploaded on the server and is editable in dreamweaver(I havn't edited it). I tried looking through the thread with no results, anyone with an idea to what could be wrong?

 

Filenames are edited and everything is probably done according to the instructions. Ajax and SPPC are activated.

What error?

What browser?

Have you SPPC installed?

Does OE work before?

 

Try other browser, IE is good.

Check installation of OE.

Try to disable SPPC and add new product.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×