Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

I'm reading through this forum but does anyone know if its possible to update the products ordered and cost of an "existing order" before its finally captured in authorize.net? There are a million reasons why a customer would want to call back after making an order and making a request to adjust it. Is there a guide, tutorial, link, web site that talks about this very issue? Is it possible to adjust the current order without reordering everything all over again from either the store front or admin????

 

stock osCommerce charges the order at the time of placing an order. This contribution does not have a facility to make adjustments to the credit card payment after an order is edited. This contribution allows you to change the order after the charge has been made, so you must manually collect the customer's CC when you have them on the phone and make adjustments through the Authnet virtual terminal as needed by the order adjustment.

 

You would want to look for contribution that allows you to delay the processing of the CC until a time of your choosing. But then, how long to do wait for the customer to call about changes? 1 day? 2 days? Do you want to delay your order fulfillment to wait for those changes? Or maybe its better to simply get the card processed and the order shipped as quickly as possible.

 

You should also consider CC merchant agreements. If you are in the US, CC merchant policy is to not store the security code electronically. So if you use a contribution to delay processing the CC in order to allow for a phone call to change the order, then you are violating the merchant agreement. If someone were to break into your site while some of those card holders' info is still there, you could get a stiff penalty from Visa or MC.

Share this post


Link to post
Share on other sites

The state field was changed to a number 223 after adding a product. Has anyone encounter this problem?

For example the state filed shows California in Customer, Billing Address, and Shipping Address but then after adding a product, all 3 state fields are changed to number 223. see the picture here:

 

Thanks in advance

 

that's quite interesting. The version I'm working from (surfalot 18 Nov 2009) has a state dropdown list, it would not be possible for what you are describing.

Share this post


Link to post
Share on other sites

I'm currently running Order Editor v5.0.5 in a production environment.

 

I want to upgrade to the most recent version.

 

Is it recommended to apply each update one by one up to the current, or can I jump straight to the current?

 

Thanks

Share this post


Link to post
Share on other sites

I'm currently running Order Editor v5.0.5 in a production environment.

 

I want to upgrade to the most recent version.

 

Is it recommended to apply each update one by one up to the current, or can I jump straight to the current?

 

Thanks

 

if you understand how to work a file compare tool, jump. I've seen a couple strange comments since the v5.0.8 & 9, so if you have trouble with the latest, try the version I upped.

Share this post


Link to post
Share on other sites

that's quite interesting. The version I'm working from (surfalot 18 Nov 2009) has a state dropdown list, it would not be possible for what you are describing.

 

I was using the newest version: 5.0.9b Full and I also tried 5.0.7 both had the same problem. The problem actually lies in my old version of general.php which had an old version of function tep_get_zone_name as follows:

  function tep_get_zone_name($zone_id) {
   $zone_query = tep_db_query("select zone_name from " . TABLE_ZONES . " where zone_id = '" . $zone_id . "'");

   if (!tep_db_num_rows($zone_query)) {
     return $zone_id;
   } else {
     $zone = tep_db_fetch_array($zone_query);
     return $zone['zone_name'];
   }
 } 

 

which should be changed to the current function:

 

  function tep_get_zone_name($country_id, $zone_id, $default_zone) { 
   $zone_query = tep_db_query("select zone_name from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country_id . "' and zone_id = '" . (int)$zone_id . "'");
   if (tep_db_num_rows($zone_query)) {
     $zone = tep_db_fetch_array($zone_query);
     return $zone['zone_name'];
   } else {
     return $default_zone;
   }
 }

Share this post


Link to post
Share on other sites

The last version support it , but you must install Send HTML email V2- Otherwhise remove the buttom.

 

You must also to update database:

DROP TABLE IF EXISTS `eorder_text`;
CREATE TABLE `eorder_text` (
 `eorder_text_id` tinyint(3) unsigned NOT NULL default '0',
 `language_id` tinyint(3) unsigned NOT NULL default '1',
 `eorder_text_one` text,
 PRIMARY KEY  (`eorder_text_id, language_id`)
) ;

etc,etc,etc

 

when i trie to run the above on DB then i get

 

Fout

SQL-query:

 

CREATE TABLE `eorder_text` (

 

`eorder_text_id` tinyint( 3 ) unsigned NOT NULL default '0',

`language_id` tinyint( 3 ) unsigned NOT NULL default '1',

`eorder_text_one` text,

PRIMARY KEY ( `eorder_text_id, language_id` )

);

 

 

 

MySQL retourneerde:

 

#1072 - Key column 'eorder_text_id, language_id' doesn't exist in table

 

 

 

 

someone any idea

 

tnxs

Share this post


Link to post
Share on other sites

someone any idea

 

tnxs

 

the error in that sql should be corrected as follows:

 

DROP TABLE IF EXISTS `eorder_text`;
CREATE TABLE `eorder_text` (
`eorder_text_id` tinyint(3) unsigned NOT NULL default '0',
`language_id` tinyint(3) unsigned NOT NULL default '1',
`eorder_text_one` text,
PRIMARY KEY (`eorder_text_id`, `anguage_id`)
) ;

but my guess is there is more to this then adding the table.

Edited by surfalot

Share this post


Link to post
Share on other sites

the error in that sql should be corrected as follows:

 

DROP TABLE IF EXISTS `eorder_text`;
CREATE TABLE `eorder_text` (
`eorder_text_id` tinyint(3) unsigned NOT NULL default '0',
`language_id` tinyint(3) unsigned NOT NULL default '1',
`eorder_text_one` text,
PRIMARY KEY (`eorder_text_id`, `anguage_id`)
) ;

but my guess is there is more to this then adding the table.

tnxs and yes there is now i added the table i get

 

Fatal error: Call to undefined function tep_add_base_ref() in edit_orders_ajax.php on line 1144

 

again any idea

Share this post


Link to post
Share on other sites

tnxs and yes there is now i added the table i get

 

Fatal error: Call to undefined function tep_add_base_ref() in edit_orders_ajax.php on line 1144

 

again any idea

sure, use the version I uploaded. It works fine.

Share this post


Link to post
Share on other sites

wich one is that ?

 

tnxs

 

there is only one that was uploaded under my id.

Share this post


Link to post
Share on other sites

there is only one that was uploaded under my id.

 

is there an difference between version 5.0.7 and the one i installed 5.0.9 ?

 

tnxs again

Share this post


Link to post
Share on other sites

is there an difference between version 5.0.7 and the one i installed 5.0.9 ?

 

tnxs again

ok version 5.0.7 works :lol:

 

but now how do i get my email send in html in stead of in text :'(

 

tnxs

Share this post


Link to post
Share on other sites

ok version 5.0.7 works :lol:

 

but now how do i get my email send in html in stead of in text crying.gif

 

tnxs

 

have you installed an html email contribution? That is what the other person was saying near the top of the last page. The reason it wasn't working is that (I believe) the person that contributed that fail to mention what contribution you needed to install to make it work. Which, if that is the case, why the newer versions are blowing-up for folks.

 

I don't know what the difference is between the versions. I haven't had any time to evaluate them. You should check the changelog in the contrib packages, or use a compare tool on the folders.

 

All I can tell you is that I'm see a lot of weird questions about it's functionality and the contributors don't seem to be hanging around to support it.

Edited by surfalot

Share this post


Link to post
Share on other sites

have you installed an html email contribution? That is what the other person was saying near the top of the last page. The reason it wasn't working is that (I believe) the person that contributed that fail to mention what contribution you needed to install to make it work. Which, if that is the case, why the newer versions are blowing-up for folks.

 

I don't know what the difference is between the versions. I haven't had any time to evaluate them. You should check the changelog in the contrib packages, or use a compare tool on the folders.

 

All I can tell you is that I'm see a lot of weird questions about it's functionality and the contributors don't seem to be hanging around to support it.

 

yes i have Send html email 2.1

Share this post


Link to post
Share on other sites

Hi,

 

Is it possible someone could make a QPBPP patch for the Order Editor, like the SPPC patch??

As I'm not getting the correct prices when I add a product.

 

Thankyou very much in advance.

Share this post


Link to post
Share on other sites

I have a little problem after trying to add the first article to the basket...

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in ..../admin/edit_orders.php on line 569

Warning: Cannot modify header information - headers already sent by (output started at ..../admin/edit_orders.php:569) in ..../admin/includes/functions/general.php on line 70

 

I'm already working on a new clean shop...

added Admin Create Order just before!

 

Anyone an idea???

 

THX in advance...

Share this post


Link to post
Share on other sites

I have a little problem after trying to add the first article to the basket...

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in ..../admin/edit_orders.php on line 569

Warning: Cannot modify header information - headers already sent by (output started at ..../admin/edit_orders.php:569) in ..../admin/includes/functions/general.php on line 70

 

I'm already working on a new clean shop...

added Admin Create Order just before!

 

Anyone an idea???

 

THX in advance...

 

Hi I am having the exact same problem when I try to update the order with a new discount.

 

It returns:

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/shopand1/public_html/admin/edit_orders.php on line 463

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/shopand1/public_html/admin/edit_orders.php on line 463

 

 

Any solution on this?...havent been able to find one in the forums...

Share this post


Link to post
Share on other sites

Hi I am having the exact same problem when I try to update the order with a new discount.

 

It returns:

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/shopand1/public_html/admin/edit_orders.php on line 463

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/shopand1/public_html/admin/edit_orders.php on line 463

 

 

Any solution on this?...havent been able to find one in the forums...

 

What contrib version are you using and what osC version? Always try to include as much info as you can with your post. Maybe try the version I uploaded, as mentioned just above, there seem to be a number odd problems with the latest couple that have been offered.

Share this post


Link to post
Share on other sites

I have a little problem after trying to add the first article to the basket...

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in ..../admin/edit_orders.php on line 569

Warning: Cannot modify header information - headers already sent by (output started at ..../admin/edit_orders.php:569) in ..../admin/includes/functions/general.php on line 70

 

I'm already working on a new clean shop...

added Admin Create Order just before!

 

Anyone an idea???

 

THX in advance...

 

Details:

Core...

osCommerce Online Merchant v2.2 RC2a

 

Contribs...

  • Cash
  • cDynamic Meta Tags
  • Easy html Editor
  • Impressum1.1
  • PayPal ipn
  • Sitemap SEO
  • Skype Contact 1.0
  • Store Pick Up
  • TagCloud_2.0.2
  • ULTIMATE Seo Urls 5
  • Ultra Pics
  • Web 2.0 Scrolling Best Sellers
  • whats new box scrolling
  • Admin Create Account 1.0

 

problems with...

  • ManualOrderMaker v1.5.7 (don't running w/o order editor)
  • order_editor_5_0_9

 

edit_orders.php:

569: if ( (!in_array($ot_class, $written_ot_totals_array)) && (!in_array($ot_title, $written_ot_titles_array)) && (tep_not_null($ot_value)) && (tep_not_null($ot_title)) && ($ot_class != 'ot_tax') && ($ot_class != 'ot_loworderfee') ) { //7

Edited by wauziweb.de

Share this post


Link to post
Share on other sites

Details:

Core...

osCommerce Online Merchant v2.2 RC2a

 

Contribs...

  • Cash
  • cDynamic Meta Tags
  • Easy html Editor
  • Impressum1.1
  • PayPal ipn
  • Sitemap SEO
  • Skype Contact 1.0
  • Store Pick Up
  • TagCloud_2.0.2
  • ULTIMATE Seo Urls 5
  • Ultra Pics
  • Web 2.0 Scrolling Best Sellers
  • whats new box scrolling
  • Admin Create Account 1.0

 

problems with...

  • ManualOrderMaker v1.5.7 (don't running w/o order editor)
  • order_editor_5_0_9

 

edit_orders.php:

569: if ( (!in_array($ot_class, $written_ot_totals_array)) && (!in_array($ot_title, $written_ot_titles_array)) && (tep_not_null($ot_value)) && (tep_not_null($ot_title)) && ($ot_class != 'ot_tax') && ($ot_class != 'ot_loworderfee') ) { //7

 

in your admin modules, do you have any order totals enabled?

Share this post


Link to post
Share on other sites

in your admin modules, do you have any order totals enabled?

 

I have the Discount Coupon Module installed.

Ive noticed when a customer has applied the Discount Coupon code, the error occurs when I try to update the order with additional products and new discount amount.

 

If there is no discount coupon code applied, the order editor works fine.

Share this post


Link to post
Share on other sites

What contrib version are you using and what osC version? Always try to include as much info as you can with your post. Maybe try the version I uploaded, as mentioned just above, there seem to be a number odd problems with the latest couple that have been offered.

 

I am using version 5.0.7 the one that you uploaded. osC version 2.2.

 

I think the problem seems to be the Discount Coupon, it does not seem to take it into account when calculating the totals.

Share this post


Link to post
Share on other sites

I've no special order totals enabled...

paypal (not installed)

extra charge for small qtzy (not installed)

 

active...

shipping

subtotal

tax

total

Share this post


Link to post
Share on other sites

As i tried before here again the question about the the html mail in the order editor.

i tried for a few days now and i cant get it to work.

anybody have a good working order editor that sends out html mail please tell me how you did that.

 

regards wim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×