Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

Im wondering if someone could help me fix a bug in Order Editor. I'll pay for your work, just give me a price.

I

Order editor is a great tool, but it contains a bug that i can't fix.

 

In the order_totals table there are some fields that shold be included in the order, right ?

 

Usally ot_shipping and ot_tax. In my case i also have a third column that shold be added, it's called ot_fixed_payment_chg.

 

My orders are OK, but if i do edit an order the order editor doesn't add the value in the field ot_fixed_payment_chg

 

If you can help solve this bug i will be glad, let me know a price for this.

 

Thanks in advice.

 

The problem is discussed here in post 763

Share this post


Link to post
Share on other sites

Hello! I think what I have seen of the screen shots on this contrib. is great. The problem is that I installed the version from April 22 ...Nothing! On the admin side I get the order editor configuration options but when I go to an actual order to edit there is no button for me to edit anything. Did I miss something?

 

I have the following contributions entered (that I remember):

Prices for logged in customer only

Manual shipping cost editor

Ultimate SEO Urls

Who's Online Enhancement 3.4

Simple Template System

 

That's it! Nothing crazy. :blush: Can please tell me where I might have gone wrong? Thanks for any help!


If at first you don't succeed, restore your backup files!

Share this post


Link to post
Share on other sites
Hello! I think what I have seen of the screen shots on this contrib. is great. The problem is that I installed the version from April 22 ...Nothing! On the admin side I get the order editor configuration options but when I go to an actual order to edit there is no button for me to edit anything. Did I miss something?

 

That's it! Nothing crazy. :blush: Can please tell me where I might have gone wrong? Thanks for any help!

 

You don't have to click on a button to update.

 

It's ajax technology = Automatic update

Share this post


Link to post
Share on other sites

Hello

 

I apologise if this has already been dealt with elsewhere, but I have searched and found no answer.

 

I am running Version 5.05

 

When in order editor, anytime I try to change anything, I keep getting sent to the login page, which itself is displayed in the middle of my existing screen! Obviously something is not quite right....

 

I am running with SSL enabled - can anyone tell me if I need to make some adjustment somewhere to allow SSL and this contrib to work properly?

 

Thanks

Share this post


Link to post
Share on other sites
What I would do is take the function count_store_contents() as it is defined in that file:

function count_store_contents()
{
$count = 0;

foreach($this->internal_get_store_products() as $key => $product)
$count += $product['quantity'];

return $count;
}

and add it to admin/order_editor/cart.php. Then you can test it out and see what you get, most likely a similar error identifying another missing function. Add that one in the same manner and continue in this way until the errors dry up. It will take some fiddling with to get it right. You will probably have to mess with the variable names used as well, for instance I don't think $product['quantity'] has any value in the Order Editor cart.php file, I believe it's actually $this->contents[$products_id]['qty'].

 

For anyone using Auctionblox with Order Editor Please see the following thread from the Auctionblox forums for fixing the classes issues:

 

http://members.auctionblox.com/community/f...db5847c2892ccd4

 

This should help fo rthe majority of cases !

 

Regards,

 

JB

Share this post


Link to post
Share on other sites

I installed Order Editor 5.0.63.

 

My shipping module (Federal Express real Time Quotes) is not being loaded.

 

Is anyone using this module with the FedEx Shipping Contribution?

Share this post


Link to post
Share on other sites
I installed Order Editor 5.0.63.

 

My shipping module (Federal Express real Time Quotes) is not being loaded.

 

Is anyone using this module with the FedEx Shipping Contribution?

 

Nevermind. This was a "read the document, idiot" moment.

Share this post


Link to post
Share on other sites

Hello!

 

I have just installed Order Editor 5.0.63. It works fine. But i have got a little problem with the shipping tax.

Every time i add a new article to the order, the shipping tax turns to 0.00 and i can't change it. If i delete the article i have added before, everything is ok and i can change the tax.

 

Has everyone the same problem or a solution?

 

Thanks!

Share this post


Link to post
Share on other sites
Im wondering if someone could help me fix a bug in Order Editor. I'll pay for your work, just give me a price.

I

Order editor is a great tool, but it contains a bug that i can't fix.

 

In the order_totals table there are some fields that shold be included in the order, right ?

 

Usally ot_shipping and ot_tax. In my case i also have a third column that shold be added, it's called ot_fixed_payment_chg.

 

My orders are OK, but if i do edit an order the order editor doesn't add the value in the field ot_fixed_payment_chg

 

If you can help solve this bug i will be glad, let me know a price for this.

 

Thanks in advice.

 

The problem is discussed here in post 763

 

Bumping this one. Anyone interested to look at my problem ?

I'll pay for the solution :) Shoot me a PM

Share this post


Link to post
Share on other sites
Hi... I have a problem with my SPPC (4.16) and my Order editor (5.0.3) ..... When I edit an order.... I choice my product.. (the price behind the product name is ok) but I the invoice... it's always the special price (retail price)..

 

Do you have an idea ??

 

thanos you very much !!

 

Please... help me..

Share this post


Link to post
Share on other sites

Hello,

 

I installed this contribution working excellent.. Thanks for that but I found some small bug.. while choosing the payment method, if i select the cash on delivery it is asking for credit card details and if I choose credit card its not asking the credit card details i thnk its a minor bug. I hope you understood what i mean?

 

And is there any contribution which allows us take orders directly in the admin area.. this contribuion will able to edit the orders but i need somethng from the scratch? is it possible??

 

Thanks,

Share this post


Link to post
Share on other sites

Hello,

 

I am using 5.0.6, and when I edit an order, and add a product, when it goes to update_order in edit_orders.php I get a blank screen? Sorry, tried to search, but may have missed the answer.

 

Thanks JR

Share this post


Link to post
Share on other sites

Hello,

 

Blank page error was doe to this line,

 

Fatal error: Call to undefined function tep_get_products_special_price() in /home/virtual/var/www/html/includes/modules/shipping/freeamount.php on line 74

 

Which was doe to having the free shipping contribution installed. Fix for this is add this to the bottom of admin/includes/functions before the end ?>

 

Add:

 

function tep_get_products_special_price($product_id) {

$product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . " where products_id = '" . (int)$product_id . "' and status");

$product = tep_db_fetch_array($product_query);

 

return $product['specials_new_products_price'];

}

 

JR

Share this post


Link to post
Share on other sites

Hello,

 

Edit order and manual order (added on contribution) are working fine now. Was just wondering, what method people are using for processing the payment when order is created from admin or modified from admin. I understand when customer does complete checkout, it processes normally through payment modules, but how is payment taken if store owner processes order from admin? Is there another contribution?

 

Thanks JR

Share this post


Link to post
Share on other sites

Hello,

 

Is there a way to add a confirm button before order is actual sent? Currently as soon as an item is added to the order and I back out, saying the customer changes their mind, the order is already sent and I have to delete and restock items? Am I missing something?

 

Thanks Dom

Share this post


Link to post
Share on other sites
Bumping this one. Anyone interested to look at my problem ?

I'll pay for the solution :) Shoot me a PM

 

Akvario,

You don't need to pay me ;) but i have done the same for a field called products_cost so if you just make the same change for your fields, you should be fine.

In edit_orders_add_product.php around line 84 extend the query ($product_query = tep_db_query("select p.products_model, p.products_price, .....) with the field you need to include. Then at line 140 ($sql_data_array = array('orders_id' => tep_db_prepare_input($oID), ......) simple add the field to the array for insertion.

It works for me ;)

Paul

Share this post


Link to post
Share on other sites

I have order editor working fine and will now attempt to install manual order!

 

Can anyone tell me, if you are placing a manual order, do you have to create a customer account first?

 

Thanks

Share this post


Link to post
Share on other sites

I've installed this with discount codes contribution.

 

All working except when I edit an order and add/remove a product the discount amount is ignored and not applied (even though it is listed).

 

Any ideas?

2008-07-28_213706.jpg

Share this post


Link to post
Share on other sites

hello everybody,

 

order editor is a great contribution.

it almost runs perfectly.

but i have a problem that is a bit annoying.

as you can see here,

ot_table.gif

the language is mixed up.

i only need german but in order editor in the order totals listing the default language is english somehow.

as you can see, the german translation is working as all the table headings are in german.

and if i update anything in the order totals listing, it gets the correct language.

but normally i do not edit the total sum or the discount and shipping, so these remain english.

that's annoying because i have only german customers.

 

i have installed a lot contributions (15 or so) and as you can see here www.flockhaus.de, i highly customized our shop.

so i can say i am familiar with the innards of our system.

but i just can't find where to change this...

does anybody know how i could fix this?

that would be so great!!!

 

thanks in advance,

spoone (daniel)

Share this post


Link to post
Share on other sites

I have installed order_editor_5_0_63 but when I press Edit Button on the orders page I get nothing It shows"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request."

What to doooooooooooooooo?

Share this post


Link to post
Share on other sites

After installing order editor I am getting the following errors in modules I uninstalled the order editoe but still the error is there. Please help to resolve the problem.

 

"Payment Modules

 

 

 

Notice: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_STATUS - assumed 'MODULE_PAYMENT_AUTHORIZENET_STATUS' in /home/xxxxxx/public_html/includes/modules/payment/authorizenet.php on line 23

 

Notice: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_SORT_ORDER - assumed 'MODULE_PAYMENT_AUTHORIZENET_SORT_ORDER' in /home/xxxxxx/public_html/includes/modules/payment/authorizenet.php on line 24

 

Notice: Use of undefined constant MODULE_PAYMENT_AUTHORIZENET_ORDER_STATUS_ID - assumed 'MODULE_PAYMENT_AUTHORIZENET_ORDER_STATUS_ID' in /home/xxxxxx/public_html/includes/modules/payment/authorizenet.php on line 26

Authorize.net

 

Notice: Undefined property: sort_order in /home/xxxxxx/public_html/admin/modules.php on line 135"

Share this post


Link to post
Share on other sites

I have installed this module, works great except for 1 function.

 

the ot_lev_discount module from the order totals is calculated automatically

is there a way to disable this calculation

Share this post


Link to post
Share on other sites
Im running the latest version of this module and Im having some problems with one of my order total modules

 

I use a shipping insurance module to calculate shipping based on the courier company I use.

 

Now when I edit orders the ot_insurance information is not updated.

 

Any ideas?

 

Bump

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×