Jump to content
Latest News: (loading..)
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

Fix for:

Call to undefined function: tep_get_products_special_price() in /home/.../includes/modules/shipping/freeamount.php on line 74

 

Open:

admin/includes/functions/general.php

 

Add:

 

  function tep_get_products_special_price($product_id) {
$product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . " where products_id = '" . (int)$product_id . "' and status");
$product = tep_db_fetch_array($product_query);

return $product['specials_new_products_price'];
 }

:thumbsup:

 

Sklep Kaspersky

Edited by darkthal

Share this post


Link to post
Share on other sites
If you ever wanted to update any part of an order's information, add new products to an order, insert new information like coupons, change taxes on a specific product, and so on, here's the tool. I truly hope this makes life easier for some of you.

http://www.oscommerce.com/community/contributions,1435

- Jonathan

 

 

What if I want to take a phone order and put it in my cart... is this the contribution to use for that?

Share this post


Link to post
Share on other sites

I have the folowing problem:

 

in manual order editor, Tax is added before shipping and discounts,

and not includes the tax on shipping, and on discounts(negative tax)

 

I want to have it after shipping and discount.

What do i have to change for this?

 

I am not having this problem on orders that are created by the customers,

only with orders created from admin.

 

 

Also clicking or selecting the Shipping quotes has no effect working from a mac+firefox or safari.

 

oscom.jpg

Share this post


Link to post
Share on other sites

where or what file would i need to modify to remove the ability to edit "suburb" also i would like to add in there cvv2 under the credit card number for editting too. how would i do that.

 

thanks for your time

Share this post


Link to post
Share on other sites
I have the folowing problem:

 

in manual order editor, Tax is added before shipping and discounts,

and not includes the tax on shipping, and on discounts(negative tax)

 

I want to have it after shipping and discount.

What do i have to change for this?

 

 

 

Hi, having the same problem as you when adding discount or shipping costs the tax dosent recalculate. I used Freds workaround as a temporary fix, but this is not a very good solution.

Do anyone got a solution for this.


Best regards,

Henrik

Share this post


Link to post
Share on other sites

Can anyone tell me how to ADD tax to the following code in the Editor version 2.6.1,

i know it's an old version but works for me,

 

Line 420 - 426

File : edit-orders.php

 

 

					if (DISPLAY_PRICE_WITH_TAX != 'true') {
				//we don't add tax to the total here because it's already added to the subtotal
					$RunningTotal += $ot_value;
					}
					} else {
					$RunningTotal += $ot_value;
					}

Share this post


Link to post
Share on other sites

Hy djmonkey1,

 

are you here anymore?

 

I have installed the new version 5.0.6 and it works very well. The ajax Feature is very nice. Before i used 3.0.2.1.

A long time ago :) i asked about the implementation to work with attributes stock e.g. qtpro.

 

I could "update" my stock every time i change a order by hand, but it would be great if your contrib could do this....;)

 

 

best regards

Craxx;)

Share this post


Link to post
Share on other sites
Hy djmonkey1,

 

are you here anymore?

 

I love it when someone writes a mod and then disappears. I installed this on my site and I get an empty cart when I click on Add Product button. This use to work. What happened?

Share this post


Link to post
Share on other sites

Hy HallMarc, i only write an translation. Or i misunderstand you ?

 

And djmonkey1,

perhaps you are on holiday... or will i get an unswer?

 

best regards

Craxx;)

Share this post


Link to post
Share on other sites

@ Daan

 

did you fix your problems?

I have the same problems..Grrr:(

 

@djmonkey1

I don´t understand that on every version the tax problems etc. are not solved????

 

 

best regards

Craxx;)

Share this post


Link to post
Share on other sites
I am having this same problem. It happens with the shipping update and on long orders when a product quantity changes

 

I would really appreciate any help you could give me.

 

Cheers

Kes

 

Hi Kes,

 

Have a look at this post: http://forums.oscommerce.com/index.php?sho...32&st=2420#. It contains the fix (as, I believe, do newer versions of Order Editor). Essentially, the fix is to replace all the "require" statements with "include" statements.

 

DJmonkey is a little quiet at the moment, but to whoever said "I love it when someone writes a mod and then disappears.", you might take note that this thread is 132 pages long and DJ's been posting all the way through. My experience with him has been that he has been exceptionally helpful (ongoing tax bugs notwithstanding). Do try to be a little less ungrateful.

 

Max.

Share this post


Link to post
Share on other sites
Hello all,

 

I just intalled this great module (order_editor_5_0_6), but have folowing bug:

When I add product to order in selection popup window I have categories, names in my lithuanian language, but after I submit "add to order" - on order is english product name.

It's ok with english language on admin - all in english on popup selection, on order.

I have 2 languages on my store.

 

How resolve it?

I know, I can manualy rename product, but...

 

I also confirm that "add a product" function in order_editor_5_0_6 add English product name only. Does not support multilanguage.

It also recode "Order Totals" fields on the admin/edit_orders.php on the way like:

 

Стоимость всего:

 

Sergei

Share this post


Link to post
Share on other sites

Hi all,

does anybody use this module together with MultiGeoZone Shipping Contrib?

I keep getting errors saying

 

PHP Fatal error: Call to a member function show_total() on a non-object in /mysite/includes/modules/shipping/mzmt.php on line 138

which is

function determineTableMethod($geozone_mode) {

global $total_count, $shipping_weight;

 

$this->geozone_mode = $geozone_mode;

 

if ($this->geozone_mode == 'price') {

$this->order_total = $_SESSION['cart']->show_total(); ///138

} elseif ($this->geozone_mode == 'count') {

$this->order_total = $total_count;

} else {

$this->order_total = $shipping_weight;

}

 

return true;

}

 

Contrib:

http://forums.oscommerce.com/index.php?showtopic=119085

 

Any help appreciated!

Share this post


Link to post
Share on other sites

Just installed Order Edit everything works great except that this mod doesn't play well with the "Individual Product Shipping v4.3 mod"

 

When I click the edit button in the admin I get this error.

 

 

Fatal error: Call to undefined method shipping::get_shiptotal() in catalog/includes/modules/shipping/indvship.php on line 54

 

Anyone have any ideas on how to fix this?

 

The error above is referring to this line of code.

// class methods

  function quote($method = '') {
  global $order, $cart, $shipping_modules;


///////////ERROR BELOW THIS LINE
 $shiptotal = $shipping_modules->get_shiptotal();
 $indvcount = $shipping_modules->get_indvcount();

if (tep_not_null($shiptotal) || tep_not_null($indvcount) || $shiptotal == '0'){
  $this->quotes = array('id' => $this->code,
						'module' => MODULE_SHIPPING_INDVSHIP_TEXT_TITLE,
						'methods' => array(array('id' => $this->code,
												 'title' => MODULE_SHIPPING_INDVSHIP_TEXT_WAY,
												 'cost' => $shiptotal)));

  if ($this->tax_class > 0) {
	$this->quotes['tax'] = tep_get_tax_rate($this->tax_class, $order->delivery['country']['id'], $order->delivery['zone_id']);
  }

  if (tep_not_null($this->icon)) $this->quotes['icon'] = tep_image($this->icon, $this->title);
}
  return $this->quotes;
}

 

 

Can anyone please help?

Edited by redbulladdict

Share this post


Link to post
Share on other sites

Hi there

Awesome contribution, but one problem

 

Everything seems to be working fine ,

when i try to add product, successfully chosen the product, chose quantity , clicked add to order

 

i get a blank screen on add a product window,

 

refreshed the browser on the order editor , i see the order there,

 

anyway to auto close window and refresh browser ?

Share this post


Link to post
Share on other sites

Hello,

 

I installed the latest version. before I got 2.7.3. When I enter a value below the Sub-total, the sum will be automatic right in the total.

 

But with 5.06 I have to push the update button first. Is there a solution for this? Because I like the automatic sum.

 

When I change the quantity the rule will automatically change

Share this post


Link to post
Share on other sites

I'm using this with Protx.

 

When I manually add a new order - I have to refresh the browser to see the product I have added - however the sub-total and total remain as 0.

 

I can get a price to display if I add a second item and refresh again, but if I then try to pay for order using Protx, its says it can't be done as the value is 0.

 

How do I get products added to automatically show without refreshing, and how do I get the order value to recalculate on adding something to the order so I can take payment.

 

Thanks

Share this post


Link to post
Share on other sites
I'm using this with Protx.

 

When I manually add a new order - I have to refresh the browser to see the product I have added - however the sub-total and total remain as 0.

 

I can get a price to display if I add a second item and refresh again, but if I then try to pay for order using Protx, its says it can't be done as the value is 0.

 

How do I get products added to automatically show without refreshing, and how do I get the order value to recalculate on adding something to the order so I can take payment.

 

Thanks

 

i have this mostly working, but still cannot create a new invoice and pay using protx - it never picks up the price from the total - so it fails as it thinks the value is 0 what can I do to get this to work. I have read every thread in this discussion but have not found one with this problem or a solution.

 

Thanks

Share this post


Link to post
Share on other sites

I have been using order editor for some time now and I noticed a problem with the inventory not matching up lately. After investigation, I found that when editing an order, if you change the quantity of an item in the order and then click "Update", the inventory is reduced as you had just entered that item in for the first time.

 

Example: Item ( Screws, begining with an inventory amount of 20. )

 

I add- ( Screws, quantity 2 )

 

Inventory is now at 18.

 

I later edit the item "Screws" , I change the quantity to 3 then click update.

 

At this point, the inventory SHOULD BE 17 but it is ACTUALLY 15.

 

The system is disregarding the previous item and it is re-subtracting the entire quantity when you update anything.

 

Does anyone else notice this problem?? If so, is there a fix??

 

Thanks in advance for any help.

 

Jason

Share this post


Link to post
Share on other sites
Hello. I've been using this wonderful contribution for several clients' stores and it keeps getting better and better. Congratulations on a job well done! :thumbsup:

 

I just installed the latest version 5.0.6 on a new store for a client and all is fine, except when I activate the free shipping module, then I get this error when clicking the edit button on the orders listing:

 

Fatal error: Call to undefined function: tep_get_products_special_price() in /home/user/public_html/loja/includes/modules/shipping/freeamount.php on line 74

 

This is the function on that file:

 

		if (MODULE_SHIPPING_FREEAMOUNT_HIDE_SPECIALS == 'True') {
	  // 28-9-2005 Check for articles on special which should not get free shipment
	  // Adjust the cart total price for this
	  $total_specials = 0;
	  if ($cart->count_contents() > 0) {
		 $products = $cart->get_products();
		 for ($i=0, $n=sizeof($products); $i<$n; $i++) {
			if ($special_price = tep_get_products_special_price($products[$i]['id'])) {
			   $products_price = $special_price;
			   $total_specials += $products_price;
			}
		 }
	  }

	  $cart_total = $cart_total - $total_specials;
	}

 

and line 74 is

if ($special_price = tep_get_products_special_price($products[$i]['id'])) {

 

If I turn off the free shipping, the error doesn't show and I can edit the order as usual.

 

Any ideas on how to fix this?

 

Also a quick question: will this contribution work fine with the Separate Princing Per Customer contribution?

 

Tks for your help with this. :)

 

 

I had the same problem. It took me time to figure this out, but I just went to the free shipping module, and chose "false" under "Disable for Specials" and that fixed the problem.

Share this post


Link to post
Share on other sites

Hi,

 

I have some problems with the order editor (ajax enabled) and our nice german "umlaute" like ö ü ä.

 

Are there others with the same problem?

 

All ideas and solutions are welcome

 

kinde regards

 

peter

Share this post


Link to post
Share on other sites

To the poster earlier about adding/substracting by changing stock, you can add all you want to the line- but if you want to remove stock quantity from the line it seems you need to delete the item and add it again as it does not keep track of what the variable used to be. Or something like that.

 

Where I have a problem is with the CVV2 value and the order total.

 

The CVV2, I just added the needed items, but the order total in V5.0.5 is not working. Anything you do is reflected fine except in the actual order total at the bottom of the order. It never changes. You can add, subtract, put in negative numbers, etc. No matter. It does not update.

 

..and it emails them out wrong too. It's not just a screen refresh issue.

 

Someone earlier said something similar about a totaling issue and said they had to click the update button. I'll presume thats not with the ajax version. But the result here seems to be the same.

 

Perhaps it's in order_editor/order_total.php?

Share this post


Link to post
Share on other sites

I have just installed Order Editor 5.06 and I am having some problems. The Update button will appear the first time I log into the admin and select an order, but when I try to make a change, I will get the following error and the Update button will disappear:

 

Fatal error: Call to a member function on a non-object in /home/flintriv/public_html/includes/modules/order_total/ot_easy_discount.php on line 18

 

Can someone please help? Thanks

Share this post


Link to post
Share on other sites

I have installed mod: order_editor_5_0_6 (works great!!!! thank you!!!) to be able to use the manual order (from admin) mod: V1.4.2.

 

BUT For some reason I get an http 500 error when trying to access create_order.php through customer or order in admin???? Basicly this mod do not work for me.......

 

The edit function still works.

 

I'm fairly new to php and sql - have checked all relevant files - but can't find any reason to why it's not working????

 

I would love to be able to use this mod so I hope you can help!!! Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×