Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

Hello djmonkey1,

 

I get this error from every tooltip.

 

BoF

 

Have you modified anything at all in the file or is it fresh out of the contribution package?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Help

 

Installed the latest copy and all i get when i click edit is a blank page.

 

No Errors

 

I have also install Manual Order Maker on top and i can create a order which opens up edit_order.php with no problem.

but then when i try and add a product to the new order i get a blank page with no errors.

 

I have seen that some one had the same problem but i cant see a fix.

 

Any one have any idea where the problem might be?

 

thanks

Share this post


Link to post
Share on other sites
The installation instructions include steps for upgrading from previous versions. Look for this header:

 

Okay stupid question but where is that header you talking about? Sorry for being so unsure of things but like I said I don't want to be stupid I want to learn.

 

Judy

Share this post


Link to post
Share on other sites
The installation instructions include steps for upgrading from previous versions. Look for this header:

 

Okay stupid question but where is that header you talking about? Sorry for being so unsure of things but like I said I don't want to be stupid I want to learn.

 

Okay I think I found that just copy and paste that yes?

 

 

 

Judy

Share this post


Link to post
Share on other sites

Need help. can't delete the order.

 

I am new to Oscommerce

 

After installing the order editor.

 

It seems that i cannot delete the order.

 

when first click the "delete" button, it direct to a new page which you can choose to restock the quantity.

 

It was here that i cannot "confirm delete" the order.

 

When i click "delete" it directs to the order details instead of deleting the order.

 

Can someone pls help?

 

i have changed nothing, simply add the php given in the file cos i know nothing about php.

 

I am using the latest order editor v5.0.6 with two bug fixes that is last updated on 8 sep.

 

Thanks in advance.

Edited by shiawase

Share this post


Link to post
Share on other sites
Need help. can delete the order.

After installing the order editor.

 

It seems that i cannot delete the order.

 

when first click the "delete" button, it direct to a new page which you can choose to restock the quantity.

 

It was here that i cannot "confirm delete" the order.

 

When i click "delete" it directs to the order details instead of deleting the order.

 

Can someone pls help?

 

i have changed nothing, simply add the php given in the file cos i know nothing about php.

 

I am using the latest order editor v5.0.6 with two bug fixes that is last updated on 8 sep.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

When I try to add or remove a product, either using the ajax version or the non-ajax, the product gets added/removed correctly, but then all of the order totals (subtotal, tax, shipping, order total, etc) get set to 0. Any ideas?

Share this post


Link to post
Share on other sites
When I try to add or remove a product, either using the ajax version or the non-ajax, the product gets added/removed correctly, but then all of the order totals (subtotal, tax, shipping, order total, etc) get set to 0. Any ideas?

 

Ignore that, I upgraded from 5.0.3 to 5.0.6 and all is well.

Share this post


Link to post
Share on other sites
Open admin/edit_orders_ajax.php, find
'" . oe_iconv($_GET['comments'])  . "')");

change it to

'" . tep_db_input(oe_iconv($_GET['comments']))  . "')");

and see if it works any better.

 

DJ, that works perfectly! Thankyou once again :) :) :)

 

Max

Share this post


Link to post
Share on other sites
Need help. can't delete the order.

 

I am new to Oscommerce

 

After installing the order editor.

 

It seems that i cannot delete the order.

 

when first click the "delete" button, it direct to a new page which you can choose to restock the quantity.

 

It was here that i cannot "confirm delete" the order.

 

When i click "delete" it directs to the order details instead of deleting the order.

 

Can someone pls help?

 

i have changed nothing, simply add the php given in the file cos i know nothing about php.

 

I am using the latest order editor v5.0.6 with two bug fixes that is last updated on 8 sep.

 

Thanks in advance.

 

As far as I know Order Editor doesn't do anything to the delete button or it's functionality. All of that is contained within admin/orders.php which is only changed minimally.

 

Undo the changes that you made and start over.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
As far as I know Order Editor doesn't do anything to the delete button or it's functionality. All of that is contained within admin/orders.php which is only changed minimally.

 

Undo the changes that you made and start over.

 

Thanks for your reply. I did not change any of the coding, Basically. i just add the file and replace the old one.

 

I find it weird too! can someone pls help.

 

It seems that there is broken link with "delete" button.

Share this post


Link to post
Share on other sites

I try to add a order but the admin shows the follow advise:

 

Fatal error: Call to a member function on a non-object in /home/restricted/home2/site/public_html/loja/includes/modules/order_total/ot_qty_discount.php on line 53

 

Line 53 from ot_qty_discount.php:

 

$qty_discount = $this->calculate_rate($_SESSION['cart']->count_contents());

Share this post


Link to post
Share on other sites
Help

 

Installed the latest copy and all i get when i click edit is a blank page.

 

No Errors

 

I have also install Manual Order Maker on top and i can create a order which opens up edit_order.php with no problem.

but then when i try and add a product to the new order i get a blank page with no errors.

 

I have seen that some one had the same problem but i cant see a fix.

 

Any one have any idea where the problem might be?

 

thanks

 

any have an idea???

Share this post


Link to post
Share on other sites

Just wanna share my tought about this contrib, wich i use since 3 years now...

 

1)The new Add Product Module is worst than the last one, the one in ver 3, and very similar to original one, so very slow and incomplete.

2)The Shipping module is buggy, meaning that if u have special char in the shipping name or description (i used to have some html in it) the code get corrupted and if u made any modify to the tax box, everything will lost the description and/or everything will be set to zero...

3)The comment part (AJAX) is not working, and sometimes the ajax gif just stay there forvere, not updating the comment status and anything else

 

everything else seems fine, but just as it where with ver 2.9 with i will stick with till all these bugs will be fixed, or till i've got enought time to fix them myself.

 

Just my 2 cent. Enjoy this great contrib, wich save us lot of time during the working process.


my contribution: Alex's Contributions

Share this post


Link to post
Share on other sites

Hello,

 

i have installed this great contrib (v5.0.5 with updated installation instructions) a couple of days ago and it works fine. Thank you.

 

I just have one problem with my discount module (http://www.oscommerce.com/community/contributions,248/ v1.1) and with the shipping quote in the order totals table.

 

For example i change sub total from 150 to 100:

Sub Total: 100.00

Shipping: 3.45

Discount 2%: -3.07 <- the discount never changes - this is 2% of 153,45

Net Amount: 103.45 <- the discount is not deducted (this is http://www.oscommerce.com/community/contributions,1926/)

Tax 19%: 19.65 <- this is 19% of 103,45

Total: 123,10 <- 103,45 + 19,65

 

The correct values should be:

Sub Total 100.00

Shipping 3.45

Discount -2.07

Net Amount 101.38

Tax 19.26

Total 120.64

 

I have read that there is a fix for ot_payment for older versions of order editor but i didnt manage to apply this fix to this version.

 

The other problem is that with every change (price, quantity, add a product, delete a product) the shipping amount is reduced by 19%. 3,45 -> 2,90 -> 2,44 -> 2,05 -> 1,72 ...

This is a minor problem. When i choose the shipping qoute via radio button the correct value is restored.

 

I hope you can help me. Thank you.

Share this post


Link to post
Share on other sites

Hi ive just installed the new version of order editor, my problem is when i click Add Product a pop up window displays the following repeatedly about 20 times

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /*****/*****/*****/catalog/admin/includes/functions/general.php on line 186

 

ive search everywhere to find a solution but cant find one... pls help

 

 

thanks

 

Claire

Share this post


Link to post
Share on other sites
Hi ive just installed the new version of order editor, my problem is when i click Add Product a pop up window displays the following repeatedly about 20 times

 

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /*****/*****/*****/catalog/admin/includes/functions/general.php on line 186

 

ive search everywhere to find a solution but cant find one... pls help

thanks

 

Claire

 

Did you find a fix to this issue? I also noticed that is you have the Discount Coupon mod installed and add another product the discount is not recalculated. Anyone else having this issue?

 

Allen

Share this post


Link to post
Share on other sites

Hello,

 

I installed 5.0.6 and works great. Only problem is when I add a custom field to the order total with a minus value it substracts it from the order total and not order SUBtotal.

 

Example:

 

 

Subtotal: 100

custom : -15

TAX 19%: 19

Total : 104

 

What happens here is simply this: 100+19= 119-15= 104

 

This what I would like:

 

Subtotal: 100

custom : -15 (meaning that subtotal is now 85)

TAX 19%: 16.15 (TAX changed because subtotal changed)

Total : 101.15

 

What happens here is this: 100-15= 85+16.15(19% of 85)= 101.15

 

Is this an order editor bug?

Do I have to alter order editor's code to realise this? Or has this been solved?

 

Thanks,

David

Share this post


Link to post
Share on other sites

Hey guys,

 

I've just finished the install and 99% of everyting is looking good!!

 

But in the top it says this error:

Warning: Division by zero in /home/XXXXXXX/public_html/admin/order_editor/shipping.php on line 61

 

Warning: Division by zero in /home/XXXXXXX/public_html/admin/order_editor/shipping.php on line 62

 

I dunno everything seems ok and working ok but what's up with the Divsion by zero error?

 

Hope someone can help me out.

 

Nigel

 

UPDATE:

I just removed those two lines and it's working fine now. It must be from when I removed something from some contribution....

 

This is what I took out:

if ($shipping_weight > SHIPPING_MAX_WEIGHT) { // Split into many boxes

$shipping_num_boxes = ceil($shipping_weight/SHIPPING_MAX_WEIGHT);

$shipping_weight = $shipping_weight/$shipping_num_boxes;

}

Edited by Tsuri Japan

Share this post


Link to post
Share on other sites

First of all, thank you very much for this highly sophisticated order editing tool.

 

I installed version 5.0.6 today. Now I'm checking that it works as it should but it does something with the sort order of the order total modules which I don't like. I had a look at the edit_orders_ajax.php but honestly, I don't want to mess it up so I better ask how I can change the sort order.

 

The original orders have the following order:

ot_subtotal 1

ot_shipping 3

ot_total 25

ot_netto 30

ot_tax 35

 

I want to display ot_netto and ot_tax at the end as ot_subtotal, ot_shipping and ot_total are all including tax.

 

After making changes to the order with order editor, the new sort order is as follows:

ot_subtotal 1

ot_tax 2

ot_shipping 3

ot_total 4

ot_netto 5

 

The calculation seems to be correct at first glance but how do I move the ot_tax to be listed after ot_netto?

 

Thanks in advance.

 

abra


The First Law of E-Commerce: If the user can't find the product, the user can't buy the product.

 

Feedback and suggestions on my shop welcome.

 

Note: My advice is based on my own experience or on something I read in these forums. No guarantee it'll work for you! Make sure that you always BACKUP the database and the files you are going to change so that you can rollback to a working version if things go wrong.

Share this post


Link to post
Share on other sites
How would you incorporate this into the order editor so that the admin side use quantity price breaks?

I was looking at the code in the cart and I'm curious, to implement the Quantity price break I think I just need to edit the cart. Would I be correct in this assumption?

Share this post


Link to post
Share on other sites

In the confirmation mail after changing an order the prices are showed as EUR100,00.

I would like to change this in €100,00. How can I do this?

 

For the record the problem only occurs when changing an order with the contribution order editor and

sending a new order confirmation. In the original order confirmation it shows the € symbol.

 

Krishly

Share this post


Link to post
Share on other sites

Hello. I've been using this wonderful contribution for several clients' stores and it keeps getting better and better. Congratulations on a job well done! :thumbsup:

 

I just installed the latest version 5.0.6 on a new store for a client and all is fine, except when I activate the free shipping module, then I get this error when clicking the edit button on the orders listing:

 

Fatal error: Call to undefined function: tep_get_products_special_price() in /home/user/public_html/loja/includes/modules/shipping/freeamount.php on line 74

 

This is the function on that file:

 

		if (MODULE_SHIPPING_FREEAMOUNT_HIDE_SPECIALS == 'True') {
	  // 28-9-2005 Check for articles on special which should not get free shipment
	  // Adjust the cart total price for this
	  $total_specials = 0;
	  if ($cart->count_contents() > 0) {
		 $products = $cart->get_products();
		 for ($i=0, $n=sizeof($products); $i<$n; $i++) {
			if ($special_price = tep_get_products_special_price($products[$i]['id'])) {
			   $products_price = $special_price;
			   $total_specials += $products_price;
			}
		 }
	  }

	  $cart_total = $cart_total - $total_specials;
	}

 

and line 74 is

if ($special_price = tep_get_products_special_price($products[$i]['id'])) {

 

If I turn off the free shipping, the error doesn't show and I can edit the order as usual.

 

Any ideas on how to fix this?

 

Also a quick question: will this contribution work fine with the Separate Princing Per Customer contribution?

 

Tks for your help with this. :)

Edited by Patty

Patty

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×