Jump to content
jhilgeman

NEW! Complete Order Editing Tool!

Recommended Posts

Aha... yes, the common thread running through these orders, which i didn't notice until you said above, is that the items ordered have been deleted recently from the catalogue. I wouln't have have noticed the problem before as it's only at this time of year that new 2008 lines become available from brands and I'm doing a lot of adding new and a lot of deleting old lines.

 

I'll give the fix a go and let you know in a moment...

 

Cheers

 

Dave

Share this post


Link to post
Share on other sites
worked a treat :)

 

Thanks for your rapid response (as usual)

 

Cheers

 

Dafve

 

I haven't found any mention of this problem after searching the forum any help would be appreciated :)

 

running I believe the latest order editor and a few other minor mods.

 

when I create a new customer in admin/customers the new customer doesn't show on the admin customers page.

I can see the new order and get to the new customers detail and edit options.

Just wondering if there is a fix for this or if it is a problem with my install.

 

TIA Thomas0012

Share this post


Link to post
Share on other sites
I haven't found any mention of this problem after searching the forum any help would be appreciated :)

 

running I believe the latest order editor and a few other minor mods.

 

when I create a new customer in admin/customers the new customer doesn't show on the admin customers page.

I can see the new order and get to the new customers detail and edit options.

Just wondering if there is a fix for this or if it is a problem with my install.

 

TIA Thomas0012

 

 

**Sorry also have Manual order maker installed

 

I haven't found any mention of this problem after searching the forum any help would be appreciated :)

 

running I believe the latest order editor and a few other minor mods.

 

when I create a new customer in admin/customers the new customer doesn't show on the admin customers page.

I can see the new order and get to the new customers detail and edit options.

Just wondering if there is a fix for this or if it is a problem with my install.

 

TIA Thomas0012

Share this post


Link to post
Share on other sites
**Sorry also have Manual order maker installed

 

I haven't found any mention of this problem after searching the forum any help would be appreciated :)

 

running I believe the latest order editor and a few other minor mods.

 

when I create a new customer in admin/customers the new customer doesn't show on the admin customers page.

I can see the new order and get to the new customers detail and edit options.

Just wondering if there is a fix for this or if it is a problem with my install.

 

TIA Thomas0012

 

I am in the wrong thread sorry

Share this post


Link to post
Share on other sites
worked a treat :)

 

Thanks for your rapid response (as usual)

 

Cheers

 

Dafve

 

You might run into a problem with tax calculations- since the item is no longer stored in the database, it no longer has a tax class assigned to it. The taxes will still be calculated, but for the products deleted the name of the tax field will simply be "Tax" instead of the real name of whatever the appropriate tax class/rate may be.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Has anyone gotten the latest version to work with auctionblox?

 

Getting Fatal error: Call to undefined function: count_store_contents() in /home/xxx/public_html/includes/modules/shipping/fixed.php on line 512

when attempting to access edit_orders.php. It's related to the fixed shipping module which when turned off, doesn't cause the error.

Share this post


Link to post
Share on other sites
Has anyone gotten the latest version to work with auctionblox?

 

Getting Fatal error: Call to undefined function: count_store_contents() in /home/xxx/public_html/includes/modules/shipping/fixed.php on line 512

when attempting to access edit_orders.php. It's related to the fixed shipping module which when turned off, doesn't cause the error.

 

Post a link to the contribution that provides the file includes/modules/shipping/fixed.php.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Just some questions if you don't mind.

 

I am not a programmer, but I follow directions well.

 

I know nothing at all about how to back up the data base so that's the first question I have

 

I know nothing at all about that SQL thing, I have added things to it with another contribution, but I just had to copy it to my FTP side and once it was there I opened the website and then deleted it from the FTP.

 

Now I read the instructions and I think I can do everything looked pretty clear to me but before I do it I have to understand the two things here.

 

Great Grandma trying

 

Judy

Share this post


Link to post
Share on other sites
Just some questions if you don't mind.

 

I am not a programmer, but I follow directions well.

 

I know nothing at all about how to back up the data base so that's the first question I have

 

I know nothing at all about that SQL thing, I have added things to it with another contribution, but I just had to copy it to my FTP side and once it was there I opened the website and then deleted it from the FTP.

 

Now I read the instructions and I think I can do everything looked pretty clear to me but before I do it I have to understand the two things here.

 

Great Grandma trying

 

Judy

 

You can back up your database using osCommerce by going to Admin->Tools->Database Backup. I recommend storing the backups locally as well as on the server (ie, keep local backups of your backups).

 

In order to install Order Editor you must be able to modify your database. You should be able to login to your database and access it with a tool such as phpMyAdmin. If necessary ask your webhost how to access your database.

 

Once you have accessed your database, if you are using phpMyAdmin you should see a row of tabs across the top of the right hand frame. One of these tabs should say SQL. Click on that tab; once you are viewing the SQL pane you can copy and paste the entire SQL command into the text box and hit the "go" button. That should be it.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
The contribution that provides the particular shipping module is at http://www.auctionblox.com.

It's not as simple as adding that function to the /functions/general.php file, I tried that but it

didn't work.

 

The fixed.php code is as follows:

 

Does this module provide instructions for modifying the file catalog/includes/classes/shopping_cart.php?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

I have a problem with all the special characters é è ê ë with your contribution order_editor (the last version 02/09/2007).

 

When I write Joël it appears J&ael WHY ?

 

I'm in Latin 1 Swedish interclassement with my mysql 5.5 database

 

Could you explain me how to do to change that problem ?

 

Thanks a lot

Edited by jokyler

Share this post


Link to post
Share on other sites
I have a problem with all the special characters é è ê ë with your contribution order_editor (the last version 02/09/2007).

 

When I write Joël it appears J&ael WHY ?

 

I'm in Latin 1 Swedish interclassement with my mysql 5.5 database

 

Could you explain me how to do to change that problem ?

 

Thanks a lot

 

I am unable to re-create this problem on my testing server. Make sure that you have iconv() compiled on your server; go to Admin->Tools->Server Info->check for "with iconv" listed in the "Configure command" section near the top.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

My Command files ....

 

'./configure' '--enable-discard-path' '--with-config-file-path=/usr/local/lib' '--enable-sigchild' '--with-pcre-regex=/usr' '--enable-magic-quotes' '--enable-short-tags' '--with-exec-dir=/home/' '--with-openssl=/usr' '--disable-rpath' '--enable-libgcc' '--disable-pic' '--with-zlib=/usr' '--enable-bcmath' '--enable-calendar' '--with-curl=/usr' '--with-gdbm=/usr' '--with-db3=/usr' '--enable-dbase' '--enable-xslt=/usr' '--with-xslt-sablot=/usr' '--with-dom=/usr' '--with-dom-xslt=/usr' '--with-kerberos' '--with-dom-exslt=/usr' '--enable-exif' '--enable-mbstring' '--enable-mbregex' '--enable-filepro' '--enable-ftp' '--with-ming=/usr/local' '--with-gd' '--with-expat-dir=/usr' '--enable-gd-native-tt=/usr' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-ttf=/usr' '--with-freetype-dir=/usr' '--with-t1lib=/usr' '--with-gettext=/usr' '--with-imap=/var/log/ovh/imap-2004g/' '--with-imap-ssl=/var/log/ovh/imap-2004g/' '--with-mcrypt=/usr' '--with-mhash=/usr' '--with-mysql=/usr' '--with-mysqli=/usr/bin/mysql_config' '--with-pdflib=/usr/local/' '--with-jpeg-dir=/usr' '--with-png-dir' '--with-tiff-dir' '--enable-trans-sid' '--with-regex=system' '--enable-sysvsem' '--enable-sysvshm' '--with-xpm-dir=/usr' '--with-zziplib=/usr' '--enable-wddx' '--with-zip=/usr/lib' '--with-sablot=/usr' '--enable-inline-optimization' '--with-gnu-ld' '--enable-soap' '--with-pspell' '--with-gmp'

 

Could I send you my admin page for you to see my problem ? (if you want)

Share this post


Link to post
Share on other sites
My Command files ....

 

Could I send you my admin page for you to see my problem ? (if you want)

 

What happens if you open admin/order_editor/functions.php and change

  function oe_iconv($string) {
if (function_exists('iconv')) {
   return iconv('UTF-8', CHARSET . '//TRANSLIT', $string);
	} else {
  return $string;
}
 }

to

  function oe_iconv($string) {

   return iconv('UTF-8', CHARSET . '//TRANSLIT', $string);

 }


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

I change my name and BAM....

 

Fatal error: Call to undefined function: iconv() in /home.10.10/mysite/www/catalog/admin/order_editor/functions.php on line 252

a été mis à jour

Edited by jokyler

Share this post


Link to post
Share on other sites
I change my name and BAM....

 

Fatal error: Call to undefined function: iconv() in /home.10.10/mysite/www/catalog/admin/order_editor/functions.php on line 252

a été mis à jour

Well, that's the problem then: you do not have iconv() compiled on your server. Contact your webhost and see if they can/will install it. It is my understanding that it is a very simple procedure.

 

You should undo the change that was made to admin/order_editor/functions.php.

 

As a workaround you can disable AJAX use in Order Editor by going to Admin->Configuration->Order Editor->Allow use of AJAX to update order information?->Set to 'false'


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Well, that's the problem then: you do not have iconv() compiled on your server. Contact your webhost and see if they can/will install it. It is my understanding that it is a very simple procedure.

 

You should undo the change that was made to admin/order_editor/functions.php.

 

As a workaround you can disable AJAX use in Order Editor by going to Admin->Configuration->Order Editor->Allow use of AJAX to update order information?->Set to 'false'

 

I have disable AJAX on Admin.

 

I don't have UPDATE BUTTON in my order to click ?

 

 

Grrr I'm disappointed because i need this contribution...

Share this post


Link to post
Share on other sites

After installing order editor my shipping charges were not being carried over from shipping to payment.

 

Once I commented out the changes in checkout_process.php it worked fine and so does order editor.

line 89

// 'shipping_module' => $shipping['id'], // order editor

 

 

My version of osc is heavily modified so I wouldn't know if this will affect anyone else.

 

The shipping mod I am using is flat rate.

 

Edward


I have moved on from oscommerce to magento and no longer monitoring this site.

Share this post


Link to post
Share on other sites
I have disable AJAX on Admin.

 

I don't have UPDATE BUTTON in my order to click ?

 

Grrr I'm disappointed because i need this contribution...

 

You should see an update button. Is there anything there at all, a blue bar, "Please click on "Update" to save all changes", etc?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
You should see an update button. Is there anything there at all, a blue bar, "Please click on "Update" to save all changes", etc?

 

 

NO.... nothing

Share this post


Link to post
Share on other sites
After installing order editor my shipping charges were not being carried over from shipping to payment.

 

Once I commented out the changes in checkout_process.php it worked fine and so does order editor.

line 89

// 'shipping_module' => $shipping['id'], // order editor

 

My version of osc is heavily modified so I wouldn't know if this will affect anyone else.

 

The shipping mod I am using is flat rate.

 

Edward

 

I have no idea how that one change to checkout_process.php could possibly cause the problem you're describing, but if it works for you that way that's great. If you don't charge tax on shipping you will never know the difference.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×