Jump to content
Sign in to follow this  
dreamscape

[Contribution] Dynamic MoPics v2.2

Recommended Posts

can someone point me in the right direction. I installed dynamic mo pics and I like it much better than mo pics but I still need the avalibility to upload the extra pictures from the admin when adding or editing a product. I do not want my customer to have access too any files other than the big and thumb folders,,, this is why i can not just use the file manager.

 

Thanks, Kirk


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

ahh never mind the above, hotscripts.com is a great place.

 

Now I just need to figure out how to make the pictures show up in the admin side when editing the product. I suppose If i can track dow all of the functions in the catalog side that make this contrib work I could integrate them into the admin side somehow


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites
Now I just need to figure out how to make the pictures show up in the admin side when editing the product. I suppose If i can track dow all of the functions in the catalog side that make this contrib work I could integrate them into the admin side somehow

 

the guts & logic of the entire thing is in includes/modules/dynamic_mopics.php... to get all the big images would be the same, just a few variable and path changes and those paths and variables are laid out in the popup_image.php that comes with the module.


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

cool, I am going to start on it later today and I will see if I can make that work.


Programmers are currently trying to make the next idiot proof software

 

The universe is currently trying to make the next idiot

 

The universe is winning

Share this post


Link to post
Share on other sites

Hi Dreamscape,

I'm hoping you can help me out. I'm getting a red x in my pop-up window. Whenn I look at the properties for the picture with the red x, it is pointing to the catalog/images/thumbs directory, not images_big.

 

Here is a link http://www.dragonbay.com/catalog/product_i...?products_id=63

 

My main image= catalog/images/crackerjack_pic.gif

 

NOTE: I would like all the thumbs to reside in catalog/images/thumbs

 

I've uploaded a test image with the following name configurations to

catalog/images/images_big

 

crackerjack_big.gif

 

 

 

catalog/images/thumbs

crackerjack_pic1.gif

 

 

My configurations look like this:

Big Images Directory images_big/

Thumbnail Images Directory thumbs/

Main Thumbnail In Thumb Directory true

Number of Pics per Row 4

Mo Pics Extension _pic

Main Big Pic Extension _big

Mo Pics Thumbnail Image Type gif

Mo Pics Big Image Type gif

 

Any assitance you can provide would be greatly appreciated.

 

Thanks

 

Mike


There is no spoon.

Share this post


Link to post
Share on other sites
Hi Dreamscape,

I'm hoping you can help me out. I'm getting a red x in my pop-up window. Whenn I look at the properties for the picture with the red x, it is pointing to the catalog/images/thumbs directory, not images_big.

 

Here is a link http://www.dragonbay.com/catalog/product_i...?products_id=63

 

My main image= catalog/images/crackerjack_pic.gif

 

NOTE: I would like all the thumbs to reside in catalog/images/thumbs

 

I've uploaded a test image with the following name configurations to

catalog/images/images_big

 

crackerjack_big.gif

 

 

 

catalog/images/thumbs

crackerjack_pic1.gif

 

 

My configurations look like this:

Big Images Directory images_big/

Thumbnail Images Directory thumbs/

Main Thumbnail In Thumb Directory true

Number of Pics per Row 4

Mo Pics Extension _pic

Main Big Pic Extension _big

Mo Pics Thumbnail Image Type gif

Mo Pics Big Image Type gif

 

Any assitance you can provide would be greatly appreciated.

 

Thanks

 

Mike

 

OK here we go again... not picking on you but I dunno why this is so hard to configure... and this is about the 3rd or 4th time I've explained it in this thread...

 

anyways...

 

Main Thumbnail In Thumb Directory should be false because your main thumbnail does not reside inside the thumbnail directory.

 

My main image= catalog/images/crackerjack_pic.gif

your main image should be crackerjack.gif.. the extra images should be crackerjack_pic1.gif, crackerjack_pic2.gif, etc...

 

if you want your main pic to be crackerjack_pic.gif, that is ok, but then you have to set Mo Pics Extension to nothing and your big main image would need renamed crackerjack_pic_big.gif OR you could set Main Big Pic Extension to nothing and then the main big image would only need to be named crackerjack_pic.gif


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

I am sorry to have you reiterate things, I did read the entire thread(twice). I tried all the different thing that were mentioned in the thread, however, none of the previous fixes worked for problems similar to mine, and am posting as a last resort.

 

I would like all of the images to reside in the thumbs/ directory which is why I left the Main Thumbnail In Thumb Directory setting to true.

 

I have changed the image name to crackerjack.gif as you suggested, however when i click on enlarge image I still get a red x..and the path to the file is catalog/images/thumbs/jack.gif .....as Iunderstand it it should be catalog/images/images_big/crackerjack_big.gif but its not workig that way.

 

sorry to be a nuisance,

 

Mike


There is no spoon.

Share this post


Link to post
Share on other sites
I am sorry to have you reiterate things, I did read the entire thread(twice). I tried all the different thing that were mentioned in the thread, however, none of the previous fixes worked for problems similar to mine, and am posting as a last resort.

 

I would like all of the images to reside in the thumbs/ directory which is why I left the Main Thumbnail In Thumb Directory setting to true.

 

I have changed the image name to crackerjack.gif as you suggested, however when i click on enlarge image I still get a red x..and the path to the file is catalog/images/thumbs/jack.gif .....as Iunderstand it it should be catalog/images/images_big/crackerjack_big.gif but its not workig that way.

 

sorry to be a nuisance,

 

Mike

 

right and it will not if Main Thumbnail In Thumb Directory is set to true.

 

because, 1st it will look for the big image. Since Main Thumbnail In Thumb Directory is true and the thumbs dir is "thumbs/" (7 characters), it will chop off the 1st 7 characters of the image name to get the actual image name (because in oscommerce to put product images in subdirs, you have to have the subdir as part of the name (thumbs/crackerjack.gif as the name for example)... so it thinks the actual filename base is jack.gif... so it is looking for images/images_big/jack.gif... it does not find it and attempts to display the thumbnail instead... again in this case you have Main Thumbnail In Thumb Directory true, but according to your info, it is not there and it is not part of the image name in admin, so of coarse a red X will appear...

 

I don't know how to make this simpler... if you have Main Thumbnail In Thumb Directory true, but the product is not setup in admin to point there, there is no possible way the module can work.


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Quick question...

 

If the Main Thumbnail In Thumb Directory is False...

 

Where would the popup image (big image) go and be named for the main image?

 

thanks!

Share this post


Link to post
Share on other sites
nm got it :) _big duh

yeah but you only need that if Main Big Pic Extension is defined as "big"... under normal conditions, I would think it should be blank and with the Main Thumbnail In Thumb Directory set to either true or false, the big image would still be: images_big/image.ext OR images_big/image_big.ext (if Main Big Pic Extension is set)


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Dreamscape,

 

Sorry to bother you, but I need a little explanation ( may be because of my poor english understanding :))

 

I'm running a Sept. 2002 OSC loaded 3 (Ian's ) with smal,medium,big image module installed

 

This is what I'd like to achieve :

 

Product_info.php should show a main image (as usual ) then , on top, a number of thumbnail of different pics of the same product . if you click a thumbnail, then it becomes the main image showned . If you click the main image, then the real size picture appeares in popup.

 

Now, I would like to store my images creating sub-folders for each product, so that they don't get messed up among them.

 

Would you be so kind to advice what version of Mopics should I use ? Dynamic ?

 

All images of the same products are the same dimensions. Do I need to create smaller version of secondary images ( resizing images ) or should I leave them as they are and thumbnail are automatically created ?

 

I've installed Dynamic Mopics, but all I get so far is a lovely "coming soon...." on top of product_info.....

 

Also, if I create subfolders for each products ( as in original installation ) do I have to build the following folder structure ?

 

...images/product_A/images_big/...

...images/product_A/thumbs/...

 

and so on for every item ?

 

Thanks for your help

 

Franco


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites

Where's everybody............. :unsure:


Outside links in signatures are not allowed!

Share this post


Link to post
Share on other sites

I thought I had this licked, but alas I was incorrect. Here is my problem:

 

I add the mopics,(extension _pic1 in the thumbs dir) but when I click to enlarge the added mopics, the enlarged picture defaults to the big picture for the main picture.

 

you can go here for an example:

Example please look here

 

Here is the setup:

 

main thumb: /images/QuatroTangbucket.jpg

click to enlarge mainthumb: /images/images_big/QuatroTangbucket_big.jpg

 

mopics: /images/thumbs/QuatroTangbucket_pic1.jpg

click to enlarge mopics: /images/images_big/QuatroTangbucket_big.jpg

 

Notice the bold text does not point to QuatroTangbucket_pic1.jpg as it should. I have added the QuatroTangbucket_pic1.jpg in the images_big and images directories in an attempt to get it to bring up the correct enlarged picture.

 

Mopics configuration:

 

Big Images Director: images_big/

Thumbnail Images Directory: thumbs/

Main Thumbnail In Thumb Directory: false

Number of Pics per Row: 4

Mo Pics Extension: _pic

Main Big Pic Extension: _big

Mo Pics Thumbnail Image Type: jpg

Mo Pics Big Image Type: jpg

 

Any guidance would be appreaciated

 

Thanks

 

Mike

Edited by mike_steinhoff

There is no spoon.

Share this post


Link to post
Share on other sites

Mike will you please post you popup_image.php file?


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Mike,

 

I think I know how you could fix your problem. I had that happening to me and I figure out how to fix it.

 

Look at this example:

 

If I have a picture name lets say "shoe.jp" and you have 3 different type of pictures of the same shoe all you have to do is this:

 

for the thumbnail of the shoe... you choose that in the administration side of your products when you add the information and weight.

 

now you want to have extra pictures on the bottom:

 

this is what you do,

 

First you need to name all 3 of your pictures name shoe like this and put them in the thumbs folder if they are thumbs.

 

/thumbs/shoe_pic1.gif

/thumbs/shoe_pic2.gif

/thumbs/shoe_pic3.gif

 

Now for the big parts (this pictures are your big pictures.. you don't have to add the big.

 

 

/images_big/shoe_pic1.gif

/images_big/shoe_pic2.gif

/images_big/shoe_pic3.gif

 

This is how it should look in your MOPics Side:

Big Images Directory                                                      images_big/ 

Thumbnail Images Directory                                            thumbs/ 

Main Thumbnail In Thumb Directory                                  false 

Number of Pics per                                                          Row 3 

Mo Pics Extension                                                            _pic 

Main Big Pic Extension   

Mo Pics Thumbnail Image Type                                        gif 

Mo Pics Big Image Type                                                  gif 

 

It all depends on you if you set your images as .gif, jpeg and so on.

I am not sure if that is what you need, but hopefully it gives you an idea.

Share this post


Link to post
Share on other sites

I think i made 2 little mistakes:

 

1 in the "shoe.jp" it should have being "shoe.gif" So it would not confuse you.

 

2. Putting the big images in the images_big directory... What I meant was that you don't have to put the extention _big if you fallow the QUOTE. Don't do this: shoe_pic1_big.gif Do This: shoe_pic1.gif

 

It would be easier if you put all your small pictures in the thumbs folder even if you are not going to use extra images, also with the big images... I personally find it easy to find the images quickly.

Share this post


Link to post
Share on other sites

I was up and around 3 nights to get this great mod working .. don't remember the steps myself now ... lol :P

 

I will track back the course and write something as a step by step thingie for everyone.

 

Dreamscape, the problem is that the latest mod's readme misses many lines of help that were found alright in version 1 of your impressive mod. I make a dought out of all the versions' help text and then roasted it in my mind for a while to get that working alright.

 

Whatever, this is a gr8 mod and deserves aplomb.

 

PP

Share this post


Link to post
Share on other sites

yes I did leave out the example scheme as it did not seem to help anyone anyways... lol... I thought it would but guess not...

 

part of the problem is also, expecially in reference to the products_info page, since nov2002, the variables & array names have changed a time or two and in MS2, the configure defines for certain paths have changed...

 

I try to accomodate for all, but it is ever difficult when there isn't a stable core (I use stable to mean non-changing - the variables, etc are the same from one version to the next)

 

Mike, if you could post your popup_image.php I am sure it is just a simple fix. Your configuration and filenames & locations appear correct.


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Sorry it took so long to get this posted...popup_image.php

 

<div align="center">
<a href="javascript:;" onclick="javascript:top.window.close();">
<?php
$thumb_len = ((MAIN_THUMB_IN_SUBDIR == 'true') ? strlen(IN_IMAGE_THUMBS) : 0);
$thumbs = ((MAIN_THUMB_IN_SUBDIR == 'true') ? IN_IMAGE_THUMBS : '');
$image_base = substr($products['products_image'], $thumb_len, -4);
$image_ext = '.' . BIG_IMAGE_TYPE;
$image_path = DIR_WS_IMAGES . IN_IMAGE_BIGIMAGES;
$image_addon = (($_GET['pic']) ? MORE_PICS_EXT . $_GET['pic'] : BIG_PIC_EXT);

/* 
  if the big image isn't shown unkomment the next line, and check the path:
  maybe you have to remove '/'. or adjust the path, depends on your configuration
*/
// echo DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext . '<br>';
if (is_file(DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext)) {
$image = $image_path . $image_base . $image_addon . $image_ext;
 } else {
$image = (($_GET['pic']) ? DIR_WS_IMAGES . IN_IMAGE_THUMBS . $image_base . $image_addon . $image_ext : DIR_WS_IMAGES . $thumbs . $image_base . $image_ext);
 }

 echo tep_image($image, $products_values['products_name'], '', '', 'lowsrc="images/pixel_trans.gif"');
?>
</a>
</div>


There is no spoon.

Share this post


Link to post
Share on other sites

sorry tried to edit the above..it would not let me...

 

 

DarkAngel:

 

I have the files setup that way :) I was unsuccesssful in figuring out a way to get the main pic in the thumbs dir. For posterity here is how I have setup the picture paths:

 

main thumb: /images/QuatroTangbucket.jpg

click to enlarge mainthumb: /images/images_big/QuatroTangbucket_big.jpg

(I realized that the _big only applied to the main image)

 

mopics: /images/thumbs/QuatroTangbucket_pic1.jpg

click to enlarge mopics: /images/images_big/QuatroTangbucket_pic1.jpg

 

 

Dreamscape:

 

Sorry it took so long to get this posted...popup_image.php

 

<div align="center">
<a href="javascript:;" onclick="javascript:top.window.close();">
<?php
$thumb_len = ((MAIN_THUMB_IN_SUBDIR == 'true') ? strlen(IN_IMAGE_THUMBS) : 0);
$thumbs = ((MAIN_THUMB_IN_SUBDIR == 'true') ? IN_IMAGE_THUMBS : '');
$image_base = substr($products['products_image'], $thumb_len, -4);
$image_ext = '.' . BIG_IMAGE_TYPE;
$image_path = DIR_WS_IMAGES . IN_IMAGE_BIGIMAGES;
$image_addon = (($_GET['pic']) ? MORE_PICS_EXT . $_GET['pic'] : BIG_PIC_EXT);

/* 
  if the big image isn't shown unkomment the next line, and check the path:
  maybe you have to remove '/'. or adjust the path, depends on your configuration
*/
// echo DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext . '<br>';
if (is_file(DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext)) {
$image = $image_path . $image_base . $image_addon . $image_ext;
 } else {
$image = (($_GET['pic']) ? DIR_WS_IMAGES . IN_IMAGE_THUMBS . $image_base . $image_addon . $image_ext : DIR_WS_IMAGES . $thumbs . $image_base . $image_ext);
 }

 echo tep_image($image, $products_values['products_name'], '', '', 'lowsrc="images/pixel_trans.gif"');
?>
</a>
</div>


There is no spoon.

Share this post


Link to post
Share on other sites

If you want it to work try it the way I posted it... If it doesn't work then, I don't know what else to tell you.

 

You should do a trial the way I explained it.

Share this post


Link to post
Share on other sites

Mike,

 

it is showing a big image and not the thumb, so I can rule out part of the script... the scripts seems to be breaking down here:

 

$image_addon = (($_GET['pic']) ? MORE_PICS_EXT . $_GET['pic'] : BIG_PIC_EXT);

 

I remember some people were having troubles with $_GET...

 

maybe try changing all instances of $_GET['pic'] to $HTTP_GET_VARS['pic']


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×