Jump to content
Sign in to follow this  
loxly

Easy Populate for MS2, and bug fixed for MS1

Recommended Posts

I haven't tested it yet, (bad me) but should work.

 

http://www.oscommerce.com/community/contributions,500

 

Added a readme with some answers to questions from the long threads here, more can be done but this is a first effort.

 

Anyone that would like to take a crack at summarizing the LONG ep thread and creating an FAQ, please email me at dc@loxly.com and I will add it to the package.

 

Also, anyone good at documentation that would like to take a crack at updating the easypopulate manual let me know.

 

This contrib is fabulous thanks to Tim Wasson and those before him, but it does have even more potential. Unfortuanately, it can't be done by one person :) If you have something to add or have added something to EasyPopulate, email dc@loxly.com so we can make it available to all.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites

I follower directions and get this when i try to download the generic catalog from osc ms2

 

1054 - Unknown column 'p.products_caratweight' in 'field list'



SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, p.products_caratweight as v_products_caratweight, p.products_gemlength as v_products_gemlength, p.products_gemwidth as v_products_gemwidth, p.products_gemheight as v_products_gemheight, p.products_dim_type as v_products_dim_type, p.products_length as v_products_length, p.products_width as v_products_width, p.products_height as v_products_height, subc.categories_id as v_categories_id, p.products_status as v_status FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id

 

any ideas

Share this post


Link to post
Share on other sites

Yes, there appear to be some custom fields in your version Deb....I've got Tim's latest version to work with MS2, and *appears to be working* correctly.

 

I'm not sure what all you had to change, but all i did in Tim's Latest version 2.6 was for any instance of:

tep_array_merge

 

I changed it to:

 

array_merge

 

And it uploads/downloads fine.

Share this post


Link to post
Share on other sites
i dont see any custom fields in my products table

 

Not you...In Deb (the contributor's) version of EP, there are many custom fields that are not in a standard OSC db.

Share this post


Link to post
Share on other sites
i dont see any custom fields in my products table

 

Not you...In Deb (the contributor's) version of EP, there are many custom fields that are not in a standard OSC db.

 

 

i got it from OScommerce downloads. where would i get a better one from

Share this post


Link to post
Share on other sites
Download the version listed before the one that loxly screwed up.

 

Done. It downloads fine but the tab delimited file doesnt work. it doesnt seperate the colums. at the begining of eact different indetifier is tv_

 

 

what is this about

Share this post


Link to post
Share on other sites
Download the version listed before the one that loxly screwed up.

 

Oh, i highly doubt its screwed up, i know she had been working very hard on it - Most likely, she forgot to take out all the customized fields. I'm going to take a look at what she has, and try and clean them up to a stock OSC db

Share this post


Link to post
Share on other sites

I also did the tep_array change to remove tep_

 

 

and now I get this error:

 

Fatal error: Cannot redeclare tep_get_tax_class_title() (previously declared in /home3/www/outposttrader/catalog/admin/includes/functions/general.php:1088) in /home3/www/outposttrader/catalog/admin/easypopulate_functions.php on line 34

 

 

any ideas on how to fix this one?


Rich

Share this post


Link to post
Share on other sites
I also did the tep_array  change to remove tep_

 

 

and now I get this error:

 

Fatal error: Cannot redeclare tep_get_tax_class_title() (previously declared in /home3/www/outposttrader/catalog/admin/includes/functions/general.php:1088) in /home3/www/outposttrader/catalog/admin/easypopulate_functions.php on line 34

 

 

any ideas on how to fix this one?

 

Look in /admin/easypopulate_functions.php at the bottom for this:

 

function tep_get_tax_class_title($tax_class_id) {

if ($tax_class_id == '0') {

 return TEXT_NONE;

} else {

 $classes_query = tep_db_query("select tax_class_title from " . TABLE_TAX_CLASS . " where tax_class_id = '" . $tax_class_id . "'");

 $classes = tep_db_fetch_array($classes_query);



 return $classes['tax_class_title'];

}

}

 

And delete it. Save. That worked for me. I suppose you could just comment it out too..

Share this post


Link to post
Share on other sites

Thanks Jason. Some else did a bug fix and forwarded the files.

 

The new versions are up and should work.

 

Glad for bug reports, but I repeated asked someone to post a corrected version and no one did. So I did, and it had a problem.

 

If you can do a better job, please do and share it with the rest of the community instead saying "I told you so" or "mine works".

 

:twisted:

 

Take a deep breath and say "this is a volunteer community with scripts written and updated by volunteers."


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
The new versions are up and should work.

 

Thanks! These seem to do the trick - had some odd problems at first, but nothing too weird...

 

Now - next question... :) How would one go about supporting product attributes with EP? I have about 100 products to put up now that all need the same four attributes added into them... EP is great in putting them up initially, but I dread having to go through them all to update the attributes...

 

Thanks for any help!

 

Kris

Share this post


Link to post
Share on other sites

Can't be done, it's been asked for and it just can't happen right now. It would take programming skill that I don't have. Attributes have a lot more than a couple of variables involved.

 

Try the Attribute Sorter/Copier contrib. That's what I started using.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
One quick question....will this work in conjunction with the big images contrib??

 

I'm not sure, you have to read the manual iincluded in the package to see all the contribs that support has been added for along the way.

 

I know it supports MoPics and Triple Images.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
Download the version listed before the one that loxly screwed up.

 

zaq, have you coded anything? **I edited myself before I posted** (it was a brilliant comeback but could have been misconstrued by small minds)

 

Seriously though, that crack makes you look bad. And it was bad advice because, as you saw, it created more problems and didn't solve any.

 

Please post positive comments and feedback and *heaven forbid* SOLUTIONS instead of onliners that insult yourself.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
i dont see any custom fields in my products table

 

Not you...In Deb (the contributor's) version of EP, there are many custom fields that are not in a standard OSC db.

 

 

i got it from OScommerce downloads. where would i get a better one from

 

Tank, go back and download the newer files. Someone gave me customized files when they sent a bug fix. The newest files will work just fine. Be sure to read the readme and the manual!!!


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
zaq, have you coded anything?

 

Many things. More than you'll ever know about in fact. I've been working with and hacking OSC since the very beginning.

 

**I edited myself before I posted** (it was a brilliant comeback but could have been misconstrued by small minds)

 

I wouldn't expect any less from you considering your history here of turning molehills into mountains. :roll:

Share this post


Link to post
Share on other sites

Do we see your work in the contribs section?


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
Do we see your work in the contribs section?

 

There's nothing that requires it to be there. :wink:

Share this post


Link to post
Share on other sites

Ah, you are correct, but nice people share..... even if they share something that needs to be fixed once an error is pointed out.

 

Debate over, point made.


[no external urls in signatures please, kthanks]

Share this post


Link to post
Share on other sites
Ah, you are correct, but nice people share.....

 

Sharing has absolutely nothing to do with being "nice". I choose not to share my work for my own reasons not those made up by others.

Share this post


Link to post
Share on other sites
There's nothing that requires it to be there. :wink:

 

In actual fact, if you wish to discuss them here, you are required to contribute them, re. the Forum Rules:

 

All external solutions (contributions) discussed in the forums must be freely available under the GNU General Public License (GPL), and must also be freely available for download at the Contributions section on the osCommerce support site.

 

These rules you agreed to when you became a member.

 

Further:

 

Postings regarding contributions that are not released under the GNU General Public License, or are not freely available, may be deleted without prior notification.

Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites

Well...I haven't discused any specific "external solutions" now have I Mr. Moderator. :roll: I would expect a moderator to know what he was talking about at least. Apparently not in this case. :wink:

 

Translation: I'm not contributing a darned thing.

 

 

*"Specific" is your addition - if you have nothing to contribute, as you say, then do not make reference to supposed code you have developed - and please stop harrassing other forum members* - Johnson

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×