Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Hi Jack -

 

I have to say that you did a great job - the contribution is awesome & the instruction were flawless...

my only questions is that when I go into different links of the site lets say like Oils - & I look at the the source for my page it shows me the following.

 

<title>Oils - mysite </title>

 

<meta name="Description" content="Oils We carry a great blah blah blah "/>

 

<meta name="Keywords" content="Oils, - then it shows all the keywords I selected here like aromatherapy, oils, cards, blah, blah

 

Is this correct as it shows the key word before the description & also before the keywords in itself.

Should I have not listed my keywords as it is listed on the site and let it autmatically fill in...or choose different keywords reflecting the product. Just a little confused so forgive for the stupid question.

 

Much Thanks,

Lydia

Share this post


Link to post
Share on other sites

Hi, well after a careful review - I really am sorry again and now so totally embarrassed for having to post so quickly again - as I found why it did that -

 

I apparently did not make sure to uncheck the boxes in the Text Control area where it shows the htta-htda-htka-htca. I had them all checked so it was listing everything like twice etc.. anyhow thanks again for this great contribution Jack!

 

Dia

Share this post


Link to post
Share on other sites

Hi Jack.

Thanks for your prefect contribution ^^

I had installed it and function well

but for the product page, the contribution no working and turn to the default header tag ...

 

And where should i get the "sts_output.php" ?

TQ~

Share this post


Link to post
Share on other sites

The sts_output file is only if you are using the STS contribution.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

I seem to have broken something within/near product_info.php. A heavily modified site, but installed without too much stress. Here's what happens:

 

OK: I go into Admin > Header tags, and fill in defaults. Then goto Catalog > Contents, and fill in a product with product specific meta data.

 

Then, goto the catalog... Click on that product, and

1) Product Info Title is Default Title

2) Meta data is all Default (Title, Desc, & Keys)

 

If I run the query in SQL, that specific product is has the correct (product specific) meta data, and all is

just peachy. I've been on this for 2 days now, and will be going through it again tonight - I'm so lost with this. If you think of anything that I might be missing, please could you drop me a line.

 

Thank you for a brilliant contrib, and for the support you give all the newbies like me.

 

Keep styling.

Lei

Edited by Lei-Mann

Share this post


Link to post
Share on other sites
The sts_output file is only if you are using the STS contribution.

 

Jack

 

I had install the contribution too.

But i fail to get the file ...

could you tell me where i can get it ?

really sorry for the matter.

 

Jack,

 

I seem to have broken something within/near product_info.php. A heavily modified site, but installed without too much stress. Here's what happens:

 

OK: I go into Admin > Header tags, and fill in defaults. Then goto Catalog > Contents, and fill in a product with product specific meta data.

 

Then, goto the catalog... Click on that product, and

1) Product Info Title is Default Title

2) Meta data is all Default (Title, Desc, & Keys)

 

If I run the query in SQL, that specific product is has the correct (product specific) meta data, and all is

just peachy. I've been on this for 2 days now, and will be going through it again tonight - I'm so lost with this. If you think of anything that I might be missing, please could you drop me a line.

 

Thank you for a brilliant contrib, and for the support you give all the newbies like me.

 

Keep styling.

Lei

 

i meet the same problem too.

For the index and category, all is function well

Just the products info, the title is the default title ...

if you get any way to slove it, please tell me too

TQ~

Share this post


Link to post
Share on other sites
Jack,

 

I seem to have broken something within/near product_info.php. A heavily modified site, but installed without too much stress. Here's what happens:

 

OK: I go into Admin > Header tags, and fill in defaults. Then goto Catalog > Contents, and fill in a product with product specific meta data.

 

Then, goto the catalog... Click on that product, and

1) Product Info Title is Default Title

2) Meta data is all Default (Title, Desc, & Keys)

 

If I run the query in SQL, that specific product is has the correct (product specific) meta data, and all is

just peachy. I've been on this for 2 days now, and will be going through it again tonight - I'm so lost with this. If you think of anything that I might be missing, please could you drop me a line.

 

Thank you for a brilliant contrib, and for the support you give all the newbies like me.

 

Keep styling.

Lei

Be sure to uncheck the HT.. boxes for product_info in admin->Header Tags->Text control.

 

Jack

Share this post


Link to post
Share on other sites

Hello Jack!

 

I've unselected every checkbox on that page, and it still only shows the Default values when I view the source of the product_info page. If I take that prod ID to SQL, all is fantastic! Where can it be!? I'm starting to lose hair...

 

Thx, Lei

Share this post


Link to post
Share on other sites

Amendment: Jack & aHfUi:

 

My index page isn't working either: So, all my pages are returning defaults. F1. What could I have broken?

 

Lei

Share this post


Link to post
Share on other sites

Hey, I have checked and triple checked to see where I made an error but I can't find it ... Doesn't mean I didn't, just means I can't find it :)

 

I'm getting Parse error: parse error, unexpected '}' in /home/www/maui-vacation/oscommerce/admin/categories.php on line 728

 

I checked all around this area and can't find what I did wrong ... I do have the text attributes mod on this site

anyway, here is the area of that file that I suspect the prob is in

 

<!-- denuz products text attributes -->

 

<tr>

<td class="main">Available Text Options:</td>

<td class="main">

 

<?php

$text_attributes_query = tep_db_query("select * from products_text_attributes");

while ($text_attributes = tep_db_fetch_array($text_attributes_query)) {

$attr_checked = false;

if ($HTTP_GET_VARS['pID'] > 0) {

$check_attr_query = tep_db_query("select * from products_text_attributes_enabled where products_id=" . (int)$HTTP_GET_VARS['pID'] . " and products_text_attributes_id = " . $text_attributes['products_text_attributes_id']);

if ($check_attr = tep_db_fetch_array($check_attr_query)) $attr_checked = true;

}

echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_checkbox_field('products_text_attributes_' . $text_attributes['products_text_attributes_id'], '', $attr_checked) . ' - ' . $text_attributes['products_text_attributes_name'] . '     ';

}

?>

 

</td>

</tr>

 

<!-- eof denuz products attributes -->

 

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<!-- HTC BOC //-->

<?php

for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

?>

<tr>

<td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_DESCRIPTION; ?></td>

<td><table border="0" cellspacing="0" cellpadding="0">

<tr>

<td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td>

<td class="main"><?php echo tep_draw_textarea_field('products_description[' . $languages[$i]['id'] . ']', 'soft', '70', '15', (isset($products_description[$languages[$i]['id']]) ? stripslashes($products_description[$languages[$i]['id']]) : tep_get_products_description($pInfo->products_id, $languages[$i]['id']))); ?></td>

</tr>

</table></td>

</tr>

<?php

}

?>

<tr>

<td colspan="2" class="main"><hr><?php echo TEXT_PRODUCT_METTA_INFO; ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<?php

for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

?>

<tr>

<td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_PAGE_TITLE; ?></td>

<td><table border="0" cellspacing="0" cellpadding="0">

<tr>

<td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td>

<td class="main"><?php echo tep_draw_textarea_field('products_head_title_tag[' . $languages[$i]['id'] . ']', 'soft', '70', '5', (isset($products_head_title_tag[$languages[$i]['id']]) ? stripslashes($products_head_title_tag[$languages[$i]['id']]) : tep_get_products_head_title_tag($pInfo->products_id, $languages[$i]['id']))); ?></td>

</tr>

</table></td>

</tr>

<?php

}

for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_HEADER_DESCRIPTION; ?></td>

<td><table border="0" cellspacing="0" cellpadding="0">

<tr>

<td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td>

<td class="main"><?php echo tep_draw_textarea_field('products_head_desc_tag[' . $languages[$i]['id'] . ']', 'soft', '70', '5', (isset($products_head_desc_tag[$languages[$i]['id']]) ? stripslashes($products_head_desc_tag[$languages[$i]['id']]) : tep_get_products_head_desc_tag($pInfo->products_id, $languages[$i]['id']))); ?></td>

</tr>

</table></td>

</tr>

<?php

}

for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_KEYWORDS; ?></td>

<td><table border="0" cellspacing="0" cellpadding="0">

<tr>

<td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td>

<td class="main"><?php echo tep_draw_textarea_field('products_head_keywords_tag[' . $languages[$i]['id'] . ']', 'soft', '70', '5', (isset($products_head_keywords_tag[$languages[$i]['id']]) ? stripslashes($products_head_keywords_tag[$languages[$i]['id']]) : tep_get_products_head_keywords_tag($pInfo->products_id, $languages[$i]['id']))); ?></td>

</tr>

</table></td>

</tr>

<?php

}

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td colspan="2" class="main"><hr></td>

</tr>

<!-- HTC EOC //-->

 

<?php

}

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr bgcolor="#ebebff">

<td class="main"><?php echo TEXT_PRODUCTS_TAX_CLASS; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_pull_down_menu('products_tax_class_id', $tax_class_array, $pInfo->products_tax_class_id, 'onchange="updateGross()"'); ?></td>

</tr>

<tr bgcolor="#ebebff">

<td class="main"><?php echo TEXT_PRODUCTS_PRICE_NET; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_input_field('products_price', $pInfo->products_price, 'onKeyUp="updateGross()"'); ?></td>

</tr>

<tr bgcolor="#ebebff">

<td class="main"><?php echo TEXT_PRODUCTS_PRICE_GROSS; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_input_field('products_price_gross', $pInfo->products_price, 'OnKeyUp="updateNet()"'); ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<script language="javascript"><!--

updateGross();

//--></script>

<?php

for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

?>

<tr>

<td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_DESCRIPTION; ?></td>

<td><table border="0" cellspacing="0" cellpadding="0">

<tr>

<td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td>

<td class="main"><?php echo tep_draw_textarea_field('products_description[' . $languages[$i]['id'] . ']', 'soft', '70', '15', (isset($products_description[$languages[$i]['id']]) ? $products_description[$languages[$i]['id']] : tep_get_products_description($pInfo->products_id, $languages[$i]['id']))); ?></td>

</tr>

</table></td>

</tr>

<?php

}

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main"><?php echo TEXT_PRODUCTS_QUANTITY; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_input_field('products_quantity', $pInfo->products_quantity); ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main"><?php echo TEXT_PRODUCTS_MODEL; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_input_field('products_model', $pInfo->products_model); ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main"><?php echo TEXT_PRODUCTS_IMAGE; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_file_field('products_image') . '<br>' . tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . $pInfo->products_image . tep_draw_hidden_field('products_previous_image', $pInfo->products_image); ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<?php

for ($i=0, $n=sizeof($languages); $i<$n; $i++) {

?>

<tr>

<td class="main"><?php if ($i == 0) echo TEXT_PRODUCTS_URL . '<br><small>' . TEXT_PRODUCTS_URL_WITHOUT_HTTP . '</small>'; ?></td>

<td class="main"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']) . ' ' . tep_draw_input_field('products_url[' . $languages[$i]['id'] . ']', (isset($products_url[$languages[$i]['id']]) ? $products_url[$languages[$i]['id']] : tep_get_products_url($pInfo->products_id, $languages[$i]['id']))); ?></td>

</tr>

<?php

}

?>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main"><?php echo TEXT_PRODUCTS_WEIGHT; ?></td>

<td class="main"><?php echo tep_draw_separator('pixel_trans.gif', '24', '15') . ' ' . tep_draw_input_field('products_weight', $pInfo->products_weight); ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<tr>

<td class="main" align="right"><?php echo tep_draw_hidden_field('products_date_added', (tep_not_null($pInfo->products_date_added) ? $pInfo->products_date_added : date('Y-m-d'))) . tep_image_submit('button_preview.gif', IMAGE_PREVIEW) . '  <a href="' . tep_href_link(FILENAME_CATEGORIES, 'cPath=' . $cPath . (isset($HTTP_GET_VARS['pID']) ? '&pID=' . $HTTP_GET_VARS['pID'] : '')) . '">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>'; ?></td>

</tr>

</table></form>

 

<!-- HTC BOC //-->

<?php

} elseif ($action == 'new_product_preview') {

if (tep_not_null($HTTP_POST_VARS)) {

$pInfo = new objectInfo($HTTP_POST_VARS);

$products_name = $HTTP_POST_VARS['products_name'];

$products_description = $HTTP_POST_VARS['products_description'];

$products_head_title_tag = $HTTP_POST_VARS['products_head_title_tag'];

$products_head_desc_tag = $HTTP_POST_VARS['products_head_desc_tag'];

$products_head_keywords_tag = $HTTP_POST_VARS['products_head_keywords_tag'];

$products_url = $HTTP_POST_VARS['products_url'];

} else {

$product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");

$product = tep_db_fetch_array($product_query);

// HTC EOC

Share this post


Link to post
Share on other sites
Amendment: Jack & aHfUi:

 

My index page isn't working either: So, all my pages are returning defaults. F1. What could I have broken?

 

Lei

 

Hello Amigos! My site was only returning the default meta data, and none of the specific product meta data that I'd added. But Ok, fixed it! aHfUi, you might want to try this too. Silly, silly me. It looks like I broke something in /catalog/includes/header_tags.php

 

Steps to correction: (back up first..)

1) Copy the file (/catalog/includes/header_tags.php) again from Jacks latest release, and replace your copy.

2) Go into the Admin section, edit a product, and make sure you have meta data added for that product.

3) Go into the Catalog section, and goto that product. View source, and if you're lucky, it's all done!

 

It's just made me extremely joyous. Jack, thank you for a great contrib and your tireless patience in helping people like me. You're a legend. Keep styling.

 

:thumbsup:

Share this post


Link to post
Share on other sites

Sorry for the long post earlier ... it doesn't appear that I can edit it :-"

 

To clarify my problem, I can get into admin and I can see all my normal stuff plus the new header tags section and I can use everything except the catalog page which is where I get the parse error

Share this post


Link to post
Share on other sites

Jack, congrats to the great contribution! Very very nice!

 

One quick question... I just installed the latest version... Header Tags Controller v2.5.9 Complete Jack_mcs 25 Apr 2006 and I am having an issue with the manufacturers page in the admin section.

 

It appears to only be listing Manufacturer's that have info listed in the manufacturers_info table. I checked MySQL and I have about 300 manufacturer's, however only about 10 of them are listed in the manufacturers_info table. Those are the 10 that are showing up when I am at the Manufacturers section of the admin.

 

All the manufacturers show up those in the online catalog in the manufacturers pulldown menu.

 

Does the Manufacturers section of the admin now require all manufacturers to have a manufacturers_info listing as well as it seems that is where it is pulling the manufacturers from. Or is this a bug?

 

Thank you,

Shawn

Edited by shawnm

Share this post


Link to post
Share on other sites

The two tables work together. When you add a new manufacturer in admin, both tables get updated. If yours doesn't do that, then there is something wrong with your code. If you are somehow bypassing the oscommerce code when you add the manufacturers, then there's no easy way to code for that.

 

Jack

Share this post


Link to post
Share on other sites
The two tables work together. When you add a new manufacturer in admin, both tables get updated. If yours doesn't do that, then there is something wrong with your code. If you are somehow bypassing the oscommerce code when you add the manufacturers, then there's no easy way to code for that.

 

Jack

 

Jack,

 

Thanks for the quick response... I think i may have found the problem... I noticed that my categories no longer have pictures as well... I used Easy Populate to upload most of my products and that is what created most of my categories... is it possible that by using Easy populate, it did not create or update both tables?

 

Cause I am looking in MySQL and it is showing all of my categories and it is showing my pictures, but for some reason it is not displaying the pictures to go along with it....

 

What do you think? Thanks again!

Shawn

Share this post


Link to post
Share on other sites

I doubt that Easy Populate is at fault. You should try to create a category in admin and see how that works. If it fails, then you have a code problem.

 

Jack

Share this post


Link to post
Share on other sites
I doubt that Easy Populate is at fault. You should try to create a category in admin and see how that works. If it fails, then you have a code problem.

 

Jack

 

Jack,

 

Thanks again... here's the update in case anyone else is having a problem...

 

It appears that Easy Populate will create a new manufacturer if it doesn't exsist, however it will only create the manufacturer in the manufacturer table, not in both the manufacturer table and the manufacturer_info table. The manufacturer_info table is left blank.

 

So, what I did was go through all the manufacturer's and input this into MySQL:

 

INSERT INTO `manufacturers_info` VALUES (434, 1, '', 0, NULL, NULL, NULL, NULL);

 

That fixed my manufacturers not being listed on the Manufacturer page and allowed me to edit and upload a picture for each manufacturer.

 

Not sure if it's a code problem on Easy Populate or what... but I just wanted to post this to maybe help someone out...

 

Thanks again Jack, nice contribution!

Shawn

Share this post


Link to post
Share on other sites

I have installed HT contribution on my site. My question is this, must you go into admin and edit every product to update description to suit the product? I was under the understanding that the contribution automatically fills it in for you according to what is on the page.

 

:::please tell me I'm just missing something and don't have to go in and type over 5000 descriptions::::

Share this post


Link to post
Share on other sites

Go to admin->Header Tags->Fill Tags, select Fill All (or fill empty if some are already set up as you like) for each column and click Update.

 

Jack

Share this post


Link to post
Share on other sites

I'm doing a little tweaking and I was wondering how to manipulate the font design (size, color, weight, face) for the category description area.

 

I finally figured out how to center and such the category and sub-category names on their pages (h1 in the stylesheet.css), but if I had added a description to a category or subcategory, the font is a heavy black blocky font and I want to change that.

 

Do I just do that as html code as I'm typing out the description? Or is there someplace else I go? I figured it was h2 in the stylesheet.css, but it wasn't.

 

Plus, can anyone tell me (cause I'm an airhead and totally forgot) where I can access the product listing page ... I need to re-adjust the width of the product listing table and for the life of me I can't find it again.

 

D'OH!


26 contributions installed - - And counting ....

 

Just want to take this time to extend my appreciation to everyone who have patiently answered my questions over the months of working on my site. I hope to be able to "pass it forward" and help new folks.

Share this post


Link to post
Share on other sites

The description uses h2 so you should adjust that if you want to change the overall look. The change particular parts of the text, add the html to the text as you type it as you thought. Someone mentioned that they installed the tinyMCE editor and it worked but I never tried it.

 

Jack

Share this post


Link to post
Share on other sites

hi i want to install this cont. in my site but have some questions

 

there are 2 ways as mentioned in the read _me , i dont know much about SQL , so think of running the databse_setup.php file as it would be easy, i need to ask you 1 thing about this: after running the file should i delete databse_setup.php there itself or after uploading the other header files to my catalog.

 

also i notice that there a reqd. a lot of changes, i have a quaetion about 1 such:

 

===================

In stylesheet.css, add the following. Set it to the desired size and\

color for your shop.

 

h1 {

font-family: Verdana, Arial, sans-serif;

font-size: 20px;

font-weight: bold;

}

 

h2 {

font-family: Verdana, Arial, sans-serif;

font-size: 14px;

}

 

 

why is this reqd. this contribution is meant for meta tags so why is it needed to add css , i have some changes to my breadcrump.php file to show the header title of the catgories & products rather than the default text "Let's see what we have here" , so i would like to know what function is this css going to do and which text formatting is it going to change.

 

also i have taken back-up of evey file in the catalog, but do i need to backup the my sql database as, i think i should

 

 

thanks

gourav

Edited by virtualadz

Share this post


Link to post
Share on other sites

- It doesn't matter when you delete the database_setup.php file but it should be deleted.

 

- This contribution is for far more than adding meta tags. The h1 and h2 tags are added because it has been shown that the SE's give extra points if the heading and sub-heading on a page use those tags. You can change the font, size and color as you like. that part doesn't matter.

 

- always back up your database before making a change to it.

 

Jack

Share this post


Link to post
Share on other sites

i ran the databse_setup.php and the following message appeared "Database successfflly updated" . now i will copy the files, but in your readme it's nowhere written that i need to copy the files to admin.

 

catalog/includes/header_tags.php

catalog/includes/languages/english/header_tags.php

catalog/includes/functions/clean_html_comments.php

catalog/includes/functions/header_tags.php

 

these are the 4 files which it says to be uploaded, but there are also many header files in catalog/admin, should i copy them too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×