Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

That is because you didnt had the $headcontent variable in your sts_template.html page header tags. Should look like this <head>$headcontent</head>

 

If only it were that easy. Not only have I tried that and

<!--$headcontent-->

and

<!-- $headcontent -->

and about every combination in between. I even tried searching for every reference of headcontent in the STS files to see if I can find where it is being added and still no dice. It's not such a big deal because manually adding it to the STS template files (xxxx.php.html) works but it's still peculiar. Later

Edited by Destra

Share this post


Link to post
Share on other sites
Also Jack since you know STS I am having a problem with the information at the top the page not being added.  I noticed this because the click to enlarge was not working.  In view source the proper javascript was not being added to the top of the generated pages.  I got around this by adding it manually and it works now.  Have you ever heard of this or seen a fix?  Later

Well, I am by no means an STS expert but I will try to help with your problem. Unfortunately, you have totally lost me. What information at the top of what page? What click to enlarge? Javascript? I take it all of these questions apply to your particular site? I don't recall any of those in STS or HTC but I'm probably missing your point.

 

Jack

Share this post


Link to post
Share on other sites

Basically in the stantard osCommerce anything that is in <head></head> does not get added to the top of my site's generated pages. The click to enlarge is a javascript generated popup window for a larger picture of your product. Here it is in product_info.php (with hard returns so it wraps):

 

<script language="javascript"><!--
function popupWindow(url) {
 window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,
menubar=no,scrollbars=no,resizable=yes,copyhistory=no,width=100,
height=100,screenX=150,screenY=150,top=150,left=150')
}
//--></script>

 

As a matter of fact none of the code in the <head></head> of product_info.php is used. I added the code to my sts_user_code.php so I can get the dynamic title and meta tags to be generated. Almost all of the problems have been fixed with work arounds I have devised but like I said it is peculiar.

Also the HTC doesnot work for me at all once I add meta information to a product (product page becomes blank). All I get when using view source of the page is the meta tags and meta tag description is the full product description instead of what I put. This whole HTC thing is starting to look like more of a headache than it is worth, and by using what product_info.php was originally supposed to do, not really needed. Later

Share this post


Link to post
Share on other sites

Hi all,

 

Anyone know where these META are coming from in the code?

 

<META NAME=".........Find the protection against fires.">

<META NAME="Keywords" CONTENT="............Firelite Notifier fire security against fires">

 

Must be hardcoded somewhere - they appear after the input from the admin META sections - only noticed them by checking source ;)

 

Best,

 

Kino

Share this post


Link to post
Share on other sites
Basically in the stantard osCommerce anything that is in <head></head> does not get added to the top of my site's generated pages.  The click to enlarge is a javascript generated popup window for a larger picture of your product.  Here it is in product_info.php (with hard returns so it wraps):

 

As a matter of fact none of the code in the <head></head> of product_info.php is used.  I added the code to my sts_user_code.php so I can get the dynamic title and meta tags to be generated.  Almost all of the problems have been fixed with work arounds I have devised but like I said it is peculiar.

Also the HTC doesnot work for me at all once I add meta information to a product (product page becomes blank).  All I get when using view source of the page is the meta tags and meta tag description is the full product description instead of what I put.  This whole HTC thing is starting to look like more of a headache than it is worth, and by using what product_info.php was originally supposed to do, not really needed.  Later

I looked at your site and it is displaying what you have in the head section so I can't see a problem there. But I did see that you have the title tag declared twice and I don't see the <!-- BOF: Generated Meta Tags --> statement that is added with HTC. That could mean you just removed it or that you don't have HTC installed correctly. As for the popup, I'm wondering if you added HTC to that? You are not supposed to. I'm not sure what code you added to sts_user_code.php but if it has to do with HTC then you are probably causing the problems yourself. You should back out all of the work arounds you added and install the contributions the way the instructions say. They really do work but can be broken if you edit them incorrectly.

 

Jack

Share this post


Link to post
Share on other sites
Hi all,

 

Anyone know where these META are coming from in the code?

 

<META NAME=".........Find the protection against fires.">

<META NAME="Keywords" CONTENT="............Firelite Notifier fire security against fires">

 

Must be hardcoded somewhere - they appear after the input from the admin META sections - only noticed them by checking source ;)

Kino, they are in includes/english/header_tags.php:

 define('HEAD_DESC_TAG_ALL','Find the protection against fires.');
define('HEAD_KEY_TAG_ALL','Firelite Notifier fire security against fires');

Whenever you run across displayed text like this, it is almost always in some file located in includes/english (or your default language type). Just search the directory for the term and it will take you right to it.

 

HTH,

Jack

Share this post


Link to post
Share on other sites

Hi Jack_mcs

 

Thanks for that - that did the trick :)

 

Right - I'm back to trying to sort out these search functions..;)

 

 

Best,

 

Kino

Share this post


Link to post
Share on other sites

:o This being my first post...

 

Thought I would mention as I did'nt see this issue in the topic yet. It took me close to 2 hours to install this cont as I did not want to mess it up. It worked perfect except I no longer had an input for price. I checked re-checked and reinstalled it twice with the same effect, anyone else have the price disappear after installing this cont. ?

Share this post


Link to post
Share on other sites
I'm getting there and noticed that Elmo and Dangeo1 also had the same issue with the (line 603) replace, as in my last post - but no answer.  I still need an answer on this one.

I am having the same problem. I cannot find that instance in categories.php. Has someone found the issue with this?

 

I did find three instances of this line

$product = tep_db_fetch_array($product_query);

So for the time being I will replace the last instance which is the closest to line 603 and see what happens. I will let you know my progress.

 

 

thanks.

Edited by PropioWeb

Samuel Mateo, Jr.

osC 2.2 MS2

Installed Mods:

WYSIWYG HTMLArea 1.7 | Basic Template System 1.0 | osC-Affiliate | OSC-SupportTicket

Featured Products 1.3 | LoginBox 5.2 | LatestNews 1.1.3 | Extras for IE

Share this post


Link to post
Share on other sites
I did find three instances of this line

$product = tep_db_fetch_array($product_query);

So for the time being I will replace the last instance which is the closest to line 603 and see what happens. I will let you know my progress.

What contribution are you working on? The code you mention has nothing to do with HTC AFAIK.

 

Jack

Share this post


Link to post
Share on other sites
I did find three instances of this line

$product = tep_db_fetch_array($product_query);

So for the time being I will replace the last instance which is the closest to line 603 and see what happens. I will let you know my progress.

What contribution are you working on? The code you mention has nothing to do with HTC AFAIK.

 

Jack

Ofcourse it mentions that in the Readme. Right here.

 

Find the following (approx line 603)

 

      $product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id  from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");

      $product = tep_db_fetch_array($product_query);

     

Replace with the following     

 

      $product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id  from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");

      $product = tep_db_fetch_array($product_query);

 

BTW I did change the last instance of it and it did work. Except for the fact that I am using the Basic Template System and could not do this part exactly.

<title><?php echo TITLE; ?></title>

Since BTS takes all the headers and replaces them with its own header system but I was smart enough to figure it out on my own. If anyone is using BTS and needs help installing this PM me.


Samuel Mateo, Jr.

osC 2.2 MS2

Installed Mods:

WYSIWYG HTMLArea 1.7 | Basic Template System 1.0 | osC-Affiliate | OSC-SupportTicket

Featured Products 1.3 | LoginBox 5.2 | LatestNews 1.1.3 | Extras for IE

Share this post


Link to post
Share on other sites
[Ofcourse it mentions that in the Readme. Right here.

 

README To Admin.txt]Find the following (approx line 603)

Oops, sorry. It was late and I was looking at an earlier release. I did a search on the configure file from the OSC zip file and there is only one such entry and it is at line 603. Sounds like a contribution has moved things around for you. You should load the original file (from the zip) and your file into a compare program like Beyond Compare or Compare and Merge. It should be easy to see where the change goes from that.

 

Jack

Share this post


Link to post
Share on other sites

Hi All,

 

I have just installed HTC 2.3.2, it seems to be working fine. The problem is i don't really know how to use this contribution optimumly, so here is my question:

 

1. How do i change the "oscommerce" title on the top of my web browser, to let's say "Hallo"?

2. There are 3 meta info: product page title, page header description and product keywords. I know how to use product page title.

But i don't know how to use the page header description and keywords and what are they for?Can somebody explain how to use them, and where does it appear on the browser (if they are designed to be appear on the browser)

3. How do you give title/tag for every page, example: checkout page or reviews page?

 

Forgive my stupid questions, would really grateful if somebody could enlighten mt on this matter.

 

Regards,

Danny

Share this post


Link to post
Share on other sites
Hi All,

 

I have just installed HTC 2.3.2, it seems to be working fine. The problem is i don't really know how to use this contribution optimumly, so here is my question:

 

1. How do i change the "oscommerce" title on the top of my web browser, to let's say "Hallo"?

2. There are 3 meta info: product page title, page header description and product keywords. I know how to use product page title.

But i don't know how to use the page header description and keywords and what are they for?Can somebody explain how to use them, and where does it appear on the browser (if they are designed to be appear on the browser)

3. How do you give title/tag for every page, example: checkout page or reviews page?

 

Forgive my stupid questions, would really grateful if somebody could enlighten mt on this matter.

 

Regards,

Danny

YOu can can change those in one of the file you uploaded found here

/catalog/includes/languages/english/header_tags.php

Towards the bottom I believe.

 

HTH


Samuel Mateo, Jr.

osC 2.2 MS2

Installed Mods:

WYSIWYG HTMLArea 1.7 | Basic Template System 1.0 | osC-Affiliate | OSC-SupportTicket

Featured Products 1.3 | LoginBox 5.2 | LatestNews 1.1.3 | Extras for IE

Share this post


Link to post
Share on other sites

I am getting this error message when I try to access the specials page.

 

Fatal error: Call to undefined function: clean_html_comments() in /home/airguns/public_html/includes/header_tags.php on line 141

 

The specials page is the only page that it shows up on. Everything else seems to be working just fine.

 

Any Help would be great as this is driving me crazy

 

Richard


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites
Hi All,

 

I have just installed HTC 2.3.2, it seems to be working fine. The problem is i don't really know how to use this contribution optimumly, so here is my question:

 

1. How do i change the "oscommerce" title on the top of my web browser, to let's say "Hallo"?

2. There are 3 meta info: product page title, page header description and product keywords. I know how to use product page title.

But i don't know how to use the page header description and keywords and what are they for?Can somebody explain how to use them, and where does it appear on the browser (if they are designed to be appear on the browser)

3. How do you give title/tag for every page, example: checkout page or reviews page?

 

Forgive my stupid questions, would really grateful if somebody could enlighten mt on this matter.

 

Regards,

Danny

HTC has a title tag it adds to each page you set up. Whatever that tile is will be displayed in the title bar of the browser. HTC comes with only a few of the basic pages included. If you want to have a different title for each page, and you should for SEO reasons, then you need to add code to both of the header_tags.php files. You just duplicate the code that is there and then change the name to match your new page. For example, it comes with the following in english/header_tags.php:

define('HTTA_SPECIALS_ON','1');

So to add an about us page you would make it:

define('HTTA_ABOUTUS_ON','1');

You need to change all the defines for that page (there are five of them). You should make the title part look something like this:

define('HEAD_TITLE_TAG_ABOUTUS','About Us - ');

Then in includes/header_tags.php, you need to duplicate the section of code again and change all of the entries as above.

 

The meta-description tag is used to descibe the page. It is what is displayed below the url when you do a search on google. Put something in there that a visitor will read, like "This is a great site for selling widgets." It should be optimized with keywords to help your SE's results. THe meta-keywords are a list of comma seperated words or phases that describe your site. The SE's use them to help find you when a search is performed. Further explanations of both of these are easily available through a google search. You should do some reading on them since they can be very important concerning your site's indexing.

 

HTH,

Jack

Share this post


Link to post
Share on other sites
I am getting this error message when I try to access the specials page.

 

Fatal error: Call to undefined function: clean_html_comments() in /home/airguns/public_html/includes/header_tags.php on line 141

 

The specials page is the only page that it shows up on. Everything else seems to be working just fine.

 

Any Help would be great as this is driving me crazy

 

Richard

Me too. I just saw that today. Does anyone have an idea?

 

Thanks


Samuel Mateo, Jr.

osC 2.2 MS2

Installed Mods:

WYSIWYG HTMLArea 1.7 | Basic Template System 1.0 | osC-Affiliate | OSC-SupportTicket

Featured Products 1.3 | LoginBox 5.2 | LatestNews 1.1.3 | Extras for IE

Share this post


Link to post
Share on other sites
I am getting this error message when I try to access the specials page.

 

Fatal error: Call to undefined function: clean_html_comments() in /home/airguns/public_html/includes/header_tags.php on line 141

 

The specials page is the only page that it shows up on. Everything else seems to be working just fine.

 

Any Help would be great as this is driving me crazy

 

Richard

Me too. I just saw that today. Does anyone have an idea?

 

Thanks

Do you have the file clean_html_comments.php in includes/functions? Did you insert

 require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

in includes/application_top.php? If you have both of the above and you have STS installed, remove the entry from application_top.php.

 

Jack

Share this post


Link to post
Share on other sites
Do you have the file clean_html_comments.php in includes/functions?

 

Yes that file is there

 

Did you insert
 require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

in includes/application_top.php?  If you have both of the above and you have STS installed, remove the entry from application_top.php.

 

I do have STS but I already have that line removed as that gave me an already called error all across the board.

 

It seems odd as the error message only comes up with the specials page.

 

Any other ideas

 

Thanks

 

Richard


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites
It seems odd as the error message only comes up with the specials page.

 

Any other ideas

You need to find out if the problem is with the clean_html_comments function or with your installation. If you look in the includes/header_tags.php file, you'll see that clean_html_comments is only used for the specials and product_info file. Try clicking on a product to get to the product_info page. Does the error occur then? If not, is the title being displayed correctly? I can't tell you what correctly is since it depends on your settings but you should see something like the name of your site followed by the products name. If you cannot tell, temporairly replace the code in that file at line 75 (assuming nothing has been changed in the original file up to this line):

 if (empty($the_product_info['products_head_title_tag'])) {
     $the_title= HEAD_TITLE_TAG_ALL;
   } else {
     if ( HTTA_PRODUCT_INFO_ON=='1' ) {
       $the_title= HEAD_TITLE_TAG_ALL . ' ' . clean_html_comments($the_product_info['products_head_title_tag']);
     } else {
       $the_title= clean_html_comments($the_product_info['products_head_title_tag']);
     }
   }

with

 if (empty($the_product_info['products_head_title_tag'])) {
     $the_title= 'A';
   } else {
     if ( HTTA_PRODUCT_INFO_ON=='1' ) {
       $the_title= 'B';
     } else {
       $the_title= 'C';
     }
   }

and display a product. If B or C is displayed in the browsers title then you know that clean_html_comments is being called here and that is not your problem.

 

Jack

Share this post


Link to post
Share on other sites

Yes it is working on the products_info page. I get the site name plus the product name in the tab and no error messages.


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites
Yes it is working on the products_info page. I get the site name plus the product name in the tab and no error messages.

Just to be clear, what's the "tab." Are you seeing the product's name in the browsers title bar?

 

Jack

Share this post


Link to post
Share on other sites
Yes it is working on the products_info page. I get the site name plus the product name in the tab and no error messages.

Just to be clear, what's the "tab." Are you seeing the product's name in the browsers title bar?

 

Jack

Yes I am. My browser has tabs.

 

OK I figured since it does seem to work it must be my installation so I went over it again. Did not see anything wrong with it. So then I think well I will just remove the title changes in the specials.php and just go without the extra info in the title bar for the specials page. So I replace the header tags changes back to

 

 

<title><?php echo TITLE ?></title>

 

Now here is the strange part. Even without the header tag code in the specials.php page It is using the information from the header_tags.php file in the lang/english folder and working. I am guessing that I did not need to make the changes to the specials.php file but reading the instructions I did not see that anywhere. The only one that was mentioned was the pop_image file.

 

Well thanks for the help.


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites
Now here is the strange part. Even without the header tag code in the specials.php page It is using the information from the header_tags.php file in the lang/english folder and working. I am guessing that I did not need to make the changes to the specials.php file but reading the instructions I did not see that anywhere. The only one that was mentioned was the pop_image file.

This isn't possible. You do have to make the change to specials.php else it will not use the header_tags.php code. Most likely you had the code declared twice. But, in any event, glad it worked out for you.

 

Jack

Share this post


Link to post
Share on other sites
This isn't possible. You do have to make the change to specials.php else it will not use the header_tags.php code. Most likely you had the code declared twice. But, in any event, glad it worked out for you.

 

Jack

This is what I thought which is why I said it was strange But I make a change in the header_tags.php file in the lang/english folder and it shows up on the specials page. I just changed it from Specials to Great Deals and it changed on the site.

 

// specials.php

// If HEAD_KEY_TAG_SPECIALS is left blank, it will build the keywords from the products_names of all products on special

define('HTTA_SPECIALS_ON','1');

define('HTKA_SPECIALS_ON','1');

define('HTDA_SPECIALS_ON','1');

define('HEAD_TITLE_TAG_SPECIALS','Great Deals');

define('HEAD_DESC_TAG_SPECIALS','');

define('HEAD_KEY_TAG_SPECIALS','');

 

Maybe the code is there and I am not seeing it but the only place I remember changing the code either way is replacing the code for the title here is my specials.php file

 

<?php

/*

$Id: specials.php,v 1.49 2003/06/09 22:35:33 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_SPECIALS);

 

 

$breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_SPECIALS));

?>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

 

<title><?php echo TITLE ?></title>

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

<!-- header //-->

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

<!-- header_eof //-->

 

<!-- body //-->

<table border="0" width="100%" cellspacing="3" cellpadding="3">

<tr>

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- left_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>

<!-- left_navigation_eof //-->

</table></td>

<!-- body_text //-->

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php //echo tep_image(DIR_WS_IMAGES . 'table_background_specials.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

$specials_query_raw = "select p.products_id, pd.products_name, p.products_price, p.products_tax_class_id, p.products_image, s.specials_new_products_price from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_SPECIALS . " s where p.products_status = '1' and s.products_id = p.products_id and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and s.status = '1' order by s.specials_date_added DESC";

$specials_split = new splitPageResults($specials_query_raw, MAX_DISPLAY_SPECIAL_PRODUCTS);

 

if (($specials_split->number_of_rows > 0) && ((PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3'))) {

?>

<tr>

<td class="main"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr class="main">

<td class="main"><?php echo $specials_split->display_count(TEXT_DISPLAY_NUMBER_OF_SPECIALS); ?></td>

<td align="right" class="smallText"><?php echo TEXT_RESULT_PAGE . ' ' . $specials_split->display_links(MAX_DISPLAY_PAGE_LINKS, tep_get_all_get_params(array('page', 'info', 'x', 'y'))); ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

}

?>

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<?php

$row = 0;

$specials_query = tep_db_query($specials_split->sql_query);

while ($specials = tep_db_fetch_array($specials_query)) {

$row++;

 

echo ' <td align="center" width="33%" class="main"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $specials['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $specials['products_image'], $specials['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $specials['products_id']) . '">' . $specials['products_name'] . '</a><br><s>' . $currencies->display_price($specials['products_price'], tep_get_tax_rate($specials['products_tax_class_id'])) . '</s><br><span class="productSpecialPrice">' . $currencies->display_price($specials['specials_new_products_price'], tep_get_tax_rate($specials['products_tax_class_id'])) . '</span></td>' . "\n";

 

if ((($row / 3) == floor($row / 3))) {

?>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<?php

}

}

?>

</tr>

</table></td>

</tr>

<?php

if (($specials_split->number_of_rows > 0) && ((PREV_NEXT_BAR_LOCATION == '2') || (PREV_NEXT_BAR_LOCATION == '3'))) {

?>

<tr>

<td><br><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td class="smallText"><?php echo $specials_split->display_count(TEXT_DISPLAY_NUMBER_OF_SPECIALS); ?></td>

<td align="right" class="smallText"><?php echo TEXT_RESULT_PAGE . ' ' . $specials_split->display_links(MAX_DISPLAY_PAGE_LINKS, tep_get_all_get_params(array('page', 'info', 'x', 'y'))); ?></td>

</tr>

</table></td>

</tr>

<?php

}

?>

</table></td>

<!-- body_text_eof //-->

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- right_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>

<!-- right_navigation_eof //-->

</table></td>

</tr>

</table>

<!-- body_eof //-->

 

<!-- footer //-->

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

<!-- footer_eof //-->

<br>

</body>

</html>

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×