Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Did you upload the files to the catalog section of your shop? It is saying the file is not there.

 

Jack

Share this post


Link to post
Share on other sites
You will need to try to isolate when the problem happens.
I think you were right about the caching. I isolated the problem to page control>delete a page. When a page is deleted, includes/header_tag.php is stripped significantly. I also noticed that the default values in language/english/header_tag.php are stripped. So the title of index is HEADER_TITLE_TAG_DEFAULT. Includes/functions/header_tags and clean_html_comments are as original.

 

Perhaps some of the problem is in the steps needed to make changes to the tags. Once a page is added in page control, should it be left alone there and edited only in the Text Control page? Then once edited, do you need to run 'Fill Tags'?

Share this post


Link to post
Share on other sites

No one has mentioned this problem before and I cannot duplicate it so I don't know what to suggest.

 

Page control is used just to add the page. Once it is added, you can't do anything else with it, other than delete it, except in Text Control. Fill Tags is only for categories/products so it would not effect any new page you might add.

 

Jack

Share this post


Link to post
Share on other sites
It means you missed a define somewhere. See the englsh/header_tags.php file for what is needed.

 

Jack

 

Thanks Jack. I manually edit the header_tags.php file and it is working fine now. I have added a define for all the missing page :D

 

I am not sure how to use the page control, so I do it manually by duplicating the define before it and edit it for the new page :P


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

To use the Page Control, you must first edit the page you want to add so that it has the header tags code in it (see Install_Catalog.txt). Then enter the name of that file in page control. So if you have an about_us.php file, first change the code for <title> as described in the above file. Then goto Page Control and use about_us as the name of the page. Note that the underscore is very important, if it is in the name of the file. Don't use about us. You can then enter your title and meta tag information for that page and click Update. That page will now have it's own title and meta tags.

 

Jack

Share this post


Link to post
Share on other sites

First off, you made a mistake on the installation. When I view the source code, I see the <meta http-equiv tag twice. That won' cause the problem you are having but it should be fixed. As for the problem you mention, I'm not sure what you mean by "pulled elements from my pages." Header Tags loads data you set up in admin. Have you ran the Fill Tags option?

 

Jack

Share this post


Link to post
Share on other sites

The code doesn't handle manufacturers currently. I have the new code aleady written but it will be a few weeks before I upload it. In the meantime, the title should display the default title. If you don't have anything in the default section, then you wouldn't see anything.

 

Jack

Share this post


Link to post
Share on other sites

HELP!!

 

I Just installed Header Tags Controller 2.5.6, and get this error when I click onto my catalog link within the admin section:

 

Parse error: parse error, unexpected $ in /home/specopst/public_html/shop/catalog/admin/categories.php on line 1148

 

When I open categories.php and look, I see that the error refers to the very last line in the file. This is the code which is there:

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

I followed the instructions, to the "T". I also used a file-comparison program to confirm that all of the correct adjustments were made to the categories.php file. I am able to see and go into the new "header tags" section as well as it's three sub-sections. I am also able to complete the "default title/description/keywords area, and at least improve from the canned OSc text. Any tips as to how I can create new "pages" to facilitate individualized page tags for each of my categories would also be appreciated.

 

thanks in advance.

Share this post


Link to post
Share on other sites
HELP!!

 

I Just installed Header Tags Controller 2.5.6, and get this error when I click onto my catalog link within the admin section:

 

Parse error: parse error, unexpected $ in /home/specopst/public_html/shop/catalog/admin/categories.php on line 1148

 

When I open categories.php and look, I see that the error refers to the very last line in the file. This is the code which is there:

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

I followed the instructions, to the "T". I also used a file-comparison program to confirm that all of the correct adjustments were made to the categories.php file. I am able to see and go into the new "header tags" section as well as it's three sub-sections. I am also able to complete the "default title/description/keywords area, and at least improve from the canned OSc text. Any tips as to how I can create new "pages" to facilitate individualized page tags for each of my categories would also be appreciated.

 

thanks in advance.

 

This is a followup to my original HELP plea. I compared all of the modified files, and found I had pasted a few extra lines of code into the filenames.php file. I went through the rest of the pertinent admin-side files, and did not find any other issues. However, I am now getting this error when I click onto ADMIN>CATALOG:

 

 

Parse error: parse error, unexpected T_CASE in /home/specopst/public_html/shop/catalog/admin/categories.php on line 1002

 

The code on that particular line is:

case 'edit_category':

 

Any ideas?

thanks.

Share this post


Link to post
Share on other sites
This is a followup to my original HELP plea. I compared all of the modified files, and found I had pasted a few extra lines of code into the filenames.php file. I went through the rest of the pertinent admin-side files, and did not find any other issues. However, I am now getting this error when I click onto ADMIN>CATALOG:

Parse error: parse error, unexpected T_CASE in /home/specopst/public_html/shop/catalog/admin/categories.php on line 1002

 

The code on that particular line is:

case 'edit_category':

 

Any ideas?

thanks.

I found another problem. When I am viewing the catalog and click the "specials" link, I get this error:

 

 

Fatal error: Call to undefined function: clean_html_comments() in /home/specopst/public_html/shop/catalog/includes/header_tags.php on line 247

 

Any Ideas?

thanks.

Share this post


Link to post
Share on other sites

Those are all installation problems. There is a admin/categories.php file included with the contribution. Upload it and see if your admin problems go away. If they do, then you need to compare files to find the problem. The clean_html error means you are missing the file or, if youare using STS, the code in the STS file wasn't changed per the instructions.

 

Jack

Share this post


Link to post
Share on other sites
Those are all installation problems. There is a admin/categories.php file included with the contribution. Upload it and see if your admin problems go away. If they do, then you need to compare files to find the problem. The clean_html error means you are missing the file or, if youare using STS, the code in the STS file wasn't changed per the instructions.

 

Jack

hi Jack,

Thanks for the reply. Here's another update: I ended up using the included categories.php (and just added the three lines for my Ultimate URL contribution to work). I can now go into my category screen, and can even update the category tags either one-by-one or all at once via the new options. However, when I try to assign tags to individual products, I get:

 

Fatal error: Call to undefined function: clean_html_comments() in /home/specopst/public_html/shop/catalog/includes/header_tags.php on line 185

 

The code on that line is:

$tags_array['title']= clean_html_comments($the_product_info['products_head_title_tag']) . ' ' . HEAD_TITLE_TAG_ALL;

 

I (unfortunately) am not running the STS Contrib. I also just checked my directories, and I do have all of the necessary files included with this mod.

Any thoughts?

Share this post


Link to post
Share on other sites

Did you add the code to the includes/application_top.php file at the bottom of the file? If so, you will need to go through the install again.

 

Jack

Share this post


Link to post
Share on other sites
Did you add the code to the includes/application_top.php file at the bottom of the file? If so, you will need to go through the install again.

 

Jack

Jack,

That did it! Thanks for the tip. Somehow, I had missed the application_top.php file modification. Now, I am able to see product-level header tag changes.

The only thing I am confused about though, is that it is adding my specific product - tags to the default ones I had set up in the header tags section. In my product screen, I only added the specific keywords. Am I doing something wrong?

thanks.

Share this post


Link to post
Share on other sites

You probably have the HT.. checkboxes set in admin->Header Tags->Text Control.

 

Jack

Share this post


Link to post
Share on other sites

I don't see any code having to do with Header Tags. I see mention of Header Tags, but no code. Out of the six or so SEF contributions, this is the only one that doesn't work with Header Tags, as far as I know. It is on my list of things to check into but it is pretty low on the list since there are so many other options available if you want to have SEF urls.

 

Jack

Share this post


Link to post
Share on other sites

Parse error: parse error, unexpected T_CASE in /home/vertica/public_html/supplementsupermarket/admin/categories.php on line 332

 

 

This is the code from around that area of categories.php

My first attemp to fix this was to delete the line :) lol, but that caused some problems as i was unable to modify my products. I installed header tags mod last nite, and although they are working fine, it seems it has resulted in this error everytime i click on categories in the admin section. Please help me!

 

tep_reset_cache_block('categories');

tep_reset_cache_block('also_purchased');

}

}

 

tep_redirect(tep_href_link(FILENAME_CATEGORIES, 'cPath=' . $categories_id . '&pID=' . $products_id));

break;

case 'new_product_preview':

// copy image only if modified

 

 

 

NOTE: the line case'new_product_preview': is line 332 (the error line)

Share this post


Link to post
Share on other sites

The line number doesn't always indicate where the actual error is at, which appears to be the case here. You will need to compare your categoires.php file with the one in the contribution. There is a free comparison tool named winmerge that works good for doing that.

 

Jack

Share this post


Link to post
Share on other sites

Jack,

 

First thanks for the contribution. I am just wondering if there is a list of the non-compatible contributions. I have a whole lot of them installed and would like to add this. One of them is a contribution that adds the product name to the Title tag, so not sure if this will work. I did search but cannot find an answer

 

Thanks

Share this post


Link to post
Share on other sites

There are very few that not compatible. The SEF one mentioned a few posts ago and Unlimited Pages (or something like that) are the only ones I am aware of. There are some that won't work since they use the same code, like Categories Description and all of the other meta tags contributions. What you have sounds like it falls into this last category. I'm not sure what you are trying to accomplish but Header Tags already displays the product name in the title tag.

 

Jack

Share this post


Link to post
Share on other sites

hi all

i have 2 problems one is relating to htc and the other is not but its not so complicated.

 

1) i am struggling to add my advanced_search.php and advanced_search_result.php to use the htc

 

i have done it thrue the admin checked the files english/header_tags and includes/header_tags to see that the admin did the changes as required and it did but the title still shows Oscommece

 

Where to look?

 

2) how can i insert bgimage to the index page under the text ?

 

i atempted to do it thrue the css and it works. the problem is that the image shows under the buttons as well

 

here is the line ffrom css

 

 

 

TD.main, P.main {

 

font-family: Verdana, Arial, sans-serif;

background-image:url(indexbg.jpg); background-repeat:no-repeat; background-position: center;

 

font-size: 11px;

 

line-height: 1.5;

 

}

Share this post


Link to post
Share on other sites

Did you add the header tags code into those files? See Install_Catalog.txt on how to do that.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×