Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

now that i have my files in order, how can i stop the main page's header tags from displaying on the categories page?

 

i have tried leaving default blank, index blank and even unchecking the HTTA tags.

 

i want the main page to have it's own tags and stay out of the other sections'. is this possible?

Share this post


Link to post
Share on other sites

The categories title and meta tags are set in admin->catalog. If you don't want the default title and meta tags tacked on to those, tehn you need to go to admin->Header Tags->Page Control and uncheck HTTA, HTDA and HTKA.

 

Jack

Share this post


Link to post
Share on other sites

Solved the disappearing problem. Was the functions/general.php and that was screwing with the categories.php


Hip Hop Jewelry | Bling Bling | Iced Out

Share this post


Link to post
Share on other sites

Hi, I installed the contrib, even doublechecked it twice!

 

I have a problem where my categories names dissapears, not being shown and also my product name in the catalog editor there is no input box for product name anymore and when I update a product it sets the product name to blank!

 

Also did some small debugging and the titles wont set correctly,

I noticed that the array values

 

[products_head_title_tag] =>

[products_head_keywords_tag] =>

[products_head_desc_tag] =>

 

Are always empty for some reason..

 

Any clues?

Edited by Woloj

Share this post


Link to post
Share on other sites

Oops, I fixed the category thing, but I am still unable to see a product name box in the catalog editor.

 

I want to be able to both have the manufacturer and product name in the <title>

 

Is this possible?

Edited by Woloj

Share this post


Link to post
Share on other sites

Nothing is more satisfying than fixing your own errors. ;)

 

Nevermind all my posts, just the last one:

 

"I want to be able to both have the manufacturer and product name in the <title>"

 

Thanks.

Share this post


Link to post
Share on other sites

The code to display the manufacturer on a category page is already in the includes/header.php file. if you want it displayed on the products page too, which is a mistake in my option, then you will need to copy the code from the index section into the product_ingo section in the above file.

 

Jack

Share this post


Link to post
Share on other sites

Found a problem.

 

<td class="pageHeading"><?php echo $category['categories_htc_title_tag']; ?></td>

 

Won't show any text on the indexpage when there is no category. Where the old "What's New Here?" text used to be.

 

And I get no title whatsoever when I am in a category.

Share this post


Link to post
Share on other sites

What is the current state of this contrib? Is it safe to install or will installation require some serious fiddling to get it running? (I don't want to risk breaking our live shop for too long)

 

forgot to tick the email notification box lol... hence this reply...

Share this post


Link to post
Share on other sites
Found a problem.

 

<td class="pageHeading"><?php echo $category['categories_htc_title_tag']; ?></td>

 

Won't show any text on the indexpage when there is no category. Where the old "What's New Here?" text used to be.

 

And I get no title whatsoever when I am in a category.

What text would you displayed if there is not a category? As for not seeing a titel, have you ran fill tags?

 

Jack

Share this post


Link to post
Share on other sites

Hello, This is a great Contribution, Thanks

I just install the contribution and looks that everything is working, but I created a new page "about us" to show in the information box, and this is the title that shows for the page:

 

HEAD_TITLE_TAG_ABOUTUS - Microsoft Internet Explorer

 

 

How can I change it, I already run the option "Add a New Page" and input Title,Description and Keywords, and select HTTA: HTDA: HTKA: HTCA:

 

But still showing in the Title: HEAD_TITLE_TAG_ABOUTUS - Microsoft Internet Explorer

 

 

 

Thanks

Share this post


Link to post
Share on other sites
What is the current state of this contrib? Is it safe to install or will installation require some serious fiddling to get it running? (I don't want to risk breaking our live shop for too long)

 

forgot to tick the email notification box lol... hence this reply...

The last update I uploaded (V 2.5.5 - Jack_mcs) is stable. I don't support the other updates so I cannot speak to how well they work. As for having to fiddle with it, the code works fine but it is an SEO package. That means that you have to adjust it to match your site. The default settings have cdroms as a keyword and oscommerce as a title so unless your shop matches those, you will have to make adjustments.

 

Jack

 

 

Hello, This is a great Contribution, Thanks

I just install the contribution and looks that everything is working, but I created a new page "about us" to show in the information box, and this is the title that shows for the page:

 

HEAD_TITLE_TAG_ABOUTUS - Microsoft Internet Explorer

How can I change it, I already run the option "Add a New Page" and input Title,Description and Keywords, and select HTTA: HTDA: HTKA: HTCA:

 

But still showing in the Title: HEAD_TITLE_TAG_ABOUTUS - Microsoft Internet Explorer

Thanks

Did you add the Header Tags code in the about_us.php file? Be sure the page you added in admin->Header Tags->Page Control matches the name of the page. From the above, if appears you added the page as aboutus so that means you must have a file in your root named aboutus.php.

 

Jack

Share this post


Link to post
Share on other sites

I just changed it back to PAGE_TITLE, is there any use of having the $category.. code there at all? Since it will not display category names there as I see it.

 

And since it did not display manufacturers name on them manufacturer page I edited index.php

 

At about line 264:

 

<td class="pageHeading"><?php echo $category['categories_htc_title_tag'] ? $category['categories_htc_title_tag'] : $the_manufacturers['manufacturers_name']; ?></td>

 

Now that displays either the category name if a category, or manufacturer name if you are in the manufacturers page.

 

 

Fill tags does absolutely nothing to me for some reason.. all the old products and categories still have NULL in the database table for title, desc, key.

Edited by Woloj

Share this post


Link to post
Share on other sites

Sounds like you have a mistake in your installation. If fill tags isn't working, you need to get it working or fill in the tags manaully.

 

Jack

Share this post


Link to post
Share on other sites

I went through the admin install again and everything was the same. The other form at text control works. After you update something in "Fill tags" should some message show? It just refreshes the page and nothing happends.

Share this post


Link to post
Share on other sites

I'm a little confused, so bear with me. I have a working version of header tags (v2.3.7). I would like to update to include Category tags as well.

 

I had attempted to use the update files from v2.3.8, but ran into trouble. I was able to remove the updates except for the database files. Then I thought I would try to update with version 2.5.4, but I noticed that the "Update_header_categories.sql" files are different than the ones I have left over from the attempted 2.3.8 version.

 

from 2.3.8

ALTER TABLE categories ADD category_head_title_tag VARCHAR(80) NULL;

ALTER TABLE categories ADD category_head_desc_tag LONGTEXT NULL;

ALTER TABLE categories ADD category_head_keywords_tag LONGTEXT NULL;

 

from 2.5.4

ALTER TABLE categories_description ADD categories_htc_title_tag VARCHAR(80) NULL;

ALTER TABLE categories_description ADD categories_htc_desc_tag LONGTEXT NULL;

ALTER TABLE categories_description ADD categories_htc_keywords_tag LONGTEXT NULL;

 

The question is, should I remove the 2.3.8 database updates before installing the 2.5.4 database updates, or is it ok to have them both there? They seem to deal with different tables. I should also add that I don't need the auto filltags feature, as I have done a lot of work on the products already.

 

Thank you in advance.

Share this post


Link to post
Share on other sites
I went through the admin install again and everything was the same. The other form at text control works. After you update something in "Fill tags" should some message show? It just refreshes the page and nothing happends.
No, a message is not displayed (will be in next release). After running fill tags looks at the header tags section of a product. If they are filled in, then it worked.

 

Jack

 

 

The question is, should I remove the 2.3.8 database updates before installing the 2.5.4 database updates, or is it ok to have them both there? They seem to deal with different tables. I should also add that I don't need the auto filltags feature, as I have done a lot of work on the products already.

 

Thank you in advance.

The previous database fields are no longer used. You can delete them or leave them there - it won't matter either way. It would be a mistake to upgrade just to 2.5.4 though. That version has some bugs in it that were fixed in 2.5.5. If you don't have need of the fill tags option, you don't have to use it. Although it allows you to fill in new products without touching the current ones which the script version didn't do.

 

Jack

Share this post


Link to post
Share on other sites

i've done a search to reveal there is no manufacturer support on this. but the manufacturer's are all assigned names through osc, how could i make a custom header tag for it (just saying general info to fit all manufacturer categories, a generic tag..) and have the title just be the manufacturer name.

 

if possible, i would also like to display the manufacturer name on the body of the manufacturers page.

anyone have an idea of how i could achieve this?

Share this post


Link to post
Share on other sites

I see what you mean now. You are correct, the code isn't set up to show title and meta tags for manufacturer pages. I will change that in the next release. For now, the "easiest" way to do it is to manually add fields in the database for each manufacturer. Then in index.php you will need to add the code to read in those fields when a manufacturer page is being shown. The code change is minor but setting up the database could take a while.

 

Jack

Share this post


Link to post
Share on other sites

what section of index.php would i need to edit?

 

when do you expect the next release? :)

Share this post


Link to post
Share on other sites

Around line 245 you will see this

	$category_query = tep_db_query("select cd.categories_htc_title_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");

Your changes need to change that to read in the manufacturers data instead of the categories data if a manufacturer page is being displayed.

 

There's no telling on the update. I just work on it when I have time. Could be this week or three months from now.

 

Jack

Share this post


Link to post
Share on other sites

I added the 2.5.5 update to my 2.3.8 version last night. My site is working, but I have a couple of problems.

 

1. When I add category titles to existing categories, nothing changes. And when I go back to edit, nothing has been saved.

 

2. If I create a new category, the changes work. However, when I go back to edit, It won't let me change anything.

 

I followed the instructions for updating for versions before 2.3.9, any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

The problem is most likely in the admin/categories.php file. Try replacing yours with the one from the contribution just to see if that problem clears up. If it does, then you need to go through the file to find the problem.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×