Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

I have just noticed that when i type in a title for the category and save it in admin, it says " Warning; no file uploaded " on top of the page..what could be wrong?

Share this post


Link to post
Share on other sites

That's normal. That refers to an image not being uploaded. It is part of the code in the categories file and would involve to much effort to disable for each contribution so you'll always see it on any contribtuion that makes changes via that file.

 

Jack

Share this post


Link to post
Share on other sites

OK one otehr thing...

in the catalog/index.php, if i change the

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

to

 

<?php

// BOF: WebMakers.com Changed: Header Tag Controller v2.5.2

// Replaced by header_tags.php

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

// EOF: WebMakers.com Changed: Header Tag Controller v2.5.2

?>

 

I get this error;

 

1054 - Unknown column 'c.category_head_title_tag' in 'field list'

 

select cd.categories_name, c.category_head_title_tag, c.category_head_desc_tag, c.category_head_keywords_tag from categories c, categories_description cd where c.categories_id = '314' and cd.categories_id = '314' and cd.language_id = '1'

 

[TEP STOP]

Share this post


Link to post
Share on other sites

You have the wrong version of Header Tags. Please download V 2.5.4 and use that.

 

Jack

Share this post


Link to post
Share on other sites
You have the wrong version of Header Tags. Please download V 2.5.4 and use that.

 

Jack

 

where is that version jack, i can only see 2.5.2 if i search for header in contributions??

and do i need to undo all the changes for the one i've already installed? :(

Share this post


Link to post
Share on other sites

The team is implenting a new policy on what can be in a contribution. I've uploaded it twice but they apparently found something else. I'll have to ask for another definition before trying to upload again.

 

Jack

Share this post


Link to post
Share on other sites

so..how long could we have to wait for that?

also..i have some people offering to install theheader tag contribution for me for a small charge...would they get stuck at the same point??

Share this post


Link to post
Share on other sites

I've just uploaded it and it is there now. I think I have it set the way they want but, if not, it will be pulled again so don't delay.:)

 

As to whether the people insalling it would get stuck or not, there's no way to tell. If they know what they are doing, they shouldn't have a problem.

 

Jack

Share this post


Link to post
Share on other sites

i would suggest you try to install the contribution yourself, Jack is pretty good about the instructions and there is plenty of help here if you run into problems.

 

so..how long could we have to wait for that?

also..i have some people offering to install theheader tag contribution for me for a small charge...would they get stuck at the same point??


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

you are right Mibble....I dont think I'll be payin anyone to do it for me especially now that I have the browser titles showin up for categories aswell....thanks JACK!

 

before i carry on with the admin install section again, a brief look tells me its the same as the last file as in V3.5.2

 

if i fill meta tags in the category section, they dont show up in the source of the page and if you go back to the category section in admin, all the meta tags, titles etc. have disappeared although the titles show in the browser.

 

any thoughts?

Share this post


Link to post
Share on other sites

actually i've just noticed that as i had this other " dynaimc meta tags " contribution added previously, the meta tags and keywords are showing up in the source for some pages where I have left it in..excellent

will give it anotehr check and try adding meta tags to other pages and get back to you guys....

:thumbsup:

Share this post


Link to post
Share on other sites

no i was wrong.... the previous meta tag contribution is not working, i had to take some HTTA ticks etc off for the unique tags to work.... everything seems fine now....thought i'll add this reply to clear any confusions.

Share this post


Link to post
Share on other sites

I have a problem with file http://www.MYSITE.it/admin/header_tags_controller.php

 

 

Warning: main(includes/languages/italian/FILENAME_HEADER_TAGS_CONTROLLER): failed to open stream: No such file or directory in /MYSITE.it/httpdocs/admin/header_tags_controller.php on line 15

 

Fatal error: main(): Failed opening required 'includes/languages/italian/FILENAME_HEADER_TAGS_CONTROLLER' (include_path='.:/usr/local/psa/apache/lib/php') in /MYSITE.it/httpdocs/admin/header_tags_controller.php on line 15

 

 

 

This is line 15:

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_HEADER_TAGS_CONTROLLER);

 

 

I have a site in Italian language

 

I have already modified the file of the Italian language instead of that English

 

What I must make?

 

Thanks

Share this post


Link to post
Share on other sites

It sound like you missed the part where you edit the filenames.php file. From the instructions:

Add to admin/includes/filenames.php anywhere before the closing ?>

define('FILENAME_HEADER_TAGS_CONTROLLER', 'header_tags_controller.php');
define('FILENAME_HEADER_TAGS_ENGLISH', 'header_tags_english.php');
define('FILENAME_HEADER_TAGS_INCLUDES', 'header_tags_includes.php');

 

Jack

Share this post


Link to post
Share on other sites
It sound like you missed the part where you edit the filenames.php file. From the instructions:
Add to admin/includes/filenames.php anywhere before the closing ?>

define('FILENAME_HEADER_TAGS_CONTROLLER', 'header_tags_controller.php');
define('FILENAME_HEADER_TAGS_ENGLISH', 'header_tags_english.php');
define('FILENAME_HEADER_TAGS_INCLUDES', 'header_tags_includes.php');

 

Jack

 

 

I have controlled but there are

 

That allowed it must have the file filenames.php?

I have 644 it's Just?

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

I have just installed this contrib and find it extremely good, although I am having a few teething problems.

When i alter the tags etc for allprods, it doesnt save them, also, a lot of my pages, eg. reviews, shipping etc dont show the title, tags, description when i view the source code.

Any ideas please?

Share this post


Link to post
Share on other sites
I have just installed this contrib and find it extremely good, although I am having a few teething problems.

When i alter the tags etc for allprods, it doesnt save them, also, a lot of my pages, eg. reviews, shipping etc dont show the title, tags, description when i view the source code.

Any ideas please?

 

Hi,

I had the same problem, as a mater of fact i still do....but you can still use the contribution in the sense that everything is saved if you check the page source...although the category title heading shows as empty, as long as you dont click "save" the previous info you typed on the page still shows...

also try ticking on and off the HTTA and other options on the header tags page and check their effect on the source page.

Share this post


Link to post
Share on other sites

I'm also getting a problem with the default description and keywords, no matter how much i change it, it goes back to saying: osCommerce : What'''s New Here? - Hardware Software DVD Movies

Share this post


Link to post
Share on other sites

First, be sure you are using V 2.5.4. Then try changing it in admin and then look at the includes/languages/english/header_tags.php file to see if it was actually changed. If not, then, assuming the installation was done correctly, your host is probably preventing it.

 

Jack

Share this post


Link to post
Share on other sites

the header contribution 2.5.4 is working perfectly but i need to know how to get rid of this email add in the source code..started getting spam already....i did a search on it but wasn't sure exactly what line of code to remove and which file exactly.

Thanks!

Share this post


Link to post
Share on other sites

If you are referring to the meta reply-to tag, that was removed in version 2.5.2 but was added back in by mistake in v 2.5.3. To remove it, just change the following line in includes/header_tags.php

echo '  <META NAME="Reply-to" CONTENT="' . HEAD_REPLY_TAG_ALL . '">' . "\n";

to

//echo '  <META NAME="Reply-to" CONTENT="' . HEAD_REPLY_TAG_ALL . '">' . "\n";

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×