Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Try replacing your product_info.php file with your backup. If it works, then you have made a mistake in that file or maybe in the products description in the database (although that is unlikely since they are all failing). If it still fails, then you have some other problem unrelated to Header Tags.

 

Jack

 

Hi Jack,

 

Sure enough? I pulled the products_info.php file from the back up I made on my local machine from before I took the leap of faith of trying to install a contribution for the first time. That fixed the problem? I guess all I need to do now is compare the modified version with the original and the install notes to figure out where I went wrong.

 

Thanks for help!

 

Terry D

Share this post


Link to post
Share on other sites
That looks deffinitely like a bug in your code somewhere in product_info.php.  What I do to trouble shoot these kinds of bug is I put echo 'something' in different places in the program and see which one shows and which ones don't.  This doesn't always work but it usually does.

 

I've noticed something odd on your site however, the URL always have 2 slashes after the domail and before the catalog  i.e.: yourdomain//catalog/product_info.php?...

 

This will not fix your problem but you may want to check it out.  Some browsers may not like it.

 

Hi ptrinephi,

 

Yeah, I noticed that too? I thought it to be a bit odd but considering it IS working I figured I would explore that one later. That was one of the first things I tried ?Taking out that second slash? in the address bar but that didn?t change anything. Thanks for pointing it out anyway? Now I?m curious what?s causing that? Sounds like another sleepless night.

 

I can tell that OSC is going to be lengthy learning experience.

 

Thanks again,

 

Terry D

Share this post


Link to post
Share on other sites

It is most likely a mistake in your configure.php file. Your url should not end in a slash since it gets added later. But this question shouldn't really be addressed in this thread so if that doesn't fix it, please open a new thread.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites
It is most likely a mistake in your configure.php file. Your url should not end in a slash since it gets added later. But this question shouldn't really be addressed in this thread so if that doesn't fix it, please open a new thread.

 

Jack

 

Ok,

 

I?ve gone over the instructions and it looks like I?m doing the code exactly like they say to do it in the instructions.

 

They say:

 

In each file of /catalog/ you will need to make the following modification:

 

Replace the existing two lines in all files that you want to use the Header Tags Controller:

 

Old Lines:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

New Lines:

 

<?php

// BOF: WebMakers.com Changed: Header Tag Controller v2.4.7

// Replaced by header_tags.php

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

// EOF: WebMakers.com Changed: Header Tag Controller v2.4.7

?>

 

SO, In PRODUCT_INFO.PHP I find the code as described:

 

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

 

And replaced it with:

 

<?php

// BOF: WebMakers.com Changed: Header Tag Controller v2.4.7

// Replaced by header_tags.php

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

// EOF: WebMakers.com Changed: Header Tag Controller v2.4.7

?>

 

And that's what makes the products stop apearing when they are clicked on.

 

So, it seems that the HTC code might have something to do with the problem?

 

I don?t know enough about PHP ?yet? to spot anything that would be obvious. Is there something here that you see?

 

Thanks for the help guys?

 

Terry D

 

PS, I will take up the double slash thing in the address bar later in a more appropriate thread or start a new one. Thanks for the pointer though....

Share this post


Link to post
Share on other sites

If that is the only change made and it fails, then the problem is in includes/header_tags.php or includes/languages/english/header_tags.php. Try replacing those files with the ones from the contribution and see what happens.

 

Jack

Share this post


Link to post
Share on other sites

Hi everyone

 

I just started to install header tags 2.5.1

 

1) Database modification OK

2) install catalog file OK

 

But all the categories are in german, I have an osc website in 3 languages english,french and german.

 

So is this normal and I just should continue with the install admin part

 

Best regards

Share this post


Link to post
Share on other sites
Hi everyone

 

I just started to install header tags 2.5.1

 

Database modification OK

install catalog file OK

 

But all the categories are in german, I have an osc website in 3 languages english,french and german.

 

Then I installed the admin part and I cannot see it, this could be because I renamed the admin folder for security reason.

 

1) So in german is this normal

2) Why i do not see the admin part

 

Thanks in advance

Best regards

Share this post


Link to post
Share on other sites

The categories section doesn't work for all languages. This is a known problem and will be fixed when I, or anyone, can get to it. But for now there is no fix for it.

 

Jack

Share this post


Link to post
Share on other sites

Have just finished installing this mod but sadly when i go to the admin section and change the header names/descriptions/keywords nothing happens. If i visit a different part of the site and then return to /catalog/admin/header_tags_english.php the changes that i have made have defaulted back to

osCommerce : What'''s New Here? - Hardware Software DVD Movies
for description and
Hardware Software DVD Movies What'''s New Here?
for keywords.

 

No errors are being shown to me.

 

 

Has anyone had this problem before? any solutions?

 

Alistair

 

 

p.s. sorry for not being able to give more information.

Share this post


Link to post
Share on other sites

You should try changing the permissions on the includes/header_tags.php and english/header_tags.php files to 777.

 

Jack

Share this post


Link to post
Share on other sites
The categories section doesn't work for all languages. This is a known problem and will be fixed when I, or anyone, can get to it. But for now there is no fix for it.

 

Jack

 

 

Thank you for your answer, well I can not help you I am not a php programmer, but if you need any help in translation for german or French, just send me an email. Do you know any other contribution, or do you have a pointer on how to make it work, or in which file I have to look.

 

Best regards

Patrick

Share this post


Link to post
Share on other sites
Thank you for your answer, well I can not help you I am not a php programmer, but if you need any help in translation for german or French, just send me an email. Do you know any other contribution, or do you have a pointer on how to make it work, or in which file I have to look.

 

Best regards

Patrick

 

 

Ouoops forgot !!!!

 

What about the admin side not showing up

Share this post


Link to post
Share on other sites

Sorry, I missed that part of the question somehow. There shouldn't be any reason why it is not showing up in admin. When you say that it is not showing up, do you mean the admin->Header Tags tool is not there or that the tags are not present in catalog? If the former, that should show up (although not work) by just copying the new files and editing the column left file.

 

Jack

Share this post


Link to post
Share on other sites

Jack, version 2.5.0 has files to be modified in the catalog root folder( contact_us, product info, etc).,, In v 2.5.1 they are not there. Were those edits not needed anymore


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

I didn't upload vrersion 2.5.0 so I don't know what changes were made to it. But if you go back through the last few pages of this thread, you will see that a lot of people had problems with it. I didn't include those changes in 2.5.1 for those reasons.

 

Jack

Share this post


Link to post
Share on other sites

Ok I gotit now Header Tags Controller v2.4.9 does not have those file edits. I'll stick with yours! v2.5.1

I did not notice they were not yours.

 

Thanks for the hard work

 

Jimmy

 

www.dvbhardware.com

Edited by RI Downlink

I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

Some small remarks concerning v2.5.1:

* the SQL statements in the Install_Catalog.txt are outdated (the category_head_description field is not yet there). As the DB structure modifications are already documented in Install_ReadMe_First.txt, wouldn't it be better to just remove them here?

* Install_Catalog.txt mentions /catalog/includes/languages/espanol/header_tags.php but this is not included in the package

* Install_Catalog.txt mentions "v2.4.7" several times while the package version is v2.5.1

* the language-specific header_tags.php mentions the following:

// The HEAD_TITLE_TAG_ALL is included BEFORE the specific one for the page

As far as I can see "BEFORE" should be "AFTER".

 

Thanks btw for maintaining/improving this contribution. :thumbsup:

Edited by aragorn231

Share this post


Link to post
Share on other sites

Additional remark to v2.5.1:

 

There's a bug in /admin/categories.php, causing the "Meta Tag Information" text to appear in between the Product Description boxes (for the different languages).

 

To solve it replace the following code (starting at line 570):

   <tr>
           <td colspan="2" class="main"><hr><?php echo TEXT_PRODUCT_METTA_INFO; ?></td>
         </tr>
<?php
   }
   for ($i=0, $n=sizeof($languages); $i<$n; $i++) {
?>

with

<?php
   }
?>
  <tr>
           <td colspan="2" class="main"><hr><?php echo TEXT_PRODUCT_METTA_INFO; ?></td>
         </tr>
<?php
   for ($i=0, $n=sizeof($languages); $i<$n; $i++) {
?>

Share this post


Link to post
Share on other sites

I didn't read thoruh all 46 pages, so this has probably been answered, but how do you get the product's name to show in the title when you are viewing it?

Share this post


Link to post
Share on other sites
Some small remarks concerning v2.5.1:

* the SQL statements in the Install_Catalog.txt are outdated (the category_head_description field is not yet there).  As the DB structure modifications are already documented in Install_ReadMe_First.txt, wouldn't it be better to just remove them here?

* Install_Catalog.txt mentions /catalog/includes/languages/espanol/header_tags.php but this is not included in the package

* Install_Catalog.txt mentions "v2.4.7" several times while the package version is v2.5.1

* the language-specific header_tags.php mentions the following:

// The HEAD_TITLE_TAG_ALL is included BEFORE the specific one for the page

As far as I can see "BEFORE" should be "AFTER".

 

Thanks btw for maintaining/improving this contribution.  :thumbsup:

All of these are fixed in the new release to be uploaded shortly.

 

Jack

Share this post


Link to post
Share on other sites
I didn't read thoruh all 46 pages, so this has probably been answered, but how do you get the product's name to show in the title when you are viewing it?

You need to run the fill_tags.php file that comes with Header Tags or edit the products yourself to add the data. They will display automatically once they are filled in.

 

Jack

Share this post


Link to post
Share on other sites

I've uploaded version 2.5.2.

 

This is what was done:

-> Changed Categories Description field for New Products to use a larger text area.

-> Added code to have the categorries header tags work in any language

-> Added txt file to explain Header Tags use

-> Fixed coding error in admin/header_tags_controller.php that was causing a new page title to be set to the page name.

-> Commented out the code for including the email in the source code. Since this is only used as a spam magnet, it is not recommended to be used. However, if you want to use it, then just uncomment the code in includes/header_tags.php at the bottom of the file.

-> Added files with code already installed (for admin only)

-> Update documentation.

 

This is not an easy update to do but is needed to get the language files to work properly. The update instructions are in the new Update_Docs directory and is named Update_Header_Tags_Language.txt.

 

Jack

Share this post


Link to post
Share on other sites

I have installed the catalog part of the contribution

 

upon trying to access my index page i get the following error

 

1054 - Unknown column 'c.category_head_title_tag' in 'field list'

 

select cd.categories_name, c.category_head_title_tag, c.category_head_desc_tag, c.category_head_keywords_tag from categories c, categories_description cd where c.categories_id = '0' and cd.categories_id = '0' and cd.language_id = '1'

 

 

 

can someone please help?

 

 

thanks for this great contribution

 

later

indi

Share this post


Link to post
Share on other sites

What version are you installing? That is not part of the 2.5.2 version.

 

Jack

Share this post


Link to post
Share on other sites

i downloaded the version that was uploaded yesterday...

// WebMakers.com Added: Header Tags Controller v2.5.2

 

 

pleasee help!

Edited by indicaz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×