Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Hi

 

Has anyone ever written a manual on how to effectively use the options in HTC, and how to choose the best & right number of words for each part?

 

Thanks

 

Adam

There is a popup help guide on the HTxx options and they have been covered here. There is a file that comes with the contribution that tries to address, a little, about the keywords. However, that is beyond the scope of this contribution. Picking out the correct keywords for a site, while the most important part of SEO, is not something that can be addressed easily on the forums.

 

Jack

Share this post


Link to post
Share on other sites

A new version has been uploaded. The support thread for it is now located here. I will continue to support my versions of the Header Tags Controller, but no updates will be released, at least by me. The new contribution is superior anyway so you should update if possible.

 

Jack

Share this post


Link to post
Share on other sites

Hey everyone,

 

I'm having a very frustrating problem and I've tried searching through this entire thread but can't find a clear answer. My problem is that the only header tags that are appearing are the ones I set for default. Individual header tags for product pages are not showing up (even when I have them defined in the product edit page in admin). What could be the problem? Any help is appreciated in advance. Thanks again!

 

Arash

Share this post


Link to post
Share on other sites
Hey everyone,

 

I'm having a very frustrating problem and I've tried searching through this entire thread but can't find a clear answer. My problem is that the only header tags that are appearing are the ones I set for default. Individual header tags for product pages are not showing up (even when I have them defined in the product edit page in admin). What could be the problem? Any help is appreciated in advance. Thanks again!

 

Arash

Either the product_info.php file has a problem or the includes/header_tags.php and/or english/header_tags.php files are not working correctly. Try replacing the last two with the ones from the contribution to isolate which file is at fault.

 

Jack

Share this post


Link to post
Share on other sites

Please need help with your mod!

Look at the picture:

d0a77916ee.jpg

 

I'have the FCKEditor Mod Installed, the multi images plus mod, the thumbs mod and that´s all.

I've followed your instrucions correctly but it still looks like in the picture.

 

Please help. Thanks.

Share this post


Link to post
Share on other sites

You've made a mistake with the code changes for that page. I suggest removing them all and then adding them in one at a time, uploading and checking the site each time.

 

Jack

Share this post


Link to post
Share on other sites

Help!!! Now, while installing the admin part of the mod this appeared when I tryed to enter to the admin catalog section!!!!!!

 

Parse error: syntax error, unexpected '}' in /web/sites/vhbu3/3/244/94027/public/www/admin/categories.php on line 828

 

PLZ HELP!

Share this post


Link to post
Share on other sites

You've made a mistake with the code changes for that page. Use the included file to isolate the problem.

 

Jack

Share this post


Link to post
Share on other sites

Seems as if you add a part of the code out of the "normal page structure". I had the same misstake. I don't know now (it was some months ago) what I did exactly but I can remember that I had to put the code some lines above (could be that it was behind the </body> tag or behind a closing table tag (</table>, </tr> or </td>

Share this post


Link to post
Share on other sites

I have also some problems with htc:

The Installation works fine and when I add a page (within admin > header tags > page control) I figured out that I can't set a special title tag for the following files. There is only the global title showed in the frontend. But the colour is black (and not red, so it sould work) I defined a special title in all installed languages but without success:

- index.php

- product_info

- popup_image.php

- info_shoppiung_cart.php

- checkout_shipping.php

- products_new.php

 

Another failure I noticed: I can't delete all of my defined pages. Just 25 pages from the enlish definitions and 27 pages from the german (but there are around 50 defined).

Share this post


Link to post
Share on other sites

I have installed the mod just fine and the majority of it works perfect. The only problem I have is :

when editing a category/product and not changing the image (which has already been uploaded) the image becomes null.

Very irritating to have to update the image each time.

 

Please help.

Edited by cgfreak76

Share this post


Link to post
Share on other sites

That is a problem in the categories file. The included one is for MS2 so it you use that, it won't work.

 

Jack

Share this post


Link to post
Share on other sites

I have a client that insists on "stuffing" his keyword meta tag on his index page. Is there any way to increase the built in character/word limit for the keyword box for the index.php and other pages for the Header Tags Controller?

 

Thanks,

 

Greg R

Share this post


Link to post
Share on other sites

You need to edit the size of the keyword field in the product description table in the database using a program like phpmyadmin.

 

Jack

Share this post


Link to post
Share on other sites
You need to edit the size of the keyword field in the product description table in the database using a program like phpmyadmin.

 

Jack

Jack,

 

Thanks for the quick reply. However, the client doesn't want to add more keywords to his product pages only his index page. The Keywords box for index in Admin -> Header Tags -> Text Control only allows a small amount of characters. How do I change that?

 

Thank you,

Greg R

Share this post


Link to post
Share on other sites

The code for that box would have to be edited to allow for inputing more characters. It is just a number you change in the line of code that draws that box.

 

Jack

Share this post


Link to post
Share on other sites
The code for that box would have to be edited to allow for inputing more characters. It is just a number you change in the line of code that draws that box.

 

Jack

 

OK. Yes I found it in header_tags_english.php.

 

Thanks again,

Greg R

Share this post


Link to post
Share on other sites

hi i am trying to make a custom page with the header tags in it so i made test.php and put the following in it:

 

<?php

/*** Begin Header Tags SEO ***/

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

/*** End Header Tags SEO ***/

?>

 

then in the admin i am able to see this file and add stuff to it, it all shows up in the database but when you go to the page it just says in the source:

 

<title>TITLE</title>

 

i guess all i really need to know is how to just make a blank page that i can link to that header tags will let me modify via its admin

 

thanks

Share this post


Link to post
Share on other sites

This is the support thread for the Header Tags Controller contribution. You need to determie which one you are using since they work differently. If you are using Header Tags SEO, as your code indicated, then you should ask in that thread.

 

Jack

Share this post


Link to post
Share on other sites

I already had STS installed 4.2 and upgraded to include HTC. Everything is working flawlessly until I click on a product in the product listing. I get a 500 error.

 

[08-Jul-2008 15:54:39] PHP Fatal error: Cannot redeclare clean_html_comments() (previously declared in /home/j/public_html/shop/includes/functions/clean_html_comments.php:11) in /home/j/public_html/shop/includes/functions/clean_html_comments.php on line 24

 

I have yet to figure this out and have been working for about 6 hrs on it :(

Share this post


Link to post
Share on other sites

You need to follow the instructions for installing it with STS since the placement of that function is in a different place. The instructions are in the STS download section.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

This is a great mod and appears to be very popular so congrats to the creators and those assisting in the development.

 

I have had this installed for some time now and just recently we added the manufacture filter.

 

When the customer filters by manufacture the title displays Let's See What We Have Here and doesn't display the manufacture description.

 

We have both the title and description set in the admin.

 

When the customer is viewing category, it displays the title and description set no problem.

 

Any assistance is greatly appreciated.

 

thanks


Sincerely

Mike

Share this post


Link to post
Share on other sites

All I can think of is that the code in the index file (that added by this contribution) is not correct since that is where it checks if a manufacturer is being shown.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×