Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Jack,

I am having the same problem. I recently had to rebuild my entire website and install all modules fresh. My product tags and descriptions are all filled in but they all show up as the Default Title Tag and Description. I have tried each of your suggestions above. I also have tried using the fill all tags section (I asked it to limit the number of characters in the description and it did that, so I know this function works). However, the source still shows the default tags. The code in the products_info.php has not changed. I have tried checking and unchecking the boxes in Text Control page.

What's next?

Thanks,

Carol Ann

Never mind. I uploaded the files again and this time it worked. Thought I had already done this.

Thanks again for your support.

Carol Ann

Share this post


Link to post
Share on other sites

Hello, this is a great mod. Thanks Jack et al. From what I can see the only thing that is not working well from previous posts is the Update_Categories_Descriptions on the index.php, and I to can’t seem to get the categories descriptions as <h2> from been displayed in the individual index.php categories even when using 'categories_htc_description' in the index.php. Was wondering if there is an updated Update_Categories_Descriptions install instructions or if anyone can help me this adding <h2> 'categories_htc_description' to index.php see http://tinyurl.com/3at9k4 or http://tinyurl.com/3843k5

Richard

Share this post


Link to post
Share on other sites

Hi Folks,

 

I have just updated my STS system to 4.5.8 (MS2) and found a strange problem.

 

There was a lot of junk being rendered at the beginning of a page, that did not happen in STS 4.2 (ish)

 

I traced it back to this routine in /includes/classes/sts.php

 

function start_capture () {

// Start redirecting output to the output buffer, if template mode on.

if ($this->display_template_output) {

// ob_end_clean(); // Clear out the capture buffer. Removed in v4.3.3

ob_start();

}

}

 

re-enabling the ob_end_clean() fixed the issue.. my question is, why did this not work for me? Is there another part opf the code that should be doing this, that I may have missed in my update?

 

Thanks a lot

Pete

Share this post


Link to post
Share on other sites

This is the support thread for Header Tags. You will need to ask in the support thread for STS for your question.

 

Jack

Share this post


Link to post
Share on other sites
This is the support thread for Header Tags. You will need to ask in the support thread for STS for your question.

 

Jack

 

D'oh!

 

Sorry - was trying to get header tags working as well - got the wrong thread!

 

Cheers

Pete

Share this post


Link to post
Share on other sites

I installed Header Tags controller and I am having a problem when I click on a category. The category title "pipes" for instance, is now black instead of white and it appears that it isn't aligned properly. I don't know if this can be edited in the h1 section of stylesheet.css or what???

Can someone point me to the right file?

 

here is an example....

 

http://www.pipemagic.com/outside-pipes-c-25.html

 

notice "outside pipes" .....it is black and to the left too far

 

Thanks,

 

Brian

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Just have installed HTC on RC2a.

 

I see that some have problems getting tags filled correctly with 2 languages. I had the same.

Just found out that i have to change language in admin to get the other language to fill. First fill language 1, then change language to 2 and fill again.

 

A futur request then must be to have the option to change language within HTC without the need to chanage language in admin CPL. :rolleyes:

Share this post


Link to post
Share on other sites
Just have installed HTC on RC2a.

 

I see that some have problems getting tags filled correctly with 2 languages. I had the same.

Just found out that i have to change language in admin to get the other language to fill. First fill language 1, then change language to 2 and fill again.

 

A futur request then must be to have the option to change language within HTC without the need to chanage language in admin CPL. :rolleyes:

This has already been coded into the next version which will be released in 2-4 weeks.

 

Jack

Share this post


Link to post
Share on other sites

Still having touble editing the color for the h1 class. I am doing this in stylesheet.css it looks like this.

 

h1 {

font-family: Verdana, Arial, sans-serif;

font-size: 20px;

color: #FFFFFF;

font-weight: bold;

margin-bottom: 0;

padding-bottom: 0;

 

}

 

 

 

is there something that could be over riding this????.....i want the color to be white and it shows up black

 

what am I doing wrong?

 

http://www.pipemagic.com

Share this post


Link to post
Share on other sites

You might have more than one h1 class declared. Also, the link you provided is to the home page but the h1 class doesn't apply to that so you may not be looking at the right place.

 

Jack

Share this post


Link to post
Share on other sites

Hi

 

I have only installed HTC on the catalog side so far, but when i click on an individual product, the column_right moves under the central column.

 

Where and how do i fix this? (i guess its fixed in index.php ?)

 

Please click on the url to see what im talking about: http://www.gamecentral.com.au/theres-somet...-mary-p-19.html

 

 

Thanks for your assistance

 

Adam

Edited by adam777

Share this post


Link to post
Share on other sites
You might have more than one h1 class declared. Also, the link you provided is to the home page but the h1 class doesn't apply to that so you may not be looking at the right place.

 

Jack

 

 

http://www.pipemagic.com/inside-out-glass-pipes-c-22.html

 

I only have one h1 class in my stylesheet.css and even toying with the font size in the h1 section of the stylesheet.css doesn't do anything

 

Any ideas im stuck?

 

Thanks

Share this post


Link to post
Share on other sites

Jack, i really need your help. I would like to use your contribution like other do, but i have this problem when trying to follow the steps into the install_catalog.txt file.

Everything worked fine until here:

"Find the following lines in index.php"

Around line 78:

Find

 

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

 

and replace it with

 

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php } ?>

 

In my index.php on from line 68 to 90 i have the following code:

<!-- body_text //-->

<?php

if ($category_depth == 'nested') {

$category_query = tep_db_query("select cd.categories_name, c.categories_image, cd.categories_htc_title_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");

$category = tep_db_fetch_array($category_query);

?>

<td width="100%" valign="top">

 

<? tep_draw_heading_top();?>

 

<? new contentBoxHeading_ProdNew($info_box_contents);?>

 

<? tep_draw_heading_top_1();?>

 

 

 

 

<table border="0" cellspacing="0" cellpadding="0" align="center" class="box_width_cont product">

<tr><td height="10"></td></tr>

<tr>

<?php

if (isset($cPath) && strpos('_', $cPath)) {

// check to see if there are deeper categories within the current category

 

Also the next steps after this one, at least regarding the code in my index.php doesn't match at all with anything you've put there.

Can you give me some hints to know how to identify the correct codes that must be replaced ?

Thank you so much and i cannot wait until i see your response on this matter.

Good luck !

Share this post


Link to post
Share on other sites
Hi

 

I have only installed HTC on the catalog side so far, but when i click on an individual product, the column_right moves under the central column.

 

Where and how do i fix this? (i guess its fixed in index.php ?)

 

Please click on the url to see what im talking about: http://www.gamecentral.com.au/theres-somet...-mary-p-19.html

Thanks for your assistance

 

Adam

That would be the product_info.php file, most likely the change that goes near the bottom. You should try again and only install one change to the file at a time to see where the problem is coming from.

 

Jack

Share this post


Link to post
Share on other sites
http://www.pipemagic.com/inside-out-glass-pipes-c-22.html

 

I only have one h1 class in my stylesheet.css and even toying with the font size in the h1 section of the stylesheet.css doesn't do anything

 

Any ideas im stuck?

 

Thanks

According to your source, you are using a file named styles.css, not stylesheet.css, and that file doesn't have an h1 class in it.

 

Jack

Share this post


Link to post
Share on other sites
Jack, i really need your help. I would like to use your contribution like other do, but i have this problem when trying to follow the steps into the install_catalog.txt file.

Everything worked fine until here:

"Find the following lines in index.php"

Around line 78:

Find

 

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

 

and replace it with

 

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php } ?>

 

In my index.php on from line 68 to 90 i have the following code:

<!-- body_text //-->

<?php

if ($category_depth == 'nested') {

$category_query = tep_db_query("select cd.categories_name, c.categories_image, cd.categories_htc_title_tag, cd.categories_htc_description from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . (int)$current_category_id . "' and cd.categories_id = '" . (int)$current_category_id . "' and cd.language_id = '" . (int)$languages_id . "'");

$category = tep_db_fetch_array($category_query);

?>

<td width="100%" valign="top">

 

<? tep_draw_heading_top();?>

 

<? new contentBoxHeading_ProdNew($info_box_contents);?>

 

<? tep_draw_heading_top_1();?>

Your shop is not using standard oscommerce code. Whoever designed it moved some of the code to a different file. You will need to locate the file that holds the lines like this one
tep_draw_heading_top_1

and make the changes there.

 

Jack

Share this post


Link to post
Share on other sites

Hi there,

 

 

Just had to say that this works fabulous, I just have some problems when editing in the "Text Control Page", if I put CHMOD 755, it doesn't let me modify it, but if I put CHMOD 777 it lets me modify it, but shows an alert message in the Tag admin panel... so I'll just have to put up with that...

 

Then the only way this works out of the box is , first you install Ultimate Seo: http://www.oscommerce.com/community/contributions,2823

 

On a fresh OSC 2.2 works superb. And then, install the Header Tags Controller. It works at first.

 

It's perfect now! Thank God.

 

so that's my tip for the day... it's worked for me!

Share this post


Link to post
Share on other sites

SO i just have to replace each line including "tep_draw_heading_top_1" in it with the whole code above:

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php } ?>

 

 

Please let me know as i'm a newbie in this matter. Thank you so much.

Alin

Share this post


Link to post
Share on other sites
SO i just have to replace each line including "tep_draw_heading_top_1" in it with the whole code above:

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php } ?>

Please let me know as i'm a newbie in this matter. Thank you so much.

Alin

There's no way for me to say since changes like the ones in your shop are non-standard code. The heading_top probably has a matcing heding_bottom which may also need to be edited.

 

Jack

Share this post


Link to post
Share on other sites

Hello Jack, sorry to have to bother you... I downloaded your last Header Tags that was to have the fix for the language problem as they work for my English side but not for the French, the index page still showing DEFAULT_TITLE. As I have a new store I copied the files directly but still have the problem. Am currently on PHP 5, using the OSC 2.2rc1 as it was the version the web hoster loads. As I say, the English loads great, all my permissions are the same on the French side but they just won't change! In Admin panel I have switched from one language to the other and still can not get the index French side to change, woe is me. Any other suggestions?

 

Thanks in advance

-Mandy

Share this post


Link to post
Share on other sites
Hello Jack, sorry to have to bother you... I downloaded your last Header Tags that was to have the fix for the language problem as they work for my English side but not for the French, the index page still showing DEFAULT_TITLE. As I have a new store I copied the files directly but still have the problem. Am currently on PHP 5, using the OSC 2.2rc1 as it was the version the web hoster loads. As I say, the English loads great, all my permissions are the same on the French side but they just won't change! In Admin panel I have switched from one language to the other and still can not get the index French side to change, woe is me. Any other suggestions?

 

Thanks in advance

-Mandy

To be clear, I haven't uploaded a version that will work with other languages so I'm not sure what version you are using. To see where the problem lies, look at the includes/languages/french/header_tags.php file and make sure it has the text you want. If it does, then the problem is on your shop side. If not, then it is on the admin side (assuming you tried changing it from there).

 

Jack

Share this post


Link to post
Share on other sites
To be clear, I haven't uploaded a version that will work with other languages so I'm not sure what version you are using. To see where the problem lies, look at the includes/languages/french/header_tags.php file and make sure it has the text you want. If it does, then the problem is on your shop side. If not, then it is on the admin side (assuming you tried changing it from there).

 

Jack

 

 

Sorry Jack, I used the version 2.6.3 (which by the way runs on one of my other websites which is based on osc2.2MS2 avec PHp 4.31 and was so esay to install and use, as I have found all of your contributions to be!). So, is this a problem maybe specific to osc 2.2rc1 which has a lot of the basic pages coded differently when I compare to my other version. I spent the day uninstalling and reinstalling and the French side just doesn't change although in Admin it says they were updated with success. I feel really dumb! thanks for your help.

 

Mandy

Share this post


Link to post
Share on other sites

Are the changes you made in admin actually in the includes/languages/french/header_tags.php file?

 

Jack

Share this post


Link to post
Share on other sites

I am using Header Tags 2.6.3 and I have osCommerce 2.2.2. I have default tags set up for general pages, but I can't get the information I set up in the products pages to show up. I think I have tried every combination in Text Control, but it always shows the default tags. I have unchecked all the HTXX boxes including HTPA, but this always remained checked.

I know you can fill tags on the Fill Tags page, but this will overwrite the tags I have set up. Is this my only option to get my keywords and descriptions to show up in the source code?

Thanks for your help,

Carol Ann

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×