Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

I just need to know how to change the permissions on those two files to 755.. I have been plugged into php mods all night and I am going to go cross eyed trying to read the pages in this topic to find it... Anyone online right now that can give me a pointer here?

Share this post


Link to post
Share on other sites

I am getting an error when i add products to my site after getting this mod installed. I changed the permissions to 755 and that worked fine in the admin side but now when i add products I get this:

 

1054 - Unknown column 'categories_name' in 'field list'

 

insert into products_description (categories_name, categories_htc_title_tag, categories_htc_desc_tag, categories_htc_keywords_tag, categories_htc_description, products_id, language_id) values ('', '', '', '', '', '38', '1')

 

[TEP STOP]

 

Anyone else experience this?

Share this post


Link to post
Share on other sites
No, the search function is limited in the standard code. There is a contribution you can install that will casue the search to include the descriptions (sorry, don't recall the name).

 

Jack

 

Thanks Jack, I'll take a look.

Share this post


Link to post
Share on other sites

Please someone help me on my title/header/meta tags as far as I know (as I have limited knowledge on this) I am using what is best described

as the manual meta tags contributions and even though in the back end I have manually put in the title and description meta tags for each category,

what ever is on the home page on the title of the web browser is coming up on every category page. Please advise how I can make the title meta tag

(and description meta tag) that I have filled in the admin panel for each category appear on every category page?

 

Thanks

Share this post


Link to post
Share on other sites
I am getting an error when i add products to my site after getting this mod installed. I changed the permissions to 755 and that worked fine in the admin side but now when i add products I get this:

 

1054 - Unknown column 'categories_name' in 'field list'

 

insert into products_description (categories_name, categories_htc_title_tag, categories_htc_desc_tag, categories_htc_keywords_tag, categories_htc_description, products_id, language_id) values ('', '', '', '', '', '38', '1')

 

[TEP STOP]

 

Anyone else experience this?

It looks like you didn't run the included sql file.

 

Jack

Share this post


Link to post
Share on other sites
Please someone help me on my title/header/meta tags as far as I know (as I have limited knowledge on this) I am using what is best described

as the manual meta tags contributions and even though in the back end I have manually put in the title and description meta tags for each category,

what ever is on the home page on the title of the web browser is coming up on every category page. Please advise how I can make the title meta tag

(and description meta tag) that I have filled in the admin panel for each category appear on every category page?

 

Thanks

This is the support thread for the Header Tags Controller contribution. I am not familiar with a contribution named "manual meta tags" but you will need to ask in the support thread for it to get your question answered.

 

Jack

Share this post


Link to post
Share on other sites

I added all of the sql files. when i tried to re add them it kept saying this for teh header sql file:

 

SQL query:

 

ALTER TABLE products_description ADD products_head_title_tag VARCHAR( 80 ) NULL ;

 

 

 

MySQL said:

 

#1060 - Duplicate column name 'products_head_title_tag'

 

It says this for the update header_categoties:

 

SQL query:

 

ALTER TABLE categories_description ADD categories_htc_title_tag VARCHAR( 80 ) NULL ;

 

 

 

MySQL said:

 

#1060 - Duplicate column name 'categories_htc_title_tag'

 

It says this for the update_header_categories_description sql file:

 

SQL query:

 

ALTER TABLE categories_description ADD categories_htc_description LONGTEXT NULL

 

MySQL said:

 

#1060 - Duplicate column name 'categories_htc_description'

 

This for the update_header_languages sql file:

 

SQL query:

 

ALTER TABLE categories_description ADD categories_htc_title_tag VARCHAR( 80 ) NULL ;

 

 

 

MySQL said:

 

#1060 - Duplicate column name 'categories_htc_title_tag'

 

 

And this for the update_header_manurafturer sql file:

 

SQL query:

 

ALTER TABLE manufacturers_info ADD manufacturers_htc_title_tag VARCHAR( 80 ) NULL ;

 

 

 

MySQL said:

 

#1060 - Duplicate column name 'manufacturers_htc_title_tag'

Share this post


Link to post
Share on other sites
I added all of the sql files. when i tried to re add them it kept saying this for teh header sql file:
I'm sorry. I didn't read your question close enough. The original error is saying the categories_name field doesn't exist in the products description table. Since that field isn't supposed to exist there, the problem isn't with the database. My guess is that you edited the categories.php file incorrectly. Try using the one from the archive to see if the problem goes away.

 

Jack

Share this post


Link to post
Share on other sites

NOO!!! That was the last thing I wanted to edit!!!!

 

 

But I will go thought it again and see what i did wrong.. Thanks Jack

Share this post


Link to post
Share on other sites

There was one section that i had to modify because it had some changed with when i added the images with light box contribution.

 

Here is the code code i had before I changed it:

 

} elseif ($action == 'new_product_preview') {

if (tep_not_null($HTTP_POST_VARS)) {

$pInfo = new objectInfo($HTTP_POST_VARS);

$products_name = $HTTP_POST_VARS['products_name'];

$products_description = $HTTP_POST_VARS['products_description'];

$products_url = $HTTP_POST_VARS['products_url'];

} else {

// BOF MaxiDVD: Modified For Ultimate Images Pack!

$product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_image_med, p.products_image_lrg, p.products_image_sm_1, p.products_image_xl_1, p.products_image_sm_2, p.products_image_xl_2, p.products_image_sm_3, p.products_image_xl_3, p.products_image_sm_4, p.products_image_xl_4, p.products_image_sm_5, p.products_image_xl_5, p.products_image_sm_6, p.products_image_xl_6, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");

// EOF MaxiDVD: Modified For Ultimate Images Pack!

$product = tep_db_fetch_array($product_query);

 

Here is the code after I changed it.

 

<!-- HTC BOC //-->

<?php

} elseif ($action == 'new_product_preview') {

if (tep_not_null($HTTP_POST_VARS)) {

$pInfo = new objectInfo($HTTP_POST_VARS);

$products_name = $HTTP_POST_VARS['products_name'];

$products_description = $HTTP_POST_VARS['products_description'];

$products_head_title_tag = $HTTP_POST_VARS['products_head_title_tag'];

$products_head_desc_tag = $HTTP_POST_VARS['products_head_desc_tag'];

$products_head_keywords_tag = $HTTP_POST_VARS['products_head_keywords_tag'];

$products_url = $HTTP_POST_VARS['products_url'];

} else {

$product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_quantity, p.products_model, p.products_image, p.products_image_sm_1, p.products_image_xl_1, p.products_image_sm_2, p.products_image_xl_2, p.products_image_sm_3, p.products_image_xl_3, p.products_image_sm_4, p.products_image_xl_4, p.products_image_sm_5, p.products_image_xl_5, p.products_image_sm_6, p.products_image_xl_6, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'");

$product = tep_db_fetch_array($product_query);

// HTC EOC

 

 

IS THIS WHERE I WENT WRONG?

Share this post


Link to post
Share on other sites

I am using Version 2.6.3 with STS.

 

I've been using it for ages, it's fantastic.

 

However, for some reason the HTC fields have dissappeared from my Categories and Product pages - does anyone know how I get them back?

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites
There was one section that i had to modify because it had some changed with when i added the images with light box contribution.

 

 

Here is the code after I changed it.

 

IS THIS WHERE I WENT WRONG?

No, that's not it. The original code you posted showed the changes for the categories section being in the line for the products description. So you need to search the file for that. It would be easier to use a program like WinMerge and compare yours with the included one though. it won't match exactly but you should be able to see this problem since fields with categories should not be in sql calls dealing with products.

 

Jack

Share this post


Link to post
Share on other sites
I am using Version 2.6.3 with STS.

 

I've been using it for ages, it's fantastic.

 

However, for some reason the HTC fields have dissappeared from my Categories and Product pages - does anyone know how I get them back?

 

Thanks

 

Lotti

Try turning STS off to see if they come back. That will tell if the problem is with STS or Header Tags. Also look in admin to see that the entries are still there. If they are, then the problem is with the files on the shop side, most likely.

 

Jack

Share this post


Link to post
Share on other sites

I'm hopig to get some help. After installing header tag controller I go into my admin and only in Categories/Products (everything else loads fine) I get this error message:

Categories / Products Search:

Go To: TopHome Theater Remote ControlsPhone Systems Talkswitch PBX Phone Systems Bizphone PBX Phone SystemsComputers CDROM Drives Graphics Cards Keyboards Memory Mice Monitors Printers SpeakersElectronicsPrinter/Fax/CopiersAccessoriesMobile Audio/VideoCloseout Deals

 

Categories / Products Status Action

 

1 - Can't create/write to file '/tmp/#sql_4538_0.MYI' (Errcode: 13)

 

select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, cd.categories_htc_title_tag, cd.categories_htc_desc_tag, cd.categories_htc_keywords_tag, cd.categories_htc_description from categories c, categories_description cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id = '1' order by c.sort_order, cd.categories_name

 

[TEP STOP]

 

Can anyone give me some advice as to how I can fix this......also I can't get into PHPMyAdmin, I get this error message:

 

phpMyAdmin - Error

 

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

 

I am lost at this point and would appreciate any help.

 

Thanks.


Jada

 

The codes of the many, outweigh the codes of the few. Live long and Prosper.

Share this post


Link to post
Share on other sites
Try turning STS off to see if they come back. That will tell if the problem is with STS or Header Tags. Also look in admin to see that the entries are still there. If they are, then the problem is with the files on the shop side, most likely.

 

Jack

Hi Jack,

 

It doesn't come back if I turn STS off so I'm guessing that's not the problem (was kind of hoping it would be something that simple!!)

 

Any suggestions as to where I go from here?

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites

OK i re wrote the entier categories.php page and now i get a new error.. this one i have no idea.. I installed the ultimate images pack with light box before doing this mod. Is that why I am having these problems??

 

Here is the error:

 

Parse error: syntax error, unexpected T_CASE in /home/myhome/myuser/mysite.com/admin/categories.php on line 511

Edited by lemnick

Share this post


Link to post
Share on other sites

The above line of code in my categories.php file is:

 

 

case 'new_product_preview':

Share this post


Link to post
Share on other sites
Hi Jack,

 

It doesn't come back if I turn STS off so I'm guessing that's not the problem (was kind of hoping it would be something that simple!!)

 

Any suggestions as to where I go from here?

 

Thanks

 

Lotti

 

I got it sorted, thanks for the help

Share this post


Link to post
Share on other sites
I'm hopig to get some help. After installing header tag controller I go into my admin and only in Categories/Products (everything else loads fine) I get this error message:
If the only problem after the installation is when you go to the categoies.php file, then the categories.php file has a mistake in it. Use the included one to compare against.

 

Jack

Share this post


Link to post
Share on other sites
OK i re wrote the entier categories.php page and now i get a new error.. this one i have no idea.. I installed the ultimate images pack with light box before doing this mod. Is that why I am having these problems??

 

Here is the error:

 

Parse error: syntax error, unexpected T_CASE in /home/myhome/myuser/mysite.com/admin/categories.php on line 511

The problem is in the categories file and you have a working one to compare against as well as a free compare program (WinMerge). If you determine the problem isn't with Header Tags, then you need to ask in the general support thread for help if you can't find the cause of the problem.

 

Jack

Share this post


Link to post
Share on other sites

Ok i just switched mods because it was easier... but the one thing i really want from this mod is the info box that has the description of the coin. In the column_left.php file. Is there a way i can just get that out of this sweet mod?

 

Thanks again for all the help with everything Jack..

Share this post


Link to post
Share on other sites
Ok i just switched mods because it was easier... but the one thing i really want from this mod is the info box that has the description of the coin. In the column_left.php file. Is there a way i can just get that out of this sweet mod?

 

Thanks again for all the help with everything Jack..

You can use whatever code is there as you like but it won't work anywhere else by itself since it requires Header Tags data.

 

Jack

Share this post


Link to post
Share on other sites

Thats what i was asking.. if there was a way to just take and use that part of the install_catalog.. and not the rest of it..

Share this post


Link to post
Share on other sites

Hi. I installed this contribution a few years ago (v2.0) and now want to update it to the latest version. I have followed the instructions in update_version_before_v_2.3.9.txt and have also altered the manufacturers table. When I try to access the "Home" section of admin I get the following error:

 

1054 - Unknown column 'c.category_head_title_tag' in 'field list'

select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, c.category_head_title_tag, c.category_head_desc_tag, c.category_head_keywords_tag from categories c, categories_description cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id = '1' order by c.sort_order, cd.categories_name

 

Also, when trying to access a category in the shop I get the following error:

 

1054 - Unknown column 'c.category_head_title_tag' in 'field list'

select cd.categories_name, c.categories_image, c.category_head_title_tag, c.category_head_desc_tag, c.category_head_keywords_tag from categories c, categories_description cd where c.categories_id = '42' and cd.categories_id = '42' and cd.language_id = '1'

 

Accessing a product works fine.

 

Could you please tell me what has gone wrong?

 

Thanks

Share this post


Link to post
Share on other sites

Okay I managed to find the solution to this. The database fields are called *_htc_* but the php files were referring to *_header_*. I changed the code and it is now working. There is one minor problem, though, when I go to page control I get the following error:

 

Permissions settings for the /includes/header_tags.php file appear to be incorrect. Change to 755
Error Permissions settings for the /includes/languages/english/header_tags.php file appear to be incorrect. Change to 755

 

It all seems to be working and I have checked the permissions on those files, so I am not sure why I am getting this message.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×