Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

anyone know why i got this error and how to fix it;

 

1054 - Unknown column 'categories_htc_title_tag' in 'field list'

 

select categories_name, categories_htc_title_tag, categories_htc_desc_tag, categories_htc_keywords_tag from categories_description where categories_id = '0' and language_id = '1'

 

[TEP STOP]

 

 

strange thing is i have installed several sites with same database and files but this time got this error

 

thanks

Share this post


Link to post
Share on other sites

It appears your database changes didn't take affect for some reason.

 

Jack

Share this post


Link to post
Share on other sites

You need to install the database changes. If they are partially installed, running the script again might say it is installed when it really isn't. In that case, you will need to use the header.sql file and install the changes through phpmyadmin one at a time.

 

Jack

Share this post


Link to post
Share on other sites
You need to install the database changes. If they are partially installed, running the script again might say it is installed when it really isn't. In that case, you will need to use the header.sql file and install the changes through phpmyadmin one at a time.

 

Jack

 

 

thanks, reinstalled and now get this, yet there is nothing wrong in that file;

 

Parse error: syntax error, unexpected T_STRING in /home/elegance/public_html/includes/header_tags.php on line 359

 

 

thanks

Share this post


Link to post
Share on other sites

Try replacing that one along with the one in the english directory with the included ones to see if the problem goes away.

 

Jack

Share this post


Link to post
Share on other sites
Try replacing that one along with the one in the english directory with the included ones to see if the problem goes away.

 

Jack

 

what the same file in english????

 

but that isn't the same file??

Share this post


Link to post
Share on other sites

I have now replaced all the header tags files and have ended up with the original database error?????

 

1054 - Unknown column 'categories_htc_title_tag' in 'field list'

 

select categories_name, categories_htc_title_tag, categories_htc_desc_tag, categories_htc_keywords_tag from categories_description where categories_id = '0' and language_id = '1'

 

[TEP STOP]

 

 

any ideas??????

 

thanks

Share this post


Link to post
Share on other sites

Hi all,

 

I have just installed this contrib on a new test site on my machine - XP Pro with iis

 

I get the following errors on the Header Tags controller

 

Error Permissions settings for the C:\Inetpub\wwwroot\TitjikalaArts/includes/header_tags.php file appear to be incorrect. Change to 777

Error Permissions settings for the C:\Inetpub\wwwroot\TitjikalaArts/includes/languages/english/header_tags.php file appear to be incorrect. Change to 777

 

I found that 777 is read, write, execute for ownder, group and other so I set that in the security permissions for the file, but the error still appears.

 

However, I can change things and that works ok.

 

How do I get rid of the error messages?

 

Thank you for your time

Share this post


Link to post
Share on other sites
I have now replaced all the header tags files and have ended up with the original database error?????

 

1054 - Unknown column 'categories_htc_title_tag' in 'field list'

 

select categories_name, categories_htc_title_tag, categories_htc_desc_tag, categories_htc_keywords_tag from categories_description where categories_id = '0' and language_id = '1'

 

[TEP STOP]

any ideas??????

 

thanks

The error is pretty clear - it can't find the required database field.

 

Jack

Share this post


Link to post
Share on other sites
Hi all,

 

I have just installed this contrib on a new test site on my machine - XP Pro with iis

 

I get the following errors on the Header Tags controller

 

Error Permissions settings for the C:\Inetpub\wwwroot\TitjikalaArts/includes/header_tags.php file appear to be incorrect. Change to 777

Error Permissions settings for the C:\Inetpub\wwwroot\TitjikalaArts/includes/languages/english/header_tags.php file appear to be incorrect. Change to 777

 

I found that 777 is read, write, execute for ownder, group and other so I set that in the security permissions for the file, but the error still appears.

 

However, I can change things and that works ok.

 

How do I get rid of the error messages?

 

Thank you for your time

The code won't work properly on a Windows setup. If you want to get rid of the error, you have to remove the code. In admin/header_tags_controller.php, remove
  if (GetPermissions(DIR_FS_CATALOG_IMAGES) != Getpermissions($filenameInc))
  $messageStack->add("Permissions settings for the $filenameInc file appear to be incorrect. Change to " . Getpermissions(DIR_WS_IMAGES));
 if (GetPermissions(DIR_FS_CATALOG_IMAGES) != Getpermissions($filenameEng))
  $messageStack->add("Permissions settings for the $filenameEng file appear to be incorrect. Change to " . Getpermissions(DIR_WS_IMAGES));

and remove the similar code in admin/header_tags_english.php.

 

Jack

Share this post


Link to post
Share on other sites

Hi again Jack

 

I get a new error in Categories.

Parse error: syntax error, unexpected T_CASE in /usr/home/dan17495/public_html/catalog/admin/categories.php on line 995

 

Line 995 says:

case 'edit_category':

Right after that is this:

$heading[] = array('text' => '<b>' . TEXT_INFO_HEADING_EDIT_CATEGORY . '</b>');

 

What seems to be the problem?

 

Thanks

Share this post


Link to post
Share on other sites
Hi again Jack

 

I get a new error in Categories.

Parse error: syntax error, unexpected T_CASE in /usr/home/dan17495/public_html/catalog/admin/categories.php on line 995

 

Line 995 says:

case 'edit_category':

Right after that is this:

$heading[] = array('text' => '<b>' . TEXT_INFO_HEADING_EDIT_CATEGORY . '</b>');

 

What seems to be the problem?

 

Thanks

See this.

 

Jack

Share this post


Link to post
Share on other sites

I installed this contribution with no problem, no errors at all. So I enter the keywords and title in and updated still no error. So i went to my webpage to veiw he source to see that the meta-tag were indeed included but i cant see my webpage all that is there is a white page with the following error:

 

Parse error: parse error, unexpected ')' in /home/content/r/a/b/rabinder/html/oscommerce/catalog/includes/header_tags.php on line 376

 

Can you please help me fix this?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Try replacing the includes/header_tags.php and english/header_tags.php file to see if the problem is fixed. If it is, compare them with yours to find what went wrong.

 

Jack

Share this post


Link to post
Share on other sites
Try replacing the includes/header_tags.php and english/header_tags.php file to see if the problem is fixed. If it is, compare them with yours to find what went wrong.

 

Jack

 

 

thanks that worked, ill be sure to check out the differences in the code :thumbsup:

Share this post


Link to post
Share on other sites

go to clear-jordans.com, when i click on a category, the category name comes up in the title bar ,instead of the tags i have filled in admin

 

 

someone please helo

Share this post


Link to post
Share on other sites
go to clear-jordans.com, when i click on a category, the category name comes up in the title bar ,instead of the tags i have filled in admin

someone please helo

Do you mean the category name is in the web browser title? If so, that is the way it is supposed to work.

 

Jack

Share this post


Link to post
Share on other sites

after installing this, and a new customer creates an account then click "NEXT"

 

 

Warning: Cannot modify header information - headers already sent by (output started at /home/clear-jo/public_html/includes/application_top.php:549) in /home/clear-jo/public_html/includes/functions/general.php on line 33

 

 

someone please help me

 

go to www.clear-jordans.com and try to purchase something, you will see what i mean

Share this post


Link to post
Share on other sites

I'm just installing this contrib, and it seems to be going well. It will be very useful when it's done.

 

The installation mentions setting permissions. Can you tell me how to do that? I did get my tech guy to set the permissions for a few of the language pages before I worked how to do it in Dreamweaver, but he did it over the phone and I don't know what he did. Thought it would be easier to do it my self than waiting til he has time to do it.

 

Cheers,

PDS

Share this post


Link to post
Share on other sites
I'm just installing this contrib, and it seems to be going well. It will be very useful when it's done.

 

The installation mentions setting permissions. Can you tell me how to do that? I did get my tech guy to set the permissions for a few of the language pages before I worked how to do it in Dreamweaver, but he did it over the phone and I don't know what he did. Thought it would be easier to do it my self than waiting til he has time to do it.

 

Cheers,

PDS

 

Famous last words. I think I jynxed myself there, did the database and catalogue bits fine, but after I did the admin section it went to pot. I shall try again.

Share this post


Link to post
Share on other sites

I had previously not made many changes to the admin section, besides removing americanisms like catalog and suburb, so I just copied the files over and edited my english.php so it matched the one in the contib. However I am still getting the same problem.

In the admin section it just has the header and the left column (minus anything to do with the header tags) and nothing in the middle, and it stays like that regardless of what page I go on, like this. Anybody know what's up?

Cheers,

PDS

Edited by powerdrive

Share this post


Link to post
Share on other sites
In the admin section it just has the header and the left column (minus anything to do with the header tags) and nothing in the middle, and it stays like that regardless of what page I go on, like this. Anybody know what's up?

Cheers,

PDS

See this.

 

Jack

Share this post


Link to post
Share on other sites

I've started comparing the files; comparing, editing and uploading one at time, the error seems to occur when I change column_left.php

I'm going to do the rest of the files and leave column_left.php til last and see if anything alse causes problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×