Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

Hi,

 

On product_info.php I get a space before all closing " on every line written by HTC when 'Title' is left empty and the HTCA option is active !!

 

The line that counts though and makes problems is around line 444: The html layout is affected in such way that the box containing the main product description completly looses its format.

 

Sorry, I dont have the code at this time but it should be easy to reproduce.

 

 

Was this noticed before?

 

Thanks any for suggestions


david

Share this post


Link to post
Share on other sites
What does "space before all closing" mean?

 

Jack

 

It is actually the line in product_info.php just below TEXT_VIEWING:

 

< a title"---" " href="----space">

 

if I remove the space the layout gets ok!

I meant the double quote by " :blush:


david

Share this post


Link to post
Share on other sites
It is actually the line in product_info.php just below TEXT_VIEWING:

 

< a title"---" " href="----space">

 

if I remove the space the layout gets ok!

I meant the double quote by " :blush:

 

Hey! and by the way I just notice the current forum title of this page ;-) contirbution or TRIbution

 

David


david

Share this post


Link to post
Share on other sites
It is actually the line in product_info.php just below TEXT_VIEWING:

 

< a title"---" " href="----space">

 

if I remove the space the layout gets ok!

I meant the double quote by " :blush:

That code doesn't exist in the contribution. Where did you get it from?

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
That code doesn't exist in the contribution. Where did you get it from?

 

Jack

 

FIND: (around line 235)

 

</table></form></td>

<!-- body_text_eof //-->

 

 

ADD ABOVE it:

 

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="smallText" align="center"><?php echo TEXT_VIEWING; ?> 

<?php echo '<a title="' . $tags_array['title'] . '" href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $tags_array['title'] . '">' . $tags_array['title']; ?></a></td>

</tr>

 

NOTE: The placement of this is not critical. Anywhere neat the bottom of the page is fine.

You can also change or remove the TEXT_VIEWING text to fit your site.

 

I think this was the original contribution ! // Header Tags Controller v2.6.3 by Jack_mcs

 

Ok that was not line 444 only on the output page, sorry.

Edited by Eim2

david

Share this post


Link to post
Share on other sites

Oh, I see now. The code uses the products header tags title to create a link. It might be that you have html in that title, which could cause the problem.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
Oh, I see now. The code uses the products header tags title to create a link. It might be that you have html in that title, which could cause the problem.

 

Jack

 

Thanks for your reply!

 

I must admit I have almost no skills in PHP whatsoever and not much in html either but this just makes no sense to me.

I definitively dont have any html in that title. It is just a normal product name.

If I remove this particular and just only this space in front of those double quotes at the end of the href link: Everthing is fine:

(I save the page in htdocs under another name, remove this space, resave and then reload).

 

The space appears when in admin Text Control for the product_info page all text fields are empty (Tiltle, Description and keywords)

and only one option is selected i.e HTCA is actif.

 

I had really no problems installing the contrib though I have TotalB2B and many other contributions. Everything worked fine untill I noticed this point. The site is bilingual. The other language works perfect side by side with other options checked and no empty title in that particular title text field and no spaces at all in front of any quotes.


david

Share this post


Link to post
Share on other sites

I have the same problem as others in that I edit my category and if I do not input the image even if there is one already it becomes blank. I do not have the same problem on the product edit. I have tried typing in the file name but it then does not allow me to save it. I have done a compare of the categories.php with the one in the distribution but there is only one difference that another mod required on line 799 of the distribution categories.php file it is <code> if (!is_array($HTTP_POST_VARS[$key])) { </code> and in my file the same line is remarked out for the separate pricing per customer mod. Would this be the problem? any solution? I tried unremarking that line and then the categories.php does not run - get a blank page.

 

I'm stumped so any help would be appreciated.

 

Thanks

Carrie

Share this post


Link to post
Share on other sites
Thanks for your reply!

 

I must admit I have almost no skills in PHP whatsoever and not much in html either but this just makes no sense to me.

I definitively dont have any html in that title. It is just a normal product name.

If I remove this particular and just only this space in front of those double quotes at the end of the href link: Everthing is fine:

(I save the page in htdocs under another name, remove this space, resave and then reload).

 

The space appears when in admin Text Control for the product_info page all text fields are empty (Tiltle, Description and keywords)

and only one option is selected i.e HTCA is actif.

 

I had really no problems installing the contrib though I have TotalB2B and many other contributions. Everything worked fine untill I noticed this point. The site is bilingual. The other language works perfect side by side with other options checked and no empty title in that particular title text field and no spaces at all in front of any quotes.

The fields in Text Control and that code on the product_info page share one thing in common - the title. If the problem is showing in both of them, the problem is with the title, assumig a working installation, of course. Try going into the product edit page and entering something as a test for the header tags title, like AAA. Does it all work then?

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
I have the same problem as others in that I edit my category and if I do not input the image even if there is one already it becomes blank. I do not have the same problem on the product edit. I have tried typing in the file name but it then does not allow me to save it. I have done a compare of the categories.php with the one in the distribution but there is only one difference that another mod required on line 799 of the distribution categories.php file it is <code> if (!is_array($HTTP_POST_VARS[$key])) { </code> and in my file the same line is remarked out for the separate pricing per customer mod. Would this be the problem? any solution? I tried unremarking that line and then the categories.php does not run - get a blank page.

 

I'm stumped so any help would be appreciated.

 

Thanks

Carrie

The only thing that can cause such a problem is the categories.php file. The line numbers in the installation instructions are estimates and may not be anywhere near where the actual change is to be done so you can't use them to make the changes.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
I have the same problem as others in that I edit my category and if I do not input the image even if there is one already it becomes blank. I do not have the same problem on the product edit. I have tried typing in the file name but it then does not allow me to save it. I have done a compare of the categories.php with the one in the distribution but there is only one difference that another mod required on line 799 of the distribution categories.php file it is <code> if (!is_array($HTTP_POST_VARS[$key])) { </code> and in my file the same line is remarked out for the separate pricing per customer mod. Would this be the problem? any solution? I tried unremarking that line and then the categories.php does not run - get a blank page.

 

I'm stumped so any help would be appreciated.

 

Thanks

Carrie

This is a bug in the osC 060817 release. It has been fixed with the Online Merchant RC1 release.

Around line 80 in your admin/categories.php file:

Find:

if ($categories_image = new upload('categories_image', DIR_FS_CATALOG_IMAGES)) {

Change to:

 

	$categories_image = new upload('categories_image');
	$categories_image->set_destination(DIR_FS_CATALOG_IMAGES);

	if ($categories_image->parse() && $categories_image->save()) {


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
The fields in Text Control and that code on the product_info page share one thing in common - the title. If the problem is showing in both of them, the problem is with the title, assumig a working installation, of course. Try going into the product edit page and entering something as a test for the header tags title, like AAA. Does it all work then?

 

Jack

 

Sure it works, but problem is just the result in product_info page:

As soon as the Title text field gets a title it is ok. Same with Title text field empty but with HTTA and HTCA selected.

It is really just this special line in product_info.php within the link that messes up. (the space seems to replace the missing Title I guess)

As you said it seems an Html problem my side as far as the layout is concerned. But I see no reason for this space in the first place.

 

I will reinstall and come back as I guess HTCA and HTPA options do not seem to do the expected anyways.

HTPA does not remain selected after update.

 

Other thing regarding HTCA on the Admin interface (text Control) as well as in the How_to_Operate.txt:

 

Maybe I did not understand right but HTTA - HTDA - HTKA are directly related to the default values of the top text fields.

What about HTCA and HTPA?


david

Share this post


Link to post
Share on other sites
As you said it seems an Html problem my side as far as the layout is concerned. But I see no reason for this space in the first place.

 

What about HTCA and HTPA?

The code doesn't add the space. It is being added as a result of the html or, maybe, the missing title.

 

HTCA and HTPA are explained in the popup. They are special cases that only work for certain files and allow the category names to be added to the title and meta tags.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
The code doesn't add the space. It is being added as a result of the html or, maybe, the missing title.

 

HTCA and HTPA are explained in the popup. They are special cases that only work for certain files and allow the category names to be added to the title and meta tags.

 

Jack

 

Ok thanks, I'll reinstall :thumbsup:


david

Share this post


Link to post
Share on other sites
This is a bug in the osC 060817 release. It has been fixed with the Online Merchant RC1 release.

Around line 80 in your admin/categories.php file:

Find:

if ($categories_image = new upload('categories_image', DIR_FS_CATALOG_IMAGES)) {

Change to:

 

	$categories_image = new upload('categories_image');
	$categories_image->set_destination(DIR_FS_CATALOG_IMAGES);

	if ($categories_image->parse() && $categories_image->save()) {

 

Awesome! Thank you so much that solved the problem.

 

Carrie

Share this post


Link to post
Share on other sites
The code doesn't add the space. It is being added as a result of the html or, maybe, the missing title.

 

HTCA and HTPA are explained in the popup. They are special cases that only work for certain files and allow the category names to be added to the title and meta tags.

 

Jack

 

My Apologies !!! I forgot to tell that I dont have the english language active but only german and french !!! Therefore I did not see the HTCA and HTPA notes fully translated. Any ways things appear to look much better and its just a matter of filling in a Title for the purpose of that special line of code.

 

Of course I installed all english files during the install process but never looked at them carefully. SO I found out that the french

includes/languages/french/header_tags.php just misses the HTPA lines.

 

So next time I ll have a better look at your original files! Sorry for this !


david

Share this post


Link to post
Share on other sites

Hi there, I installed HTC and the STS bundle... and everything was working fine, until I renamed and added some new pages. Now I can't seem to add any header info to any of my new pages, but the header info does seem to be working for the pages for the previously named (but non-existent) files... I also can't seem to modify any of the title information for my about_us, page, but that seems to be the only one! Is there anything I should have done before renaming these files, and/or adding new files? Now I'm totally stuck, can I clear the database and reinstall a few key files to get a fresh HTC?

 

Here's my shop:

http://www.perfectlocks.com

 

I find that to be very odd! Any idea why this could be happening?

Share this post


Link to post
Share on other sites

Hi All,

 

I am trying to track down some problems with HTC and Ultimate SEO urls, and in the process of going through my files I find the HTC contrib has fields in the categories_description table

 

 

categories_htc_title_tag

categories_htc_desc_tag

categories_htc_keywords_tag

categories_htc_description

 

The question is why are there 2 fields for what appears to be the description meta tag..??

 

 

and via the admin/categories.php file I have form fields to edit these Description database fields. One is a single line text input field and the other a multiline text input feild.

 

 

in products_description table I only have

 

products_head_title_tag

products_head_desc_tag

products_head_keywords_tag

 

No doubling up on the Description field.

 

Cheers.

Share this post


Link to post
Share on other sites
Hi All,

 

I am trying to track down some problems with HTC and Ultimate SEO urls, and in the process of going through my files I find the HTC contrib has fields in the categories_description table

categories_htc_title_tag

categories_htc_desc_tag

categories_htc_keywords_tag

categories_htc_description

 

The question is why are there 2 fields for what appears to be the description meta tag..??

and via the admin/categories.php file I have form fields to edit these Description database fields. One is a single line text input field and the other a multiline text input feild.

in products_description table I only have

 

products_head_title_tag

products_head_desc_tag

products_head_keywords_tag

 

No doubling up on the Description field.

 

Cheers.

categories_htc_desc_tag is for the description meta tag. categories_htc_description is for the text that appears on a category page under the category name.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Hi,

 

For categories that have sub-categories I am not getting the text of the name of the category output on the page of that top level category.

 

Down at the sub-category (final level down) I get the text coming out no problem.

 

I need the text to come out regardless of whether it's the top or lower level category that's being viewed..

 

Can anyone help?

 

Thanks guys,

 

Marv

Share this post


Link to post
Share on other sites

That is controlled by the code in the index.php file. Each one is handled by different code. It appears you missed a step or installed the changes for that file incorrectly.

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
That is controlled by the code in the index.php file. Each one is handled by different code. It appears you missed a step or installed the changes for that file incorrectly.

 

Jack

 

Hi,

 

Thanks for your help. I checked back through that though and all is as it should be.. ANy ideas possible causes you can think of?

 

Thanks,

 

Marv

Share this post


Link to post
Share on other sites

I assumed you ran Fill Tags but maybe not. If you edit a category in admin are all of the header tags fields filled in?

 

Jack


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites
I assumed you ran Fill Tags but maybe not. If you edit a category in admin are all of the header tags fields filled in?

 

Jack

 

Yes, I ran Fill Tags initially upon installing the contribution - and if I edit a category in admin all of the header tags fields are filled in as should be.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×