Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

That code, as you know, isn't from Header Tags code. To determine if Header Tags is at fault, remove the code added to the column_left.php file and go to a page that hasn't been altered by Header Tags (maybe contact_us.php). If it still fails, it isn't Header Tags.

 

Jack

Share this post


Link to post
Share on other sites
That code, as you know, isn't from Header Tags code. To determine if Header Tags is at fault, remove the code added to the column_left.php file and go to a page that hasn't been altered by Header Tags (maybe contact_us.php). If it still fails, it isn't Header Tags.

 

Jack

 

Thanks for the quick reply Jack, I am not sure, but I think that piece of code belongs to a category optimization mod that I installed some time ago. However, I haven't had any problems until after I installed the HTC contribution.

 

The code that was added to the column_left.php has already been removed (actually this problem first came about when I did insert the code into the column_left.php file) so I removed it and placed it in the column_right.php file and had the same problem, so I removed it as well.

 

NOTE: This is optional. It will add an info box on the product pages with keyword loaded text from the product page. This will increase the keyword density for that page, which should help with its position. If you don't want to use this option, just skip this step.

 

So, I am not blaming your contribution Jack, but just letting you know what has occurred so far and trying to find out what I can do to eliminate this problem. If you have any other suggestions, I would be glad to try them out.

 

regards

 

Andrew

Share this post


Link to post
Share on other sites

There was no offense taken. I was just trying to isolate the problem. Did you try looking at a page that doesn't use Header Tags as suggested?

 

Jack

Share this post


Link to post
Share on other sites
There was no offense taken. I was just trying to isolate the problem. Did you try looking at a page that doesn't use Header Tags as suggested?

 

Jack

 

Hi again Jack,

 

Yes, the only pages at the moment that seem to be unaffected are index.php and login.php and just now I refreshed the index.php page and the problem is appearing there now too. hmmmm this seems to be getting worse for some reason, I will finish this post and close my browser and restart it to see if that makes a difference. It appears to be affecting most pages now except login.php.

 

I did happen to find something on this forum regard the foreach() warning but no clear solution was offered, and it had something to do with the foreach() being an array and not a string, so I am still scratching my head with this one.

 

Thanks Jack, great contribution btw, hopefully this turns out to be just a minor gliche.

 

Andrew

Share this post


Link to post
Share on other sites

Hi again Jack

 

thanks for pointing me in the right direction, I ended up going to my catalog/includes/boxes/categories.php file and removing the category optimization code that I had installed a while back. Problem solved. This is the contribution that I had installed --> tep_show_category optimization which was causing the error just FYI.

 

Andrew

Share this post


Link to post
Share on other sites

Quick HTC question

 

Hello All,

 

I have STSv4.5 and I'd like to add HTC. What is the best way of doing this:

 

A: Uninstalling STS and then installing the bkellum bundle?

 

--OR--

 

B: Adding HTC?

 

If you say B, what is the best way of doing this? Are there particular instructions for STS users to add HTC?

 

Thank you in advance!

 

Best,

 

Chris

Share this post


Link to post
Share on other sites
Quick HTC question

 

Hello All,

 

I have STSv4.5 and I'd like to add HTC. What is the best way of doing this:

 

A: Uninstalling STS and then installing the bkellum bundle?

 

--OR--

 

B: Adding HTC?

 

If you say B, what is the best way of doing this? Are there particular instructions for HTC users to add STS?

 

Thank you in advance!

 

Best,

 

Chris

Chris, follow the link in my signature below on "How to install STS with HTC" Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Change Base Href:

 

I just installed HTC, and it inserts this code into my header:

 

base href="http://geekfitters.com/

 

This takes the "www" out of all of the links on my page. Is there a way to change this? Thank you in advance for your help.

 

Best,

 

Chris

Share this post


Link to post
Share on other sites

Idon't recall anywhere in the code where it adds a link, although it could. You will need to isolate wher that is coming from to determine the fix.

 

Jack

Share this post


Link to post
Share on other sites

great contrib! - installed with a few errors, double checked over instructions and fixed errors - presto! works as advertised!

 

side note - many of the search engine emulators take the first information available on the page after the header tags to present the information below your link - please take that into consideration as this contrib may not provide that valuable SEO service!

Share this post


Link to post
Share on other sites

That's a problem with the oscommerce code, not Header Tags. I could add the instructions to fix that but it would greatly increase the difficulty of the contribution and I'm not sure it would make a big difference. This thread explains how to do that if anyone is interested.

 

Jack

Share this post


Link to post
Share on other sites

After installing this contribution and going over my work several times, my index.php meta tags look like this:

<META NAME="Description" Content="HEAD_DESC_TAG_DEFAULT">

<META NAME="Keywords" CONTENT="HEAD_KEY_TAG_DEFAULT">

 

Every other page works well except for index.php. Any thoughts??

Share this post


Link to post
Share on other sites

That means it can't find the definitions for the index page. Did you alter that section in includes/header_tags.php or english/header_tgas.php? Either way, you might want to reload those from the contribution to be sure they are correct.

 

Jack

Share this post


Link to post
Share on other sites
That's a problem with the oscommerce code, not Header Tags. I could add the instructions to fix that but it would greatly increase the difficulty of the contribution and I'm not sure it would make a big difference. This thread explains how to do that if anyone is interested.

 

Jack

Jack,

Thanks for the link; however, it leads to a page that is missing the first 10 or so posts. Has that thread been removed by the moderater or is it a bad link?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I tried the link and it works fine for me.

 

Jack

The link works...

It's just that the first 10 posts are missing.

OK...I just went back and the posts were still missing. I then opened up the Forum Options tab and selected "Standard" and...

well, what do ya know, there they are.

 

Here is a good link (also referred to in that thread):

http://forums.oscommerce.com/index.php?showtopic=105994

 

Gives a good step by step on how to accomplish this. :thumbsup:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Thank you for the contribution!

 

Everything seems to be working, except I cannot seem to edit the category information in the How_To_Operate.txt. In step 5 it says "At the bottom of the

edit section to the right, you will see a large box for Categories Description." I can't seem to find this large box. When I go to admin->catalog and click edit I see in plain text: "Header Tags Category Title, Header Tags Category Description, Header Tags Category Keywords, Header Tags Categories Description"

but; with no way to edit these.

 

Have I done something wrong in the installation process?

 

Thank you for any help.

Share this post


Link to post
Share on other sites
Thank you for the contribution!

 

Everything seems to be working, except I cannot seem to edit the category information in the How_To_Operate.txt. In step 5 it says "At the bottom of the

edit section to the right, you will see a large box for Categories Description." I can't seem to find this large box. When I go to admin->catalog and click edit I see in plain text: "Header Tags Category Title, Header Tags Category Description, Header Tags Category Keywords, Header Tags Categories Description"

but; with no way to edit these.

 

Have I done something wrong in the installation process?

If you are only seeing the text and no input boxes then, yes, you probably made a mistake. There is a categories file in the contribution that you can try or use to compare against to help isolate the problem.

 

Jack

Share this post


Link to post
Share on other sites
If you are only seeing the text and no input boxes then, yes, you probably made a mistake. There is a categories file in the contribution that you can try or use to compare against to help isolate the problem.

 

Jack

 

 

Thanks Jack!

 

I found the problem, I had just missed one copy and paste from the contribution. I really appreciate the help.

 

I realized how dumb my question was after my last post. I should have asked which file I should look in to find the error, but you told me anyway

Edited by pulp2

Share this post


Link to post
Share on other sites

I changed the permission to 755 but the 2 header_tags.php still asking to me to change the permissions...

 

Any help please...

 

Thank you


OScommerce Rocks!

Share this post


Link to post
Share on other sites
I changed the permission to 755 but the 2 header_tags.php still asking to me to change the permissions...

 

Any help please...

 

Thank you

 

 

I'm really new at this so I don't know if this would work, but.... Have you tried setting the permission to 777?

Share this post


Link to post
Share on other sites
I changed the permission to 755 but the 2 header_tags.php still asking to me to change the permissions...

 

Any help please...

 

Thank you

Change the permissions to the same permission settings as your "images" folder.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I have three more quick questions:

 

How long does it usually take before google starts seeing ones header tags? I have most of mine in place but can find myself anywhere in Google search on any of my keywords. I'm guessing I have to wait a while before I start seeing my site on google searches, but I was just wondering how long.

 

Do any other contributions mess with google rank? I have only have additional images, and simple template system so far.

 

Are there any other essential contributions that will help improve my google page rank?

Share this post


Link to post
Share on other sites
I have three more quick questions:

 

How long does it usually take before google starts seeing ones header tags? I have most of mine in place but can find myself anywhere in Google search on any of my keywords. I'm guessing I have to wait a while before I start seeing my site on google searches, but I was just wondering how long.

 

Do any other contributions mess with google rank? I have only have additional images, and simple template system so far.

 

Are there any other essential contributions that will help improve my google page rank?

Once installed and fill tags is ran, products should start showing up in 2-8 weeks. Of course, that will vary with your product titles and the competition for them.

 

Header Tags doesn't affect Page Rank at all. The only way to change that is to have links to your site.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×