Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

I installed version 2.63. Everything was fine, but my server shut down while I was editing and I received a "No space left on device" error. Although this has not caused many problems in the past, now it erased all the pages in the text control file. I get a long error // .php define('HTTA__ON','0'); define('HTDA__ON','0'); define('HTKA__ON','0'); on and on. The error is only on my catalog and index pages. Has anyone experienced this problem? I would hate to reinstall this contribution just to have this happen every time the server has problems. My page has been generating business and this is a pretty serious problem. The admin controller will not add any pages to the text control. Any suggestions?

Share this post


Link to post
Share on other sites

You will need to replace either (or both) includes/header_tags.php and english/header_tags.php.

 

Jack

Share this post


Link to post
Share on other sites

I went ahead and reinstalled all the files. It worked. I just wonder if changing the file permissions to 777 (required to work) allows my server to automatically overwrite this contribution and if every time I end a work session I should change the permissions back to 755. But this may not be the reason it deleted anyways.

Share this post


Link to post
Share on other sites

Hi Folks,

 

I've just install the new version 2.6.3 from april 2nd.

 

I get this odd message "The file isn't writable".

 

I try to update the text control.

 

Further I get this at the top

"Permissions settings for the /hsphere/local/home/xxxxx/xxxxx/xxxxx/catalog/includes/languages/danish/header_tags.php file appear to be incorrect. Change to 755"

 

What file do we talk about???

 

Thanks in advance,

 

THomas

Share this post


Link to post
Share on other sites

It tells you what file to change in the error message as well as what to change it to.

 

JAck

Share this post


Link to post
Share on other sites

I have installed the contribution. THe following lines appear at the top of the front page.

 

// BOF: Header Tags Controller v2.6.0

require(DIR_WS_FUNCTIONS . 'header_tags.php');

// Clean out HTML comments from ALT tags etc.

require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

// EOF: Added: Header Tags Controller v2.6.0

 

I included these lines directly before the final ?> in the includes/application_top.php file.

 

// BOF: Header Tags Controller v2.6.0

require(DIR_WS_FUNCTIONS . 'header_tags.php');

// Clean out HTML comments from ALT tags etc.

require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

// EOF: Added: Header Tags Controller v2.6.0

 

 

?>

 

I am not sure what I have done wrong. TIA Chris

Share this post


Link to post
Share on other sites

Please post the last 10 or 15 lines of your application_top file.

 

Jack

Share this post


Link to post
Share on other sites
It tells you what file to change in the error message as well as what to change it to.

 

JAck

 

Hi Jack,

 

I've set the attribute to 777 and 755, but none of it works!!!

 

Any ideas?

 

/Thomas

Share this post


Link to post
Share on other sites

You need to set it to what your images directory is set to. If you have done that, try updating something in Header Tags anyway. The message is just a warning and will not prevent the script from working. They won't work though if the permissions are wrong so the easy way to find out is to see if a change can be made.

 

Jack

Share this post


Link to post
Share on other sites
You need to set it to what your images directory is set to. If you have done that, try updating something in Header Tags anyway. The message is just a warning and will not prevent the script from working. They won't work though if the permissions are wrong so the easy way to find out is to see if a change can be made.

 

Jack

 

Hi Jack,

 

When I press update, the next screen says

 

"The file isn't writable" !!!!

 

Any clue???

 

The attributes are OK I think. But what file is it that is "The file isn't writable"?

 

Thanks in advance,

 

Thomas

Share this post


Link to post
Share on other sites

The file that is listed in the warning. The warning is saying the file is not writeable and the error is saying the file is not writeable. The fix is to make it writeable. You may not be able to do that using an ftp program. Try it using the file manager in your hosts control panel.

 

Jack

Share this post


Link to post
Share on other sites
The file that is listed in the warning. The warning is saying the file is not writeable and the error is saying the file is not writeable. The fix is to make it writeable. You may not be able to do that using an ftp program. Try it using the file manager in your hosts control panel.

 

Jack

 

Thanks Jack that did the trick....

 

However, I do still get the warning in the top!!!

 

How can I eliminate that one :)

 

Thanks in advance,

 

/Thomas

Share this post


Link to post
Share on other sites
Yes, I type my url in place of "yourdomain.com" and it was found.

That was a typo. ... it wasn't found. I'm showing up on Yahoo but not on Google.

Share this post


Link to post
Share on other sites

hi,

 

I've got installed sts+ht, and now I've installed a contribution that modify the same code in admin/categories, I included just the part of the code that is new to keep Header Tags untouched, but I found one thing that I'm not able to choose if change it or not, because I'm not a programer

 

so what it is and what is for?, what will happen if I change it? (look line in bold, the "empty" and the exclamation mark before ($HTTP_POST_VARS)) )

 

with the new contribution

 

if (isset($HTTP_GET_VARS['pID']) && empty($HTTP_POST_VARS)) {

// Start adapted for product thickness shipping module

$product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_thickness, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");

// Stop adapted for product thickness shipping module

$product = tep_db_fetch_array($product_query);

 

with header tags

 

//HTC BOC

if (isset ($HTTP_GET_VARS['pID']) && (!$HTTP_POST_VARS) ) {

$product_query = tep_db_query("select pd.products_name, pd.products_description, pd.products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "' and p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "'");

$product = tep_db_fetch_array($product_query);

//HTC EOC

 

thank you


gatosol.jpg

Share this post


Link to post
Share on other sites
Thanks Jack that did the trick....

 

However, I do still get the warning in the top!!!

 

How can I eliminate that one :)

 

Thanks in advance,

 

/Thomas

If you are still seeing the warning, it means the permissions on the images directory and the header_tags file(s) don't match. If you can't get those to match, then you can delete the code that displays the message from admin/header_tags_controller.php and admin/header_tags_english.php. Here is the code
  if (GetPermissions(DIR_FS_CATALOG_IMAGES) != Getpermissions($filename))
  $messageStack->add("Permissions settings for the $filename file appear to be incorrect. Change to " . Getpermissions(DIR_WS_IMAGES));

 

Jack

Share this post


Link to post
Share on other sites
hi,

 

I've got installed sts+ht, and now I've installed a contribution that modify the same code in admin/categories, I included just the part of the code that is new to keep Header Tags untouched, but I found one thing that I'm not able to choose if change it or not, because I'm not a programer

 

so what it is and what is for?, what will happen if I change it? (look line in bold, the "empty" and the exclamation mark before ($HTTP_POST_VARS)) )

 

with the new contribution

with header tags

thank you

They are basically the same and, in this case, it doesn't matter which you use.

 

Jack

Share this post


Link to post
Share on other sites
They are basically the same and, in this case, it doesn't matter which you use.

 

Jack

 

ok, thanks for the information :thumbsup:


gatosol.jpg

Share this post


Link to post
Share on other sites

I have installed everything OK but I appear to have two sets of TITLE, META DESCRIPTION and META KEYWORDS for my pages. If I view the source of a product page I see identical text repeated twice within the <HEAD> tags. Is this normal? Will it affect my rankings if it isn't normal (most likely a negative effect?). Finally, where have I gone wrong and how do I correct it?

 

Thanks

Share this post


Link to post
Share on other sites

Do you have the HTxx boxes checked for those pages? If so, try un-checking them.

 

Jack

Share this post


Link to post
Share on other sites
Do you have the HTxx boxes checked for those pages? If so, try un-checking them.

 

Jack

 

Thanks for your reply. This is an existing problem from the original Header Tags contrib, how can I untick the boxes manually via the header_tags.php (language file?) ?

 

If it helps, some tracking code I placed on my site has also appeared twice wihin the head area.

Share this post


Link to post
Share on other sites

The HT options are in the includes/languages/enligh/header_tags.php file. You just them as you want and save the file.

 

Jack

Share this post


Link to post
Share on other sites

Fill Tags appearing incorrectly...please help

 

Hi Everyone,

 

I have just installed the contribution and everything is working well as it should be. I just have one problem - after completing 'Fill All Tags' for all categories I have the heading of the category appearing in an odd position on the screen and dont know how to correct it. You can see what I mean in this link: http://www.inmyimagination.com.au/index.php?cPath=25

 

I already have a title and description for the category positioned on the left using the category descriptions contribution. But after completing the 'Fill All Tags' I have another heading in large text in between the description and top right image. I want to know how to place the new heading in the top left. I can then remove the smaller heading from the descriptions file. Anyone know how to change its position though??

 

Thanks in advance.

Share this post


Link to post
Share on other sites

The code for Categories Description and the code for Header Tags can't both be in the file since they server the same purpose. If you added the code to the index.php file for Header Tags, except for the<title> section, you will need to remove it (or remove Categories Description).

 

Jack

Share this post


Link to post
Share on other sites

Hi

 

Just installed on a clean install and I'm getting these errors when a category is selected -

 

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/idealmc/public_html/shop/includes/classes/seo.class.php on line 115

 

Warning: Cannot modify header information - headers already sent by (output started at /home/idealmc/public_html/shop/includes/classes/seo.class.php:115) in /home/idealmc/public_html/shop/includes/classes/seo.class.php on line 1992

 

Warning: Cannot modify header information - headers already sent by (output started at /home/idealmc/public_html/shop/includes/classes/seo.class.php:115) in /home/idealmc/public_html/shop/includes/classes/seo.class.php on line 1993

 

but its fine when on the "home" page.

I've been through the install twice now but can't spot my mistake - any clues?

 

thanks

Share this post


Link to post
Share on other sites
The code for Categories Description and the code for Header Tags can't both be in the file since they server the same purpose. If you added the code to the index.php file for Header Tags, except for the<title> section, you will need to remove it (or remove Categories Description).

 

Jack

 

Sorry I dont completley understand your answer. Are you basically saying that these two contributions can't both be installed?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×