Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

No, I don't use them but have installed it in many shops. I used the first one you mentioned, only because it was available at the time. I imagine the other works just as well since the editor code is the same.

 

Jack

 

Well that's good news i suppose! maybe i'm getting the issues because of STS - I don't know - I'll try again. Can you remember if you had to use the 'stripslashes' function as Tinymce mentions this could be used to stop some problems when using it with a php page?

 

Becki

Share this post


Link to post
Share on other sites

No, the database file should be uploaded to the root directory (public_html in your case). You have it in the english directory.

 

Jack

Share this post


Link to post
Share on other sites
Well that's good news i suppose! maybe i'm getting the issues because of STS - I don't know - I'll try again. Can you remember if you had to use the 'stripslashes' function as Tinymce mentions this could be used to stop some problems when using it with a php page?

 

Becki

That function is not required but should be used. But I may have misunderstood what it is you are trying to do. The change I am talking about is to the admin section. But STS wouldn't affect that. Are you trying to apply the editor to the shop side somehow?

 

Jack

Share this post


Link to post
Share on other sites
That function is not required but should be used. But I may have misunderstood what it is you are trying to do. The change I am talking about is to the admin section. But STS wouldn't affect that. Are you trying to apply the editor to the shop side somehow?

 

Jack

 

Sorry i may have been saying the wrong thing, I put the TinyMce code into admin/categories.php between the title tags so that I could use the editor when creating a new product. For some reason though when I used it and updated the product - if I went to the product_info page and looked at the product (live) i had some '>/' at the top of the page and also if I turned the HTCA on in 'text control' for the product_info page these '>/' then turned into the meta tag information! Also in the title bar of IE I got all kinds of wonderfull pieces of code such as '<xml...> instead of the meta information.

Also when i went back into edit the product the info I'd typed into just the english description box had replicated into every other language box (both description and HTC boxes)

 

Did you just control the description box with Tinymce instead of every box on the page. Is there any chance someone could post their categories.php code from between the head tags so I can double check it if they have this working?

 

It is worth to note that the contribution I used said they had these '>/' in the product info page aswell - although i found it was worse when I turned the HTCA on as described!

 

thank you

Becki

Share this post


Link to post
Share on other sites

Where exactly are you placing the code in the categories file? It goes in the <head> section but not in the <title> tag.

 

Jack

Share this post


Link to post
Share on other sites
Where exactly are you placing the code in the categories file? It goes in the <head> section but not in the <title> tag.

 

Jack

 

Sorry once again! I must be too busy to concentrate. I put the code in the <head tags>!My mistake in my previous post.

 

 

Becki

Share this post


Link to post
Share on other sites

That's really all that is required for it to work, other than installing the editor, of course. Does it work for your email and newsletter? If so, then there is a mistake in the categories file. If not, then there is a mistake in the basic installation and you would need to ask in the support thread for it.

 

Jack

Share this post


Link to post
Share on other sites
That's really all that is required for it to work, other than installing the editor, of course. Does it work for your email and newsletter? If so, then there is a mistake in the categories file. If not, then there is a mistake in the basic installation and you would need to ask in the support thread for it.

 

Jack

 

I'll try the 'TinyMce Anywhere' tonight and see how it goes with the email and newsletter, I did use the latest version of TinyMce (2_10) i think, but this shouldn't be the problem surely.

 

Anyway I'll give it go and if not get on the support thread if there is one!

 

Thanks

Becki

Share this post


Link to post
Share on other sites

Hi, Jack,

 

Thanks for pointing out to upload data base changes to the root directory It works. When I continune to install at Install_Catalog I get a problem you may know how to fix it. According to the instructions, I should do

Around line 78:

 

Find

 

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

 

and replace it with

 

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php } ?>

 

But I found that I have modified the code line 78 as the followings to Display Category Name Plase see Knowledge Base Tips & Tricks

 

<td class="pageHeading"><?php echo HEADING_TITLE . ' ' . tep_get_categories_name($current_category_id); ?></td>

 

For displaying category / sub category names, I just wonder where I shoud add the code: ' ' . tep_get_categories_name($current_category_id); to the new code lines.

I hope that I have explain the problem clearly.

 

Thanks,

 

Charles

Share this post


Link to post
Share on other sites

The line

<td class="pageHeading"><?php echo HEADING_TITLE . ' ' . tep_get_categories_name($current_category_id); ?></td>

is the one referenced by

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

So you would replace that line code up to the </tr> beneath it.

 

Jack

Share this post


Link to post
Share on other sites
The line
<td class="pageHeading"><?php echo HEADING_TITLE . ' ' . tep_get_categories_name($current_category_id); ?></td>

is the one referenced by

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

So you would replace that line code up to the </tr> beneath it.

 

Jack

 

Yes, I know what you mean. But if I don't keep the line

<td class="pageHeading"><?php echo HEADING_TITLE . ' ' . tep_get_categories_name($current_category_id); ?></td>

, It will breaks th function of display category name.

 

Thanks,

 

Charles

Share this post


Link to post
Share on other sites
I'll try the 'TinyMce Anywhere' tonight and see how it goes with the email and newsletter, I did use the latest version of TinyMce (2_10) i think, but this shouldn't be the problem surely.

 

Anyway I'll give it go and if not get on the support thread if there is one!

 

Thanks

Becki

 

JUST to let you know...

 

I installed 'TinyMce Anywhere' and it works great on the mail.php and category.php, it shows in newsletter.php but when I actually send and recieve the email it just shows in html code - maybe not an issue with installing the editor - still to be fixed.

 

Thanks

 

Becki

Share this post


Link to post
Share on other sites
Yes, I know what you mean. But if I don't keep the line
<td class="pageHeading"><?php echo HEADING_TITLE . ' ' . tep_get_categories_name($current_category_id); ?></td>

, It will breaks th function of display category name.

 

Thanks,

 

Charles

That's the function of the code in Header Tags. You can have one or the other, but not both. The code in Header Tags allows you to control it via admin.

 

Jack

Share this post


Link to post
Share on other sites
JUST to let you know...

 

I installed 'TinyMce Anywhere' and it works great on the mail.php and category.php, it shows in newsletter.php but when I actually send and recieve the email it just shows in html code - maybe not an issue with installing the editor - still to be fixed.

 

Thanks

 

Becki

It's because the code to send emails for newsletters has to be edited to handle html. But that is a matter for the other support thread.

 

Jack

Share this post


Link to post
Share on other sites

I had uploaded this as a part of the STS4 pack. Works great but I kept getting an error message about the permissions on the header_tags.php files not being correct even though I had set them to 777 and then tried 755 and still got the errors message.

I then thought that since it was working- I would ignore it.

Bill K. was kind enough to mention in the STS thread to look at what permissions were set for the images folder and use that permission setting on the header_tags.php files. I checked and my images folder was set to 775 and so I changed the permissions on my header_tags.php files and voila! No more warnings.

Thought I would post it here in case anyone else runs into the same thing.

This is a great contribution that is saving me tons of time and helping inch my site closer in the rankings. When I started my site it was about 715 in the listings (yes- I always check every page until I find it so I know where I am and if customers can find me). But now it was made it to #12 and I could not have done that without all the help I get from the forums and the nice people I have met along the way.

I read more than I post so I guess this is a long overdue THANKS! When you take the time to help one person there are probably 100 more like me who are "readers" and also get the advise and wisdom you share. So for all us "readers" a HUGE THANKS!

Pattie

Share this post


Link to post
Share on other sites

Thanks for posting what you found. The question about permissions has been addressed a number of times in this thread. I have added a note in the instruction file of the next release that explains how to check this in more detail.

 

If you are checking your index position often, it might save you time and trouble to install the SEO Assistant contribution.

 

Jack

Share this post


Link to post
Share on other sites

I've installed HeaderTags_V_2.6.2 .

 

it seems to run fine until I change the error_reporting(E_ALL & ~E_NOTICE); to error_reporting(E_ALL)

 

i see error message at the top of my shop

 

Notice: Use of undefined constant FILENAME_ALLPRODS - assumed 'FILENAME_ALLPRODS' in mydomain.com/shop/includes/header_tags.php on line 15

 

Notice: Use of undefined constant FILENAME_ALLPRODS - assumed 'FILENAME_ALLPRODS' in mydomain.com/shop/includes/header_tags.php on line 15

 

Notice: Undefined variable: the_manufacturers in

mydomain.com/shop/includes/header_tags.php on line 107

 

header_tags.php on line 15 is something like this ,

 

  // ALLPRODS.PHP
 case (strstr($_SERVER['PHP_SELF'],FILENAME_ALLPRODS) or strstr($PHP_SELF,FILENAME_ALLPRODS) ):
   $the_category_query = tep_db_query("select cd.categories_name from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_id = '" . $current_category_id . "' and cd.categories_id = '" . $current_category_id . "' and cd.language_id = '" . $languages_id . "'");
   $the_category = tep_db_fetch_array($the_category_query);

 

 

header_tags.php on line 107 is something like this

 

    if (HTTA_DEFAULT_ON=='1') {
     if ($showCatTags == true) {
       if (HTTA_CAT_DEFAULT_ON=='1') {
         $tags_array['title']= $the_category['htc_title_tag'] .' '.  HEAD_TITLE_TAG_DEFAULT . " " .  $the_manufacturers['manufacturers_name'] . ' - ' . HEAD_TITLE_TAG_ALL;
       } else {
         $tags_array['title']= $the_category['htc_title_tag'] .' '.  $the_manufacturers['manufacturers_htc_title_tag'] . ' - ' . HEAD_TITLE_TAG_ALL;
       }
     } else {
       $tags_array['title']= HEAD_TITLE_TAG_DEFAULT . " " . $the_category['name'] . $the_manufacturers['manufacturers_htc_title_tag'] . ' - ' . HEAD_TITLE_TAG_ALL;
     }

 

 

 

I read the install instruction again, I check the filenames.php . I think filename_allprods was not defined in admin/includes/filenames.php . am I missing something or should I check any other files ? appreciate if someone may help.

Share this post


Link to post
Share on other sites

Not all shops have the All Products with Images contribution installed, although they should, so that define is not present. It is not a problem though since it is not used if the contribution isn't installed. The other warning is probably referring to the fact the the variable, the_manufacturers, is not defined prior to the block it is. This, again, is not a problem since it is only used in that block so it doesn't need a wider scope.

 

Jack

Share this post


Link to post
Share on other sites
Not all shops have the All Products with Images contribution installed, although they should, so that define is not present. It is not a problem though since it is not used if the contribution isn't installed. The other warning is probably referring to the fact the the variable, the_manufacturers, is not defined prior to the block it is. This, again, is not a problem since it is only used in that block so it doesn't need a wider scope.

 

Jack

 

 

thanks for your help, jack. I could then go ahead with other contribution.

Share this post


Link to post
Share on other sites

Hello Jack,

 

What is the best configuration on Text Control page and Fill Tags?

What is the best configuration for each page to not have many repeatation on google?

HTTA: HTDA: HTKA: HTCA:

Fill products meta description with Products Description with how many characters?

 

I had 14000 hits on my site:

but now I have 260 hits and others are repeatation :(

 

thanks alot

Edited by shaytaan

?,???`???,?? God must love stupid people, he made so many ??,???`???,?

Share this post


Link to post
Share on other sites

The HT.. boxes are meant to appeand the default title and tags to those for the page where the boxes are checked. If your default title and tags are the same as the ones for the index page, which they usually are, then you should not check the checkboxes. Using the descriptions option in Fill Tags is a judgement call. It should only be used if the keyword(s) for that page are in the description. How much is up to you. The search engines will use the parts they want.

 

Jack

Share this post


Link to post
Share on other sites
strickliesl it appears that you don't have the databse update installed

jakegaisser you must have missed some thing in the install if you check again you should find what you missed

I wish i could post my cataegories.php but i have mine heavly modified so it would not be help you should have no problem installing the mod by following the instructions

 

for the admin section use this 09/25/2003 - Header Tags Admin MS 2.2

 

for the catalog section use this 09/05/2003 - Header Tags Controller v2.1

 

I try to download all the Header tags Controller files base upon your recommendation above, but I can not locate the files during the download (from http:www.oscommerce.com/solution/downloads, which is osCommerce 2.2 M2 update 060817), is that possible you can forward the files to me:

 

/catalog/includes/header_tags.php

/catalog/includes/languages/english/header_tags.php

/catalog/includes/functions/clean_html_comments.php

/catalog/includes/functions/header_tags.php

 

Your help highly appreciated! thanks!

Subrina Wang

subrinacwang@yahoo.com

Share this post


Link to post
Share on other sites
I believe these two are all you need:

 

09/25/2003 - Header Tags Admin MS 2.2

09/05/2003 - Header Tags Controller v2.1

 

THe Header Tags Controller 2.1 Tags are Iconsistant as noted in the description.

 

I recomend trying out the software below. I just used it to integrate my last mod and it worked great. (It definately helps if the tags are inconsistant)

 

MergeandCompare

 

Good Luck,

 

Adam

 

I went to http://www.oscommerce.com/solutions/downloads try to download the

09/25/2003 - Header Tags Admin MS 2.2

09/05/2003 - Header Tags Controller v2.1

It seems like that the download version is 2.2 Milestone 2 updat 060817, and do not have the following files i need:

/catalog/includes/header_tags.php

/catalog/includes/languages/english/header_tags.php

/catalog/includes/functions/clean_html_comments.php

/catalog/includes/functions/header_tags.php

 

Am I download the wrong place?

please help or you are able to send the the above 4 php files, I would appreciate very much, thanks!

Subrina Wang

subrinacwang@yahoo.com

Share this post


Link to post
Share on other sites

Go to the first page of this thread and you will find a link to the contribution.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack,

 

I had just noticed this within the header tags. It looks like all my pages are working but one, the product reviews write

 

heres what i got in the includes/header_tags.php for this

// PRODUCT_REVIEWS_INFO.PHP and PRODUCT_REVIEWS.PHP
case((basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS) or (basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_INFO)):
if ( HEAD_DESC_TAG_PRODUCT_REVIEWS_INFO=='' ) {
  if ( HTDA_PRODUCT_REVIEWS_INFO_ON=='1' ) {
	$tags_array['desc']= tep_get_header_tag_products_desc($HTTP_GET_VARS['reviews_id']) . ' ' . HEAD_DESC_TAG_ALL;
  } else {
	$tags_array['desc']= tep_get_header_tag_products_desc($HTTP_GET_VARS['reviews_id']);
  }
} else {
  $tags_array['desc']= HEAD_DESC_TAG_PRODUCT_REVIEWS_INFO;
}

if ( HEAD_KEY_TAG_PRODUCT_REVIEWS_INFO=='' ) {
  if ( HTKA_PRODUCT_REVIEWS_INFO_ON=='1' ) {
	$tags_array['keywords']= tep_get_header_tag_products_keywords($HTTP_GET_VARS['reviews_id']) . ' ' . HEAD_KEY_TAG_ALL;
  } else {
	$tags_array['keywords']= tep_get_header_tag_products_keywords($HTTP_GET_VARS['reviews_id']);
  }
} else {
  $tags_array['keywords']= HEAD_KEY_TAG_PRODUCT_REVIEWS_INFO;
}

if ( HEAD_TITLE_TAG_PRODUCT_REVIEWS_INFO=='' ) {
  if ( HTTA_PRODUCT_REVIEWS_INFO_ON=='1' ) {
	$tags_array['title']= ' Reviews: ' . tep_get_header_tag_products_title($HTTP_GET_VARS['reviews_id']) . HEAD_TITLE_TAG_ALL;
  } else {
	$tags_array['title']= tep_get_header_tag_products_title($HTTP_GET_VARS['reviews_id']);
  }
} else {
  $tags_array['title']= HEAD_TITLE_TAG_PRODUCT_REVIEWS_INFO;
}
break;

// PRODUCT_REVIEWS_WRITE.PHP
case((basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_WRITE)):
if ( HEAD_DESC_TAG_PRODUCT_REVIEWS_WRITE=='' ) {
  if ( HTDA_PRODUCT_REVIEWS_WRITE_ON=='1' ) {
	$tags_array['desc']= tep_get_header_tag_products_desc($HTTP_GET_VARS['reviews_id']) . ' ' . HEAD_DESC_TAG_ALL;
  } else {
	$tags_array['desc']= tep_get_header_tag_products_desc($HTTP_GET_VARS['reviews_id']);
  }
} else {
  $tags_array['desc']= HEAD_DESC_TAG_PRODUCT_REVIEWS_WRITE;
}

if ( HEAD_KEY_TAG_PRODUCT_REVIEWS_WRITE=='' ) {
  if ( HTKA_PRODUCT_REVIEWS_WRITE_ON=='1' ) {
	$tags_array['keywords']= tep_get_header_tag_products_keywords($HTTP_GET_VARS['reviews_id']) . ' ' . HEAD_KEY_TAG_ALL;
  } else {
	$tags_array['keywords']= tep_get_header_tag_products_keywords($HTTP_GET_VARS['reviews_id']);
  }
} else {
  $tags_array['keywords']= HEAD_KEY_TAG_PRODUCT_REVIEWS_WRITE;
}

if ( HEAD_TITLE_TAG_PRODUCT_REVIEWS_WRITE=='' ) {
  if ( HTTA_PRODUCT_REVIEWS_WRITE_ON=='1' ) {
	$tags_array['title']= ' Reviews: ' . tep_get_header_tag_products_title($HTTP_GET_VARS['reviews_id']) . HEAD_TITLE_TAG_ALL;
  } else {
	$tags_array['title']= tep_get_header_tag_products_title($HTTP_GET_VARS['reviews_id']);
  }
} else {
  $tags_array['title']= HEAD_TITLE_TAG_PRODUCT_REVIEWS_WRITE;
}
break;

 

This is the same code and in the latest one. Any ideas??

 

Thanks,

Eric


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×