Jump to content
Sign in to follow this  
Farrukh

[Contribution] Header Tags Controller for Admin MS 2.2

Recommended Posts

HTC Contribution

 

I have installed header tags and now loaded some data.

 

When I access the CGI site direct everything appears to be working fine. For example the reverse info line at the top of the browser shows all the title information etc

 

When I access through a domain name that get redirected to the CGI site, the site works fine, but there are no indications that header tags are there (eg nothing in the reverse info line)

 

I am assuming this is incorrect behaviour, ie the header tags title should show whatever

 

I have rechecked the code, have searched this support area to no avail. I guess one of my problems is I dont know how to properly describe the issue

 

Please can someone give me some suggestions as to where to start looking for a resolution to my problem.

 

Thank you

 

Nossum

I don't understand the problem. What is the cgi site?

 

Jack

Share this post


Link to post
Share on other sites
Still having troubles with my header tags. If you look HERE you can see that I am getting a variable name instead of the page title. Also having some difficulties getting the right things to display on some of the pages.

 

Is there a way to display the product name there when I view a specific product, instead of just my company default header tag?

 

Thanks for the help

 

Kelvin

If you go to admin->Text Control, do you see a section for about us and is it in black? For the products, it appears you don't have the code installed in the products_info.php page.

 

Jack

Share this post


Link to post
Share on other sites
If you go to admin->Text Control, do you see a section for about us and is it in black? For the products, it appears you don't have the code installed in the products_info.php page.

 

Jack

 

I checked my Header Tags in Admin and yes about_us is black, not red. I also checked the product_info.php and the code changes had been made. This is the code in product_info.php:

 

<?php
/*
 $Id: product_info.php,v 1.97 2003/07/01 14:34:54 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

 require('includes/application_top.php');

 require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRODUCT_INFO);

 $product_check_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
 $product_check = tep_db_fetch_array($product_check_query);
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="stylesheet.css">
<script language="javascript"><!--
function popupWindow(url) {
 window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res
izable=yes,copyhistory=no,width=50,height=50,screenX=100,screenY=100,top=0,left=0')
}
//--></script>
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<!-- body //-->
<table border="5" width="100%" cellspacing="3" cellpadding="3">
 <tr>
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="5" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- left_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>
<!-- left_navigation_eof //-->
</table></td>
<!-- body_text //-->
<td width="100%" valign="top"><?php echo tep_draw_form('cart_quantity', tep_href_link(FILENAME_PRODUCT_INFO, tep_get_all_get_params(array('action')) . 'action=add_product')); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">
<?php
 if ($product_check['total'] < 1) {
?>
  <tr>
	<td><?php new infoBox(array(array('text' => TEXT_PRODUCT_NOT_FOUND))); ?></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
  <tr>
	<td><table border="5" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="5" width="100%" cellspacing="0" cellpadding="2">
		  <tr>
			<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
			<td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>
			<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
		  </tr>
		</table></td>
	  </tr>
	</table></td>
  </tr>
<?php
 } else {
$product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id,  p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");
$product_info = tep_db_fetch_array($product_info_query);

tep_db_query("update " . TABLE_PRODUCTS_DESCRIPTION . " set products_viewed = products_viewed+1 where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and language_id = '" . (int)$languages_id . "'");

if ($new_price = tep_get_products_special_price($product_info['products_id'])) {
  $products_price = '<s>' . $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) . '</s> <span class="productSpecialPrice">' . $currencies->display_price($new_price, tep_get_tax_rate($product_info['products_tax_class_id'])) . '</span>';
} else {
  $products_price = $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id']));
}

if (tep_not_null($product_info['products_model'])) {
  $products_name = $product_info['products_name'] . '<br><span class="smallText">[' . $product_info['products_model'] . ']</span>';
} else {
  $products_name = $product_info['products_name'];
}
?>
  <tr>
	<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
	  <tr>
  [color=#FF0000]		 <td valign="top"> <h1> <?php echo $products_name; ?></h1></td>
		<td align="right" valign="top"><h1><?php echo $products_price; ?></h1></td>[/color]

	  </tr>
	</table></td>
  </tr>

  <tr>
	<td class="main">
<?php
if (tep_not_null($product_info['products_image'])) {
?>
	  <table border="5" cellspacing="0" cellpadding="2" align="right">
		<tr>
		  <td align="center" class="smallText">
<script language="javascript"><!--
document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], addslashes($product_info['products_name']), SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>');
//--></script>
<noscript>
<?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . $product_info['products_image']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'; ?>
</noscript>
		  </td>
		</tr>
	  </table>
<?php
}
?>
	  <p><?php echo stripslashes($product_info['products_description']); ?></p>
<?php
$products_attributes_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "'");
$products_attributes = tep_db_fetch_array($products_attributes_query);
if ($products_attributes['total'] > 0) {
?>
	  <table border="5" cellspacing="0" cellpadding="2">
		<tr>
		  <td class="main" colspan="2"><?php echo TEXT_PRODUCT_OPTIONS; ?></td>
		</tr>
<?php
  $products_options_name_query = tep_db_query("select distinct popt.products_options_id, popt.products_options_name from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "' order by popt.products_options_name");
  while ($products_options_name = tep_db_fetch_array($products_options_name_query)) {
	$products_options_array = array();
	$products_options_query = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . (int)$products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . (int)$languages_id . "'");
	while ($products_options = tep_db_fetch_array($products_options_query)) {
	  $products_options_array[] = array('id' => $products_options['products_options_values_id'], 'text' => $products_options['products_options_values_name']);
	  if ($products_options['options_values_price'] != '0') {
		$products_options_array[sizeof($products_options_array)-1]['text'] .= ' (' . $products_options['price_prefix'] . $currencies->display_price($products_options['options_values_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) .') ';
	  }
	}

	if (isset($cart->contents[$HTTP_GET_VARS['products_id']]['attributes'][$products_options_name['products_options_id']])) {
	  $selected_attribute = $cart->contents[$HTTP_GET_VARS['products_id']]['attributes'][$products_options_name['products_options_id']];
	} else {
	  $selected_attribute = false;
	}
?>
		<tr>
		  <td class="main"><?php echo $products_options_name['products_options_name'] . ':'; ?></td>
		  <td class="main"><?php echo tep_draw_pull_down_menu('id[' . $products_options_name['products_options_id'] . ']', $products_options_array, $selected_attribute); ?></td>
		</tr>
<?php
  }
?>
	  </table>
<?php
}
?>
	</td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
$reviews_query = tep_db_query("select count(*) as count from " . TABLE_REVIEWS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'");
$reviews = tep_db_fetch_array($reviews_query);
if ($reviews['count'] > 0) {
?>
  <tr>
	<td class="main"><?php echo TEXT_CURRENT_REVIEWS . ' ' . $reviews['count']; ?></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
}

if (tep_not_null($product_info['products_url'])) {
?>

  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
<?php
}

if ($product_info['products_date_available'] > date('Y-m-d H:i:s')) {
?>
  <tr>
	<td align="center" class="smallText"><?php echo sprintf(TEXT_DATE_AVAILABLE, tep_date_long($product_info['products_date_available'])); ?></td>
  </tr>
<?php
} else {
?>

<?php
}
?>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
  <tr>
	<td><table border="5" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
	  <tr class="infoBoxContents">
		<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
		  <tr>
			<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
			<td class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>
			<td class="main" align="right"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_IN_CART); ?></td>
			<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
		  </tr>
		</table></td>
	  </tr>
	</table></td>
  </tr>
  <tr>
	<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
  </tr>
  <tr>
	<td>
<?php
if ((USE_CACHE == 'true') && empty($SID)) {
  echo tep_cache_also_purchased(3600);
} else {
  include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS);
}
 }
?>
	</td>
  </tr>
</table></form></td>
<!-- body_text_eof //-->
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="5" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
</table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
<br>
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

The red code is line 140 that was suppose to be changed according to the "Install Catalog" instructions that came with HTC.

 

 

And while I have you here, on a NON HTC related problem. I have been trying to find the code to add a border around the products listing as I have on all of the rest of the pages on My Site but cannot find the code. I thought it might be in catagories.php but it is not there. Would you know where I could find it?

 

Thanks

Kelvin

Share this post


Link to post
Share on other sites

Sorry, changing the color in the code above didn't take. this is the line of code I was referring to.

 

<td valign="top"> <h1> <?php echo $products_name; ?></h1></td>

<td align="right" valign="top"><h1><?php echo $products_price; ?></h1></td>

 

It is about the middle of the code.

 

Thanks

 

Kelvin

Share this post


Link to post
Share on other sites

You missed the code for the title. Take another look at the Install_Catalog.txt file.

 

Jack

Share this post


Link to post
Share on other sites
You missed the code for the title. Take another look at the Install_Catalog.txt file.

 

Jack

 

 

Thanks a lot Jack. Sometimes I could just bang my head up against the wall!!! I thought I got all of the changes. Sorry for the trouble.

 

Kelvin

Share this post


Link to post
Share on other sites

Ok, I got them all working correctly, except THIS ONE! Its driving me crazy!

 

I don't know where to look for the problem. Can anyone help me????

 

I fixed the problem in a number of files as Jack mentioned above and am SURE that I got them all, but I think something is missing somewhere.

 

about_us.php is black in the Admin>Header Tags>text control area. All looks well, but is not.

 

Thank you

Kelvin

Share this post


Link to post
Share on other sites

Hi

 

I have installed the header tags v.2.5.9

 

But had some porblems during the installation

 

In index.php - Around line 78:

Find

 

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

 

and replace it with

 

<td><h1><?php echo $category['categories_htc_title_tag']; ?></h1></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

<?php if (tep_not_null($category['categories_htc_description'])) { ?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><h2><?php echo $category['categories_htc_description']; ?></h2></td>

</tr>

<?php } ?>

 

This was not to replace in my index.php file - i could not find it.

 

My header over the product disappear after installation and after i have put in the meta tags in the admin.

 

Some one tell me way?

Sorry, but is not so good in programming

Share this post


Link to post
Share on other sites
Hi

 

I have installed the header tags v.2.5.9

 

But had some porblems during the installation

 

In index.php - Around line 78:

This was not to replace in my index.php file - i could not find it.

 

My header over the product disappear after installation and after i have put in the meta tags in the admin.

 

Some one tell me way?

Sorry, but is not so good in programming

 

How did you try to find it? Did you "search" for it? I would recommend doing a "search" for

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>
and if that doesn't find it then do a "search" for
class="pageHeading
. That will definitely find it.

 

Kelvin

Share this post


Link to post
Share on other sites
How did you try to find it? Did you "search" for it? I would recommend doing a "search" for and if that doesn't find it then do a "search" for . That will definitely find it.

 

Kelvin

 

 

I have made a search for it, but i was not there.

I have also located the error it must be on the admin/categories.php

I don't have any fields to put in "Products Name:" any more.

I am now jusing the orginal admin/categories.php, where i can put in "Products Name:" and thats works.....

But i do not have the option to write meta tags etc on easch product.

Teh i have tryed to "add and replace" all on categories again but with out luck.

 

Patrick

Share this post


Link to post
Share on other sites
Ok, I got them all working correctly, except THIS ONE! Its driving me crazy!

 

I don't know where to look for the problem. Can anyone help me????

 

I fixed the problem in a number of files as Jack mentioned above and am SURE that I got them all, but I think something is missing somewhere.

 

about_us.php is black in the Admin>Header Tags>text control area. All looks well, but is not.

 

Thank you

Kelvin

That's a mistake in the code. Open up includes/header_tags.php and replace all instances of ABOUTUS with ABOUT_US. It should be OK then.

 

Jack

Share this post


Link to post
Share on other sites
Hi

 

I have installed the header tags v.2.5.9

 

But had some porblems during the installation

 

In index.php - Around line 78:

This was not to replace in my index.php file - i could not find it.

 

My header over the product disappear after installation and after i have put in the meta tags in the admin.

 

Some one tell me way?

Sorry, but is not so good in programming

Are you using a template? If so, the code has probably been altered to where the instructions won't work with it.

 

Jack

Share this post


Link to post
Share on other sites
That's a mistake in the code. Open up includes/header_tags.php and replace all instances of ABOUTUS with ABOUT_US. It should be OK then.

 

Jack

 

 

Thanks a million Jack. That fixed it.

Share this post


Link to post
Share on other sites

Hello and good day! First off, this contribution is wonderful!

 

Currently I am experiencing a problem where ONLY the default header information is being displayed on index.php, product_info.php, and products_new.php. I also have header tags set for my articles.php and articles_new.php, in which it is working properly (i.e. combining the page specific header data and the default header data).

 

Any suggestions? The header data is saved in the database correctly, however it is not being displayed on the main product pages.

 

Thanks so much!

 

My test site can be seen by visiting http://demo.cicsolutions.com

Share this post


Link to post
Share on other sites

I don't have an answer for you but this problem was addressed before. You might want to read by through the thread to see if it was resolved.

 

Jack

Share this post


Link to post
Share on other sites

Hello,

 

My name is Margaret and I have been creating www.daylightgifts.com. I had installed your contribution and everything worked properly :thumbsup:, except that I just used easypopulate to update my items and now none of the images are showing up in the admin and website views :'( .

 

How can I get the images to show up again?

 

Thanks,

Margaret

Share this post


Link to post
Share on other sites
Hello,

 

My name is Margaret and I have been creating www.daylightgifts.com. I had installed your contribution and everything worked properly :thumbsup:, except that I just used easypopulate to update my items and now none of the images are showing up in the admin and website views :'( .

 

How can I get the images to show up again?

 

Thanks,

Margaret

 

Never mind, I figured it out. Thanks anyways!

 

Margaret

Share this post


Link to post
Share on other sites

I'm preparing to install this contribution but have a few questions...

 

I've got the latest snapshot of OSC with basic design pack and faqdesk installed. Will there be a problem with these and HTC?

 

Also, I've got the Display Category Name in Main Display installed (latest update), will this conflict with HTC? Other updates to the site are mostly cosmetic, so I'm hoping they will be ok. Removed info boxes, etc. by commenting them out.

 

Any help with this is appreciated. Thank You!

Share this post


Link to post
Share on other sites

There is not a problem with HTC and the oscommerce updates. In fact, it already has changes in it to take a few of those into account. I'm not familiar with Display Category Name.

 

Jack

Share this post


Link to post
Share on other sites
There is not a problem with HTC and the oscommerce updates. In fact, it already has changes in it to take a few of those into account. I'm not familiar with Display Category Name.

 

Jack

 

Thanks for the info. I'm working on the install now.

Share this post


Link to post
Share on other sites
I don't understand the problem. What is the cgi site?

 

Jack

 

Hi Jack good evening

 

Sorry for the long delay - I have been away and no access to the web - its different!

 

Whilst I was away I had to smile at the newspaper report about it being 25 years since IBM launched the first personal PC - monitor and disk drives were optional - I wonder what people will have 25 years from now and how will they regard this era?

 

My ISP hosts my web site on a CGI server which I understand stands for common gateway interface and historically was created as a standard, all I know is that is where it sits! I then have domain names which happen to be with another entity (long story but cant change) and they redirect to the ISP and the CGI server and site.

 

So you type in "nossum.co.uk" and it goes (I presume) to the domain server which then points it to the CGI server and bingo. It all seems to work fine, no problems with speed etc, but the only issue is that situation I have described in my original query.

 

Does this make my query clearer?

 

Thanks Jack

 

Regards

 

Nossum

Share this post


Link to post
Share on other sites

I know what cgi scripting is but am not familiar with a server based on it. But, regardless, if your site loads fine in all other regards, then the Header Tags infomation should display fine too since it is just being read in like the rest of the shops data. So, in that case, it would appear Header Tags is not installed correctly. I suggest going through the instructions and checking the first part where it says to check it before making the changes to admin. That is as basic as it can get and only involves a few changes. If it is not working there, then it will be a lot easier to find the problem.

 

Jack

Share this post


Link to post
Share on other sites
So, in that case, it would appear Header Tags is not installed correctly. I suggest going through the instructions and checking the first part where it says to check it before making the changes to admin.

Jack

 

Thank you for the suggestion Jack. I will work through the code as you suggest and report back

 

Cheers Nossum

Share this post


Link to post
Share on other sites

In the catalog install instructions it says to find this in index.php around line 247:

 

 

?>

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

 

 

This is what I have because of the Display Category In Main Content Contrib:

 

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading">

<?php

//hacked to display current category name in main content area!

//echo HEADING_TITLE . $tree[$current_category_id]['name'];

echo $tree[$current_category_id]['name'];

?>

</td>

 

The Contrib would display the category on every main product display page.

 

Is there a way to integrate this with HTC or will HTC do this on its own? Or is there a better way that I haven't learned yet? :blush:

Share this post


Link to post
Share on other sites

A quick question....

 

Do I need to install the error fix for Header Tags Controller v2.5.9 and v2.5.9.1 (by drachenpaps 29 july 2006)???

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×