Jump to content
Sign in to follow this  
Brenden

[Contribution] Basic Template Structure v1.0 - For MS2

Recommended Posts

ya come to think of it I'm gonna gamble and say its a php problem. I did some more testing, and its weird but when it does happen to throw the footer off, it takes the session id off the url as well. When I click another link there is a session id and all is well. It's weird I tell ya :)

 

Thanks.. I'll try installing a newer version of php now.

Share this post


Link to post
Share on other sites
ya come to think of it I'm gonna gamble and say its a php problem. I did some more testing, and its weird but when it does happen to throw the footer off, it takes the session id off the url as well. When I click another link there is a session id and all is well. It's weird I tell ya :)

 

Thanks.. I'll try installing a newer version of php now.

 

Thanks to Brenden, I managed to resolve the same bug.

 

It is a problem with the version of php you are running.

 

See this thread

 

http://www.forums.oscommerce.com/viewtopic.php?t=51146

Share this post


Link to post
Share on other sites

yep.. that was the problem. I am using the Easyphp 1.6, and added the one line to my .htaccess and no more footer problems :)

 

Thanks!

Share this post


Link to post
Share on other sites

Brenden,

 

Thanks for the template contribution. I have installed it and done some testing.

 

So far, I have come across the bug that Tim found earlier in regards to the

$javascript = 'formcheck.js.php';

needing to be changed to

$javascript = 'form_check.js.php';

in the account_edit.php and account_password.php files.

 

In addition, I have come across a similar issue in the create_account.php file. On line 1 of the content/create_account.tpl.php file there is a reference to some javascript code:

onSubmit="return check_form(create_account);"

 

The javascript code is not included in the file, however. To fix the problem, I added a reference to the needed javascript file to the create_account.php file on line # 255. This line needs to bee added:

$javascript = 'form_check.js.php';

 

If I come across any other issues I'll let you know.

 

Eric Stamper

Share this post


Link to post
Share on other sites

Brilliant :D this is very VERY nice guys! this shud deffo be blended in to the CVS release!

 

I can see this getting very good very soon.

 

http://www.phunky.co.uk/wwpc/catalog/ 5mins playing and got basic layout there! very nice! still got a lot of hunting around to do to fix parts and also to get rid of as many nestid tables as possible!

 

When this turns 100% <div>'s and CSS i will be knocking out a lot of CSS Layouts for this!

 

nice :D

 

http://www.phunky.co.uk

Share this post


Link to post
Share on other sites

Hi brenden,

 

i've installed the BTS, great job btw it's realy usefull, but i've got a problem...

 

I'm new @ osc so perhaps it's my own fault so don't laugh to hard ;)

 

my problem:

all works just fine on my local webserver but if I upload it to my main webserver i get an error... http://www.z-web.be/cc/shop/ --> link to the problem...

 

I did change the configure files for mysql and so on....

 

 

any ideas ?

 

greetz,

 

zilla

Share this post


Link to post
Share on other sites

I got an error message after I have installed the code.

 

I have checked the file ?meta_tages.php ? is under the dir /includes

 

I have checked the file testincludesconfigure.php

 

the code is added after define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_TEMPLATES', 'templates/');

define('DIR_WS_CONTENT', DIR_WS_TEMPLATES . 'content/');

define('DIR_WS_JAVASCRIPT', DIR_WS_INCLUDES . 'javascript/');

 

 

Warning: main(DIR_WS_INCLUDESmeta_tags.php): failed to open stream: No such file or directory in d:appservwwwtesttemplatesmain_page.tpl.php on line 5

 

Fatal error: main(): Failed opening required 'DIR_WS_INCLUDESmeta_tags.php' (include_path='.;c:php4pear') in d:appservwwwtesttemplatesmain_page.tpl.php on line 5

 

 

Would you please help me fix the error ?

Share this post


Link to post
Share on other sites

I have installed the templates v.09 contribution twice (exactly to the letter) over a v2.2 ms2 installation.

 

Everything works fine until you try and pay by check - pressing confirm order on the checkout_confirmation.php page links to CONTENT_CHECKOUT_PROCESS.php (i.e. the value has not been initiated)

 

also NAVBAR_TITLE appears in the title (so ditto there)

 

is there an error in an include somewhere?

 

Or is it just my installation?

 

Thanks

Share this post


Link to post
Share on other sites

Hey All

i have a quick question for you, haw do i apply

a new box design to the new products box.

Well to be more clear i have two box.tpl.php files,

both work ok, right left sides.

now i've made a third one i would like to apply this, to the

New Products For Month Box,

any easy way to do this

:?: :?: :?: :wink:

THX


The more you do, the more you learn

Share this post


Link to post
Share on other sites

Hi Greg,

 

There is no easy way to do that :(.

 

There are only 3 files on the catalog side that still use the infoBox class.

They are:

 

catalog/includes/modules/also_purchased_products.php

catalog/includes/modules/new_products.php

catalog/includes/templates/content/shopping_cart.tpl.php

 

Hopefully, in a future version of BTS these will also make use of templates instead of the infoBox class.


Perdure - Transparent Object Relational Persistence

Share this post


Link to post
Share on other sites

TXS Brenden,

just as i thought, oh well can't hurt to ask, right?

i'll give it a shot, i'll keep you posted :wink:


The more you do, the more you learn

Share this post


Link to post
Share on other sites

Brenden,

 

I get the same exact error that plmx does. Everything seems to be kosher with the file and directory set up. Ive double/triple checked everything. But when trying to open catalog/templates/main_page.tpl.php in my browser, I get this error

 

-----

 

Warning: main(DIR_WS_INCLUDESmeta_tags.php): failed to open stream: No such file or directory in /home/dvd2you/public_html/catalog/templates/main_page.tpl.php on line 5

 

Fatal error: main(): Failed opening required 'DIR_WS_INCLUDESmeta_tags.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/dvd2you/public_html/catalog/templates/main_page.tpl.php on line 5

 

----

 

As an experiment, I eliminated the line referring to the meta_tags.php file (which Ive since replaced) and I got the same error for warnings.php. Is there something preventing the template from recognizing the new files in the includes directory?

 

I should also add that this cart was installed by fantastico, but, as far as I know, everything should be kosher with that. I wonder though if plmx also installed with fantastico.

 

Brenden, can you shed any light?

Share this post


Link to post
Share on other sites

Hi Walt and plmx,

 

I think Ive figured out the problem. You never open catalog/includes/main_page.tpl.php in your browser. The only files you ever open in your browser are in the catalog/ directory. Open catalog/index.php in your browser.

 

Hope that Works.

Brenden


Perdure - Transparent Object Relational Persistence

Share this post


Link to post
Share on other sites

Hi, i just installed this mod and everything seems to be fine but my images all have a X on them, am I suppose to move them somewhere else?

Share this post


Link to post
Share on other sites

I have found some bugs with page titles

so i think,,, some pages were coming up with

NAV_TITLE so here is a fix, DOWNLOAD

there is a few files that i didn't see reference to in

./includes/meta_tags.php

Those are:

account_edit.php

account_history.php

account_newsletters.php

account_notifications.php

account_password.php

address_book.php

address_book_process.php

checkout_shipping_address.php

 

If you run into the same problem, as i did grab the fix i've included

a readme file that should explain what and where

THX

:wink:


The more you do, the more you learn

Share this post


Link to post
Share on other sites

Hey All:

 

Just set this contrib up and have gone through all the posts stomping on them annoying little critters. Was testing out some of the pages and landed this little pest:

 

Warning: main(includes/javascript/address_book_process.js.php): failed to open stream: No such file or directory in /var/www/commercial/catalog/templates/main_page.tpl.php on line 11

 

Fatal error: main(): Failed opening required 'includes/javascript/address_book_process.js.php' (include_path='.:/usr/local/lib/php') in /var/www/commercial/catalog/templates/main_page.tpl.php on line 11

 

Fix is very simple: :D

go to catalog/includes/javascript/ and rename the file address_book_process.php to address_book_process.js.php

 

From what I have seen: So far, So good! This contrib has great potential. :wink:


ElLeonBlanco

 

"The man of genius makes no mistakes. His errors are volitional and are the portals of discovery." James Joyce (1882?1941)

Share this post


Link to post
Share on other sites

Is there a update for all the fixes listed in the previous post? Also I was wondering since everything is referenced to the templates folder, do we now delete the files in the root catalog folder?

Share this post


Link to post
Share on other sites

I think this is the greatest mod ever!! Thanks for creating it, if I new anything about coding I would be trying to help with the bugs. Thanks again

Share this post


Link to post
Share on other sites

So far I do not believe that the author has released an update on this contrib. So if you install it you need to go through all the posts and make the edits yourself. Make sure that before make the edit you actually have the bug though. As with all the contribs it is a wise thing to test ALL aspects and features affected by it's installation. This template system is quite usefull. I have found that the addition of the javascripts folder is one of the sweeter features. At first I was a bit reluctant about that portion of it. Now however I find that it allows you to easily add some slick tricks to your pages. :wink:

 

All there is to say about MS2 and these new contribs is:

Nice work guys!!


ElLeonBlanco

 

"The man of genius makes no mistakes. His errors are volitional and are the portals of discovery." James Joyce (1882?1941)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×