Jump to content
Sign in to follow this  
RandyR

Fedex Ground Not Showing Up

Recommended Posts

My fedex module is showing all the high rates. It is not showing their ground rates. How can I fix this? I did not know they even had ground rates till I visited thier site. Man are they a LOT cheaper!

Share this post


Link to post
Share on other sites

You have to have a Fedex account that is set up to allow ground shipments. You have to specifically get this added to your account.


Steve

Share this post


Link to post
Share on other sites

Well I had them add ground shipments to my account. But it does not show up in my store. Please advise me what I can do.

Share this post


Link to post
Share on other sites

Tnis is something you have to work out with Fedex tech support, there is nothing I can do. It is a Fedex issue with your account.

 

The module can't MAKE them send your rates! The difference between this and other shipping modules is that this module returns YOUR rates, not my rates or anyone elses rates.


Steve

Share this post


Link to post
Share on other sites

I think it is great you have them returning MY rates. Home delivery shows up under 70 lbs. That is exacly as it should be. But it is not showing ground rates, all other rates are showing.

 

Since we did not have ground rates set up until today are you saying that we need to call fedex and get a new account number for the administration module or should we go and sign up again at the website?

 

Thanks Randy

Share this post


Link to post
Share on other sites

I am saying you need to find out from Fedex what is wrong with your account on their server.

 

My module does not compute ground rates. It only shows what fedex sends, and it requests ALL rates. So, if Fedex doesn't send a given rate, I can't show it to you. That's all I am saying.

 

So, no matter how long it takes, you need to insist that they fix the problem. I am assuming you are on the production server. On the test server, things break all the time as it is not really a test server, it's a development server!


Steve

Share this post


Link to post
Share on other sites

I think I am on the test server this whole time according to you documentation: gateway.fedex.com/GatewayDC.

 

I could never find the url of their production server and I did not find it listed in your documentation. What is the name of the Fedex production server?

Share this post


Link to post
Share on other sites

Well I got with the fedex software guys and they confirmed that they are getting the gorund rate and the home delivery rate when they try it. I onder what is wrong on my end.

 

I am still only seeing the Home delivery rate but not the ground rate. Thay said to look at the transaction log to see if it is indicated the service number 92 in field 1274.

 

How do we trouble shoot this from our end if fedex says they see gound rates returned?

Share this post


Link to post
Share on other sites

I just tested it taking out our regular fedex account number and putting in out fedex ground rate account number. It returns just the home delivery rate and drops all the express rates.

 

Does this tell us that something connected to the home delivery rate is screwed up on our end?

Share this post


Link to post
Share on other sites

I'm so proud of myself (me not being any way, shape, or form of a programmer).

 

I looked at the code in /includes/modules/shipping/fedex1.php and changed:

 

case 92:

if ($order->delivery['company'] == '') {

$skip = TRUE;

 

to:

 

case 92:

if ($order->delivery['company'] != '') {

$skip = TRUE;

 

and yeahhhhhhhh!!!! it now shows "ground service" along with all the rest.

Just wanted to post this hoping it will help someone else.

Share this post


Link to post
Share on other sites

Which module is this referring to? I've been trying to get a Fedex Ground

module working on my shopping cart, but havn't found it. Any help is greatly appreciated.

 

PS I have a Fedex Ground account if that makes a difference.

Share this post


Link to post
Share on other sites

Randy, actually, ground service is NOT home delivery service, the change you made is not actually the correct change and not the correct rate either.

 

Unlike UPS, a ground package going to a business address is called Fedex Ground. A ground package going to a residential address is called Fedex Home Delivery. They are different trucks too in many cases. If you call one the other, you will find delays in delivery, and as I said, incorrect rates. The code was actually correct.

 

Try using the production server. If that is not your problem, perhaps your account has not been approved for home delivery service.


Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×