Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Duffy73

Problem with Sales Channel

Recommended Posts

Posted (edited)

Hi!

I just made a clean installation (several clean installations) in a folder of my website , but can't set up a new sales channel. All it doe's is show me a blank page in preview. I changed none of the installation values. The problem occurs either setting up a new channel or copying an existing one. What's going wrong, can anybody give me a hint?

Edited by Duffy73

Share this post


Link to post
Share on other sites
Posted (edited)

btw: the demo sales channels work perfectly. little improvemnet:

now he tells me: 

Oops!

We can't seem to find the page you're looking for

Edited by Duffy73

Share this post


Link to post
Share on other sites

Do you create a new theme ? If yes you must create a symslink on your root server to the new theme



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites
10 hours ago, Gyakutsuki said:

Do you create a new theme ? If yes you must create a symslink on your root server to the new theme

no, I only want to create a new sales channel. I have no root access.

Share this post


Link to post
Share on other sites

In this case you can not use osC. But you only chance is to affect an existing design (origin) to your new channel. No tested, I do not know if it's possible.

Else you must change and take another hosting.

Maybe the osc team can give more information about that.



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites
34 minutes ago, Gyakutsuki said:

In this case you can not use osC. But you only chance is to affect an existing design (origin) to your new channel. No tested, I do not know if it's possible.

Else you must change and take another hosting.

Maybe the osc team can give more information about that.

do I get something wrong? I've created a new channel, no new design, an that doesn't work. I also copied an existing demo channel, doesn't work either. the demo channel works perfectly. I don't want/need a new design....

Share this post


Link to post
Share on other sites

Old or new it's not th problem, the problem you must create a symslink on your server.

Please wait the answer come from the team. You will have a confirmation or not about that.

@VadymG



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello,

Try to add to .htaccess file, located in the osCommerce 4 website root folder, the following:

Options FollowSymLinks
Edited by asandros

Share this post


Link to post
Share on other sites
Posted (edited)

Please also make sure that your host allows to use rewrite rules in .htaccess file.

  1.  Apache module "mod_rewrite" should be enabled by host.
  2. "AllowOverride" directive should be set to "All" by host in the Apache VirtualHost configuration.

By default Apache directives AllowOverride and AllowOverrideList are set to "None", and in this case  .htaccess files are completely ignored.

Edited by asandros

Share this post


Link to post
Share on other sites

Still not working, sorry. There is no virtual host section in my .htaccess.
I can't understand the problem: during installation, the demo sales channels are set up by the install script perfectly. I don't understand, why another new sales channel can't be set up automatically in the correct way. Be it as it is, I'll stop trying osCommerce and give it up. It seems to me that it's not the right software for me.

Thank you for trying!

Share this post


Link to post
Share on other sites
12 hours ago, Duffy73 said:

Still not working, sorry. There is no virtual host section in my .htaccess.

Hello,

It should be checked in the Apache configuration (on the server level), and not in .htaccess (user level).

Share this post


Link to post
Share on other sites
On 8/30/2022 at 10:48 AM, asandros said:

Hello,

It should be checked in the Apache configuration (on the server level), and not in .htaccess (user level).

I have no root access, so I can't check my apache config. Anyway, that's not logical. During installation, the system can set up sales channels correctly; then why not from inside the admin dashboard?

But please don't spend any more thought on it, I'm trying another ecommerce solution.

Share this post


Link to post
Share on other sites


Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites

Osc is not very recommended to use on mutual server specifically if if you not access to a console.

Indeed, if you want to create a new theme, you need to know to create  a symslink.

Also if you can not customize your apache, php it's worst. You can try with an htaccess but in your case, if i understand well, you have just a simple access. I recommend you to change for another hosting. Your problems will be resolved.

try this, o2switch.fr



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites

I can't understand the problem: during installation, the demo sales channels are set up by the install script perfectly. I don't understand, why another new sales channel can't be set up automatically in the correct way. Be it as it is, I'll stop trying osCommerce and give it up. It seems to me that it's not the right software for me.

Share this post


Link to post
Share on other sites
1 hour ago, khaanekii said:

I can't understand the problem: during installation, the demo sales channels are set up by the install script perfectly. I don't understand, why another new sales channel can't be set up automatically in the correct way. Be it as it is, I'll stop trying osCommerce and give it up. It seems to me that it's not the right software for me.

@Ivan Holbi please add an article to Wiki on how to add a Sales Channel that would automatically create a link on the server to it. Thanks!

Share this post


Link to post
Share on other sites
On 11/2/2022 at 9:07 AM, khaanekii said:

I can't understand the problem: during installation, the demo sales channels are set up by the install script perfectly. I don't understand, why another new sales channel can't be set up automatically in the correct way. Be it as it is, I'll stop trying osCommerce and give it up. It seems to me that it's not the right software for me.

Hi,

At the moment it is impossible to add a sales channel that would automatically create a link on the server. We are working on this development so as soon as it is available we will let you know.

Please see the link below with the article explaining how to proceed with adding a new sales channel now.

https://wiki.oscommerce.com/index.php?title=Adding_New_Sales_Channel

Best regards,

Ivan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×