Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

osCommerce-Official

Migrate osCommerce 2.x or its forks to osCommerce 4

Recommended Posts

34 minutes ago, samu33 said:

hello,

 created in 2005 the site with osc.2.1,

today under v2.3.3 with php 5.4,

the host tells me not to ensure security, we are at php 7.4 today

I just read your post of May 5,

I would like to try a migration to osc v4

what should I do??

Thank you for your reply

Cordially samuel

You have 3 choices here:

1) do the migration yourself - there's a built in tool that moves data from old osCommerce (2.x) to the new one (4.x). You can download new osCommerce from www.osCommerce.com, and install it on the new account with your host. Then use the migration tool to move data. OR you could choose to "Host with osCommerce" and it will create a hosting account with our environment (free for 1 month, very cost efficient after) and just use new osCommerce there

2) ask one of our development partners to help you with migration - please PM us to let us recommend you at least 2

3) ask us to help you with the migration - please PM us to give you a quote

Thanks for using osCommerce and looking forward to hearing from you! 

Share this post


Link to post
Share on other sites

thank's

 i will organize this around october

Samuel


site 1 ---> MS 2.3.3 + AJAX Attribute Manager + Option Types v2 + Header Tags SEO + E transaction

site 2 ---> MS 2.3.4 en cours d'essais

Share this post


Link to post
Share on other sites

I have similar issues and could never get to SAVE step completed.. Tried all that in this post and also adding ip address as whitelist in remotesql. Nothing works.

 

Unable to migrate

Share this post


Link to post
Share on other sites

Migration from 2.3xx to 2.4 is failing after 2 weeks of hard work.. Never works and fails at OSC link bridge URL 

Share this post


Link to post
Share on other sites
3 hours ago, rmandiga said:

Migration from 2.3xx to 2.4 is failing after 2 weeks of hard work.. Never works and fails at OSC link bridge URL 

Please PM us the particular errors so that we could help you. Thanks! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×