Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

osCommerce-Official

Migrate osCommerce 2.x or its forks to osCommerce 4

Recommended Posts

12 minutes ago, pandrei said:

You are right. Of course the new OSC must be able to access the old OSC at the same server. But using URL - is the legal and standard method to do it. Have no idea why your hosting provider denies to do that.

You can try OSCommerce hosting here (its free for 1 month): https://www.oscommerce.com/host-with-oscommerce

as it turns out it's IP related and probably and IP mirror avoidance system.
Whitlisting the same IP address I'm on with the server fixed it and brought in a succseful connection.

Share this post


Link to post
Share on other sites

 

9 minutes ago, Yak39 said:

it's fine I'd rather debug the script atm. Speaking of which do you know where modules are stored at?

Look at admin menu Modules.

Share this post


Link to post
Share on other sites
55 minutes ago, pandrei said:

 

Look at admin menu Modules.

Sorry I meant the absolute path of the OScLink connector on the server. 
I believe I still need to debug. Despite mapping and connection being successful nothing happens once I begin to request imports.

Share this post


Link to post
Share on other sites
10 hours ago, pandrei said:

Is there any messages in the status area (it is under import buttons)?

nothing - yet again no php errors or anything. It's becoming a bit of a hiccup just willing to test the new OSC with an old catalog! :)

Share this post


Link to post
Share on other sites
2 hours ago, Yak39 said:

nothing - yet again no php errors or anything. It's becoming a bit of a hiccup just willing to test the new OSC with an old catalog! :)

Do you have the Clean imported data tab to the right of the Run import action?

Share this post


Link to post
Share on other sites
6 hours ago, pandrei said:

Do you have the Clean imported data tab to the right of the Run import action?

 

No I don't, simply nothing appears after the mapping and the various import options.

Share this post


Link to post
Share on other sites
1 hour ago, Yak39 said:

No I don't, simply nothing appears after the mapping and the various import options.

Please open again Run Import actions tab and click Import for Tax Zones. After confirmation all buttons must be disabled. Wait for ~1 min. Buttons should be enabled again and you should get something like this

ImportResults.png

Share this post


Link to post
Share on other sites

heheh I wish :) and Pandrei I'm sorry to keep bombing you with non positive news 🙂
Unfortunately no progress bar appears, nor the buttons get grayed out even for a second. After the modal request about confirming the import action, simply nothing happens.
I though at a certain moment it could be an asyncronous problem, but Java and everything appear to be fine.

Share this post


Link to post
Share on other sites

I's hard to believe that. I would prefer see it with my own eyes ☺️
Try to wait more time. For example 5 minutes.
Is it possible to create an limited user for me or record a screencast?

 

Share this post


Link to post
Share on other sites
11 hours ago, pandrei said:

I's hard to believe that. I would prefer see it with my own eyes ☺️
Try to wait more time. For example 5 minutes.
Is it possible to create an limited user for me or record a screencast?

 

Sure I actually appreciate that: just PM'd you

Share this post


Link to post
Share on other sites

I am having some troubles too with the connection.
I have followed the steps in the readme but I keep getting the following error when trying to save the settings:
"Error while establishing connection: file_get_contents(https://www.mydomain.nl/my_secret_directory/index.php?): failed to open stream: no suitable wrapper could be found"

To make sure I can read from my online store I created a small test using "file_get_contents" to output some text on my new osCommerce 4.x shop (from a file hosted at my online osCommerce shop v2.x) and that works fine so a connection is possible.

Only thing I noticed is in the example secret key it starts with OSC_alotofsymbolshere, and mine starts with DEST_, could that be the problem?

Share this post


Link to post
Share on other sites
6 hours ago, petervd said:

I am having some troubles too with the connection.
I have followed the steps in the readme but I keep getting the following error when trying to save the settings:
"Error while establishing connection: file_get_contents(https://www.mydomain.nl/my_secret_directory/index.php?): failed to open stream: no suitable wrapper could be found"

To make sure I can read from my online store I created a small test using "file_get_contents" to output some text on my new osCommerce 4.x shop (from a file hosted at my online osCommerce shop v2.x) and that works fine so a connection is possible.

Only thing I noticed is in the example secret key it starts with OSC_alotofsymbolshere, and mine starts with DEST_, could that be the problem?

Check your php.ini file, the following configuration option should be turned on:

allow_url_fopen = On

Share this post


Link to post
Share on other sites

That is 

39 minutes ago, pandrei said:

Check your php.ini file, the following configuration option should be turned on:

allow_url_fopen = On

Yes, that is set to on.

Share this post


Link to post
Share on other sites
15 minutes ago, pandrei said:

Check it in the admin panel, please

Done that, thanks.
There it says it is not enabled. How is that possible?
It is enabled in php.ini file in the account. (I enabled it through Cpanel).
It shows enabled under phpinfo(); but it shows disabled in the admin panel 😲

Any idea?

Edited by petervd

Share this post


Link to post
Share on other sites
3 minutes ago, petervd said:

It shows enabled under phpinfo(); but it shows disabled in the admin panel 😲

Admin panel uses the same phpinfo() to show information.

4 minutes ago, petervd said:

There it says it is not enabled. How is that possible?

It may be a delay before your changes take effect. Anyway, I think your hosting provider knows best 🙂

I recommend you to try our hosting: https://www.oscommerce.com/host-with-oscommerce

Share this post


Link to post
Share on other sites

Osclink URL invalid and also 

Error while establishing connection: file_get_contents(https://www.xxxxxxx.com/index.php?): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden

Using secure key generated but still error

need help importing from 2.3 to 4.0 connection settings

have admin panel showing

allow_url_fopen On On

 also php.ini has settings

 

Edited by rmandiga

Share this post


Link to post
Share on other sites

I have similar issues and could never get to SAVE step completed.. Tried all that in this post and also adding ip address as whitelist in remotesql. Nothing works.

 

Unable to migrate

Share this post


Link to post
Share on other sites
11 hours ago, pandrei said:

Admin panel uses the same phpinfo() to show information.

It may be a delay before your changes take effect. Anyway, I think your hosting provider knows best 🙂

I recommend you to try our hosting: https://www.oscommerce.com/host-with-oscommerce

But, at the same time my own  file_get_contents() test, from my new osC4.x to my old osC 2.x (from within the exact same folders) does work. Isnt that a bit weird, cause that means allow_url_fopen = On is working, else it would not work.

(oh, and both sites are running on the same server as well)

Edited by petervd

Share this post


Link to post
Share on other sites
9 hours ago, rmandiga said:

Error while establishing connection: file_get_contents(https://www.xxxxxxx.com/index.php?): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden

It does not look like a correct link for OSC bridge. It have to be  like https://www.xxxxxxx.com/oscb/index.php?

Check the steps 1-3 here: https://wiki.oscommerce.com/index.php?title=Importing_Data_from_Older_osCommerce_Version_to_New_One

Share this post


Link to post
Share on other sites
8 minutes ago, pandrei said:

It does not look like a correct link for OSC bridge. It have to be  like https://www.xxxxxxx.com/oscb/index.php?

I dont understand. The readme specifically states to rename that oscb directory.
This is my url (after renaming the folder):
https://www.mydomain.nl/my_secret_directory/index.php?

That is exactly the same isnt it? (if you account for different domain and renamed folder).
Unless there should be info after the question mark but it does not state so in the readme (nor in your link above but maybe the editor cuts those off)?

Share this post


Link to post
Share on other sites
26 minutes ago, petervd said:

I dont understand. The readme specifically states to rename that oscb directory.

It was a reply to @rmandiga

54 minutes ago, petervd said:

But, at the same time my own  file_get_contents() test, from my new osC4.x to my old osC 2.x (from within the exact same folders) does work. Isnt that a bit weird, cause that means allow_url_fopen = On is working, else it would not work.

(oh, and both sites are running on the same server as well)

Usually when you change php.ini, you have to restart apache server for the changes to take effect. But if you launch your php test from command line  - changes are applied immediately.

Share this post


Link to post
Share on other sites

Restarting Apache made no change.

However I have found how to fix this.
I copied the php.ini file (which Cpanel creates automatically if you change certain php settings for a user) in which the "allow_url_fopen = On" setting is set and uploaded it to the admin folder as well. That fixed the whole problem.

No, I dont understand why cause since the php.ini file is in the root (public_html folder) it should be set for any subfolder as far as I know.

But anyway, it works now. I now have access to the mapping settings and the "Run import actions". Hopefully from here it all goes well.


Thanks for the assistance! Maybe my "fix" helps others too here.

Share this post


Link to post
Share on other sites

hello,

 created in 2005 the site with osc.2.1,

today under v2.3.3 with php 5.4,

the host tells me not to ensure security, we are at php 7.4 today

I just read your post of May 5,

I would like to try a migration to osc v4

what should I do??

Thank you for your reply

Cordially samuel


site 1 ---> MS 2.3.3 + AJAX Attribute Manager + Option Types v2 + Header Tags SEO + E transaction

site 2 ---> MS 2.3.4 en cours d'essais

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×