Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

herbsandhelpers

Installation osCommerce v4 Beta 2 - No Admin Page

Recommended Posts

I got positive messages throughout the installation and all seemed to go well except I can't get beyond splash screens and no admin. All I get with most links is Page Not Found. I've tried to access the feedback but it takes too long to load. Can anyone shed light on why I can't move from splash to anything else? How do I access the admin dashboard? Mystery! Very excited to be getting this far though.

Lorraine

Share this post


Link to post
Share on other sites
On 1/27/2022 at 4:44 AM, herbsandhelpers said:

I got positive messages throughout the installation and all seemed to go well except I can't get beyond splash screens and no admin. All I get with most links is Page Not Found. I've tried to access the feedback but it takes too long to load. Can anyone shed light on why I can't move from splash to anything else? How do I access the admin dashboard? Mystery! Very excited to be getting this far though.

Lorraine

Lorraine check to see if the .htaccess file was written properly. Mine was written to all one line.


osCommerce user since 2003! :thumbsup:

Share this post


Link to post
Share on other sites

I've tried a number of installs now, with different combinations and had mostly errors post-installation. Try the following:

  • Begin the zip extraction from your www or public_html (webroot) directory.
  • Start installation from your browser and specify / as the starting point, not for example /catalog
  • Specify Test for the Sales Channel and name it Test
  • Do not add a suffix on the URL
  • Include the demo data

It won't give you a production ready site but does appear to set things up to be in a usable state.

Additionally, check file and directory permissions are suitable for your environment - mine were set 'potty' during initial extraction and post installation. This can cause a 500 error at the worst, and error log warnings..

SoftException in Application.cpp:249: File "/home/osc4osc/public_html/index.php" is writeable by group

HTH

Edited by ejsolutions
more info

Share this post


Link to post
Share on other sites
54 minutes ago, herbsandhelpers said:

No admin login folder ...

Hopefully it will be possible to resolve it by checking and correcting the htaccess of the main website. Please keep us posted!

Share this post


Link to post
Share on other sites

Hello Vadym,
Is it possible to add the wiki Osc4 inside the documentation tab ?

Tk



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites
1 hour ago, Gyakutsuki said:

Hello Vadym,
Is it possible to add the wiki Osc4 inside the documentation tab ?

Tk

Sure, thanks for reminding us, updated the Documentation section of osCommerce.com

Share this post


Link to post
Share on other sites

Okay so I deleted all files including htaccess and tried again. I got exactly the same result:

No errors except to clear database

A bit longer to get to admin password, but exactly the same, no admin.

I don't know what to do? I've never had any issues installing the previous OSCommerce. Why does it keep failing?

Lorraine

Share this post


Link to post
Share on other sites

Yes but there’s no admin, I can get the splash page, go to a page but none of the links work.

How can I install? I don’t know why it keeps falling?

I’d really like to be checking out all the new features and getting it ready!?!!?

Lorraine

Share this post


Link to post
Share on other sites
1 minute ago, herbsandhelpers said:

Yes but there’s no admin, I can get the splash page, go to a page but none of the links work.

How can I install? I don’t know why it keeps falling?

I’d really like to be checking out all the new features and getting it ready!?!!?

Lorraine

There seem to be a configuration peculiarity that is affecting the back end URL. Will message you now. 

Share this post


Link to post
Share on other sites

Hi,

I've had the same problems when I tried to install on a shared hosting into a subfolder like /shop. The problem is with not writing the rewrite base entries in both .htaccess files, only after entering the correct rewrite base values I could access the splash and the admin. No luck with watches and furniture though. 

Another question  maybe a dumb one: What are the symlinks for?

And a litlte note: I hope the name of the admin folder will be changeable on install in the future for security reasons.

Kind regards

Christoph

 

 

 

Edited by beerbee

Share this post


Link to post
Share on other sites

Hello,

Ive sent my current server environment screenshots on php 7.4.25 where shopBlank is located. I hope this helps to solve my installation issue. The configure files don’t get written.

I’ve never had any issues installing either OSC or Phoenix before in the same environment as you can see from the screenshots.

Lorraine 

Share this post


Link to post
Share on other sites

had a look at the pre installed version and had issues with it.

 

would love to install it on my own srever and see how it behaves.

 

whats the minimum requirements

Share this post


Link to post
Share on other sites
20 hours ago, herbsandhelpers said:

Hello,

Ive sent my current server environment screenshots on php 7.4.25 where shopBlank is located. I hope this helps to solve my installation issue. The configure files don’t get written.

I’ve never had any issues installing either OSC or Phoenix before in the same environment as you can see from the screenshots.

Lorraine 

Lorraine, we are looking into it. Thanks for sharing your feedback.

Share this post


Link to post
Share on other sites
12 hours ago, MadWayne said:

had a look at the pre installed version and had issues with it.

 

would love to install it on my own srever and see how it behaves.

 

whats the minimum requirements

Wayne, will send you download link. Manual is always available here:

https://wiki.oscommerce.com/index.php?title=Main_Page

Share this post


Link to post
Share on other sites

had enough for today, database populated and files installed but wont log into admin  think the instructions are pretty poor in the first instance.

well relook at this again next week probably

Share this post


Link to post
Share on other sites

Had another look at installing this several times today and whilst the database populates and the files get extracted cant access admin or see the shop front either.

Can anyone give us a quick guide on the process to be followed as I get pretty much no errors until I try and login to admin or try and view the shop front

 

Thanks

Edited by MadWayne

Share this post


Link to post
Share on other sites

Hello,

Do you look the documentation : https://wiki.oscommerce.com/index.php?title=Installing_osCommerce_v.4.0

Osc v4 is more appropriate on dedicated server, Tested on my local ubuntu and with IspConfig ubuntu server (OVH), work fine
tested in this moent on Cpanel, I have a problem on the last step. On Cpanel, maybe with different hoster you can have some restrictions. I do not know if other people can share their experiences and if successful, share your Cpanel configuration to allow the people to test on their side.

 



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites

indeed it appears to fall over on the final step, worked with my hosting company to verify everything was correct based on the requirements stated and it was.

 

Share this post


Link to post
Share on other sites

On the installation page where it shows "Complete the Installation", you have to scroll down and click the button. I doubt that this is the problem based on all that has been said here but I thought it might be worth mentioning.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Need Help? See this thread and provide the information requested.

How to Upgrade to the latest version

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×