Jump to content
MadWayne

Considering a return

Recommended Posts

Many years ago I used oscommerce and even contributed around 15 years ago.

I registered afew years ago with the means to look at adding OSC to my latest website/venture, but found it ho so much more confusing.

 

Which OSC version should I look at?

How do I integrate paypal and go cardless?  (seem to recall there were many ways to integrate paypal)

Postage modules.

importing and exporting feeds (not a biggy)

What about legislation in the UK? GDPR springs to mind.

Keeping the familiarity of my current website is a concern and to be fair I did have a look at some of the live sites and some were dead which wasn''t helpful.

Also worried about checking for security issues, seem to remember having the suite scanned daily to check for known issues, but have to confess I have slept many times since them days.

To be fair the current shop side of the website is only a few pages and a shop seems over kill but the degree of control is more important which you just cant get will  paypal generated buttons.

 

Any advice on where to start and have a look would be greatly appreciated..

Share this post


Link to post
Share on other sites

sad to see that its dying off, even got a pm telling me as much.

Shame, so as I have been advised that I should look elsewhere for something where do i start as far back as I can remember a lot of the solutions were very similar.

Share this post


Link to post
Share on other sites
9 hours ago, MadWayne said:

sad to see that its dying off, even got a pm telling me as much.

Shame, so as I have been advised that I should look elsewhere for something where do i start as far back as I can remember a lot of the solutions were very similar.

You need to be aware of these members sending you these PMs.

Share this post


Link to post
Share on other sites

completely but looking at forum and that its clear V2 is no longer supported officially and v4 isn't available in anything other than beta.

As its free I can always see how I get on but the store isnt my main concern.

I guess now the question is what is in V4 and what are the minimum/ recommended requirements before I embark and how do I check the vulnerability of site I set up, seems to recall having a daily report done for free by some online scanner.

Share this post


Link to post
Share on other sites
3 hours ago, MadWayne said:

completely but looking at forum and that its clear V2 is no longer supported officially and v4 isn't available in anything other than beta.

As its free I can always see how I get on but the store isnt my main concern.

I guess now the question is what is in V4 and what are the minimum/ recommended requirements before I embark and how do I check the vulnerability of site I set up, seems to recall having a daily report done for free by some online scanner.

You may want to refer to 

https://wiki.oscommerce.com/index.php?title=Installing_osCommerce_v.4.0

for minimum server requirements. We have run v4 through a number of scans recently but always encourage developers and businesses to use their own scans that review not just the software but also the server. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×