Jump to content
pilon

Admin Links Stop

Recommended Posts

Hi,

Sorry for this message... i make this website in 2009 its very old... now i see in the admin area... the links stop working, cant open categories and see the products inside, can open nothing. In the front, everything works well.

Maybe the php change for that time.

Anyone can help me?

Thanks

Share this post


Link to post
Share on other sites

@pilonIt is most likely due to your host upgrading the php version. I suggest you check with them to see if they did that. If they did, you can ask them to revert the change, though they probably won't,  or you will either need to update your shop to work with the new version or move to a host that is able to run the php version you need.

If it isn't the php version, see if there is a file named error_log in the admin directory. If there is, it might indicate the problem you are having. If you don't know how to find or understand that log, you can ask your host to see if they will tell you why it is failing. Some will - some won't. You can also post the last 10 or so lines of the file here so someone can check it for you.

All of the above assumes there have not been any changes to the admin. It sounds that way from your post but if someone was working in the admins files, then that would be the first place to look.

Share this post


Link to post
Share on other sites

Hi Jack,

Thanks, the version of php is 5.3 i think they dont change this, because we have now 7.4 i guess.

Error log,

[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_is_registered() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 50
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_is_registered() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 50
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_register() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 46
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_register() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 46
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_is_registered() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 50
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_is_registered() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 50
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_register() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 46
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function session_is_registered() is deprecated in /home/mcmsapt/public_html/sv/admin/includes/functions/sessions.php on line 50
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function ereg() is deprecated in /home/mcmsapt/public_html/sv/admin/configuration.php on line 70
[28-Sep-2021 16:29:14 Europe/Lisbon] PHP Deprecated:  Function ereg() is deprecated in /home/mcmsapt/public_html/sv/admin/configuration.php on line 70

Share this post


Link to post
Share on other sites

That's a mountain of work waiting for you there. i.e updating from php 5 -> 7/8.

You have the errors and the line numbers so use the links in my sig as a reference to fix them. Or better still, migrate your shop to one of those options.

Share this post


Link to post
Share on other sites
On 9/28/2021 at 11:48 AM, pilon said:

Thanks, the version of php is 5.3 i think they dont change this, because we have now 7.4 i guess.

A shop from 2009 won't work with php 7.4. But there must have been changes made to the shop side since you said that was working. Many host's are removing php version before 7.2 and will automatically set the version to 7.4. That is probably what happened in your case.  You can ask them if they will switch the account back to something lower but I doubt they will. If they will, the shop may work with php 5.6. I can only guess without seeing the files. You may need to revert to 5.3 to have it work.

If your host won't switch you back, then you will either need to upgrade the shop so it works under 7.4 or switch hosts. You host may tell you that they can't switch you back but that they can move you to a dedicated server. While that would work, it would mostly like be very costly so I wouldn't recommend it.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×