Jump to content
bholiand

PayPal App with osCommerce 2.2-MS2

Recommended Posts

@bholiandYes, it will work fine in that version. Just be sure to follow the installation instructions closely.

Share this post


Link to post
Share on other sites

Thanks for the reply.

I followed the instructions but when I try to click on one of the three button nothing happens.

I think i should see a new page?

1266025590_Screenshot2021-10-06at08-57-21osCommerce.thumb.png.a099b0d84b5fdcb54724a29dc5114838.png

Share this post


Link to post
Share on other sites

The capital letters in the left column (last entry) indicate the addon isn't installed correctly. Be sure you made the change to the admin application_top file and that you used the correct code (it's different than the code for the shop side). Also make sure you have uploaded all of the files into the includes/hooks/admin/ directory (shop side).

Share this post


Link to post
Share on other sites

I checked everything again but still not working.

In the documentation under "legacy changes":

Zitat

Only the changes in (1) are required to add the PayPal App links to the Administration
Tool.

1. Administration Tool App Setup
I did this but still not working.

Zitat

The capital letters in the left column (last entry) indicate the addon isn't installed correctly.

The text "MODULES_ADMIN_MENU_PAYPAL_HEADING" appears when i add "include(DIR_WS_BOXES . 'paypal.php');" to myadmin/includes/column_left.php.

How can i install the app?

If I click under modules -> PayPal Payments Standard on "install" or Manage App i always get to the same page (picture above) and nothing happens.
Only the get parameter change in the URL

  • admin/paypal.php?action=start&subaction=process&type=live
  • admin/paypal.php?action=start&subaction=process&type=sandbox
  • admin/paypal.php?action=credentials

Under "Minimum Requirements" it says
"PayPal App - The PayPal App can be used from osCommerce Online Merchant v2.2RC2a (2008) onwards, and is optimized for and bundled with v2.3.5."

I see the following modules:

  1. PayPal Express Checkout
  2. PayPal, Lastschrift, Kreditkarte oder Rechnung
  3. PayPal Payments Pro (Direct Payment)
  4. PayPal Payments Pro (Hosted Solution)
  5. PayPal Payments Standard
  6. PayPal

Share this post


Link to post
Share on other sites
1 hour ago, bholiand said:

1. Administration Tool App Setup
I did this but still not working.

There are a number of other changes you missed if this is the only one you did. The instructions can be difficult to follow due to all of the version checks. But there are at least five steps, as I recall, required to install the app into an older shop.

Share this post


Link to post
Share on other sites
Zitat

But there are at least five steps, as I recall, required to install the app into an older shop.

Can you help me with the steps?

I did the following:

  1. I downloaded the full paypal app (app-paypal-5_010)
  2. After extracting the App package, I copied the files located in the catalog directory to my shop.
  3. I followed the insctructions on page 45: "1. Administration Tool App Setup" and "2. Hooks for the Administration Tool and Catalog".
  4. I skipped "3. Administration Tool Order Administration Page" since I dont need the new order page.
  5. I did "4. Public CA Certificate Bundle" and uploaded the file.

Than it says on page 47:

Zitat

When the files have been copied to their appropriate locations and the Legacy
Changes have been performed, a new PayPal navigation menu box will show in the
Administration Tool. The first time the App is run, it automatically configures itself and
migrates older module configuration parameters to the App parameters, and checks if
an online update is available.

I do see the new PayPal navigation menu box and can open the page. But nothing happens when I click on a buttons or open the page.

Share this post


Link to post
Share on other sites

Did you make the changes to the two application_top files and the order class file?

Share this post


Link to post
Share on other sites
vor 1 Stunde schrieb Jack_mcs:

Did you make the changes to the two application_top files and the order class file?

application_top files: yes (its optional as well)

order.php: no (its optional)
The order.php should not effect the installation process at all.

Share this post


Link to post
Share on other sites

I think you may be misreading the instructions, which is easy to do. For example, changes to the application_top files are not optional for your version of oscommerce.

Share this post


Link to post
Share on other sites
vor 23 Stunden schrieb Jack_mcs:

I think you may be misreading the instructions, which is easy to do. For example, changes to the application_top files are not optional for your version of oscommerce.

Can I hire you for a screenshare session? I think this might be more effective. Please send me a PM.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×