Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Archived

This topic is now archived and is closed to further replies.

Jan_hartvig

Product to basket problem

Recommended Posts

I notised that when I put a product to the basket it througs a wrong error

 

“ The information you are about to send is not secure

Because the form is submitted with a connection that is not secure, the information will be visible to others.”

 

I don't know if this problem came up with me changing from HTTP to HTTPS

If so, this has been a problem for months now.

The wrong error is in swedish 🙂 I translated in to english in the text above.

When I pres "Send anyway"(Sänd ändå) it goes to the customer basket but it is empty

problem med webbsidan.jpg

Share this post


Link to post
Share on other sites

I notised that it only happens when I'm on the product page an press “Put to basket”(Lägg I varukorgen) it happens.

When I press "Buy now"(Köp nu) it works

Share this post


Link to post
Share on other sites

Go to Admin -> Tools -> Server Info. Tell us what version of PHP your server is on.

With this version of osCommerce you're going to have endless problems with outdated code.

Rather try building your store on one of these more updated versions of osCommerce:

 

Share this post


Link to post
Share on other sites
Servervärd: bikesupport.se (77.111.240.176)      Databasvärd: bikesupport.se.mysql (10.27.2.145)
Server O/S: Linux      Databas: MySQL 5.5.5-10.3.30-MariaDB-1:10.3.30+maria~focal
Server datum: 2021-08-29 09:55:40 +0200 CEST      Databas datum: 2021-08-29 07:55:40
Server Upptid:  
pixel_trans.gif
HTTP Server: Apache
PHP Version: 7.4.23 (Zend: 3.4.0)
pixel_trans.gif

Share this post


Link to post
Share on other sites

PHP 7.4

And soon your host will probably go over to version 8 and your shop will break completely.

I have seen this problem before with the add to cart throwing this error. Can't remember what fixed it, now.

Share this post


Link to post
Share on other sites

Your site is showing that you are using/forcing SSL encryption on all site pages. This may conflict with the osCommerce configuration file if it is not set up properly for SSL. 

As I recall, the last time you posted, you had a somewhat similar SSL issue with the admin configuration file. So, I recommend looking at the catalog configuration file, because it looks like the session is breaking due to the connection.

Also, the osC version you have is not designed for PHP version 7.4 ...so, unless you had your site patched/upgraded to that version, it too could be the cause of this sessions issue. Retracting to version 7.0 may fix this problem. 

 

 


osCommerce: made for programmers, ...because store owners do not want to be programmers.

https://trends.google.com/trends/explore?date=all&geo=US&q=oscommerce

Share this post


Link to post
Share on other sites

Is it a big problem jobb to retracting to version 7,0 or updating to a new version?

 

As you wrote last time, there are coming a new version soon. So I was waiting for that

Share this post


Link to post
Share on other sites

In your hosting control panel there may a toggle switch for you to switch between available php versions.

However, going back to a lower version is only a temporary solution and when your host removes that version you will have the same problem again.

We cannot recommend anymore that people wait for V4, especially if you know the history of osCommerce. If you have a project that you want to get going then you have to use what's production ready, and those are the links that i posted above. With the lack of communication from the new owners, all kinds of questions are raised, including why people should use osCommerce at all, even if they do manage to come up with a release.

Share this post


Link to post
Share on other sites

If you have not updated your osCommerce software to PHP7.4, then reverting back to PHP7 is as easy as calling your hosting company and asking them to change that PHP version.

Updating to 8.0 is a bit more involved, especially if your site is not really supposed to be on 7.4

-----------------

A few others are waiting for the new version as well.

 

 


osCommerce: made for programmers, ...because store owners do not want to be programmers.

https://trends.google.com/trends/explore?date=all&geo=US&q=oscommerce

Share this post


Link to post
Share on other sites

×