Jump to content

Recommended Posts

Hi 

I have a problem with the shop showing "Page not safe in adres field before the webbadress. what am I tod do , is it my webbhotell or the shop that is the problem

And my second problem is the text "

I am able to write to the configuration file: /customers/e/0/4/bikesupport.se/httpd.www/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

It has been over 30 days since the extended security checks were last performed. Please re-run the extended security checks under Tools -> Security Checks."

Where is it I have to change this?

 

image.thumb.png.10aae1699e8956b4b01fcd6a6cec6b5c.png

problem.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, Jan_hartvig said:

I am able to write to the configuration file: /customers/e/0/4/bikesupport.se/httpd.www/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

You need to browse to this file on your server using a ftp client such as Filezilla and set the permissions to 444. On the catalog and admin side.

5 minutes ago, Jan_hartvig said:

In Admin go to Tools -> Security Checks.

 

6 minutes ago, Jan_hartvig said:

I have a problem with the shop showing "Page not safe in adres field before the webbadress. what am I tod do , is it my webbhotell or the shop that is the problem

You can speak to your host about installing SSL to your domain.

Share this post


Link to post
Share on other sites

Add the following line to both of the application_top.php files. That will set the file permissions to 440 any time an admin or catalog page is loaded. To upload and overwrite either of those files, you will need to manually set the file permissions to 660 or higher using an FTP application or File Manager. 

chmod('includes/configure.php', 0440);

 

 


osCommerce: made for programmers, ...because store owners do not want to be programmers.

https://trends.google.com/trends/explore?date=all&geo=US&q=oscommerce

Share this post


Link to post
Share on other sites
22 hours ago, Hotclutch said:

You need to browse to this file on your server using a ftp client such as Filezilla and set the permissions to 444. On the catalog and admin side.

In Admin go to Tools -> Security Checks.

 

You can speak to your host about installing SSL to your domain.

Hi

found it but after i activated it the webshop design on the first page changed from alt 2 to alt 1.

This is just on the first page. When I click on a link in the shop it goes over to alt 2 again ???

 

alt 2.jpg

alt1.jpg

Share this post


Link to post
Share on other sites

Not sure what you mean. If you mean you activated SSL, then you also have to go edit both your configure files.

  define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers
  define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

This section you need to change false to true. You also have to change your values in the first 2 lines from http to https.

Share this post


Link to post
Share on other sites

Seriously? Put an active link to your admin folder and make it public ...

Delete this link and also hide the link in your screenshot.

Immediately rename your administration folder.

These are basic safety rules ...


Live   : OsC 2.2, php 5.6 & UTF-8  |  Local : phoenix and oscommerce v4 test when v4 will be available

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×