Jump to content
ezfindit

Hosting Companies and Plans Supporting PHP 5.6 Long Term

Recommended Posts

Posted (edited)

Hi everyone,

Does anyone currently use a hosting company that allows you to keep using PHP v. 5.6 for at least another year?

My hosting company is forcing me to upgrade to PHP 7.4 in June. I'm using osCommerce v. 2.3.4 on a live site. 

I would like to keep using PHP 5.6 for the next 9-12 months to allow me to test v. 4 when it's released and then give me sufficient time to migrate and test my current live site. 

Any hosting recommendations or alternative hosting plans (looking at VPS) to keep using PHP v. 5.6 will be greatly appreciated.

Thanks,

- Chris

Edited by ezfindit

Chris

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Hotclutch said:

Another option for you is to install a debugger that will report all php errors. The fixes are well documented on the forum or can be found in later osC (community) versions.

I've seen a few threads mentioning some changes to make v. 2.3.4 be compatible with PHP v. 7.4. Is there a consolidated thread or step-by-step documentation on how to make osCom 2.3.4 run on PHP 7.4? It would help thousands of us, I think, and buy us time to explore and test the latest upcoming version being promised.

Edited by ezfindit

Chris

Share this post


Link to post
Share on other sites

No thread that I recall. 

You are on version 2.3.4 which is one behind the last official release 2.3.4.1 - so that is some additional fixes to apply. However, if this was my store, then this would be the route I take, then you can plan upgrading to a later version at your leisure.

 

Share this post


Link to post
Share on other sites

I use Fast Comet and as far as I know they don't plan to discontinue 5.6. Regardless, I will begin the process of upgrading my code very soon. I've decided waiting for V4 or using Phoenix is not a viable option for me at this time.


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites
16 minutes ago, ezfindit said:

Moving to 2.3.4.1 won't solve the PHP v. 7+ compatibility issues.

See: https://forums.oscommerce.com/topic/496977-install-oscommerce-2341-new-installation/

"v2.3.4.1 was written to run under PHP v5.x, and will give you problems when running under PHP v7.x. "

You can ignore that thread.

Install this debugger to tell you what the errors are under php 7.

The number of errors will be numerous but they are all of a certain type. If you need help resolving the error you can just post on the open forum, someone will point you in the right direction.

Share this post


Link to post
Share on other sites

@ezfindit hey Chris,

https://www.webhostinghub.com/

Their minimum is PHP5.4 but this is shared hosting, not VPS. And, it is based in the US.


osCommerce: made for programmers, ...because store owners do not want to be programmers.

https://trends.google.com/trends/explore?date=all&geo=US&q=oscommerce

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×