Jump to content
cyberfruits

Changing from http to https: not working

Recommended Posts

Hi i am using osCommerce Online Merchant v2.3.4.1 and in configure.php I set the value to true and the c panel to force htts and after that, it brakes my web page, my boxes disappear and my whole display just appears on left on the webpage. i did the same with another site and it worked just fine, display as normal, and a secure site up and working, the only difference is a customer-designed layout whereas the one which will not work is an out-of-the-box standard layout. are there other files I would to modify to make it HTTPS compatible?

Thanks

Share this post


Link to post
Share on other sites
  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

You only need to set ENABLE_SSL to true.

  define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers
  define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

And these 2 defines you can change the values to https...

That's all you need to do. If your site is breaking it could be due to hardcoded links in the code pointing to http, especially stylesheets.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×