Jump to content

Recommended Posts

I trying to install a Google reCaptcha v2 in my old v2.2 RC2a store since there doesn't seem to be a reCaptcha v3 available (this v2.3 add on didn't function since the admin side boxes would not display (https://apps.oscommerce.com/M93NH&google-recaptcha-v3). 

So, I'm using the 19th September 2016 template found here:

https://apps.oscommerce.com/DMTEK&google-recaptcha-2-0&v=22

It directs you to open catalog/includes/template_top.php and find <script type="text/javascript" src="ext/jquery/jquery.stringball.js"></script> . The file template_top.php doesn't exist in my store. I believe it is a typo?  Is it suppose to be applications_top.php?  If not where should I put that javascript?

Otherwise, is there an easy way to just upgrade the v1 add on that is currently on my site (https://apps.oscommerce.com/tYsNN) to a v2 or v3 reCAPTCHA?

 

Share this post


Link to post
Share on other sites

I believe no one wants to work on 2.2 anymore. It is better if you DIY.  Google has been generous to let people use their code freely and has provided proper guidance on the usage too.

"The easiest method for using reCAPTCHA v3 on your page is to include the necessary JavaScript resource and add a few attributes to your html button."

... says https://developers.google.com/recaptcha/docs/v3

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Did you find a way to make it to work on oSC-2.2-rc2a?  I'm running same version and wouldn't mind to implement reCaptcha v3


#Joseph

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×