Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Guest

Stripe Issue

Recommended Posts

Guest

Just started happening.

Customer pays with stripe, completes the transaction on their site, then the page goes nuts and does not return them to my site to complete the order.

In Admin, I get the order listed as processed, but there is no list of what the customer purchased.

I have osc 2.2

Share this post


Link to post
Share on other sites
Guest

Yes.

 I am waiting for a reply.

Just thought someone might have had the same issue.

I was thinking maybe a API change.

Share this post


Link to post
Share on other sites

I believe you are using an outdated version which is not supported any more.

The latest stripe SCA 3.0 version doesn't redirect the customer to stripe. It stays and processes everything in the store.

You should update to Stripe SCA 3.0:

https://apps.oscommerce.com/EbCL1&stripe-v3-sca

 

Share this post


Link to post
Share on other sites
Guest

ok

I just tested it and I got the following error after clicking process:

1364 - Field 'vendors_product_price' doesn't have a default value

insert into orders_products (orders_id, products_id, products_model, products_name, products_price, final_price, products_tax, products_quantity) values ('123148', '1851', '9591AC', 'GM Turbo 400 Stock Capacity Pan', '200.9500', '200.95', '6.35', '1')

[TEP STOP]

Share this post


Link to post
Share on other sites

vendors_product_price  is not core. You may need to integrate your custom fields.

Depending on your store version you need to add support for this custom field to the payment module.

Or fix your database to have a default value for this field.

Edited by raiwa

Share this post


Link to post
Share on other sites
Guest

Its funny.

I have'nt changed a thing in three years.

Just started today.

Share this post


Link to post
Share on other sites

I am  a bit surprised that the module is still working and Stripe are allowing payments without strong SCA.

I am using version 1.0.16 on a frozen store with no problems so updating to even an older version of the current module should work.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×