Jump to content
xylo

Update from 2.3.3.3 to Phoenix

Recommended Posts

Hello

I have a small shop, which is currently running on 2.3.3.3 and php 5. My provider closes the support for php 5 so I have to update. I read about the Phoenix-Club and I like the new features. For the time beeing I would just do the minimal updates required to run on php 7.2.

I read about the update-Process and just would be happy if someone, with more knowledge could confirm my plan to update:

  1. Update to 2.3.3.4 using the update package (official version)
  2. Update to 2.3.4 using the update package (official version)
  3. Convert the database with this script : 
  4. Install the Bootstrap Version 2.3.4.
  5. Done

Is this the correct way? Thank You very much for any Ideas.

Mirko

Share this post


Link to post
Share on other sites
9 hours ago, xylo said:

Is this the correct way?

The files in Phoenix are almost totally different than in non-Phoenix shops so upgrading your current shop to the 2.3.4 version won't accomplish anything. You need to do the following:

  •  Set up a test site and install Phoenix. This might be a problem off the bat if you are not able to run php 7.
  •  Convert your database and apply it to the test shop.
  •  Install whatever addons you need for your shop.
  • Make any appearance changes that are needed.
  • Test the shop thoroughly.
  • If it all looks good, block your live shop with a down for maintenance page to prevent database changes.
  • Do a final conversion of the database.
  • Make the test site live.

It can be a lot of work, depending upon what addons and appearance changes are needed. For the addons, many of the popular ones that have Phoenix versions are just file uploads so the installation is much easier. Good luck.

 

Share this post


Link to post
Share on other sites

@xylo

22 hours ago, xylo said:

I have a small shop, which is currently running on 2.3.3.3 and php 5. My provider closes the support for php 5 so I have to update. I read about the Phoenix-Club and I like the new features. For the time being I would just do the minimal updates required to run on php 7.2.

To convert your 2.3.3.3 shop to run under PHP v7.x will require a LOT of work. AFAIK, there are no published instructions on how to do this. Lastly, if you do manage to accomplish this, you will essentially have created your own fork of osC, and no-one will be able to support it for you.

22 hours ago, xylo said:
  1.  
  2. Install the Bootstrap Version 2.3.4.
  3. Done

There is no 'official' Bootstrap Version 2.3.4. The only Bootstrap version of osC is the Community Edition, which has evolved over the years, and is now called Phoenix. You can't install ANY Bootstrap version on top of an existing store, you have to install it in it's own directory, and migrate your data into the new store (see @Jack_mcs's post above).

HTH

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×