Jump to content
Fredi

Phoenix Datepicker jQuery. ht_modules. Date format.

Recommended Posts

Datepicker when registering clients in Russian, it gives the wrong date format:  mm:dd:yy
The date format set for the Russian language is ---  dd:mm:yy
How would you advise to configure the module so that it displays the date in the correct format?
Due to incorrect date display, registration is not possible using the Datapicker for russian language.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

In file    locale/bootstrap-datepicker.ru.min.js

date format correct.  

I think a correction of the module file and language files is needed.

It's a pity that we removed the general data format option and moved it to the language file.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Our dear teachers!
I would like to receive an answer ...


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Is there not a section in the language files where this can be changed. Near the top in the english one in both admin and store front.

I altered mine to the following and it seems to all be working fine.

// look in your $PATH_LOCALE/locale directory for available locales
// or type locale -a on the server.
// Array examples which should work on all servers:
// 'en_US.UTF-8', 'en_US.UTF8', 'enu_usa'
// 'en_GB.UTF-8', 'en_GB.UTF8', 'eng_gb'
// 'en_AU.UTF-8', 'en_AU.UTF8', 'ena_au'
@setlocale(LC_ALL, ['en_GB.UTF-8', 'en_GB.UTF8', 'enu_gb']);

const DATE_FORMAT_SHORT = '%d/%m/%Y';  // this is used for strftime()
const DATE_FORMAT_LONG = '%A %d %B, %Y'; // this is used for strftime()
const DATE_FORMAT = 'd/m/Y'; // this is used for date()
const DATE_TIME_FORMAT = DATE_FORMAT_SHORT . ' %H:%M:%S';
const JQUERY_DATEPICKER_FORMAT = 'dd/mm/yy'; // see http://docs.jquery.com/UI/Datepicker/formatDate

 

Edited by 14steve14

REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Hello dear Steve!

Please tell us your secret information:
In which file did you make the correction?


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Is it in the main language file?

It used to be there.
But Phoenix changed that ...
I wrote about this before I was kicked out of the club, but it was explained to me that I was asking the wrong questions.

So what to do? Breaking the core ???

No problem.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Look where it used to be near the top of the includes/language/English.php. it must also be there in other language files if they have been created correctly..

The code I pasted was copied from 1.0.7.9 so it must be there.

Edited by 14steve14

REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

My file russian.php

// look in your $PATH_LOCALE/locale directory for available locales
// or type locale -a on the server.
// Array examples which should work on all servers:
// 'en_US.UTF-8', 'en_US.UTF8', 'enu_usa'
// 'en_GB.UTF-8', 'en_GB.UTF8', 'eng_gb'
// 'en_AU.UTF-8', 'en_AU.UTF8', 'ena_au'
/// @setlocale(LC_ALL, ['en_US.UTF-8', 'en_US.UTF8', 'enu_usa']);
@setlocale(LC_ALL, ['ru_RU.UTF-8', 'ru_RU.UTF8', 'ru_ru']);

define('DATE_FORMAT_SHORT', '%d/%m/%Y');  // this is used for strftime()
define('DATE_FORMAT_LONG', '%A %d %B, %Y'); // this is used for strftime()
define('DATE_FORMAT', 'd/m/Y'); // this is used for date()
define('DATE_TIME_FORMAT', DATE_FORMAT_SHORT . ' %H:%M:%S');
define('JQUERY_DATEPICKER_FORMAT', 'dd/mm/yy'); // see http://docs.jquery.com/UI/Datepicker/formatDate
 


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Youre russian.php is not updated yet, the defines becomes constant, and have you copied bootstrap-datepicker.ru.min.js from locale into directory js? Also ad in youre russian.php

const JQUERY_DATEPICKER_I18N_CODE = 'ru';

 

ru.png

Share this post


Link to post
Share on other sites

Hello Bert,

I have the latest version of Datapicker installed, all files are copied.

I have updated russian.php
But the problem remained ...
Datapicker is displayed in English and date format:  mm/dd/YY
153405.jpg.1393fb03c2b1d4b0531a056738e77c7e.jpg
 

Edited by Fredi

Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
13 minutes ago, Fredi said:

I have the latest version of Datapicker installed

Is that the addon or from github? If it is the addon in admin disable the default datepicker jQuery, and install the addon, I did only the ht files and not de directory ext..and i have test it with version 1.0.7.10

Share this post


Link to post
Share on other sites

From Github.
/ext/datepicker/locales/bootstrap-datepicker.ru.min.js 
I turn it on and off ht modules   /includes/modules/header_tags/ht_datepicker_jquery.php

194050.jpg.572449bfbabb49b02c325374c5050f23.jpg

Where am I making a mistake?

Sorry, I have to ask questions here because our great leader and teacher kicked me out of the Phoenix Club, which created huge problems for Phoenix to adapt to existing stores ...
I am so sorry.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

How can I disable in admin the default datepicker jQuery?


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
45 minutes ago, Fredi said:

Where am I making a mistake?

 

By the beginning the default datepicker works..

And I thought I read somewhere else that you were using the addon for bootstrap datepicker, the default datepicker also works of course. quote from readme addon "After this addon you can use datepicker on catalog side in desired catalog languages."

Share this post


Link to post
Share on other sites
45 minutes ago, Fredi said:

How can I disable in admin the default datepicker jQuery?

??
Click on edit and set to false 🙂

Share this post


Link to post
Share on other sites

Click false - datepicker not worked


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

I understand that there is a conflict between the two versions of the datapicker.
Probably the basic version works for me.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
13 hours ago, Fredi said:

Click false - datepicker not worked

If you turn something off, it no longer works, which is quite logical

Share this post


Link to post
Share on other sites
13 hours ago, Fredi said:

I understand that there is a conflict between the two versions of the datapicker.
Probably the basic version works for me.

Both on will not work, that's right 🙂 it is one or the other

Share this post


Link to post
Share on other sites

Thank Tou Bert!

It's understandable that when you turn off the light, it gets dark ...  😊

What else can you advise me besides shutdown?

How do I enable language support? I still can't do it.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
25 minutes ago, Fredi said:

How do I enable language support? I still can't do it.

Turn off the default datepicker and turn on the bootstrap datepicker as mentioned before

Share this post


Link to post
Share on other sites

My file  russian.php

define('DATE_FORMAT_SHORT', '%d/%m/%Y');  // this is used for strftime()
define('DATE_FORMAT_LONG', '%A %d %B, %Y'); // this is used for strftime()
define('DATE_FORMAT', 'd/m/Y'); // this is used for date()
define('DATE_TIME_FORMAT', DATE_FORMAT_SHORT . ' %H:%M:%S');
// const JQUERY_DATEPICKER_FORMAT = 'dd/mm/yy';  //  see http://docs.jquery.com/UI/Datepicker/formatDate
const JQUERY_DATEPICKER_I18N_CODE = 'ru';

Should I do this?
I did it.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
22 minutes ago, Fredi said:

Should I do this?
I did it.

here you say 

22 hours ago, Fredi said:

I have updated russian.php

But youre code says no 🙂

And thats not the only thing, but everthing is already said

Share this post


Link to post
Share on other sites
define('DATE_FORMAT_SHORT', '%d/%m/%Y');  // this is used for strftime()
define('DATE_FORMAT_LONG', '%A %d %B, %Y'); // this is used for strftime()
define('DATE_FORMAT', 'd/m/Y'); // this is used for date()
define('DATE_TIME_FORMAT', DATE_FORMAT_SHORT . ' %H:%M:%S');
const JQUERY_DATEPICKER_FORMAT = 'dd/mm/yy';  //  see http://docs.jquery.com/UI/Datepicker/formatDate
const JQUERY_DATEPICKER_I18N_CODE = 'ru';

Now he says yes?

The result is the same.

I understand the members of the Club. They're having fun now!
I am very grateful to the Club members and their teachers for the great support of the real store owners!
Thank you very much!


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×