Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
m11rf

You do not have permissions to make this API call

Recommended Posts

The website has been working fine and then i got this problem when you click to pay with paypal.

I recently update the paypal certificate

(https://github.com/gburton/CE-Phoenix/blob/master/ext/modules/payment/paypal/paypal.com.crt)

but after that the website has been working fine for weeks.

In the admin panel on the website itself i have nothing in the API Username API Password and API Signature fields, but i never have had anything in there.

I tried adding the username and password from the API settings in paypal but it's still the same error. 

Any help very much appreciated :)

Share this post


Link to post
Share on other sites

Does Oscommerce have a third party permission username that i can add and allow in paypal? If so, what is it?

 

 

Share this post


Link to post
Share on other sites

Have you tried clicking this?  As you can see I have five fields populated.

image.thumb.png.c5948ee6294498553cd8cbf89ba36465.png


Live shop Phoenix 1.0.8.4 on PHP 7.4 Working my way up the versions.

Share this post


Link to post
Share on other sites

Thanks for your help. Thanks for showing me an example of yours, that really helped :)

It's now sorted. I'm not sure why all of a sudden i needed to enter the API details when the shop has been up and running for 6 years without it.

But i put in all the information and it's working fine now.

If anyone else is searching for this, you are given a choice on paypal when you request API details

  1. Click Request API Credentials.
  2. Click Request API signature.   

You need to choose 2. I chose number 1 and was going round in circles for a while trying to input the wrong information. So i deleted number 1 and requested number 2 and got the right info.

 

Edited by m11rf

Share this post


Link to post
Share on other sites

Mine is not a PayPal business account but I am getting this same error. I'v never had anything in the API fields.

I have tried resetting everything and nothing seems to work. Any help would be greatly appreciated!

Cheers,

Aaron

API ERROR.jpg

Share this post


Link to post
Share on other sites

Just to close out my comments here, I did finally upgrade to a PayPal Business Account 

and the API & Security Header Errors are now gone.

Thanks for the help here, you folks are awesome!

Aaron

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×