Jump to content
ce7

admin/reviews.php

Recommended Posts

hi,

i have phoenix 1075, upload to server, somehow one of the domain (the other domains are ok), the image on admin/categories.php not show up, so tested 1077 and found the configuration files cause the problem, so now i have 1075 configuration file with 1077 const syntax, and on the very top, it has code : error_reporting(E_ALL);

with this error report code, i fix most of the notices or error messages, except the reviews.php

Warning: array_merge(): Expected parameter 3 to be an array, null given in /admin/reviews.php on line 309

               

$review_info = array_merge($reviews_text, $reviews_average, $products_name); 

Warning: array_merge(): Expected parameter 2 to be an array, null given in /admin/reviews.php on line 310
               

$rInfo_array = array_merge($reviews, $review_info, $products_image);

 

Warning: Invalid argument supplied for foreach() in /admin/includes/classes/object_info.php on line 21

     

foreach($object_array as $key => $value) { 

i know that i can just comment out the error report, but if i didn't, how to fix the 3 errors show up on reviews.php file?

 

any help or suggestion is appreciated, thanks!  Lyn

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, ce7 said:

Warning: array_merge(): Expected parameter 3 to be an array, null given in /admin/reviews.php on line 309

This is telling you that there is no entry for the given product and language in the products_description table. 

Either switch to a language that does have an entry in the table or add an entry for your current language. 


Always back up before making changes.

Share this post


Link to post
Share on other sites
2 hours ago, ecartz said:

This is telling you that there is no entry for the given product and language in the products_description table. 

Either switch to a language that does have an entry in the table or add an entry for your current language. 

@ecartz

Hi Matt,

Thank you very much! Yes, after you explained, i found that i upload to the server, updated the product info for real product, so the previous template shinny apple been delete, but the reviews still have the record about shinny apple, now i know i need to delete it completely. Thank you to explain it, good learning for me!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×